Re: [bess] Roman Danyliw's No Objection on draft-ietf-bess-evpn-bum-procedure-updates-11: (with COMMENT)

"Jeffrey (Zhaohui) Zhang" <zzhang@juniper.net> Wed, 20 October 2021 17:50 UTC

Return-Path: <zzhang@juniper.net>
X-Original-To: bess@ietfa.amsl.com
Delivered-To: bess@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 77F7F3A0883; Wed, 20 Oct 2021 10:50:02 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.553
X-Spam-Level:
X-Spam-Status: No, score=-2.553 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.452, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_MSPIKE_H2=-0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=juniper.net header.b=oDXh1+dE; dkim=pass (1024-bit key) header.d=juniper.net header.b=LVycgIDg
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id W4RHUSG5PWMN; Wed, 20 Oct 2021 10:49:55 -0700 (PDT)
Received: from mx0b-00273201.pphosted.com (mx0b-00273201.pphosted.com [67.231.152.164]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 11CFD3A0B2E; Wed, 20 Oct 2021 10:49:54 -0700 (PDT)
Received: from pps.filterd (m0108161.ppops.net [127.0.0.1]) by mx0b-00273201.pphosted.com (8.16.1.2/8.16.1.2) with SMTP id 19KEZjV9014850; Wed, 20 Oct 2021 10:49:49 -0700
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=juniper.net; h=from : to : cc : subject : date : message-id : references : in-reply-to : content-type : content-transfer-encoding : mime-version; s=PPS1017; bh=X8yryWoIJUbtqm/Rv4lFvCMvbYqtrrgsnO7amOj8TAs=; b=oDXh1+dEdbbQPOJsroLAfkEBYU+uSMMLtN1ByoqzA3CUwTmcwJbHn191jXXxyjL6F6lx lMzosqELWpSiUy8DVSGrdbA4RSzjxHG62KD7AGkrRos1oFntGpHm3i3Jwm6dyGI4ADTm 8OZwDW7ASdc53/o3Bk1qLTK6Yzqeh1+Vvl4ZM84vNCQ6Nv7WVqxs7LkF19G7MiPT9zZm 4zXJfDwZYa5ooSloMSPAMReAWkUEho5JILkU2hOCvsLMQ/QmhBvXn/PubvPBFcVhI+TL 2LVe21jVJ5Xp6yOvkVJ1j3q9MY7/EQwS5pM+ITj50kL7P6A7XpTQENXH8pdc84EDMA4w Zg==
Received: from nam10-dm6-obe.outbound.protection.outlook.com (mail-dm6nam10lp2107.outbound.protection.outlook.com [104.47.58.107]) by mx0b-00273201.pphosted.com with ESMTP id 3btn0vrdxj-1 (version=TLSv1.2 cipher=ECDHE-RSA-AES256-GCM-SHA384 bits=256 verify=NOT); Wed, 20 Oct 2021 10:49:48 -0700
ARC-Seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=EuRArfrmBjtQf/75v4Y77CX1AnHQaXxnS3lRzLTIqMwvCUBiYaGLZaaQ1RPy5/ePRKnYE+01CIubkmplC23QJpa0nDjFv4wX7dEU3ZSIa/xo3mPFCrpR3VXwrZTJ9i4ZjE1+Pf/P9ith04ebH3xrDOnsUfVFSUbk2KHWyipaFwB96B08v9aNtYDYsMOAJWi+mVHo0JYqMLie/4y2OsG0MBk6g5XJTJA9bLZzRV4mXJvV1rZ33UP6+H4Unk1jIOHT0F6cZquQBjw/7HBDYPcqv2wIKt6xh0frzifdzSZTa2D1aZAoJmze1cvJqNhQd4NE1kvp6dl6mq6hSDyx+rtndA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=X8yryWoIJUbtqm/Rv4lFvCMvbYqtrrgsnO7amOj8TAs=; b=bkH+LFxeBf+dEQaI3091UD9Z7AX5waMN0fKw09AcOcvk1i+xlYZXGOiq6YFsNQbYhN13SlJW3K4kvo03+mA7BsnBh38iuRWyAGdS18fYeZd5rM4kPygVz+yFPLjdlrvpBWBDEmB386iqg0RB786zDHSRC4eZRCHh6IF+BtpXGgkHYo9TqovsGFvbTNbWRNM/9aqfvlRxcH16SxC54VCfqC7xOBqfEFVjDhXAbaw0O1oxjHJXu8Ieu9yMBbhpu6oncZ9fW+8p7mvy1ihpXkNG8QeUtPu19xjJz2lJUJTrKXAkyqxI2sHyKst0n/h+1Oq6idhwsoqZnAbgP6eTUhSNKQ==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=juniper.net; dmarc=pass action=none header.from=juniper.net; dkim=pass header.d=juniper.net; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=juniper.net; s=selector1; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=X8yryWoIJUbtqm/Rv4lFvCMvbYqtrrgsnO7amOj8TAs=; b=LVycgIDgei3M/CgpXKgclnO6Obnj4RaPxpyk0Gzg2HSU8P+3I2ZnOSzzBMOStcPfuk5b+74lCXOcOllXZrTGH9iUu0mihKpg9lww7SRfXUwWaXEcXWQkjkHiy53tmA44aJlgBA3AzW502Lh0xiULHvOW+kAuDt0kawJNIjJz/q4=
Received: from BYAPR05MB5654.namprd05.prod.outlook.com (2603:10b6:a03:18::17) by BY3PR05MB8305.namprd05.prod.outlook.com (2603:10b6:a03:3b4::15) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.4628.10; Wed, 20 Oct 2021 17:49:24 +0000
Received: from BYAPR05MB5654.namprd05.prod.outlook.com ([fe80::c45e:9bd8:83c5:6af]) by BYAPR05MB5654.namprd05.prod.outlook.com ([fe80::c45e:9bd8:83c5:6af%6]) with mapi id 15.20.4628.016; Wed, 20 Oct 2021 17:49:24 +0000
From: "Jeffrey (Zhaohui) Zhang" <zzhang@juniper.net>
To: Roman Danyliw <rdd@cert.org>, The IESG <iesg@ietf.org>
CC: "draft-ietf-bess-evpn-bum-procedure-updates@ietf.org" <draft-ietf-bess-evpn-bum-procedure-updates@ietf.org>, "bess-chairs@ietf.org" <bess-chairs@ietf.org>, "bess@ietf.org" <bess@ietf.org>, "EXT-zzhang_ietf@hotmail.com" <zzhang_ietf@hotmail.com>
Thread-Topic: Roman Danyliw's No Objection on draft-ietf-bess-evpn-bum-procedure-updates-11: (with COMMENT)
Thread-Index: AQHXxT4b+FaHylbjFUiWAC4njn7nP6vcJ6kA
Date: Wed, 20 Oct 2021 17:49:24 +0000
Message-ID: <BYAPR05MB56546C4F99D1C06D4EAED040D4BE9@BYAPR05MB5654.namprd05.prod.outlook.com>
References: <163468484917.8162.14591537016797250038@ietfa.amsl.com>
In-Reply-To: <163468484917.8162.14591537016797250038@ietfa.amsl.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
dlp-product: dlpe-windows
dlp-version: 11.6.100.41
dlp-reaction: no-action
msip_labels: MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_ActionId=9b57295e-9702-4709-8b16-813aacc8f68b; MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_ContentBits=0; MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_Enabled=true; MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_Method=Standard; MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_Name=0633b888-ae0d-4341-a75f-06e04137d755; MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_SetDate=2021-10-20T17:36:55Z; MSIP_Label_0633b888-ae0d-4341-a75f-06e04137d755_SiteId=bea78b3c-4cdb-4130-854a-1d193232e5f4;
authentication-results: cert.org; dkim=none (message not signed) header.d=none;cert.org; dmarc=none action=none header.from=juniper.net;
x-ms-publictraffictype: Email
x-ms-office365-filtering-correlation-id: 46be2aed-45c6-46ef-bbdc-08d993f1f45c
x-ms-traffictypediagnostic: BY3PR05MB8305:
x-ld-processed: bea78b3c-4cdb-4130-854a-1d193232e5f4,ExtAddr
x-microsoft-antispam-prvs: <BY3PR05MB8305F18576C482AEA28A1FE6D4BE9@BY3PR05MB8305.namprd05.prod.outlook.com>
x-ms-oob-tlc-oobclassifiers: OLM:10000;
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;
x-microsoft-antispam-message-info: oA/iCqZ/Drf8UqWbe96i/E4gyE0k9fNgDhQTk0AgvHf+bzRiJAuHBWsfZutKU2sRsTOqMK+D0yRO9/Cm7FVnzg/n6nTgdvfH3TLsIwlW8ROtx2X5cqIw3Qlv1SSMkl6gBeFPbvJxqEOd8W7NdvIuTNIpo2Ncg64Z3sDGY6dkeXHo+Fwb8+BC/JMqsqqOhZcRi0AMgMNj4W3GMKWRq3JOioZaCaaNepNZ4vBP5UwerXcrY1XZh8SQQHJIqG8J81UU3vs1BS72o+1U5n/sHXAqpe8QvEmZM7huWO2sSfkzewYl/C9At5XOvdE6To7Wdg3IXi68ZgRKFsWQpMpmXguHkQDna1MORJS8h7Edrohn55ZjOSf1ZOxecoRM597SoH5aCtCZQnEGz8ojH0BmF5Ev5EnZ4k9UKKi8z13QSNJZroqEyKzG9oG98bdF0g8u8DSBFuQVx+J+yJ2n2sOWxaildpsqCfeHnuaILRr4lZqqfkkkgcf7Lj4n+1WcDTS98nRUDUaUmNXUUTHFpwJUdHajBb8pYQmbhbjO7oU09cMSNSedKXwVL5rKw9rpxOdnL82f4+pqkW922A2bj1+8jp+6FW4dTdHCW3R32DJ3HeCH+MzOuDbnOaxz7LyV82xKfuN5MWEZc9f0LYxusjXdezRno6Wpeel/lKkVgJc8rVr/vhMR2VJQLs0Aw8mSavSUr2RQrIjywKfrb0dGvBiRYaNo90r4W0HuslrPYq+nOK0TOpSPU/4ehruoNyOCJjbQ4ngqszjOdMLkze5myYQRqkgkCJOlwRQ4xTVJMtI+SWi4m1Ig0ceBf5/zIUlSo97qi50fuBtZXxX2+9vUqNtZ4V9lpQ==
x-forefront-antispam-report: CIP:255.255.255.255; CTRY:; LANG:en; SCL:1; SRV:; IPV:NLI; SFV:NSPM; H:BYAPR05MB5654.namprd05.prod.outlook.com; PTR:; CAT:NONE; SFS:(4636009)(366004)(76116006)(66556008)(110136005)(33656002)(508600001)(9686003)(38070700005)(86362001)(83380400001)(71200400001)(66946007)(66446008)(7696005)(45080400002)(15650500001)(38100700002)(54906003)(4326008)(8936002)(5660300002)(52536014)(6506007)(53546011)(66476007)(2906002)(186003)(26005)(316002)(122000001)(64756008)(966005)(55016002)(8676002); DIR:OUT; SFP:1102;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: 4XRTIpmRSyAya5uGxxbffj3A5nSn8Api7hUT6+ct2a4v9UhdjT9zXrc2MZAg54SO1LrhrQi5OJh5IxlQnh7aKHyqX3bhR84jLQE21rIeglW0C+gB+owm8/eSJLDo7dAcim32l6sja9gj90khX1GD62mnBxlfAioG6e+oXL6TOzk57o4FbE+0h4p6CtEb5SdI95qRHwgR7HugBaWc4zurSpCf1EPvxmAL8E3BeTZDgBHis1jMjnYcjJL6iyEe1SvO8nGh31EYdowYwon8SExBveO3Jz8FpJLHHHYCS3w4ciI6Wvj0TJllWuIyLSOtA1dpFIVMHzd4uLBLTAek1sPk17sv46RITc3yL4iOYNCc8coHhwXtC7cuBlzifKoQxX6kLvAC4JsSx7ZU4mUkPSQtc42mLh55dOH2sGW7goLjDGNmgp1YeWqHeOnQrd6NS0C5K3ppD7ePz4VnOWhqt4brdRh44Ldv8IE8C2g86dXN+/mCSyFFmUshrlsym6xpoXTxoalM3yAWA5QmVogbcmje9qjhzjpjkaVukdJeKAbOatR8/q+vsN8I2wegq/4Uoy7H6H7kNobFjAU7wappfrBN1BPvLCdQ8TZq8NebtMfVqILXa8J0mTMKd/QBztObogOeED9WIcBZImWTLSpX2/sNohaWmic9Tu+N1TGYznFVG2VNagEOQ3DnX50S/V6AUEbQNCywOvoZWTW08PyrDeuPlTZUC++FhLRbkLpXCSLngdvD4HunD9XymIrYOcvynvvtI7UO8NsNZ2FSdrL5aGtWM2FYFFQYc1T48JE9j6AcgPfyeTYf/JvCipjCi4ncKEekkjsYIax/NHMd7Zok/wzvShffYaOg0A4zStS52ihxMYQPct0eSLKjKR8YmnzlekdyWvrEzbeP7yosJDjVPQSm4pIaawlDRYCjzpXMhd4+gzLeBVJY9HxwQ26fX50rqPP0LzjdJRN7HV3MU12KC92YTh1OK1owZ1E8fGP6Oz7lsf4hrKN3OLPC18vuHHkTbjMHJCdP94vSF+B06Ymy9Zp7qIowP/cAztggzB82edWYsfT4nDLdasEmFB9A7fsmqmq2lwCGYS+zs/l3tNBga2wFMp5l8saR1kti5hUaiP+HkOgnp4jrBuwD+kVceB7G4z2N7dFshR8DK1rqO6fuzFoqaM3+g1agG4bQ98b6bTb0iRq2dFK7ZOYi0WGwyXRVpHVv1LuWW8KiGwbAKS5Js6dOtxCZtzGxSxgVy5M5hgp5lvnO/FQbLit7l1m6odOLuRuCq5SShN/nmBf2xk8QQRBJuKgPm9XwUkZcdsUY8xwOra8zgkOD/+lKrzcifZKVXDh1fwDShtrYdQpt7fYbb85iluutT0HQOkR/C7F9nFPo7i/+ycaO1qlOMv7sX/CEr1AO/8PBqI6Ca4stI4ZM5LVHRlvZ5lDPASQjY7DeanRtbbY=
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-OriginatorOrg: juniper.net
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: BYAPR05MB5654.namprd05.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 46be2aed-45c6-46ef-bbdc-08d993f1f45c
X-MS-Exchange-CrossTenant-originalarrivaltime: 20 Oct 2021 17:49:24.4556 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: bea78b3c-4cdb-4130-854a-1d193232e5f4
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: zzhang@juniper.net
X-MS-Exchange-Transport-CrossTenantHeadersStamped: BY3PR05MB8305
X-Proofpoint-GUID: laJnh2QJYJz-2-Vv_q5NTQ2kt_uQLs0t
X-Proofpoint-ORIG-GUID: laJnh2QJYJz-2-Vv_q5NTQ2kt_uQLs0t
X-Proofpoint-Virus-Version: vendor=baseguard engine=ICAP:2.0.182.1,Aquarius:18.0.790,Hydra:6.0.425,FMLib:17.0.607.475 definitions=2021-10-20_06,2021-10-20_02,2020-04-07_01
X-Proofpoint-Spam-Details: rule=outbound_spam_notspam policy=outbound_spam score=0 priorityscore=1501 mlxscore=0 mlxlogscore=999 phishscore=0 spamscore=0 adultscore=0 clxscore=1011 impostorscore=0 malwarescore=0 bulkscore=0 suspectscore=0 lowpriorityscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.12.0-2109230001 definitions=main-2110200100
Archived-At: <https://mailarchive.ietf.org/arch/msg/bess/sMhOY7tgrn2KYQf_ZuwEf64DXaI>
Subject: Re: [bess] Roman Danyliw's No Objection on draft-ietf-bess-evpn-bum-procedure-updates-11: (with COMMENT)
X-BeenThere: bess@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: BGP-Enabled ServiceS working group discussion list <bess.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bess>, <mailto:bess-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/bess/>
List-Post: <mailto:bess@ietf.org>
List-Help: <mailto:bess-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bess>, <mailto:bess-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 20 Oct 2021 17:50:03 -0000

Hi Roman,

Thanks for your review and comments. Please see zzh> below.

-----Original Message-----
From: Roman Danyliw via Datatracker <noreply@ietf.org>
Sent: Tuesday, October 19, 2021 7:07 PM
To: The IESG <iesg@ietf.org>
Cc: draft-ietf-bess-evpn-bum-procedure-updates@ietf.org; bess-chairs@ietf.org; bess@ietf.org; EXT-zzhang_ietf@hotmail.com <zzhang_ietf@hotmail.com>; EXT-zzhang_ietf@hotmail.com <zzhang_ietf@hotmail.com>
Subject: Roman Danyliw's No Objection on draft-ietf-bess-evpn-bum-procedure-updates-11: (with COMMENT)

[External Email. Be cautious of content]


Roman Danyliw has entered the following ballot position for
draft-ietf-bess-evpn-bum-procedure-updates-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://urldefense.com/v3/__https://www.ietf.org/blog/handling-iesg-ballot-positions/__;!!NEt6yMaO-gk!W9aXZSC6YB_tGS-I05oE_xAchhv7ZbAc7eyvp9QLkay63a9oKtRPkl9f-wuQRPzJ$
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-bum-procedure-updates/__;!!NEt6yMaO-gk!W9aXZSC6YB_tGS-I05oE_xAchhv7ZbAc7eyvp9QLkay63a9oKtRPkl9f-5KAvuRS$



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

** I support Lars Eggert’s DISCUSS position.  I have come to the same
conclusion as the GENART reviewer (Paul Kyzivat).  It isn’t clear what this
document is updating.

-- The document header and abstract explicitly say that RC7432 is updated.
However, I can’t find a clear explanation of how the next in this documents
updates RFC7432

-- Section 5.1. is titled as “Changes to Section 7.2.2 of [RFC7117]” and
changes behavior in RFC7117, but RFC7117 is not being updated (according to the
header and abstract).

Zzh> This document updates RFC7432 in that it provides extensions to support: a) selective tunnels b) tunnel segmentation. Perhaps it's arguable that counts as "updates". I am fine with removing the "update" tag if that does not count as "updates".
Zzh> This document does NOT update RFC7117/7524, which are for VPLS. This document is for EVPN (though both are different solutions for ethernet VPNs), but it refers to the selective or segmented tunnel procedures for VPLS defined in 7117/7524. While minor changes/modifications are needed to apply to EVPN (and they are pointed out in this document as you noted), the procedures for VPLS are not modified (therefore this document does not update 7117/7524).

Zzh> It was an intentional choice not to copy text from 7117/7524. I understand that is causing some concern here but I hope we'd eventually agree that it is better than copying text.

** Section 9.
   They do not introduce new security concerns besides what have been
   discussed in [RFC6514], [RFC7117], [RFC7432] and [RFC7524].

Which parts of these security considerations specifically apply here.  For
example, RFC7524 and RFC7432 makes references to MPLS mechanisms (which seem
out of scope here).  Additionally, it appears some of the guidance across these
documents is directed at securing generic EVPN technology – this is helpful,
but please be clear about this case.  What specific guidance is relevant to the
procedures for handling BUM traffic?

Zzh> No guidance. It simply says that there are no new issues/concerns introduced by this document, so whatever discussed in those referenced RFCs applies here as well.
Zzh> Thanks!
Zzh> Jeffrey



Juniper Business Use Only