Comments on Chassis MIB Draft - S. Horowitz (Steve Horowitz) Mon, 19 October 1992 18:17 UTC

Return-Path: <owner-chassismib>
Received: by CS.UTK.EDU (5.61++/2.8s-UTK) id AA23446; Mon, 19 Oct 92 14:17:37 -0400
Received: from by CS.UTK.EDU with SMTP (5.61++/2.8s-UTK) id AA23440; Mon, 19 Oct 92 14:17:30 -0400
Received: from dino.stealth ([]) by (4.1/SMI-4.0) id AA03266; Mon, 19 Oct 92 14:16:44 EDT
Received: by dino.stealth (4.1/SMI-4.1) id AA05692; Mon, 19 Oct 92 14:17:36 EDT
Date: Mon, 19 Oct 92 14:17:36 EDT
From: (Steve Horowitz)
Message-Id: <9210191817.AA05692@dino.stealth>
Subject: Comments on Chassis MIB Draft - S. Horowitz

Is this the appropriate time to comment on this draft ? :)

First, being new to this process, I'd like to say that the group/authors
have done a fairly good job.  If I can participate in some way (other
than attending the IETF), please send me a request (Donna ?).

After reading Dave Perkin's comments of which I agree with about all of
them, I have the following to add:

1. chasSlotModuleDescr size is too small.  I recommend using 255 which
	is what MIB-II uses for sysDescr.

2. chasEntityObjectId should correspond to sysObjectID in name. Please
	capitalize the 'D' in "ID" and also correct the text in the

3. chasEntityFunction - Nice to have. Seems a bit limited for future 

4. chasEntityDescr must be sized to 255 as it corresponds directly to 

5. chasEntityAdminStatus should have a test enumeration.  Also, how
	would we add vendor specific enumerations ?  Is this a case
	for the "OID" method ?

6. chasEntityAdminStatus description, last paragraph.  What does this
	mean ?  Should I return readOnly or invalidData ?  I recommend
	the latter.

7. chasEntityArgument - Does this belong ?  How can it be used ?  If you
	are going to keep this, at least make it big enough.  32 chars
	is pretty limiting.

8. chasType - Isn't this really a sysObjectID for the chassis ?  Maybe
	the object should be named chasObjectID for clarity.

9. chasConfigIndexType - I believe that the syntax is incorrectly specified.
	Should it be OID ?

I disagree with Dave's comment that the table should not be allowed to 
be sparse if you are really going to support 64K of entries (slots).  
Forcing the agent to maintain all 64K seems onerous.

I wholeheartedly agree with Dave's comments that 
	- optional/mandatory needs to spelled out.
	- create/delete options ditto
	- logical mapping needs to be explored and explained better.

The following are spelling errors or style notes:

Section 5, "Thus, this memo" is indented incorrectly.

Section 5.4, "wether" is spelled incorrectly.

chasEntityAdminStatus: "a entity" should be "an entity" throughout the

Bye - Steve