[core] Re: Coreconf Notifications
Thomas.Graf@swisscom.com Thu, 18 July 2024 17:35 UTC
Return-Path: <Thomas.Graf@swisscom.com>
X-Original-To: core@ietfa.amsl.com
Delivered-To: core@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 77B94C151063; Thu, 18 Jul 2024 10:35:38 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.403
X-Spam-Level:
X-Spam-Status: No, score=-4.403 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_NONE=0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=swisscom.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id rvcRM22dcTe4; Thu, 18 Jul 2024 10:35:34 -0700 (PDT)
Received: from mail.swisscom.com (mailout110.swisscom.com [138.188.166.110]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 12B35C14F694; Thu, 18 Jul 2024 10:35:33 -0700 (PDT)
Received: by mail.swisscom.com; Thu, 18 Jul 2024 19:35:26 +0200
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=swisscom.com; s=iscm; t=1721324126; bh=Aix2wMCv2YnBU76eJWiAMb8A2MHjdnoW1RcFgmX17t4=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=AwkDotGtKqCbz8FmFOLnKpg3j/7V9XTuIxNSW3j4b5p/X8YFQsbDDg/eYgImYi/2j ZGtijrt7uEy5fCUFU8JUvX+BwFrvYlXcrqIGJsuhR79c3CcGWZfXkACdm9y9eSEYJC 9F5Iy9avspQa9NujXK1Cr6AUUV8fTbH3QAAN1ghHh3z6WOPNgl1aSrAvJSNF1jkbXh vxpcxAnFkLbou5zlutZmc1SObT/tXX9evVtf+GFaeg7zvX113eOh/Ub19x9zuCTAne lFJBUz3BZ9qtFG6lgv2c/RvWRbgRYR/EVwojidcMtZv5s87VEH/+2gXWxLgEDr6+5N PfM5LnkvRytwg==
MIME-Version: 1.0
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg="sha-256"; boundary="----=_Part_301866_959366201.1721324125762"
X-Mailer: Totemo_TrustMail_(Notification)
From: Thomas.Graf@swisscom.com
To: andy@yumaworks.com, alex.huang-feng@insa-lyon.fr
Thread-Topic: Coreconf Notifications
Thread-Index: AQHa2SsThgXVwBWCxkCBE1ZgPPD4AbH8hP0AgAA2rDA=
Date: Thu, 18 Jul 2024 17:35:22 +0000
Message-ID: <184eb6b79c684428ac6d2d0b2c63ac1b@swisscom.com>
References: <E2DFFA8E-9766-4CB4-BCAA-6897402B8FB2@insa-lyon.fr> <CABCOCHTxe+d6nhS_zQXvsQne4YXvwtMtdXxCecjSuBhvqvvWxg@mail.gmail.com>
In-Reply-To: <CABCOCHTxe+d6nhS_zQXvsQne4YXvwtMtdXxCecjSuBhvqvvWxg@mail.gmail.com>
Accept-Language: en-US, de-CH
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
msip_labels: MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_ActionId=b0e48053-51d6-437f-b9f2-025269df796d;MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_ContentBits=0;MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_Enabled=true;MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_Method=Standard;MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_Name=C2 Internal;MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_SetDate=2024-07-18T17:22:00Z;MSIP_Label_2e1fccfb-80ca-4fe1-a574-1516544edb53_SiteId=364e5b87-c1c7-420d-9bee-c35d19b557a1;
x-originating-ip: [138.188.161.184]
X-CFilter-Loop: Reflected
X-Trustmail: processed
Message-ID-Hash: RWBKCL3276LGDPX6OIX3ZK2TBRX5CRPF
X-Message-ID-Hash: RWBKCL3276LGDPX6OIX3ZK2TBRX5CRPF
X-MailFrom: Thomas.Graf@swisscom.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-core.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-core-comi@ietf.org, core@ietf.org, pierre.francois@insa-lyon.fr, vivekananda.boudia@insa-lyon.fr, benoit.claise@huawei.com
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [core] Re: Coreconf Notifications
List-Id: "Constrained RESTful Environments (CoRE) Working Group list" <core.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/core/et6__HFovplBGmsw7Jkbdf8ykGM>
List-Archive: <https://mailarchive.ietf.org/arch/browse/core>
List-Help: <mailto:core-request@ietf.org?subject=help>
List-Owner: <mailto:core-owner@ietf.org>
List-Post: <mailto:core@ietf.org>
List-Subscribe: <mailto:core-join@ietf.org>
List-Unsubscribe: <mailto:core-leave@ietf.org>
Dear Andy, * The notification message defined in RFC 5277 is a conceptual container that has an eventTime leaf and this event part * that is modeled in YANG as child nodes. I haven't found a normative statement in any document supporting that. Could you please point me. On top what Alex already wrote, what puzzles me and dares for an explanation is that RFC 5277 is intended for Netconf https://datatracker.ietf.org/doc/html/rfc5277#section-1, has been specified prior to YANG, and has been intended in the previous netconf working group charter https://datatracker.ietf.org/doc/charter-ietf-netconf/19/ in section 5 to be declared obsolete once netconf working group specified its successor which is RFC 8639/8641 and a new notification structure. Best wishes Thomas From: Andy Bierman <andy@yumaworks.com> Sent: Thursday, July 18, 2024 9:06 AM To: Alex Huang Feng <alex.huang-feng@insa-lyon.fr> Cc: draft-ietf-core-comi@ietf.org; core@ietf.org; Pierre Francois <pierre.francois@insa-lyon.fr>; Vivekananda Boudia <vivekananda.boudia@insa-lyon.fr>; Graf Thomas, INI-NET-VNC-HCS <Thomas.Graf@swisscom.com>; Benoit Claise <benoit.claise@huawei.com> Subject: Re: Coreconf Notifications Be aware: This is an external email. On Thu, Jul 18, 2024 at 8:56 AM Alex Huang Feng <alex.huang-feng@insa-lyon.fr<mailto:alex.huang-feng@insa-lyon.fr>> wrote: Dear authors and CORE WG, I have some questions regarding how YANG notifications are encoded in CBOR. I am co-authoring draft-ahuang-netconf-notif-yang-05 where we are defining how NETCONF notifications are encoded in XML, JSON and CBOR. This definition is not explicit in JSON (RFC7951). Reading the YANG-CBOR (RFC9254) specification, the notifications are encoded as a “container-like” instance. This is rather a different approach from XML (RFC7950) and JSON (RFC7951) which to my understanding a leaf “eventTime” needs to be present in the notification as defined in RFC5277. I am wondering why YANG-CBOR defined YANG notifications differently. I don’t follow this WG closely but would love to hear the reasons which led to the wording in RFC9254. (Or if more consistency with XML and JSON is expected) For CORECONF, reading https://datatracker.ietf.org/doc/html/draft-ietf-core-comi-17#name-notify-examples, the notifications are also defined without the leaf defined in RFC5277 but still references this RFC. YANG has the notification-stmt which only models the event part of the notification message. The notification message defined in RFC 5277 is a conceptual container that has an eventTime leaf and this event part that is modeled in YANG as child nodes. YANG-CBOR defines the mapping to the YANG notification-stmt, not any conceptual protocol messages that are not defined in YANG. Andy We plan to use CBOR encoding with YANG-Push (RFC8641) to reduce the size of the YANG-defined messages between the NETCONF server and client. In https://datatracker.ietf.org/doc/html/draft-ahuang-netconf-notif-yang-05#name-cbor-structure we define how we expect the CBOR message to be encoded. Having a similar approach to encode YANG notifications between JSON and CBOR ease the development of some open-source projects, such as the integration of YANG in the Kafka message broker. Here some references of such integration: - https://datatracker.ietf.org/doc/html/draft-ietf-nmop-yang-message-broker-integration-03 - https://github.com/network-analytics/draft-daisy-kafka-yang-integration/blob/main/schema-registry-yangkit-integration-02.pdf Note also that we request a .sid file for YANG-SIDs for compressed CBOR messages in https://datatracker.ietf.org/doc/html/draft-ahuang-netconf-notif-yang-05#appendix-A. We will be onsite in Vancouver, so happy to have a live discussion regarding these encoding mismatches. I think the integration of YANG and CBOR into Kafka might also be of interest to the WG. Feel free to ping me back to have a discussion during the IETF week. We will also be present at the Hackathon Saturday and Sunday. Regards, Alex
- [core] Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Thomas.Graf
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Thomas.Graf
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Henk Birkholz