[core] Re: Coreconf Notifications
Andy Bierman <andy@yumaworks.com> Thu, 18 July 2024 18:11 UTC
Return-Path: <andy@yumaworks.com>
X-Original-To: core@ietfa.amsl.com
Delivered-To: core@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 51AFEC151993 for <core@ietfa.amsl.com>; Thu, 18 Jul 2024 11:11:01 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.105
X-Spam-Level:
X-Spam-Status: No, score=-2.105 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=yumaworks.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id wXB4c7SCMHXg for <core@ietfa.amsl.com>; Thu, 18 Jul 2024 11:10:57 -0700 (PDT)
Received: from mail-pl1-x634.google.com (mail-pl1-x634.google.com [IPv6:2607:f8b0:4864:20::634]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 96C2DC14CEFE for <core@ietf.org>; Thu, 18 Jul 2024 11:10:57 -0700 (PDT)
Received: by mail-pl1-x634.google.com with SMTP id d9443c01a7336-1fb3b7d0d56so7681365ad.1 for <core@ietf.org>; Thu, 18 Jul 2024 11:10:57 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yumaworks.com; s=google; t=1721326257; x=1721931057; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=8pCHgXPwdofEeUcnJFoJ0zGjkLIgLDHlu6SJzfQ0KCg=; b=fGMh8RbfxMBJzXIeTecM70Za1j/+8CiLhdRXk6EGCg7U95bp/Ce1CnXo5nxkmtZWmc JluI16G9OPYeeYT+6PMesgEYaQKl2wneq60xECmw2W1SIPzRtr1ZjrPX79N95PUJ0cXv wamCVTzGP4MXbOOF8Ldj34Q0n0PAOndhAoyoXkbSEfSPPoMZVPX/een7AEctO2xtdjJd Zp5sJAf2nFPD2vryyBdprvvZZalRhxW1z0L0stpfSyYgw1LpWLqAot0h9SY6pIpQ1r2L OdprGBbrXc1Br1Ffs01Vp4iSDr/3XUU8ZFQCtKwVscqfBCiSoCzO6iTvwKtm7vP8/ZVn RMLw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1721326257; x=1721931057; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=8pCHgXPwdofEeUcnJFoJ0zGjkLIgLDHlu6SJzfQ0KCg=; b=OqdKo0KQ31mloZg66HDiotStrQP/ONRwq4HOwZDkan0mMvQnygtdeG4ydAL50v4Z2N ntKh8aGjiZB4lJcMFbxgB9Qqhfgzn70L70s2sEbnWAf2/CSYWnyqi66mfIkb4EcM91lg ywjkknJzYjoIspAMnOScL21mvOUOkOOU6T8TRgzYTiGzyt9OAoNHXuLD4qb71HmjaiPW 67VwmD1b0AknrGfr9q2uJQFtlxVgo8fYxdfsrRbXnj/fW/mxzfOYN0pavWk/tq6dJAKo iATKlOfPuYsLGJqbHdnmd5oNo3Ykh33m4k3WtLe5Yrb1bCXf57QCgPLwle1jJwJWCl7s wrjg==
X-Forwarded-Encrypted: i=1; AJvYcCVT5ElzhT6GTHhhV4eFEpEl1csVYxuojyjgR0R8VMvhKycysVIypAyUryJ/2dYpDVTRzrymY9N01ywRP9Tl
X-Gm-Message-State: AOJu0YyAR56R2bzgSSGdUbGpx8cPDfT+4cWFi791r/HnTKadAFPeg/pf ZTj3i+rsNBZynM1gZ4/ztOe53Yjko3sRcGXlCI1SO36vCAGvz0wiL0ZQtV+WTulY0RFCL8oAmv8 F8Anm+mQunf32ixF8cl5R+SsXwOVEHOmEgGLKwQ==
X-Google-Smtp-Source: AGHT+IFda5xEptchEPAYWD0gWCiVMjJp6MqE20uhBmExY1LzScRcTtNy2+Lgcem6sTrjo8xxgLFsfIPyv6DK2ahnUdE=
X-Received: by 2002:a17:90b:485:b0:2c2:c149:ca4 with SMTP id 98e67ed59e1d1-2cb5295096emr4127179a91.43.1721326256963; Thu, 18 Jul 2024 11:10:56 -0700 (PDT)
MIME-Version: 1.0
References: <E2DFFA8E-9766-4CB4-BCAA-6897402B8FB2@insa-lyon.fr> <CABCOCHTxe+d6nhS_zQXvsQne4YXvwtMtdXxCecjSuBhvqvvWxg@mail.gmail.com> <184eb6b79c684428ac6d2d0b2c63ac1b@swisscom.com>
In-Reply-To: <184eb6b79c684428ac6d2d0b2c63ac1b@swisscom.com>
From: Andy Bierman <andy@yumaworks.com>
Date: Thu, 18 Jul 2024 11:10:46 -0700
Message-ID: <CABCOCHS==Qzvvo9yhrgFbDJjtQjZzrAg5-YpXau3BLajyHpjqg@mail.gmail.com>
To: Thomas.Graf@swisscom.com
Content-Type: multipart/alternative; boundary="00000000000016deed061d898035"
Message-ID-Hash: JCP2MBUBP2PKDW6T4KAA2ZTNT6UHYVJN
X-Message-ID-Hash: JCP2MBUBP2PKDW6T4KAA2ZTNT6UHYVJN
X-MailFrom: andy@yumaworks.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-core.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: alex.huang-feng@insa-lyon.fr, draft-ietf-core-comi@ietf.org, core@ietf.org, pierre.francois@insa-lyon.fr, vivekananda.boudia@insa-lyon.fr, benoit.claise@huawei.com
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [core] Re: Coreconf Notifications
List-Id: "Constrained RESTful Environments (CoRE) Working Group list" <core.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/core/njKv5EBkxkgE2kKEmZbtRNsviag>
List-Archive: <https://mailarchive.ietf.org/arch/browse/core>
List-Help: <mailto:core-request@ietf.org?subject=help>
List-Owner: <mailto:core-owner@ietf.org>
List-Post: <mailto:core@ietf.org>
List-Subscribe: <mailto:core-join@ietf.org>
List-Unsubscribe: <mailto:core-leave@ietf.org>
On Thu, Jul 18, 2024 at 10:35 AM <Thomas.Graf@swisscom.com> wrote: > Dear Andy, > > > > - The notification message defined in RFC 5277 is a conceptual > container that has an eventTime leaf and this event part > - that is modeled in YANG as child nodes. > > > > I haven't found a normative statement in any document supporting that. > Could you please point me. > > > Those words are not in the RFC. However an XSD for the XML representation of the Onw-Way Message is quite clear. > On top what Alex already wrote, what puzzles me and dares for an > explanation is that RFC 5277 is intended for Netconf > https://datatracker.ietf.org/doc/html/rfc5277#section-1, has been > specified prior to YANG, and has been intended in the previous netconf > working group charter > https://datatracker.ietf.org/doc/charter-ietf-netconf/19/ in section 5 to > be declared obsolete once netconf working group specified its successor > which is RFC 8639/8641 and a new notification structure. > > > The RFC 5277 message definition for XML needs to be adapted or changed for different protocols. NETCONF has only XML support. RFCs that claim to define more than that for NETCONF do not exist yet. RESTCONF has XML and JSON support. NETCONF and RESTCONF both use or adapt the RFC 5277 message, based on the XSD. Notifications over HTTP that are not RESTCONF need their own solution. Other protocols need their own solution. A fake module or a manual SID file could provide the 2 missing SIDs for the notification and eventTime nodes. The fake module name "ietf-restconf" only applies to RESTCONF JSON. The RFC 5277 XSD has no module-name only a namespace URI. IMO the WG is making this problem way too complicated. A simple RFC with simple hacks is needed, so everybody uses the same strings and SIDs. Best wishes > > Thomas > Andy > > > *From:* Andy Bierman <andy@yumaworks.com> > *Sent:* Thursday, July 18, 2024 9:06 AM > *To:* Alex Huang Feng <alex.huang-feng@insa-lyon.fr> > *Cc:* draft-ietf-core-comi@ietf.org; core@ietf.org; Pierre Francois < > pierre.francois@insa-lyon.fr>; Vivekananda Boudia < > vivekananda.boudia@insa-lyon.fr>; Graf Thomas, INI-NET-VNC-HCS < > Thomas.Graf@swisscom.com>; Benoit Claise <benoit.claise@huawei.com> > *Subject:* Re: Coreconf Notifications > > > > *Be aware:* This is an external email. > > > > > > > > On Thu, Jul 18, 2024 at 8:56 AM Alex Huang Feng < > alex.huang-feng@insa-lyon.fr> wrote: > > Dear authors and CORE WG, > > > > I have some questions regarding how YANG notifications are encoded in CBOR. > > > > I am co-authoring draft-ahuang-netconf-notif-yang-05 where we are defining > how NETCONF notifications are encoded in XML, JSON and CBOR. > > This definition is not explicit in JSON (RFC7951). > > > > Reading the YANG-CBOR (RFC9254) specification, the notifications are > encoded as a “container-like” instance. This is rather a different approach > from XML (RFC7950) and JSON (RFC7951) which to my understanding a leaf > “eventTime” needs to be present in the notification as defined in RFC5277. > > I am wondering why YANG-CBOR defined YANG notifications differently. I > don’t follow this WG closely but would love to hear the reasons which led > to the wording in RFC9254. (Or if more consistency with XML and JSON is > expected) > > > > For CORECONF, reading > https://datatracker.ietf.org/doc/html/draft-ietf-core-comi-17#name-notify-examples, > the notifications are also defined without the leaf defined in RFC5277 but > still references this RFC. > > > > > > > > YANG has the notification-stmt which only models the event part of the > notification message. > > The notification message defined in RFC 5277 is a conceptual container > that has an eventTime leaf and this event part > > that is modeled in YANG as child nodes. > > > > YANG-CBOR defines the mapping to the YANG notification-stmt, not any > conceptual protocol messages > > that are not defined in YANG. > > > > Andy > > > > > > > > > > We plan to use CBOR encoding with YANG-Push (RFC8641) to reduce the size > of the YANG-defined messages between the NETCONF server and client. > > In > https://datatracker.ietf.org/doc/html/draft-ahuang-netconf-notif-yang-05#name-cbor-structure we > define how we expect the CBOR message to be encoded. > > Having a similar approach to encode YANG notifications between JSON and > CBOR ease the development of some open-source projects, such as the > integration of YANG in the Kafka message broker. > > Here some references of such integration: > > - > https://datatracker.ietf.org/doc/html/draft-ietf-nmop-yang-message-broker-integration-03 > > - > https://github.com/network-analytics/draft-daisy-kafka-yang-integration/blob/main/schema-registry-yangkit-integration-02.pdf > > > > Note also that we request a .sid file for YANG-SIDs for compressed CBOR > messages in > https://datatracker.ietf.org/doc/html/draft-ahuang-netconf-notif-yang-05#appendix-A > . > > > > We will be onsite in Vancouver, so happy to have a live discussion > regarding these encoding mismatches. > > > > I think the integration of YANG and CBOR into Kafka might also be of > interest to the WG. > > Feel free to ping me back to have a discussion during the IETF week. We > will also be present at the Hackathon Saturday and Sunday. > > > > Regards, > > Alex > > > > > > > > > > > > > >
- [core] Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Thomas.Graf
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Thomas.Graf
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Alex Huang Feng
- [core] Re: Coreconf Notifications Carsten Bormann
- [core] Re: Coreconf Notifications Andy Bierman
- [core] Re: Coreconf Notifications Henk Birkholz