[dnsext] IPN RRTYPE application
Scott Johnson <scott@spacelypackets.com> Sat, 20 April 2024 21:32 UTC
Return-Path: <scott@spacelypackets.com>
X-Original-To: dnsext@ietfa.amsl.com
Delivered-To: dnsext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 5D5BEC14F6FD for <dnsext@ietfa.amsl.com>; Sat, 20 Apr 2024 14:32:41 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.896
X-Spam-Level:
X-Spam-Status: No, score=-6.896 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_HI=-5, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id lfJYUwHTYC2D for <dnsext@ietfa.amsl.com>; Sat, 20 Apr 2024 14:32:37 -0700 (PDT)
Received: from www.spacelypackets.com (www.spacelypackets.com [IPv6:2602:fdf2:bee:feed::ee]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-256) server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 7F47BC14F5EB for <dnsext@ietf.org>; Sat, 20 Apr 2024 14:32:37 -0700 (PDT)
Received: from scott (helo=localhost) by www.spacelypackets.com with local-esmtp (Exim 4.96) (envelope-from <scott@spacelypackets.com>) id 1ryIIu-00041L-0Y; Sat, 20 Apr 2024 21:31:24 +0000
Date: Sat, 20 Apr 2024 21:31:24 +0000
From: Scott Johnson <scott@spacelypackets.com>
To: dnsext@ietf.org
Message-ID: <13cc6bb5-c720-b2db-6cfd-9485b44c8079@spacelypackets.com>
MIME-Version: 1.0
Content-Type: text/plain; format="flowed"; charset="US-ASCII"
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsext/JJSE1r85WAVNA8TPRR68PSC4hYE>
Subject: [dnsext] IPN RRTYPE application
X-BeenThere: dnsext@ietf.org
X-Mailman-Version: 2.1.39
Precedence: list
List-Id: DNS Extensions working group discussion list <dnsext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/dnsext>, <mailto:dnsext-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsext/>
List-Post: <mailto:dnsext@ietf.org>
List-Help: <mailto:dnsext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/dnsext>, <mailto:dnsext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 20 Apr 2024 21:32:41 -0000
Hi DNS Friends,
Please find below a draft application for a new RRTYPE for your review and
feedback prior to formal submission of the application . Thanks in
advance for your consideration.
Sincerely,
Scott Johnson
---------------------------------------------------------------------------
DNS RRTYPE PARAMETER ALLOCATION TEMPLATE
When ready for formal consideration, this template is to be submitted
to IANA for processing by emailing the template to dns-rrtype-
applications@ietf.org.
A. Submission Date:
B.1 Submission Type: [X] New RRTYPE [ ] Modification to RRTYPE
B.2 Kind of RR: [X] Data RR [ ] Meta-RR
C. Contact Information for submitter (will be publicly posted):
Name: Scott M. Johnson Email Address: scott@spacelypackets.com
International telephone number: +13868887311
Other contact handles:
D. Motivation for the new RRTYPE application.
Bundle Protocol (RFC 9171), specifies the "ipn" URI scheme
(section 4.2.5.1.2) for use in naming nodes in Delay and
Disruption Tolerant Networks (DTNs). This URI scheme is widely
deployed among DTNs, and would benefit from having the capability
to look up CBHE the Node Number (node-nbr) component (or successor
standard) for a given node based on a domain name.
https://www.iana.org/assignments/bundle/bundle.xhtml#cbhe-node-numbers
E. Description of the proposed RR type.
A record using the proposed RRTYPE would consist of one 64 bit
integer, representing the CBHE Node Number component of the "ipn"
URI of a given DTN node (RFC 7116), encoded in US-ASCII. Future
amendments to the "ipn" URI scheme may modify the Node Number data
structure, but given that the RRTYPE is to be processed as an
"unknown RRTYPE" these amendments will be irrelevant to nameserver
operation.
F. What existing RRTYPE or RRTYPEs come closest to filling that need
and why are they unsatisfactory?
There are many RRTYPES which are similar and complementary in
function to the proposed new RRTYPE, such as A, AAAA, X25 or ISDN.
These are unsatisfactory due to incompatible data structures and
the desire for disambiguity in the use of a particular RRTYPE.
G. What mnemonic is requested for the new RRTYPE (optional)?
IPN
H. Does the requested RRTYPE make use of any existing IANA registry
or require the creation of a new IANA subregistry in DNS
Parameters?
Other than the addition of the IPN RRTYPE to the existing
"Resource Record (RR) TYPEs" IANA Registry, no modifications
are required.
I. Does the proposal require/expect any changes in DNS
servers/resolvers that prevent the new type from being processed
as an unknown RRTYPE (see [RFC3597])?
No.
J. Comments:
---------------------------------------------------------------------------
- [dnsext] IPN RRTYPE application Scott Johnson