[dnsext] [IANA #1363508] [Errata Verified] RFC3445 (7836)

David Dong via RT <iana-matrix-comment@iana.org> Sat, 11 May 2024 00:30 UTC

Return-Path: <iana-shared@icann.org>
X-Original-To: dnsext@ietfa.amsl.com
Delivered-To: dnsext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 0F949C1DA2D8; Fri, 10 May 2024 17:30:06 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.626
X-Spam-Level:
X-Spam-Status: No, score=-0.626 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HEADER_FROM_DIFFERENT_DOMAINS=0.249, MISSING_HEADERS=1.021, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=no autolearn_force=no
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id b-oBYWqK4Jdv; Fri, 10 May 2024 17:30:01 -0700 (PDT)
Received: from smtp.lax.icann.org (smtp.lax.icann.org [IPv6:2620:0:2d0:201::1:81]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id B0C7BC1DA2C9; Fri, 10 May 2024 17:30:01 -0700 (PDT)
Received: from request6.lax.icann.org (request1.lax.icann.org [10.32.11.221]) by smtp.lax.icann.org (Postfix) with ESMTP id BB7A3E2338; Sat, 11 May 2024 00:30:00 +0000 (UTC)
Received: by request6.lax.icann.org (Postfix, from userid 48) id B86F14E30B; Sat, 11 May 2024 00:30:00 +0000 (UTC)
RT-Owner: david.dong
From: David Dong via RT <iana-matrix-comment@iana.org>
In-Reply-To: <rt-5.0.3-1273370-1714597076-1875.1363508-9-0@icann.org>
References: <RT-Ticket-1363508@icann.org> <20240423140357.CED5A11FDEC@rfcpa.amsl.com> <rt-5.0.3-1273370-1714597076-1875.1363508-9-0@icann.org>
Message-ID: <rt-5.0.3-118903-1715387400-599.1363508-9-0@icann.org>
X-RT-Loop-Prevention: IANA
X-RT-Ticket: IANA #1363508
X-Managed-BY: RT 5.0.3 (http://www.bestpractical.com/rt/)
X-RT-Originator: david.dong@iana.org
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
X-RT-Original-Encoding: utf-8
Precedence: bulk
Date: Sat, 11 May 2024 00:30:00 +0000
MIME-Version: 1.0
Message-ID-Hash: FCRK6ENDC5TCLONWFF7MY45IKGO7SVO3
X-Message-ID-Hash: FCRK6ENDC5TCLONWFF7MY45IKGO7SVO3
X-MailFrom: iana-shared@icann.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dnsext.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: evyncke@cisco.com, scott.rose@nist.gov, masseyd@isi.edu, iesg@ietf.org, dnsext@ietf.org
X-Mailman-Version: 3.3.9rc4
Reply-To: iana-matrix-comment@iana.org
Subject: [dnsext] [IANA #1363508] [Errata Verified] RFC3445 (7836)
List-Id: DNS Extensions working group discussion list <dnsext.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsext/_R4b5XZ7FF0VSGzqVb8qwp7jwFM>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsext>
List-Help: <mailto:dnsext-request@ietf.org?subject=help>
List-Owner: <mailto:dnsext-owner@ietf.org>
List-Post: <mailto:dnsext@ietf.org>
List-Subscribe: <mailto:dnsext-join@ietf.org>
List-Unsubscribe: <mailto:dnsext-leave@ietf.org>

Hi Eric,

Following up; there are two references to RFC 2931 in https://www.iana.org/assignments/dns-parameters/ (by the SIG RR record); do we need to update any of these references?

Thank you

Best regards,

David Dong
IANA Services Sr. Specialist

On Wed May 01 20:57:56 2024, david.dong wrote:
> Hi Eric,
> 
> There are two references to RFC 2931 in
> https://www.iana.org/assignments/dns-parameters/ (by the SIG RR
> record); do we need to update any of these references?
> 
> Thank you
> 
> Best regards,
> 
> David Dong
> IANA Services Sr. Specialist
> 
> On Tue Apr 23 14:04:20 2024, rfc-editor@rfc-editor.org wrote:
> > The following errata report has been verified for RFC3445,
> >  "Limiting the Scope of the KEY Resource Record (RR)".
> >
> > --------------------------------------
> > You may review the report below and at:
> > https://www.rfc-editor.org/errata/eid7836
> >
> > --------------------------------------
> > Status: Verified
> > Type: Technical
> >
> > Reported by: Ted Lemon <mellon@fugue.com>
> > Date Reported: 2024-03-04
> > Verified by: Eric Vyncke (IESG)
> >
> > Section: GLOBAL
> >
> > Original Text
> > -------------
> > Updates: RFC2535
> >
> > Corrected Text
> > --------------
> > Updates: RFC2535, RFC2931
> >
> > Notes
> > -----
> > This is based on our experience that when writing draft-ietf-dnssd-
> > srp, we had no idea that the KEY RR format was updated, because there
> > was no reference to the updated format in the datatracker page for
> > RFC2931. I think it makes sense to say that 3445 updates 2931,
> > because
> > it does so explicitly.
> >
> > -- Verifier (Eric Vyncke) note --
> > See also
> > https://mailarchive.ietf.org/arch/msg/dnsext/bSBYA97VQItwQS26fpVdQocrvnA/
> >
> > I will request the IETF secretariat to update the datatracker.
> >
> > --------------------------------------
> > RFC3445 (draft-ietf-dnsext-restrict-key-for-dnssec-04)
> > --------------------------------------
> > Title               : Limiting the Scope of the KEY Resource Record
> > (RR)
> > Publication Date    : December 2002
> > Author(s)           : D. Massey, S. Rose
> > Category            : PROPOSED STANDARD
> > Source              : DNS Extensions
> > Stream              : IETF
> > Verifying Party     : IESG