Re: [DNSOP] Anycast and DNS questions

Joe Abley <jabley@hopcount.ca> Wed, 06 August 2014 14:15 UTC

Return-Path: <jabley@hopcount.ca>
X-Original-To: dnsop@ietfa.amsl.com
Delivered-To: dnsop@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C2C7F1A01F1 for <dnsop@ietfa.amsl.com>; Wed, 6 Aug 2014 07:15:34 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.001
X-Spam-Level:
X-Spam-Status: No, score=-4.001 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, GB_I_LETTER=-2, SPF_PASS=-0.001] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 12mXuQQRBN2d for <dnsop@ietfa.amsl.com>; Wed, 6 Aug 2014 07:15:28 -0700 (PDT)
Received: from mail-ig0-x22a.google.com (mail-ig0-x22a.google.com [IPv6:2607:f8b0:4001:c05::22a]) (using TLSv1 with cipher ECDHE-RSA-RC4-SHA (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 6FE871B2A8F for <dnsop@ietf.org>; Wed, 6 Aug 2014 07:15:27 -0700 (PDT)
Received: by mail-ig0-f170.google.com with SMTP id h3so10448417igd.1 for <dnsop@ietf.org>; Wed, 06 Aug 2014 07:15:26 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=hopcount.ca; s=google; h=date:from:to:message-id:in-reply-to:references:subject:mime-version :content-type:content-transfer-encoding:content-disposition; bh=4E9ceCBpdSs+/pDz+HMghJytRkKL6LJ7tnjx0VMuXBM=; b=mADP7sOvGHudbr1HPTWLSTBjrJB/o1M0oUD+DNpJSlsuX9CQqGURpZyxuj/rJiMKI9 Vmn3MTM/NNQL1SB86TXtXZCb2hCyTpovpiUHAvA06SprMu/0D3kCmxWOQLVcQJRX8+6o 2uJcQ3uYHnJyfH5eZd11OFcxa5VnPQG89EzvI=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:date:from:to:message-id:in-reply-to:references :subject:mime-version:content-type:content-transfer-encoding :content-disposition; bh=4E9ceCBpdSs+/pDz+HMghJytRkKL6LJ7tnjx0VMuXBM=; b=bvyEBJ1DNge8fLqHniudSKKAsWxZZGdIIwK05ddG+tEftlU8Uh61cjqwhZAQS9jp9l p9cb6J2q2Nnuqirmg7bbw/Nl/VqrA6xhq/W0nfeFrQs0/1Ely8Hzhy5JvNralQ9o1f8y +Y+c/2rAjdGQ/fePGGLG/AKRJpW1wAwLSPIhGVogO+rDtMOYVPBhng8Va3YxuW1g1jFb egAq5bs0XuFoMpJ6z381hfxjGvqJ8lwdFkAgyvFpoODdRcHKA8VoiEmuSkeHex6729d+ FxZiWzo0z7v5W72TZll6zLLDouqFwl9v4wTzVd/45FCiq0+6tApeBdwH9mhLoxQUFgVM Tkzg==
X-Gm-Message-State: ALoCoQmfE2ySK9Qo9CUCxi0bbxw2w8Be8G5I46JY3oqacrzIQexU4bIHJlXBkqAz/tJH5O5ADOdU
X-Received: by 10.42.35.8 with SMTP id o8mr15320247icd.41.1407334526679; Wed, 06 Aug 2014 07:15:26 -0700 (PDT)
Received: from walrus.hopcount.ca (dhcp66.calod3a.shl.io. [199.212.92.66]) by mx.google.com with ESMTPSA id o9sm8046388igv.18.2014.08.06.07.15.25 for <multiple recipients> (version=TLSv1.2 cipher=ECDHE-RSA-RC4-SHA bits=128/128); Wed, 06 Aug 2014 07:15:26 -0700 (PDT)
Date: Wed, 06 Aug 2014 10:15:24 -0400
From: Joe Abley <jabley@hopcount.ca>
To: "Patrick W. Gilmore" <patrick@ianai.net>, "dnsop@ietf.org" <dnsop@ietf.org>
Message-ID: <etPan.53e2387c.628c895d.d8c2@walrus.hopcount.ca>
In-Reply-To: <25907D96-0076-417A-8DB9-41A5A178D479@ianai.net>
References: <20140806114759.GF5546@cisco.com> <25907D96-0076-417A-8DB9-41A5A178D479@ianai.net>
X-Mailer: Airmail (247)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline
Archived-At: http://mailarchive.ietf.org/arch/msg/dnsop/_qF6A6g4IoNeeqtehMHCgHKqqF0
Subject: Re: [DNSOP] Anycast and DNS questions
X-BeenThere: dnsop@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: IETF DNSOP WG mailing list <dnsop.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/dnsop>, <mailto:dnsop-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/dnsop/>
List-Post: <mailto:dnsop@ietf.org>
List-Help: <mailto:dnsop-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/dnsop>, <mailto:dnsop-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 06 Aug 2014 14:15:35 -0000

On 6 August 2014 at 8:10:25, Patrick W. Gilmore (patrick@ianai.net) wrote:

> Composed on a virtual keyboard, please forgive typos.
> 
> On Aug 6, 2014, at 7:47, Toerless Eckert wrote:
> >
> > Sorry, haven't been following this group for a long time, so
> > please excuse if answers to these questions have been discussed in before:
> >
> > a) What documents beside RFC3258 are describing any uses/procedures
> > for having DNS servers use an anycast address to receive and respond to
> > requests ?
> 
> Dunno, but something tells me a quick BING search would return millions of answers.

I've written some stuff:

RFC 4786 has some general advice
ISC-TN-2003-1 and ISC-TN-2004-1 were mainly written with F-Root in mind
https://www.usenix.org/legacy/publications/login/2008-02/openpdfs/abley.pdf
https://www.nanog.org/meetings/nanog34/presentations/abley.nameservers.pdf

> > b) How common are deployments in which the information returned by different
> > anycast member DNS servers for the same query would be different,
> > aka: to "localize" lookup results, such as pointing to
> > local CDN caches or the like ? What would be the most well known examples
> > of such deployed instances ? Any IETF documents describing this ? Any
> > rules to follow ?
> 
> Common? Ridiculously so, for at least 20 years.
> 
> Well known examples? CDNs, as you already mentioned. E.g. LLNW.

Various commercial DNS services do this (e.g. Dyn does this). I'm not aware of any documentation produced in the IETF beyond the base DNS specification (which doesn't talk about anycast, but does talk about the loose coherence between sibling authority servers and between caching resolvers and authority servers).

It's not obvious to me whether pool.ntp.org does this. I think the geo focus there is pulled in the QNAME, and the RRSets in the response are near-consistent across the authority set at query time (but the response sets vary with time, according to performance of the target NTP servers). But you could ask Ask. I bet he never gets tired of people saying that.

> > c) Any example in which the DNS servers utilizing a single shared
> > IP address (anycast address) are run by different operators ? Any
> > documents describing this ? (RFC3258 seems to focus on single operator
> > anycast group of DNS servers.
> 
> How about the root servers?

Root servers are not an example of that: each letter is run by a single organisation and each letter has a set of service addresses that are unique to that letter.

AS112 is a better example (see RFC 6304, http://www.as112.net/)


Joe