[DNSOP] Mike Bishop's No Objection on draft-ietf-dnsop-must-not-sha1-06: (with COMMENT)

Mike Bishop via Datatracker <noreply@ietf.org> Mon, 19 May 2025 16:33 UTC

Return-Path: <noreply@ietf.org>
X-Original-To: dnsop@ietf.org
Delivered-To: dnsop@mail2.ietf.org
Received: from [10.244.8.226] (unknown [104.131.183.230]) by mail2.ietf.org (Postfix) with ESMTP id 8217C2A4F391; Mon, 19 May 2025 09:33:51 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Mike Bishop via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
X-Test-IDTracker: no
X-IETF-IDTracker: 12.40.0
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <174767243139.310160.5719310416177616736@dt-datatracker-59b84fc74f-84jsl>
Date: Mon, 19 May 2025 09:33:51 -0700
Message-ID-Hash: KHODGSEV2QFBCKKWCGPNGVENN3VN57PP
X-Message-ID-Hash: KHODGSEV2QFBCKKWCGPNGVENN3VN57PP
X-MailFrom: noreply@ietf.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-dnsop.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: draft-ietf-dnsop-must-not-sha1@ietf.org, dnsop-chairs@ietf.org, dnsop@ietf.org, tjw.ietf@gmail.com
X-Mailman-Version: 3.3.9rc6
Reply-To: Mike Bishop <mbishop@evequefou.be>
Subject: [DNSOP] Mike Bishop's No Objection on draft-ietf-dnsop-must-not-sha1-06: (with COMMENT)
List-Id: IETF DNSOP WG mailing list <dnsop.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/dnsop/aZpVGNLxHGs9QEH40KFEV7R3s5Y>
List-Archive: <https://mailarchive.ietf.org/arch/browse/dnsop>
List-Help: <mailto:dnsop-request@ietf.org?subject=help>
List-Owner: <mailto:dnsop-owner@ietf.org>
List-Post: <mailto:dnsop@ietf.org>
List-Subscribe: <mailto:dnsop-join@ietf.org>
List-Unsubscribe: <mailto:dnsop-leave@ietf.org>

Mike Bishop has entered the following ballot position for
draft-ietf-dnsop-must-not-sha1-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-must-not-sha1/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 1:

The current phrasing of the second sentence in the Introduction suggests that
the use of SHA-1 by DNSSEC is an example of its diminishing security; I suspect
that's not the intended reading.

CURRENT: DNSSEC [RFC9364] originally [RFC3110] made extensive use of SHA-1 as a
cryptographic hash algorithm in RRSIG and Delegation Signer (DS) records, for
example. CONSIDER: DNSSEC [RFC9364] originally [RFC3110] made extensive use of
SHA-1, for example as a cryptographic hash algorithm in RRSIG and Delegation
Signer (DS) records.

"are now" => "have become"

Section 2:

"MAY wish to" requires an RFC6919 reference (see
https://datatracker.ietf.org/doc/html/rfc6919#section-6) and associated
boilerplate. Instead, "MAY" is sufficient here. However, that seems in direct
contradiction to the MUST in the first sentence. Is the intended sense here
that implementations MUST retain the ability to validate, but SHOULD/MAY
disable it by default?