Re: [Hipsec] Adding CMAC and GMAC to 5202-bis

"Henderson, Thomas R" <thomas.r.henderson@boeing.com> Tue, 12 November 2013 17:57 UTC

Return-Path: <thomas.r.henderson@boeing.com>
X-Original-To: hipsec@ietfa.amsl.com
Delivered-To: hipsec@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B4FC611E811B for <hipsec@ietfa.amsl.com>; Tue, 12 Nov 2013 09:57:31 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -106.599
X-Spam-Level:
X-Spam-Status: No, score=-106.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, RCVD_IN_DNSWL_MED=-4, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id GjvQzYOZ0zA6 for <hipsec@ietfa.amsl.com>; Tue, 12 Nov 2013 09:57:14 -0800 (PST)
Received: from stl-mbsout-02.boeing.com (stl-mbsout-02.boeing.com [130.76.96.170]) by ietfa.amsl.com (Postfix) with ESMTP id C193711E80E4 for <hipsec@ietf.org>; Tue, 12 Nov 2013 09:57:14 -0800 (PST)
Received: from stl-mbsout-02.boeing.com (localhost.localdomain [127.0.0.1]) by stl-mbsout-02.boeing.com (8.14.4/8.14.4/DOWNSTREAM_MBSOUT) with ESMTP id rACHvD2h013070 for <hipsec@ietf.org>; Tue, 12 Nov 2013 11:57:13 -0600
Received: from XCH-PHX-409.sw.nos.boeing.com (xch-phx-409.sw.nos.boeing.com [10.57.37.40]) by stl-mbsout-02.boeing.com (8.14.4/8.14.4/UPSTREAM_MBSOUT) with ESMTP id rACHvCIj013023 (version=TLSv1/SSLv3 cipher=AES128-SHA bits=128 verify=OK); Tue, 12 Nov 2013 11:57:12 -0600
Received: from XCH-BLV-104.nw.nos.boeing.com ([169.254.4.229]) by XCH-PHX-409.sw.nos.boeing.com ([169.254.9.131]) with mapi id 14.03.0158.001; Tue, 12 Nov 2013 09:57:11 -0800
From: "Henderson, Thomas R" <thomas.r.henderson@boeing.com>
To: 'Robert Moskowitz' <rgm@htt-consult.com>, HIP <hipsec@ietf.org>
Thread-Topic: [Hipsec] Adding CMAC and GMAC to 5202-bis
Thread-Index: AQHO1XtvMmTWCSl/eUS/dlcSoxsK55oh9OyA
Date: Tue, 12 Nov 2013 17:57:11 +0000
Message-ID: <C018CAF7B620E64D87620E581C4E6BB905BAFB@XCH-BLV-104.nw.nos.boeing.com>
References: <527115EC.4060608@htt-consult.com>
In-Reply-To: <527115EC.4060608@htt-consult.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [130.247.104.6]
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
X-TM-AS-MML: disable
Subject: Re: [Hipsec] Adding CMAC and GMAC to 5202-bis
X-BeenThere: hipsec@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: "This is the official IETF Mailing List for the HIP Working Group." <hipsec.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/hipsec>, <mailto:hipsec-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/hipsec>
List-Post: <mailto:hipsec@ietf.org>
List-Help: <mailto:hipsec-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/hipsec>, <mailto:hipsec-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 12 Nov 2013 17:57:31 -0000

> -----Original Message-----
> From: hipsec-bounces@ietf.org [mailto:hipsec-bounces@ietf.org] On
> Behalf Of Robert Moskowitz
> Sent: Wednesday, October 30, 2013 7:22 AM
> To: HIP
> Subject: [Hipsec] Adding CMAC and GMAC to 5202-bis
> 
> We added the 'modern' modes:  CCM and GCM to 5202-bis, but left out the
> authentication only modes.  Thus I propose adding to sec 5.1.2:
> 
>   AES-CMAC-96         14              [RFC4493], [RFC4494]
>   AES-GMAC              15              [RFC4543]
> 
> If you have CCM in your implementation, it makes sense to offer CMAC,
> and likewise GCM/GMAC.
> 
> If there is no down votes on this, Tom said he would add them.

I will plan to add these on Friday if there are no further comments.

> 
> 
> There is JUST one MINOR point about manditory to implement, also in sec
> 5.1.2.
> 
> Keep it as is, or change it two either CCM or GCM?  I can argue this
> all ways around.  I suspect that sensor implementations may well ignore
> the manditory and just do CCM.
> 

I will keep as is in the next revision, unless there is support voiced for changing it.  Current statement is:

   Mandatory implementations: AES-128-CBC with HMAC-SHA-256 and NULL
   with HMAC-SHA-256.

Rene also pointed out in his reviews that the current spec set may need to be slightly modified to accommodate sensor requirements, but I believe that we decided to leave those for further study/specification.

- Tom