Return-Path: <ietf-http-wg-request+bounce-httpbisa-archive-bis2juki=lists.ie@listhub.w3.org>
X-Original-To: ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com
Delivered-To: ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1])
 by ietfa.amsl.com (Postfix) with ESMTP id E03901A1B69
 for <ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com>;
 Fri, 27 Mar 2015 19:51:09 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.289
X-Spam-Level: 
X-Spam-Status: No, score=-6.289 tagged_above=-999 required=5
 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
 FM_FORGED_GMAIL=0.622, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_HI=-5,
 SPF_HELO_PASS=-0.001, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01]
 autolearn=ham
Received: from mail.ietf.org ([4.31.198.44])
 by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
 with ESMTP id Z9AKm72AUz7A
 for <ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com>;
 Fri, 27 Mar 2015 19:51:06 -0700 (PDT)
Received: from frink.w3.org (frink.w3.org [128.30.52.56])
 (using TLSv1.2 with cipher DHE-RSA-AES128-SHA (128/128 bits))
 (No client certificate requested)
 by ietfa.amsl.com (Postfix) with ESMTPS id BAED61A1B64
 for <httpbisa-archive-bis2Juki@lists.ietf.org>;
 Fri, 27 Mar 2015 19:51:06 -0700 (PDT)
Received: from lists by frink.w3.org with local (Exim 4.80)
 (envelope-from <ietf-http-wg-request@listhub.w3.org>)
 id 1YbgmP-0001Pw-ND
 for ietf-http-wg-dist@listhub.w3.org; Sat, 28 Mar 2015 02:47:21 +0000
Resent-Date: Sat, 28 Mar 2015 02:47:21 +0000
Resent-Message-Id: <E1YbgmP-0001Pw-ND@frink.w3.org>
Received: from lisa.w3.org ([128.30.52.41])
 by frink.w3.org with esmtp (Exim 4.80)
 (envelope-from <phluid61@gmail.com>) id 1YbgmE-0001P6-U6
 for ietf-http-wg@listhub.w3.org; Sat, 28 Mar 2015 02:47:10 +0000
Received: from mail-oi0-f43.google.com ([209.85.218.43])
 by lisa.w3.org with esmtps (TLS1.0:RSA_ARCFOUR_SHA1:16) (Exim 4.72)
 (envelope-from <phluid61@gmail.com>) id 1YbgmC-0002de-Kd
 for ietf-http-wg@w3.org; Sat, 28 Mar 2015 02:47:10 +0000
Received: by oifl3 with SMTP id l3so90837460oif.0
 for <ietf-http-wg@w3.org>; Fri, 27 Mar 2015 19:46:42 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;
 h=mime-version:sender:in-reply-to:references:date:message-id:subject
 :from:to:cc:content-type;
 bh=7FMg5acbwCESNsJ8SHiELRQZed10KDNUp5ZMWAedQq0=;
 b=eyOE+TlCUrfjM9DNitXWoZymUqkTq1JGikXVrihC5b2thvHh2hFV1mVbjr4tJC021s
 tXermEszXvnXdVz2PEkb9skOaANgBAK2LtMFPvuPzTc/12iQ577qkYgzZvum9s+BcI4z
 y3D6YFONwssAB3aOWFrqI14Rmm9IooCMtZUjkPWqpXZgYfsJW+u3dYPqZBN/4nl9C+MN
 DQpBMxcXYebONyzlIbIsZZAALW0MBFKtHh6NQECda9oWbeBMcZe4vUCQ7e4jXSR/R2J8
 IDVM/uy+6egSwJmO66rScD4ItL+aGi4Idhw7YZByg2mFFJUqNXEEY1WsCM2e8nRR5cUc
 Sx4g==
MIME-Version: 1.0
X-Received: by 10.182.236.196 with SMTP id uw4mr18506989obc.41.1427510802650; 
 Fri, 27 Mar 2015 19:46:42 -0700 (PDT)
Sender: phluid61@gmail.com
Received: by 10.202.178.3 with HTTP; Fri, 27 Mar 2015 19:46:42 -0700 (PDT)
In-Reply-To: <CABkgnnW1hR=utRNAYJhYDLtQiofAjdCYj1UQyC13duNMmOA5Ng@mail.gmail.com>
References: <5515D627.1000106@brendanlong.com>
 <CABkgnnW1hR=utRNAYJhYDLtQiofAjdCYj1UQyC13duNMmOA5Ng@mail.gmail.com>
Date: Sat, 28 Mar 2015 12:46:42 +1000
X-Google-Sender-Auth: ID9d77JIaaqH8s0FRTnLNzvpU1U
Message-ID: <CACweHNDyy14A4yRkbUqRgY0fu8t-G46B5q2GDQgEEeYnXYCuDw@mail.gmail.com>
From: Matthew Kerwin <matthew@kerwin.net.au>
To: Martin Thomson <martin.thomson@gmail.com>
Cc: Brendan Long <self@brendanlong.com>,
 HTTP Working Group <ietf-http-wg@w3.org>
Content-Type: multipart/alternative; boundary=001a11c300ee4e1d7e05125042aa
Received-SPF: pass client-ip=209.85.218.43; envelope-from=phluid61@gmail.com;
 helo=mail-oi0-f43.google.com
X-W3C-Hub-Spam-Status: No, score=-4.2
X-W3C-Hub-Spam-Report: AWL=-1.728, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
 FREEMAIL_ENVFROM_END_DIGIT=0.25, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001,
 RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001, W3C_AA=-1, W3C_WL=-1
X-W3C-Scan-Sig: lisa.w3.org 1YbgmC-0002de-Kd 03111e7c433e1dfbb2b6997eee537ae7
X-Original-To: ietf-http-wg@w3.org
Subject: Re: "Timeout" request header to tell server to wait for resource to
 become available
Archived-At: <http://www.w3.org/mid/CACweHNDyy14A4yRkbUqRgY0fu8t-G46B5q2GDQgEEeYnXYCuDw@mail.gmail.com>
Resent-From: ietf-http-wg@w3.org
X-Mailing-List: <ietf-http-wg@w3.org> archive/latest/29044
X-Loop: ietf-http-wg@w3.org
Resent-Sender: ietf-http-wg-request@w3.org
Precedence: list
List-Id: <ietf-http-wg.w3.org>
List-Help: <http://www.w3.org/Mail/>
List-Post: <mailto:ietf-http-wg@w3.org>
List-Unsubscribe: <mailto:ietf-http-wg-request@w3.org?subject=unsubscribe>

--001a11c300ee4e1d7e05125042aa
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

On 28 March 2015 at 11:46, Martin Thomson <martin.thomson@gmail.com> wrote:

>
> I believe that what you want is accomplished by RFC 7240:
>
> Prefer: wait=3D5
>
> The units are perhaps suboptimal for your use case (seconds instead of
> milliseconds), but we might be able to make a change to support finer
> grained timing.
>
>
Incidentally, I've just found an erratum in RFC 7240: Section 1.1 says that
"delta-seconds" is defined in Section 8.1.3 of [RFC7231], but it's actually
in RFC 7234, Section-1.2.1. =E2=80=8BI'll report it.

Regarding extending/modifying the header to accept sub-second timings, how
would current implementations treat:

    Prefer: wait=3D0.2

? It doesn't fit the syntax, so would it be ignored outright (as an
unrecognised header) most of the time?

Cheers
--=20
  Matthew Kerwin
  http://matthew.kerwin.net.au/

--001a11c300ee4e1d7e05125042aa
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div class=3D"gmail_default" style=3D"font-family:georgia,=
serif;color:rgb(7,55,99)"><br></div><div class=3D"gmail_extra"><br><div cla=
ss=3D"gmail_quote">On 28 March 2015 at 11:46, Martin Thomson <span dir=3D"l=
tr">&lt;<a href=3D"mailto:martin.thomson@gmail.com" target=3D"_blank">marti=
n.thomson@gmail.com</a>&gt;</span> wrote:<br><blockquote class=3D"gmail_quo=
te" style=3D"margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-col=
or:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><br>
I believe that what you want is accomplished by RFC 7240:<br>
<br>
Prefer: wait=3D5<br>
<br>
The units are perhaps suboptimal for your use case (seconds instead of<br>
milliseconds), but we might be able to make a change to support finer<br>
grained timing.<br>
<br>
</blockquote></div><div class=3D"gmail_extra"><br></div><div class=3D"gmail=
_default" style=3D"font-family:georgia,serif;color:rgb(7,55,99)">Incidental=
ly, I&#39;ve just found an erratum in RFC 7240: Section 1.1 says that &quot=
;delta-seconds&quot; is defined in Section 8.1.3 of [RFC7231], but it&#39;s=
 actually in=C2=A0RFC 7234, Section-1.2.1. =E2=80=8BI&#39;ll report it.</di=
v><div class=3D"gmail_default" style=3D"font-family:georgia,serif;color:rgb=
(7,55,99)"><br></div><div class=3D"gmail_default" style=3D"font-family:geor=
gia,serif;color:rgb(7,55,99)">Regarding extending/modifying the header to a=
ccept sub-second timings, how would current implementations treat:</div><di=
v class=3D"gmail_default" style=3D"font-family:georgia,serif;color:rgb(7,55=
,99)"><br></div><div class=3D"gmail_default" style=3D"font-family:georgia,s=
erif;color:rgb(7,55,99)">=C2=A0 =C2=A0 Prefer: wait=3D0.2</div><div class=
=3D"gmail_default" style=3D"font-family:georgia,serif;color:rgb(7,55,99)"><=
br></div><div class=3D"gmail_default" style=3D"font-family:georgia,serif;co=
lor:rgb(7,55,99)">? It doesn&#39;t fit the syntax, so would it be ignored o=
utright (as an unrecognised header) most of the time?</div><div class=3D"gm=
ail_default" style=3D"font-family:georgia,serif;color:rgb(7,55,99)"><br></d=
iv><div class=3D"gmail_default" style=3D"font-family:georgia,serif;color:rg=
b(7,55,99)">Cheers</div>-- <br><div class=3D"gmail_signature"><div dir=3D"l=
tr">=C2=A0 Matthew Kerwin<br>=C2=A0 <a href=3D"http://matthew.kerwin.net.au=
/" target=3D"_blank">http://matthew.kerwin.net.au/</a></div></div>
</div></div>

--001a11c300ee4e1d7e05125042aa--

