Re: feedback on draft-murchison-webdav-prefer-09
Julian Reschke <julian.reschke@gmx.de> Mon, 14 November 2016 22:13 UTC
Return-Path: <ietf-http-wg-request+bounce-httpbisa-archive-bis2juki=lists.ie@listhub.w3.org>
X-Original-To: ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com
Delivered-To: ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id AB4151295B7 for <ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com>; Mon, 14 Nov 2016 14:13:01 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -8.398
X-Spam-Level:
X-Spam-Status: No, score=-8.398 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HEADER_FROM_DIFFERENT_DOMAINS=0.001, RCVD_IN_DNSWL_HI=-5, RP_MATCHES_RCVD=-1.497, SPF_HELO_PASS=-0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id xJZCC-4awfCE for <ietfarch-httpbisa-archive-bis2Juki@ietfa.amsl.com>; Mon, 14 Nov 2016 14:13:00 -0800 (PST)
Received: from frink.w3.org (frink.w3.org [128.30.52.56]) (using TLSv1.2 with cipher DHE-RSA-AES128-SHA (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 4A1981295D6 for <httpbisa-archive-bis2Juki@lists.ietf.org>; Mon, 14 Nov 2016 14:13:00 -0800 (PST)
Received: from lists by frink.w3.org with local (Exim 4.80) (envelope-from <ietf-http-wg-request@listhub.w3.org>) id 1c6PRN-0005iJ-OK for ietf-http-wg-dist@listhub.w3.org; Mon, 14 Nov 2016 22:09:25 +0000
Resent-Date: Mon, 14 Nov 2016 22:09:25 +0000
Resent-Message-Id: <E1c6PRN-0005iJ-OK@frink.w3.org>
Received: from mimas.w3.org ([128.30.52.79]) by frink.w3.org with esmtps (TLS1.2:RSA_AES_128_CBC_SHA1:128) (Exim 4.80) (envelope-from <julian.reschke@gmx.de>) id 1c6PRG-0005gr-1r; Mon, 14 Nov 2016 22:09:18 +0000
Received: from mout.gmx.net ([212.227.17.21]) by mimas.w3.org with esmtps (TLS1.2:DHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.84_2) (envelope-from <julian.reschke@gmx.de>) id 1c6PR8-0005q3-Cr; Mon, 14 Nov 2016 22:09:12 +0000
Received: from [31.133.147.187] ([31.133.147.187]) by mail.gmx.com (mrgmx102 [212.227.17.168]) with ESMTPSA (Nemesis) id 0MLi1v-1c68Rc18j5-000rHW; Mon, 14 Nov 2016 23:08:35 +0100
To: Ken Murchison <murch@andrew.cmu.edu>, HTTP Working Group <ietf-http-wg@w3.org>, WebDAV <w3c-dist-auth@w3.org>
References: <147647657198.18541.16272058165406493619.idtracker@ietfa.amsl.com> <c01d2bd4-4495-ba7d-b3bd-3b3bab4314e2@gmx.de> <7fdc3595-9e50-3515-1822-ef13e9197518@gmx.de> <7e92cd24-569e-7eae-e9d9-397660ec0798@andrew.cmu.edu> <5869f8f6-0ded-16a6-e844-0a7e982e6936@gmx.de> <ce13daf5-c685-3e5f-d36d-c961eb158c4d@andrew.cmu.edu>
From: Julian Reschke <julian.reschke@gmx.de>
Message-ID: <ce932309-f738-cfb0-36ce-ad73f68f4704@gmx.de>
Date: Mon, 14 Nov 2016 23:08:32 +0100
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0
MIME-Version: 1.0
In-Reply-To: <ce13daf5-c685-3e5f-d36d-c961eb158c4d@andrew.cmu.edu>
Content-Type: text/plain; charset="windows-1252"; format="flowed"
Content-Transfer-Encoding: 7bit
X-Provags-ID: V03:K0:R9edOiXKSvAnwP4rJ6pQY4meHkt8pOdJkhtLv3nCY4ISGgMqIjj pTlbS8n+5b/j2sOHWxVTKeudTtouDJSqk8MRgQhYeszpTxi1yYOiCou2Qi+vtHH9Jiyj3kA 3/EnHDQHCm+lrPVwW4hAzqi85eHnTOq4sXSp9xEvCz9GkneNn61Y8ZE4J6KmGJxWunuaqtX BaDrKJwmp+21u9uASA2Tg==
X-UI-Out-Filterresults: notjunk:1;V01:K0:Jj/5VsuSe/0=:nSp0hD7sq2PpBJAsvthqT4 OMytdhrgV57eOAynRKFYzIPvwrdOLlNqsspO1dADnegJ+N2oDLV8H9XMPoDqYhRtgzejdx0z0 tMBXjFNB3gsDKMN1BO4EKsuGkbI0Yi+RPGlmvPF6LCCIyaXM9+XcMitZQDcn8r0rTbAxWaIGN AM3Yt6k0EAS7ZNgHHtiYXxZNeyZ+rq77mMmE077XSsGWOBdgiIEWuW06ZzIcNDi40daCb7U73 +khHpcLD+TxOawJducpaKM1zldazE/m6tqhMVfGLszvogiLj90CkHKDFH68Pj0Odgt/RA8r5Y BdJTyUPx3GjFWqIXIbM45cw2t/T+Rh7iUdRw7wQ107ROap1cYr960MD1U3sRYt001CFdpPutM h2VkXvEGqnjqgTZ6cfKfjfdtUiC2NrkFeDPFvmoP7t9AiV4Go4xg8Esf7CVZ8p44dqc3tmqKL 03fwuC/91TEGLpB1t9+xW498yt20U4jUmLynXSkt1tZLs4OQxSQ1R4g/9OwUicDUA+pSLWWqQ Uh6dFBgfybY1l+bDPM7cesR9X0lnajlH40Mgraxh8gHRJ2OeznszL/4xW7UgG9QG3ohF/4N8p tavPvcV8qya8i0GWBbPxqUDsM8JJ4tnLQiJniidPxQkURrt+ECurgmUgd+f9jHZF8PS8HgBgk 2TJo+0O78btPU9LXNTrebzecVwmBE9hYmk3uIrvDPTxZ5XyravtXr5NUiGJdfD9uwKdLf6EFT nOL21f12xt5vFG8A++fSNnfKxAnfrk1lsNgqfyDqt/JLdqKyBN30B6qHpY7TE7B6XyPHoM4GG gV4aJ8l
Received-SPF: pass client-ip=212.227.17.21; envelope-from=julian.reschke@gmx.de; helo=mout.gmx.net
X-W3C-Hub-Spam-Status: No, score=-6.5
X-W3C-Hub-Spam-Report: AWL=0.120, BAYES_00=-1.9, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H2=-0.001, SPF_PASS=-0.001, W3C_AA=-1, W3C_DB=-1, W3C_IRA=-1, W3C_WL=-1
X-W3C-Scan-Sig: mimas.w3.org 1c6PR8-0005q3-Cr c361b938ed386f1471f3b4dec707d8c5
X-Original-To: ietf-http-wg@w3.org
Subject: Re: feedback on draft-murchison-webdav-prefer-09
Archived-At: <http://www.w3.org/mid/ce932309-f738-cfb0-36ce-ad73f68f4704@gmx.de>
Resent-From: ietf-http-wg@w3.org
X-Mailing-List: <ietf-http-wg@w3.org> archive/latest/32899
X-Loop: ietf-http-wg@w3.org
Resent-Sender: ietf-http-wg-request@w3.org
Precedence: list
List-Id: <ietf-http-wg.w3.org>
List-Help: <http://www.w3.org/Mail/>
List-Post: <mailto:ietf-http-wg@w3.org>
List-Unsubscribe: <mailto:ietf-http-wg-request@w3.org?subject=unsubscribe>
On 2016-11-14 18:42, Ken Murchison wrote: > > > On 11/14/2016 09:41 AM, Julian Reschke wrote: >> On 2016-11-14 14:42, Ken Murchison wrote: >>> ... >>>> o Should we use a non-protocol-specific REPORT example such as >>>> DAV:sync-collection rather than using CalDAV:calendar-multiget? >>>> >>>> Yes, optimally one defined in the base specs. >>> >>> I think the most widely used REPORT that is closest to being part of the >>> base specs would be DAV:sync-collection. Unless you think I should use >>> DAV:version-tree from 3253 or one of the WebDAV ACL REPORTs. >> >> Actually, I was thinking of >> <https://greenbytes.de/tech/webdav/rfc3253.html#REPORT_expand-property>, >> which "SHOULD" be supported by any server implementing REPORT. > > OK, I will generate an example using expand-property. Do you feel I > should remove the CALDAV:calendar-multiget example? One example should be enough. > I was thinking of adding a non-exhaustive list of current REPORTs that > return=minimal would apply to. Thoughts? Can we clarify this based on the report's response format? >>>> 3. Reducing WebDAV Round-Trips with "return=representation" >>>> >>>> The PUT, COPY, MOVE, [RFC4918] PATCH, [RFC5789] and POST [RFC5995] >>>> >>>> Nit: reference looks a bit weird in between. Also, PUT is defined RFC >>>> 723x, which brings us to the question whether this spec needs to >>>> update RFC 723x. >>> >>> Just remove the references altogether, or place them elsewhere? >> >> Remove sounds good to me. > > Actually, I just realized the I had commas in a stupid place. I fixed > it so it now looks like this: > > "The PUT, COPY, MOVE [RFC4918], PATCH [RFC5789], and POST [RFC5995] > methods ..." > > Does this look better to you? A bit, but it's still misleading for PUT, right? Best regards, Julian
- Fwd: I-D Action: draft-murchison-webdav-prefer-09… Julian Reschke
- feedback on draft-murchison-webdav-prefer-09 Julian Reschke
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Julian Reschke
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Julian Reschke
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Julian Reschke
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Julian Reschke
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison
- Re: feedback on draft-murchison-webdav-prefer-09 Julian Reschke
- Re: feedback on draft-murchison-webdav-prefer-09 Ken Murchison