[I2nsf] Re: IETF Independent Submission for I2NSF Drafts

"Independent Submissions Editor (Eliot Lear)" <rfc-ise@rfc-editor.org> Fri, 02 August 2024 08:32 UTC

Return-Path: <rfc-ise@rfc-editor.org>
X-Original-To: i2nsf@ietfa.amsl.com
Delivered-To: i2nsf@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 12EA0C15106A for <i2nsf@ietfa.amsl.com>; Fri, 2 Aug 2024 01:32:08 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.907
X-Spam-Level:
X-Spam-Status: No, score=-4.907 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_HI=-5, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001, URI_DOTEDU=1.999] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=rfc-editor-org.20230601.gappssmtp.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ua7d6XlZI6xy for <i2nsf@ietfa.amsl.com>; Fri, 2 Aug 2024 01:32:03 -0700 (PDT)
Received: from mail-wr1-x42e.google.com (mail-wr1-x42e.google.com [IPv6:2a00:1450:4864:20::42e]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 9A8FBC14CE3F for <i2nsf@ietf.org>; Fri, 2 Aug 2024 01:32:03 -0700 (PDT)
Received: by mail-wr1-x42e.google.com with SMTP id ffacd0b85a97d-3687fb526b9so3835978f8f.0 for <i2nsf@ietf.org>; Fri, 02 Aug 2024 01:32:03 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=rfc-editor-org.20230601.gappssmtp.com; s=20230601; t=1722587522; x=1723192322; darn=ietf.org; h=in-reply-to:from:content-language:references:cc:to:subject :user-agent:mime-version:date:message-id:from:to:cc:subject:date :message-id:reply-to; bh=9g6nvWJhDT64PKE02pgUW0/9aWFfSy7DV3/KnJtTMkc=; b=HnBbcSsPLdQUWxgy8zvmAq02yg+sWfy6o8picomaL94n4or8TP7B1qoXoDPSkNLJXH rEaZpHCu8txRIGOUO1+JBsoavvzi8gQM5tM4iVlmrT/rhiPTglIse9gBKpENbgjFde/P nQgD4DVUupFKMF/pu81S8zWN67bwPECpvxGpe+vqy50q2mzbs18eDnRCod8tLs5wgj2t FiHTIZP8dNZ7nEnChgbFCLZKZdzMQ+/a5AaJUrz0WuUI6U7pb2e4o4OINITaq9Pti+9I /MVGPPq7YfLGYg90NMYmEqWr4rDJBxqgn9j3wcr2F17g6gsLcHp5+B7dkMDA8e5BDXop dr5w==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1722587522; x=1723192322; h=in-reply-to:from:content-language:references:cc:to:subject :user-agent:mime-version:date:message-id:x-gm-message-state:from:to :cc:subject:date:message-id:reply-to; bh=9g6nvWJhDT64PKE02pgUW0/9aWFfSy7DV3/KnJtTMkc=; b=dhLqd0Nc8lkBZohfxG9YvtgsToy7NVaW1McEF7pMVzBOKCOf7v5O1gMIrv9QvTozcu hHhubpNLLiksuWGmlxS0k+1Ptor53ox2UuqWZmCdw52YiB0pUjz5EjWy01SIEcWR4ssI kCitKaM9nkqJeUpQ/AfcHr0UKJm+rIODb5Z6fFwVJGBvlrAdrZvdG/+AWFxABzlXP+Jh 1epvPMYB7OsGJWpehHaNqNPKHjx3TJQypYwTrShpmVgWK/Dl+PiisCPpeJI06N9qJ/i0 ihiBoxj8XPCQjzR6dFcMxAw9KtH4QoplaN+Du1dR3f3TLh0ct+AzAXAN3j56JtQMdnDV l01w==
X-Gm-Message-State: AOJu0YziGgz2ePx2yPsf0eVpVRmjWvHIv6/xJSNEnElqFGEF20zhvs/z buhvcbbkdMt1HLEQY4nA48e41cSV/prZ2R12zsJd7JLSBxG2noucYjD44BGoc1TOuQ==
X-Google-Smtp-Source: AGHT+IFBvx4TXXdBMShjI9bkc1DfvSH7BaX3qYmY38LXtaO0w75FEdwfISwc85jlwtccI65Mi6VUow==
X-Received: by 2002:a5d:5e05:0:b0:36b:bcb7:f00c with SMTP id ffacd0b85a97d-36bbcb7f06amr1564638f8f.19.1722587521175; Fri, 02 Aug 2024 01:32:01 -0700 (PDT)
Received: from [192.168.1.112] (108.69.76.83.dynamic.cust.swisscom.net. [83.76.69.108]) by smtp.gmail.com with ESMTPSA id ffacd0b85a97d-36bbd0598a7sm1356536f8f.67.2024.08.02.01.32.00 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Fri, 02 Aug 2024 01:32:00 -0700 (PDT)
Content-Type: multipart/alternative; boundary="------------X0bwbovNTI7D8nak8PfvIQpS"
Message-ID: <aa28793f-4e8c-410f-9a60-af0853a0fb17@rfc-editor.org>
Date: Fri, 02 Aug 2024 10:31:59 +0200
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: "Mr. Jaehoon Paul Jeong" <jaehoon.paul@gmail.com>
References: <CAPK2Dexj1pg8x_ndMUyM1YFhNk=16nWB1Lw6gvJf2p-UqEqzsg@mail.gmail.com> <b2f31955-5e3a-4440-8bd6-ac1649dcae2d@rfc-editor.org> <CAPK2DexM67W6Wv6DOf7C55Z3g9J7LF1vnQ+058SicaDJzeeUgw@mail.gmail.com>
Content-Language: en-US
From: "Independent Submissions Editor (Eliot Lear)" <rfc-ise@rfc-editor.org>
In-Reply-To: <CAPK2DexM67W6Wv6DOf7C55Z3g9J7LF1vnQ+058SicaDJzeeUgw@mail.gmail.com>
Message-ID-Hash: MQJ6GXA6XA227JEP2AAHEHSJOK23QWU2
X-Message-ID-Hash: MQJ6GXA6XA227JEP2AAHEHSJOK23QWU2
X-MailFrom: rfc-ise@rfc-editor.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-i2nsf.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "i2nsf@ietf.org" <i2nsf@ietf.org>, Linda Dunbar <linda.dunbar@futurewei.com>, Yoav Nir <ynir.ietf@gmail.com>, Adrian Farrel <adrian@olddog.co.uk>, Paul Wouters <paul.wouters@aiven.io>, Roman Danyliw <rdd@cert.org>, skku-iotlab-members <skku-iotlab-members@googlegroups.com>
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [I2nsf] Re: IETF Independent Submission for I2NSF Drafts
List-Id: "*I2NSF: Interface to Network Security Functions mailing list*" <i2nsf.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/i2nsf/mRdk1RaIitlM8rBYASouCrGm2gU>
List-Archive: <https://mailarchive.ietf.org/arch/browse/i2nsf>
List-Help: <mailto:i2nsf-request@ietf.org?subject=help>
List-Owner: <mailto:i2nsf-owner@ietf.org>
List-Post: <mailto:i2nsf@ietf.org>
List-Subscribe: <mailto:i2nsf-join@ietf.org>
List-Unsubscribe: <mailto:i2nsf-leave@ietf.org>

Hi Paul,

Perhaps, but the way you stated the initial request would lead one to 
believe otherwise.

> However, the publication of RFCs will let the technologies in these 
> two documents be widely
> used by the industry because they are Internet Standard Specifications 
> even though they are
> an Informational RFC and Experimental RFC, respectively.

Perhaps your intent was otherwise, but independent submissions MUST NOT 
be represented as standards.  Your statement on the record would leave 
others to question the truth of that statement if these documents were 
published as RFCs.  Unfortunately there is no room for subtlety on this 
point.

Eliot Lear
Independent Submissions Editor

On 01.08.2024 20:04, Mr. Jaehoon Paul Jeong wrote:
> Hi Eliot,
> Thanks for your kind opinion and guideline for the Independent Submissions
> for our two drafts.
>
> Let me clarify my intent for these independent submissions.
>
> According to Section 2 (The Role of Independent Submissions) in RFC 4846
> (Independent Submissions to the RFC Editor), we can see my intent for 
> independent submissions:
> https://datatracker.ietf.org/doc/html/rfc4846#page-4
>
> o  Introduction of important new ideas as a bridge publication venue
>    between academia and IETF engineering.
>
> As you may see, I2NSF WG has finished the IETF standardization of the 
> YANG data models for
> I2NSF main interfaces as a concluded WG.
> https://datatracker.ietf.org/group/i2nsf/about/
>
> Also, NMRG as a venue for Internet Research in IRTF has published two RFCs
> (RFC 9315 and RFC 9316) for Intent-Based Networking (IBN).
> https://datatracker.ietf.org/doc/rfc9315/
> The academia has been actively researching the IBN for the last 7 years.
>
> My intent is to bridge the academia work and I2NSF work
> for security management automation based on the concept of the IBN.
>
> What do you think about my intent befitting the above role of 
> Independent Submissions?
>
> Thanks.
>
> Best Regards,
> Paul
>
> On Thu, Aug 1, 2024 at 10:16 PM Independent Submissions Editor (Eliot 
> Lear) <rfc-ise@rfc-editor.org> wrote:
>
>     Hi Paul,
>
>     Thank you for your submissions.  However, if your intent is to
>     present the completed works as Internet Standards, I can't accept
>     them, as the independent stream is specifically precluded from
>     producing specifications on that basis by RFC 4846.  The IETF is
>     the correct place for this work to continue if and when you garner
>     sufficient interest.
>
>     Eliot Lear
>     Independent Submissions Editor
>
>     On 30.07.2024 03:58, Mr. Jaehoon Paul Jeong wrote:
>>     Hi IETF Independent Submission Editor Eliot,
>>
>>     I would like to submit two I2NSF Drafts to IETF Independent
>>     Submission Stream.
>>     Event though the I2NSF WG concluded one year ago, the following
>>     drafts are submitted
>>     to the IETF Independent Submission Stream because they can
>>     complete Security Service
>>     Automation based on Intent-Based Networking (IBN) in RFC 9315.
>>     This submission was discussed with our I2NSF WG under the
>>     guidance of Linda Dunbar
>>     (I2NSF WG Chair).
>>
>>     - Security Management Automation of Cloud-Based Security Services
>>     in I2NSF Framework
>>     . URL:
>>     https://datatracker.ietf.org/doc/html/draft-jeong-i2nsf-security-management-automation-08
>>     . Summary:
>>       The scope of this document is to propose an extension of the
>>     standard I2NSF framework
>>       such that it can perform security management automation based
>>     on Intent-Based Networking
>>       (IBN) in RFC 9315. This document augments the existing I2NSF
>>     framework by adding the
>>       features of  security policy translation, closed-loop security
>>     control, and security audit system
>>       to it. For this system augmentation, a system component called
>>     I2NSF Analyzer and a new
>>       external interface called Analytics Interface are introduced
>>     for Closed-Loop Security Control
>>       on the basis of the analysis of NSF monitoring data.
>>     . Purpose: Informational RFC
>>
>>     - I2NSF Analytics Interface YANG Data Model
>>     . URL:
>>     https://datatracker.ietf.org/doc/html/draft-lingga-i2nsf-analytics-interface-dm-04
>>     . Summary:
>>       The scope of this document is to propose a YANG data model for
>>     a new external interface
>>       (called Analytics Interface) between Security Controller in the
>>     I2NSF framework and an
>>       Analyzer (performing the analysis of NSF monitoring data and
>>     the generation of policy
>>       reconfiguration and feedback). With this Analytics Interface,
>>     the I2NSF framework can
>>       perform Security Management Automation in terms of Closed-Loop
>>     Security Control.
>>     . Purpose: Experimental RFC
>>
>>     The two documents of
>>     draft-jeong-i2nsf-security-management-automation and
>>     draft-lingga-i2nsf-analytics-interface-dm can be published in
>>     either conferences or journals.
>>     However, the publication of RFCs will let the technologies in
>>     these two documents be widely
>>     used by the industry because they are Internet Standard
>>     Specifications even though they are
>>     an Informational RFC and Experimental RFC, respectively.
>>
>>     For draft-jeong-i2nsf-security-management-automation, this
>>     document is needed to complete
>>     the I2NSF Framework in RFC 8329 (Framework for Interface to
>>     Network Security Functions)
>>     in terms of Security Management Automation based on IBN in RFC
>>     9315 (Intent-Based
>>     Networking - Concepts and Definitions).
>>
>>     For draft-lingga-i2nsf-analytics-interface-dm, the YANG Data
>>     Model of Analytics Interface in
>>     draft-jeong-i2nsf-security-management-automation is
>>     well-synchronized with other I2NSF
>>     YANG Data Models (approved as RFCs) such as Consumer-Facing
>>     Interface, NSF-Facing
>>     Interface, Registration Interface, and Monitoring Interface.
>>     Also, the concept of this YANG
>>     data model was proved by the IETF-113 Hackathon Project:
>>     https://github.com/jaehoonpaul/i2nsf-framework/tree/master/Hackathon-113
>>
>>     Adrian Farrel reviewed these two drafts and gave me lots of
>>     valuable comments.
>>     I have tried to address all of his comments on the current
>>     versions of the two drafts.
>>
>>     Linda (as I2NSF WG Chair) will ask for the YANG doctor review for
>>     draft-lingga-i2nsf-analytics-interface-dm soon.
>>
>>     I CC Roman Danyliw (as the previous responsible AD) and Paul
>>     Wouters (as a possible sponsor AD).
>>
>>     If you have questions, please let me know.
>>
>>     Thanks for your help and support.
>>
>>     Best Regards,
>>     Paul
>>     -- 
>>     ===========================
>>     Mr. Jaehoon (Paul) Jeong
>>     Department of Computer Science and Engineering
>>     Sungkyunkwan University
>>     Phone: +82-31-299-4957
>>     Email: pauljeong@skku.edu, jaehoon.paul@gmail.com
>>     URI: http://iotlab.skku.edu/people-jaehoon-jeong.php
>