[Idr] Re: WG adoption call for draft-scudder-idr-bgp4-rfc4271bis-00.txt - Ends 10/09/2025
Robert Raszuk <robert@raszuk.net> Thu, 09 October 2025 10:30 UTC
Return-Path: <robert@raszuk.net>
X-Original-To: idr@mail2.ietf.org
Delivered-To: idr@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id EE3E36FF449C for <idr@mail2.ietf.org>; Thu, 9 Oct 2025 03:30:45 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.099
X-Spam-Level:
X-Spam-Status: No, score=-2.099 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=raszuk.net
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id BAY2tA6mb0XB for <idr@mail2.ietf.org>; Thu, 9 Oct 2025 03:30:44 -0700 (PDT)
Received: from mail-ed1-x52c.google.com (mail-ed1-x52c.google.com [IPv6:2a00:1450:4864:20::52c]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 2AD626FF4480 for <idr@ietf.org>; Thu, 9 Oct 2025 03:30:44 -0700 (PDT)
Received: by mail-ed1-x52c.google.com with SMTP id 4fb4d7f45d1cf-6364eb29e74so1445288a12.0 for <idr@ietf.org>; Thu, 09 Oct 2025 03:30:44 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=raszuk.net; s=google; t=1760005843; x=1760610643; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=qeVbeAn7pBkKtxigqPxyyYy39GVapfBo/jpjc+B8oaU=; b=LllYlC7leVxlxP0IPoBGeHvG0V6atbowi6CKb8t9UX6A5wsj4qjsCs/RT/LzCmNFgN ab2Lc4++33RA37O7Juhcc8/sicXyai5mb0sSwBrEBowieDQWZJhSA1pJXUIZnNnMfXte LbgotNmR9u10YBhEODHA1hPyUG9vdBucLjW+RKIhZ8h45QPW/IhUfEIQxmLDYXlWHDaM j4ylWWFn/g7t6UT1CJ/BgnoXDKnl+vhL/Bfhzzk2EqlzdYiAoVh/5SGtAMLOquJwuStB qIOzbAyiQMWSN1VzK+B7XW71RwTZ47A2gypQ7VyoDB1y9SH7F4RqsTvWYeY7BABW7H2L bZBw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1760005843; x=1760610643; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=qeVbeAn7pBkKtxigqPxyyYy39GVapfBo/jpjc+B8oaU=; b=bLoARufzvSWOiDbCbZmE24bav4l7mmQdJqNsa90sNKJsxhSCfKJtDOEbfPcB+c26sm BRj2MN3XzOdMsjSj3askuAiamf2w43XLWA8zmV5jot0bfUnMKIe6sncRq3OZ22bQ3Ncg gTXWT20oayuXMPTpMOSghA3M3braBaPduj7QiZKtG45n0FA7LfvIwsYUne12vreODhzL MFm/MBgFH7QTtWGzZIk8M8fm2LG3NMk19EoNQhpw/WUKYDmLYBtD5ae8BCSB7EQqgj/z 2uYS2flov1GOeeCoQeNO8y1cxGcsvNzKaZIw9svQcp1pMwSlNRZD+T3p0WW0YISG8vNH Wtew==
X-Forwarded-Encrypted: i=1; AJvYcCWThKK1jA/8vk7y9VF+3hnwJ6qesajnW2Uv8DHJGyMP2uOsdKH/dHf4XSGdMEirHhMibd4=@ietf.org
X-Gm-Message-State: AOJu0YyopYV6LEdqB4l+xSKk7mYc8KZlWzKlhMBxNMDt2sPfd0Ua2rU+ R8/kEsJEoe8kp2N9qdq5MmqLJ4eTv1l/0syybR8yAt563iF5vtFw7RRqkwjJiO8nsLF2qEYHODi F1wEVCe9gyjT7cgu89NrHgF4sLtGvqYsa80Uz6ZcklA==
X-Gm-Gg: ASbGnctfwSNOi2c42nu+eTBw+DX+tvtTE8lPz9tJopD3BkGxmYihLGXlM9DhZUaXNnp M0TJ7/6+ENH783T3aLssMnb1sQ9vl9g+03h/yeswH5sVTJDWAy0MMlcrJkal0YS4StrWKyBb1Rj anS5R/2KzywkT+Djnr3GPLuQH4cUMyTeYeRZeu6VbCwR0ZGvNSjzGvJqIYaEVxAgEsm3cA+BAO8 thmq0Jrq3+13Arr35PW+XmgnGOLbuiTvCfs2qOgXQ==
X-Google-Smtp-Source: AGHT+IHW/y6C5f3dOufBKnm5AZSiQrGB+nPGHcozTagGx4JAWfH69A07Zu0HZeYHE7i0vabH6b/U1fdvYWZSyYxdwAQ=
X-Received: by 2002:a50:fb0e:0:b0:637:dbfe:6787 with SMTP id 4fb4d7f45d1cf-639d5c75d7amr4741949a12.35.1760005843112; Thu, 09 Oct 2025 03:30:43 -0700 (PDT)
MIME-Version: 1.0
References: <SJ0PR18MB3980DD016D08C9E3266F407FC11FA@SJ0PR18MB3980.namprd18.prod.outlook.com> <e5983153184345e0a02608c3b3fdbb68@huawei.com>
In-Reply-To: <e5983153184345e0a02608c3b3fdbb68@huawei.com>
From: Robert Raszuk <robert@raszuk.net>
Date: Thu, 09 Oct 2025 12:30:31 +0200
X-Gm-Features: AS18NWBAZNTITnDDl3zU_GD-zI8GzmdkQN4Ja_ff3dEI0uAwoOCW8GILvtWmROs
Message-ID: <CAOj+MMH8UPtYb8JX77YJ55rG-ReDFxXmyGrrjAQy3Sady=PiJg@mail.gmail.com>
To: "Dongjie (Jimmy)" <jie.dong=40huawei.com@dmarc.ietf.org>
Content-Type: multipart/alternative; boundary="00000000000014e3600640b74bb4"
Message-ID-Hash: DGVPZECIC6QYE5YN6W3SIP5SCKDC7ZCI
X-Message-ID-Hash: DGVPZECIC6QYE5YN6W3SIP5SCKDC7ZCI
X-MailFrom: robert@raszuk.net
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-idr.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Keyur Patel <keyur=40arrcus.com@dmarc.ietf.org>, idr <idr@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Idr] Re: WG adoption call for draft-scudder-idr-bgp4-rfc4271bis-00.txt - Ends 10/09/2025
List-Id: Inter-Domain Routing <idr.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/idr/WHH2FFnu0gGckHmQWMaoM9a5Eb8>
List-Archive: <https://mailarchive.ietf.org/arch/browse/idr>
List-Help: <mailto:idr-request@ietf.org?subject=help>
List-Owner: <mailto:idr-owner@ietf.org>
List-Post: <mailto:idr@ietf.org>
List-Subscribe: <mailto:idr-join@ietf.org>
List-Unsubscribe: <mailto:idr-leave@ietf.org>
Hi Jimmy, Ad 1) But neither RFC 4271 nor RFC 4271 bis support IPv6. MP extensions and AFI/SAFI are needed for other than IPv4 Unicast routing. Your point is correct and we discussed it already; however based on my observations adding MP-BGP and IPv6 to RFC4271bis is not going to happen. It would be a rather significant rewrite. Ad 2) To your second point RFC6286 already addresses that point as a formal update to RFC4271. Not sure if you are recommending merging RFC6286 with 4271bis. Ad 3) As far as redundant subsections ... only titles are redundant not entire subsections: 5.1.4. MULTI_EXIT_DISC 5.1.5. MULTI_EXIT_DISC & 9.2.1.1. Frequency of Route Advertisement 9.2.1.2. Frequency of Route Advertisement Thx, R. On Thu, Oct 9, 2025 at 9:45 AM Dongjie (Jimmy) <jie.dong= 40huawei.com@dmarc.ietf.org> wrote: > Hi Keyur, > > > > I’ve read the -00 version of this draft and support its adoption. As > discussed during the IDR session at IETF 123, this is a good starting > point. > > > > I have the following few comments for the editors to consider: > > > > 1) In section 3, the draft keeps the description about the term “IP > address” as it was in RFC 4271: > > > > “In the context of this document, the term "IP address" refers to an IP > Version 4 address [RFC791].” > > > > Since IPv6 has been widely deployed these years, it seems it would clearer > for the bis to use “IPv4 address” throughout this document. And some text > may be added to refer to RFC2545 for the support of IPv6. > > > > 2) In section 1.1, the definition of BGP Identifier, currently it > says: > > > > “A given BGP speaker sets the value of its BGP Identifier to an IP address > assigned to that BGP speaker”. > > > > Does this assume a BGP speaker has at least one IPv4 address? May consider > to relax or rephrase the text for BGP speakers with only IPv6 addresses. > > > > 3) There are redundant subsections on “MULTI_EXIT_DISC” and > “Frequency of Route Advertisement”. > > > > > > Best regards, > > Jie > > > > *From:* Keyur Patel <keyur=40arrcus.com@dmarc.ietf.org> > *Sent:* Friday, September 26, 2025 2:45 AM > *To:* idr <idr@ietf.org> > *Subject:* [Idr] WG adoption call for > draft-scudder-idr-bgp4-rfc4271bis-00.txt - Ends 10/09/2025 > > > > Hi Folks, > > > > This is a Working Group adoption call for > draft-scudder-idr-bgp4-rfc4271bis-00.txt, “A Border Gateway Protocol 4 > (BGP-4)”. Please reply to the list with your comments. This adoption call > will conclude on October 9th, 2025. > > > > The draft can be found at: > https://datatracker.ietf.org/doc/draft-scudder-idr-bgp4-rfc4271bis/. > > > > Best Regards, > > Keyur > _______________________________________________ > Idr mailing list -- idr@ietf.org > To unsubscribe send an email to idr-leave@ietf.org >
- [Idr] WG adoption call for draft-scudder-idr-bgp4… Keyur Patel
- [Idr] Re: WG adoption call for draft-scudder-idr-… Tony Li
- [Idr] Re: WG adoption call for draft-scudder-idr-… Job Snijders
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Job Snijders
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Tony Li
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… Job Snijders
- [Idr] Re: WG adoption call for draft-scudder-idr-… bruno.decraene
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Jeff Tantsura
- [Idr] Re: WG adoption call for draft-scudder-idr-… tom petch
- [Idr] Re: WG adoption call for draft-scudder-idr-… Jeffrey Haas
- [Idr] Re: WG adoption call for draft-scudder-idr-… tom petch
- [Idr] Re: WG adoption call for draft-scudder-idr-… Tony Li
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Jeffrey Haas
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… je_drake@yahoo.com
- [Idr] Re: WG adoption call for draft-scudder-idr-… Jeffrey Haas
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… tom petch
- [Idr] Re: WG adoption call for draft-scudder-idr-… John Scudder
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… Nat Kao
- [Idr] Re: WG adoption call for draft-scudder-idr-… Jeffrey Haas
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… Maria Matejka
- [Idr] Re: WG adoption call for draft-scudder-idr-… Kevin Wang
- [Idr] Re: WG adoption call for draft-scudder-idr-… slitkows.ietf
- [Idr] Re: WG adoption call for draft-scudder-idr-… Luuk Hendriks
- [Idr] Re: WG adoption call for draft-scudder-idr-… Jeffrey Haas
- [Idr] Re: WG adoption call for draft-scudder-idr-… Serge Krier (sekrier)
- [Idr] Re: WG adoption call for draft-scudder-idr-… zhang.zheng
- [Idr] Re: WG adoption call for draft-scudder-idr-… Dongjie (Jimmy)
- [Idr] Re: WG adoption call for draft-scudder-idr-… Robert Raszuk
- [Idr] Re: WG adoption call for draft-scudder-idr-… Dongjie (Jimmy)
- [Idr] Re: Closed -- WG adoption call for draft-sc… Keyur Patel