Return-Path: <alissa@cooperw.in>
X-Original-To: ietf@ietfa.amsl.com
Delivered-To: ietf@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1])
 by ietfa.amsl.com (Postfix) with ESMTP id 9D07B129A39;
 Mon, 14 Nov 2016 23:58:19 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.72
X-Spam-Level: 
X-Spam-Status: No, score=-2.72 tagged_above=-999 required=5
 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
 DKIM_VALID_AU=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7,
 RCVD_IN_MSPIKE_H3=-0.01, RCVD_IN_MSPIKE_WL=-0.01, SPF_PASS=-0.001]
 autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key)
 header.d=cooperw.in header.b=tx0bITB2;
 dkim=pass (1024-bit key)
 header.d=messagingengine.com header.b=ADfte68F
Received: from mail.ietf.org ([4.31.198.44])
 by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
 with ESMTP id aqAdzYlA94aE; Mon, 14 Nov 2016 23:58:18 -0800 (PST)
Received: from out4-smtp.messagingengine.com (out4-smtp.messagingengine.com
 [66.111.4.28])
 (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits))
 (No client certificate requested)
 by ietfa.amsl.com (Postfix) with ESMTPS id F15D51294E3;
 Mon, 14 Nov 2016 23:58:17 -0800 (PST)
Received: from compute4.internal (compute4.nyi.internal [10.202.2.44])
 by mailout.nyi.internal (Postfix) with ESMTP id 66C6A2081A;
 Tue, 15 Nov 2016 02:58:17 -0500 (EST)
Received: from frontend1 ([10.202.2.160])
 by compute4.internal (MEProxy); Tue, 15 Nov 2016 02:58:17 -0500
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=cooperw.in; h=cc
 :content-type:date:from:in-reply-to:message-id:mime-version
 :references:subject:to:x-me-sender:x-me-sender:x-sasl-enc
 :x-sasl-enc; s=mesmtp; bh=RvtvCJgyrqiPKeI5jMDcCbKxErc=; b=tx0bIT
 B2CLqdyT5xIjgWxJWGrO7LMyYnx10pvxWgsxR/n4KHOTRTZ3lmAkfWlUBkIdpC7F
 LIvtNW1H06E3tXRMDs0BgQlVfsfHEzMmSSHlNSrf/2NCvnHNyYgzad0jdrTySWFk
 0WfvCCOGrXenMsdo2MODmRC4jR/OJPZW4PIVo=
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=
 messagingengine.com; h=cc:content-type:date:from:in-reply-to
 :message-id:mime-version:references:subject:to:x-me-sender
 :x-me-sender:x-sasl-enc:x-sasl-enc; s=smtpout; bh=RvtvCJgyrqiPKe
 I5jMDcCbKxErc=; b=ADfte68FVa630swixBfEyJL5w+nyVr2w/m/KPpwZ/xQcBQ
 NBaAQABlG9YOyfJahbbu16IKVW6QDzhWn1fRJzbCrvN+QHABc8SbPYFib64aE6U2
 i2+648gMSoJi/3dxqOFmvQbrIvU0UQTgO2vKqpvRLYdyFfXHfLrpNY62RUohA=
X-ME-Sender: <xms:GcAqWMorjX_mAjFiK5Lo3CLsaTjPTXoRL8x0JpzTXWjkDFErHHSexg>
X-Sasl-enc: omFN6gS3U+0urEMT3/XJcX4jQtWf7xY6RJGbQOO7oTdX 1479196696
Received: from [10.24.8.140] (unknown [128.107.241.187])
 by mail.messagingengine.com (Postfix) with ESMTPA id 5D9337E427;
 Tue, 15 Nov 2016 02:58:15 -0500 (EST)
Content-Type: multipart/alternative;
 boundary="Apple-Mail=_EBCA3FCA-7450-4487-87BB-D9E6E1FA244C"
Mime-Version: 1.0 (Mac OS X Mail 9.3 \(3124\))
Subject: Re: Last Call: <draft-ietf-6man-default-iids-16.txt> (Recommendation
 on Stable IPv6 Interface Identifiers) to Proposed Standard
From: Alissa Cooper <alissa@cooperw.in>
In-Reply-To: <CAKD1Yr25zv1AQfNtEX-EnShU900WRNLhPF4X2SrF4gQFp0actw@mail.gmail.com>
Date: Tue, 15 Nov 2016 16:58:12 +0900
Message-Id: <AD56502B-7533-41D1-AD91-1BF6114B3032@cooperw.in>
References: <147917959004.8493.15676171079880753223.idtracker@ietfa.amsl.com>
 <CAKD1Yr25zv1AQfNtEX-EnShU900WRNLhPF4X2SrF4gQFp0actw@mail.gmail.com>
To: Lorenzo Colitti <lorenzo@google.com>
X-Mailer: Apple Mail (2.3124)
Archived-At: <https://mailarchive.ietf.org/arch/msg/ietf/EZHAYyHEtzfyBSvT5RAEbfaciHE>
Cc: IETF IPv6 Mailing List <ipv6@ietf.org>,
 draft-ietf-6man-default-iids@ietf.org, IETF Discussion <ietf@ietf.org>,
 Bob Hinden <bob.hinden@gmail.com>, 6man-chairs@ietf.org
X-BeenThere: ietf@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: IETF-Discussion <ietf.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ietf>,
 <mailto:ietf-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/ietf/>
List-Post: <mailto:ietf@ietf.org>
List-Help: <mailto:ietf-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ietf>,
 <mailto:ietf-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 15 Nov 2016 07:58:19 -0000


--Apple-Mail=_EBCA3FCA-7450-4487-87BB-D9E6E1FA244C
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=utf-8

Hi Lorenzo,

> On Nov 15, 2016, at 4:44 PM, Lorenzo Colitti <lorenzo@google.com> =
wrote:
>=20
> On Tue, Nov 15, 2016 at 12:13 PM, The IESG <iesg-secretary@ietf.org =
<mailto:iesg-secretary@ietf.org>> wrote:
> It formally updates RFC2464, RFC2467,
>    RFC2470, RFC2491, RFC2492, RFC2497, RFC2590, RFC3146, RFC3572,
>    RFC4291, RFC4338, RFC4391, RFC5072, and RFC5121.
>=20
> Does this document need to be a formal update to those RFCs? After all =
the issues were resolved, the only remaining text that references those =
RFCs is:
>=20
>    In particular,
>    this document RECOMMENDS that nodes do not generate stable IIDs =
with
>    the schemes specified in [RFC2464], [RFC2467], [RFC2470], =
[RFC2491],
>    [RFC2492], [RFC2497], [RFC2590], [RFC3146], [RFC3572], [RFC4338],
>    [RFC4391], [RFC5121], and [RFC5072].
>=20
> Does that require a formal update?

I think so. If the documents listed were being written from scratch =
today, I think they would contain the recommendation quoted above. That =
seems to align with the definition of =E2=80=9CUpdates=E2=80=9D given in =
RFC 2223.

One thing we could do is add a note about why this document updates the =
documents listed above, taking the recommendation from =
https://tools.ietf.org/html/draft-wilde-updating-rfcs-00 =
<https://tools.ietf.org/html/draft-wilde-updating-rfcs-00>.

Alissa=

--Apple-Mail=_EBCA3FCA-7450-4487-87BB-D9E6E1FA244C
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=utf-8

<html><head><meta http-equiv=3D"Content-Type" content=3D"text/html =
charset=3Dutf-8"></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" =
class=3D""><div class=3D"">Hi Lorenzo,</div><br =
class=3D""><div><blockquote type=3D"cite" class=3D""><div class=3D"">On =
Nov 15, 2016, at 4:44 PM, Lorenzo Colitti &lt;<a =
href=3D"mailto:lorenzo@google.com" class=3D"">lorenzo@google.com</a>&gt; =
wrote:</div><br class=3D"Apple-interchange-newline"><div class=3D""><div =
dir=3D"ltr" class=3D""><div class=3D"gmail_extra"><div =
class=3D"gmail_quote">On Tue, Nov 15, 2016 at 12:13 PM, The IESG <span =
dir=3D"ltr" class=3D"">&lt;<a href=3D"mailto:iesg-secretary@ietf.org" =
target=3D"_blank" class=3D"">iesg-secretary@ietf.org</a>&gt;</span> =
wrote:<br class=3D""><blockquote class=3D"gmail_quote" style=3D"margin:0px=
 0px 0px 0.8ex;border-left:1px solid =
rgb(204,204,204);padding-left:1ex">It formally updates RFC2464, =
RFC2467,<br class=3D"">
&nbsp; &nbsp;RFC2470, RFC2491, RFC2492, RFC2497, RFC2590, RFC3146, =
RFC3572,<br class=3D"">
&nbsp; &nbsp;RFC4291, RFC4338, RFC4391, RFC5072, and =
RFC5121.</blockquote><div class=3D""><br class=3D""></div><div =
class=3D"">Does this document need to be a formal update to those RFCs? =
After all the issues were resolved, the only remaining text that =
references those RFCs is:</div><div class=3D""><br class=3D""></div><div =
class=3D""><div class=3D"">&nbsp; &nbsp;In particular,</div><div =
class=3D"">&nbsp; &nbsp;this document RECOMMENDS that nodes do not =
generate stable IIDs with</div><div class=3D"">&nbsp; &nbsp;the schemes =
specified in [RFC2464], [RFC2467], [RFC2470], [RFC2491],</div><div =
class=3D"">&nbsp; &nbsp;[RFC2492], [RFC2497], [RFC2590], [RFC3146], =
[RFC3572], [RFC4338],</div><div class=3D"">&nbsp; &nbsp;[RFC4391], =
[RFC5121], and [RFC5072].</div></div><div class=3D""><br =
class=3D""></div><div class=3D"">Does that require a formal =
update?</div></div></div></div>
</div></blockquote></div><br class=3D""><div class=3D"">I think so. If =
the documents listed were being written from scratch today, I think they =
would contain the recommendation quoted above. That seems to align with =
the definition of =E2=80=9CUpdates=E2=80=9D given in RFC 2223.</div><div =
class=3D""><br class=3D""></div><div class=3D"">One thing we could do is =
add a note about why this document updates the documents listed above, =
taking the recommendation from&nbsp;<a =
href=3D"https://tools.ietf.org/html/draft-wilde-updating-rfcs-00" =
class=3D"">https://tools.ietf.org/html/draft-wilde-updating-rfcs-00</a>.</=
div><div class=3D""><br class=3D""></div><div =
class=3D"">Alissa</div></body></html>=

--Apple-Mail=_EBCA3FCA-7450-4487-87BB-D9E6E1FA244C--

