Return-Path: <otroan@employees.org>
X-Original-To: ietf@ietfa.amsl.com
Delivered-To: ietf@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1])
 by ietfa.amsl.com (Postfix) with ESMTP id 56C83129464;
 Sat,  4 Feb 2017 00:32:41 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.001
X-Spam-Level: 
X-Spam-Status: No, score=-2.001 tagged_above=-999 required=5
 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
 DKIM_VALID_AU=-0.1, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key)
 header.d=employees.org; domainkeys=pass (1024-bit key)
 header.from=otroan@employees.org header.d=employees.org
Received: from mail.ietf.org ([4.31.198.44])
 by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
 with ESMTP id zonjCVekCSzr; Sat,  4 Feb 2017 00:32:39 -0800 (PST)
Received: from esa01.kjsl.com (esa01.kjsl.com [IPv6:2607:7c80:54:3::87])
 by ietfa.amsl.com (Postfix) with ESMTP id 96AE7129451;
 Sat,  4 Feb 2017 00:32:39 -0800 (PST)
Received: from cowbell.employees.org ([198.137.202.74])
 by esa01.kjsl.com with ESMTP; 04 Feb 2017 08:32:39 +0000
Received: from cowbell.employees.org (localhost [127.0.0.1])
 by cowbell.employees.org (Postfix) with ESMTP id BF074D788D;
 Sat,  4 Feb 2017 00:32:38 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed; d=employees.org; h=from
 :message-id:content-type:mime-version:subject:date:in-reply-to
 :cc:to:references; s=selector1; bh=3iZcSrtPjtq/NhMnB39Oe4WcN7M=; b=
 M7jx0EOgq3/5CaOVdQw0syCtbJOJYk2xFy/FYFq18JpcMNr2cuVqNhp3S2lRIPb8
 o97tDnrr4QTih07t8IzodyezmWMxfL3CXNs4syAw9nrxSUPaM6cC+D2bZyj4Ad8a
 /UPCqSkSVqtmr3Hgh615n6fbZ+HycKxzQ3ejRsNDfYU=
DomainKey-Signature: a=rsa-sha1; c=nofws; d=employees.org; h=from
 :message-id:content-type:mime-version:subject:date:in-reply-to
 :cc:to:references; q=dns; s=selector1; b=eWnjXwam4DPu/yyanzpdeUD
 AUUnDiPVgNCiMRCOYsjFJd5eCcRcwdSpmtHVm/mA4wJ1A2kxONNcyN3nTVeISuQn
 Q4TeeTIOy8v2j5l/hx2VdM2/bv+qzVRFFrleZjQ33D6F6B2JzI46KWURI6PkgYmO
 VNd/O8/Zx5sE5davtj78=
Received: from h.hanazo.no (96.51-175-103.customer.lyse.net [51.175.103.96])
 (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
 (No client certificate requested) (Authenticated sender: otroan)
 by cowbell.employees.org (Postfix) with ESMTPSA id 61E03D788B;
 Sat,  4 Feb 2017 00:32:38 -0800 (PST)
Received: from [IPv6:::1] (localhost [IPv6:::1])
 by h.hanazo.no (Postfix) with ESMTP id 25D3A83DE987;
 Sat,  4 Feb 2017 09:32:38 +0100 (CET)
From: otroan@employees.org
Message-Id: <D2D907D5-84B4-43BB-9103-F87DA9F122EB@employees.org>
Content-Type: multipart/signed;
 boundary="Apple-Mail=_7551FFB2-5870-4FE9-A24F-602551AEAF8B";
 protocol="application/pgp-signature"; micalg=pgp-sha512
Mime-Version: 1.0 (Mac OS X Mail 10.2 \(3259\))
Subject: Re: Last Call: <draft-ietf-6man-rfc2460bis-08.txt> (Internet
 Protocol, Version 6 (IPv6) Specification) to Internet Standard
Date: Sat, 4 Feb 2017 09:32:37 +0100
In-Reply-To: <8D401C5B-C3C3-4378-9DFA-BF4ACC8E9DAF@qti.qualcomm.com>
To: Pete Resnick <presnick@qti.qualcomm.com>
References: <148599296506.18647.12389618334616420462.idtracker@ietfa.amsl.com>
 <30725d25-9829-bf50-23c6-9e1b757e5cba@si6networks.com>
 <7ee506c2-4213-9396-186a-2b742c32f93b@gmail.com>
 <EA7E5B60-F136-47C6-949C-D123FB8DA70E@cisco.com>
 <00af01d27e11$fe539500$4001a8c0@gateway.2wire.net>
 <60F01869-8B32-46D3-80B1-A140DF1DDA8A@employees.org>
 <8D401C5B-C3C3-4378-9DFA-BF4ACC8E9DAF@qti.qualcomm.com>
X-Mailer: Apple Mail (2.3259)
Archived-At: <https://mailarchive.ietf.org/arch/msg/ietf/MJexpTisUTSN2XrkkYVVLPJrjFM>
Cc: draft-ietf-6man-rfc2460bis@tools.ietf.org, ietf@ietf.org,
 Stefano Previdi <sprevidi@cisco.com>, 6man-chairs@ietf.org
X-BeenThere: ietf@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: IETF-Discussion <ietf.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ietf>,
 <mailto:ietf-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/ietf/>
List-Post: <mailto:ietf@ietf.org>
List-Help: <mailto:ietf-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ietf>,
 <mailto:ietf-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 04 Feb 2017 08:32:41 -0000


--Apple-Mail=_7551FFB2-5870-4FE9-A24F-602551AEAF8B
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=utf-8

Thank you Pete! You are of course right.

Let me try to provide some background of the issue.

The contentious text is the following paragraph from 2460:

  With one exception, extension headers are not examined or processed
  by any node along a packet's delivery path, until the packet reaches
  the node (or each of the set of nodes, in the case of multicast)
  identified in the Destination Address field of the IPv6 header.

Essentially the question is:
- Does the IPv6 architecture permit insertion of extension headers =
and/or header options by a node along the packet's delivery path?

This question came up triggered by discussions around some recent =
proposals:
- draft-ietf-conex-destopt,
- RFC4782 (does header deletion)
- draft-ietf-6man-segment-routing-header
- draft-brockners-inband-oam-transport

The IP architecture (IPv4 and IPv6) supports _modifying_ IP options in =
flight, but it is unclear if it could permit changing the IP datagram's =
size.
Increasing a packets size in flight would break PMTUD (RFC1981), AH, and =
might results in other ICMP error messages being sent to an unsuspecting =
source.

There were three main positions argued in the working group.

1) Ban header insertion outright.
2) Describe the problems with header insertion.
3) No changes to RFC2460 text.

Permitting header insertion in the sense of specifying how header =
insertion could possibly work is of course outside the scope of =
advancing RFC2460.

The chairs tried various approaches to find a consensus without luck. =
The approach finally chosen was a poll between the three options. And =
the (rough) consensus was based on the data from the poll.

Excerpt from the shepherds writeup:

A working group last call for moving this and the other two documents to =
Internet Standard was started on 30 May 2016. Reviews were also =
requested. Issues found during the last call and reviews were entered =
into the 6MAN ticket system. These are now closed. The biggest issue =
raised was how to handle the issue of Extension Header insertion in this =
document. After many discussion on the mailing list and face to face =
meeting, there wasn=E2=80=99t a clear consensus. The chairs conducted an =
online survey that provided three choices: Ban header insertion, =
describe the problems with header insertion, or say nothing. The result =
of the survey was to describe the solution. The results and methodology =
used to evaluate the results can be seen at: =
https://mailarchive.ietf.org/arch/msg/ipv6/_gG2foiugk5B7w3TpnPvBbjHDzs =
This was discussed at the 6MAN session at IETF97 and on the mailing list =
after the meeting. The chairs believe there is a consensus to go forward =
with the text that is in draft-ietf-6man-rfc2460bis-08.

The summary given to the working group calling for the poll:
=
https://mailarchive.ietf.org/arch/msg/ipv6/AtY92TpJ3vvmiidzcPkJdXKZQIA/?qi=
d=3D84de5e109c8f8f255d03c4c98ff3e50c

Best regards,
Ole, 6man co-chair

--Apple-Mail=_7551FFB2-5870-4FE9-A24F-602551AEAF8B
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename=signature.asc
Content-Type: application/pgp-signature;
	name=signature.asc
Content-Description: Message signed with OpenPGP

-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - https://gpgtools.org

iQIcBAEBCgAGBQJYlZGlAAoJEL7aWKiYQt92YHIP/jz9Z/iAA8d444m/uVi6Ta+U
pBgbWJbCgLkQWks8xWaB+BC2lnzx3BB6YQlWCYzqN1on8Te4ZivuIOSlkYaS9fLl
QaySI2NNrFRut9/7lWxdImbPWFEubNGG2q/ZxdaY3DRS1VinASloZreHCzsqv/PB
AdMybaDq1Xw8/fSVfIHRDbzLBtlU1ybwtIvlv/yZ66Z8hG6LF0FteaqcUwtoQb6i
uGmfTqzGWX3m7D+IIIFm1/5B/bqTNhH7aVbCTN+ZtVBhMmXeOgFUEvK33SxfXZAF
G4VbK+xx1NnUaiiDrZ4hWjs4jGnZR8vL0HW7FXOf70m2+XstT1kOhSqpbz24tVJL
/RyrsABeVbKNUqFRo6D2usUeF8KjRATA90WFN04AGTlZiNF2Pb+NErfP8K74WsEm
jq0BcUq+5Tk3LQZYJ+m+hstUNekxS+g/AExrEeVPN6iPUPLhX0K4/WTNcDSOqCby
ntSxiT9NnlF9T2y9UhIg3lmOmzw3N5Yn/hf4mQ16H9rwACs+7j1VoewJn+Ra7+6C
fRgmL0q+xJNls0yoJ27hK71s1XMCs61FYZtArq8faEd5nPnSNN9A+Zt7SfjTEmWR
dnh+jBJ/Dcao4WOmqGpGTtaCk0vu0egfvdeUS5ua4rZvdED6ugZy89KuShvU58i2
FYDalwhVqinIMAeNeQbQ
=KWhE
-----END PGP SIGNATURE-----

--Apple-Mail=_7551FFB2-5870-4FE9-A24F-602551AEAF8B--

