[IPv6]Re: Comments on draft-ietf-6man-icmpv6-reflection

Erik Auerswald <auerswal@unix-ag.uni-kl.de> Sat, 26 April 2025 12:17 UTC

Return-Path: <auerswal@unix-ag.uni-kl.de>
X-Original-To: ipv6@mail2.ietf.org
Delivered-To: ipv6@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 8968F2185CC5; Sat, 26 Apr 2025 05:17:20 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level:
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id T4tHf41bJ61o; Sat, 26 Apr 2025 05:17:19 -0700 (PDT)
Received: from mailgw1.uni-kl.de (mailgw1.uni-kl.de [IPv6:2001:638:208:120::220]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 32D552185CB9; Sat, 26 Apr 2025 05:17:18 -0700 (PDT)
Received: from sushi.unix-ag.uni-kl.de (sushi.unix-ag.uni-kl.de [IPv6:2001:638:208:ef34:0:ff:fe00:65]) by mailgw1.uni-kl.de (8.17.1.9/8.17.1.9/Debian-2+deb12u2) with ESMTPS id 53QCHBxQ600879 (version=TLSv1.2 cipher=ECDHE-RSA-AES256-GCM-SHA384 bits=256 verify=NOT); Sat, 26 Apr 2025 14:17:11 +0200
Received: from sushi.unix-ag.uni-kl.de (ip6-localhost [IPv6:::1]) by sushi.unix-ag.uni-kl.de (8.14.4/8.14.4/Debian-8+deb8u2) with ESMTP id 53QCHBTJ027463 (version=TLSv1/SSLv3 cipher=ECDHE-RSA-AES256-GCM-SHA384 bits=256 verify=NO); Sat, 26 Apr 2025 14:17:11 +0200
Received: (from auerswal@localhost) by sushi.unix-ag.uni-kl.de (8.14.4/8.14.4/Submit) id 53QCHAOW027462; Sat, 26 Apr 2025 14:17:10 +0200
Date: Sat, 26 Apr 2025 14:17:10 +0200
From: Erik Auerswald <auerswal@unix-ag.uni-kl.de>
To: Ron Bonica <rbonica@juniper.net>
Message-ID: <20250426121710.GA26036@unix-ag.uni-kl.de>
References: <DM6PR11MB4692FDDA63996F0D9E216F8CDEB42@DM6PR11MB4692.namprd11.prod.outlook.com> <DM6PR05MB6169533D4A0D97B01A80B2F2AEB42@DM6PR05MB6169.namprd05.prod.outlook.com> <DM6PR11MB4692C14FCA96B02359AC0086DEB42@DM6PR11MB4692.namprd11.prod.outlook.com> <DM6PR05MB6169A7DA793BEA323E99C90EAEB42@DM6PR05MB6169.namprd05.prod.outlook.com> <ABA1B56D-EF4A-4F42-9F29-975403D695B4@gmx.de> <BYAPR05MB6168B18C83EF8CB0BABA0A04AEB22@BYAPR05MB6168.namprd05.prod.outlook.com> <1EDF7F8B-2977-4DEA-8803-F95E8D86926F@gmx.de> <DM6PR05MB61690D71319BB2413CD9D4B6AE852@DM6PR05MB6169.namprd05.prod.outlook.com> <20250425133330.GA2228@unix-ag.uni-kl.de> <DM6PR05MB6169574A992468A290FC6456AE842@DM6PR05MB6169.namprd05.prod.outlook.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Disposition: inline
In-Reply-To: <DM6PR05MB6169574A992468A290FC6456AE842@DM6PR05MB6169.namprd05.prod.outlook.com>
Author: Erik Auerswald <auerswal@unix-ag.uni-kl.de>
Message-ID-Hash: BT3AB2CRZJMEIR6SE5ECLEH2A7XNSG4F
X-Message-ID-Hash: BT3AB2CRZJMEIR6SE5ECLEH2A7XNSG4F
X-MailFrom: auerswal@unix-ag.uni-kl.de
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-ipv6.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Sebastian Moeller <moeller0@gmx.de>, 6man Chairs <6man-chairs@ietf.org>, "6man@ietf.org" <6man@ietf.org>, draft-ietf-6man-icmpv6-reflection <draft-ietf-6man-icmpv6-reflection@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [IPv6]Re: Comments on draft-ietf-6man-icmpv6-reflection
List-Id: "IPv6 Maintenance Working Group (6man)" <ipv6.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/ipv6/ndDK7eZt_Toze0PZyrumS-YdmEo>
List-Archive: <https://mailarchive.ietf.org/arch/browse/ipv6>
List-Help: <mailto:ipv6-request@ietf.org?subject=help>
List-Owner: <mailto:ipv6-owner@ietf.org>
List-Post: <mailto:ipv6@ietf.org>
List-Subscribe: <mailto:ipv6-join@ietf.org>
List-Unsubscribe: <mailto:ipv6-leave@ietf.org>

Hi Ron,

On Fri, Apr 25, 2025 at 05:00:40PM +0000, Ron Bonica wrote:
> [...]
> I have also done some research with a popular platform. I found that:
> 
>   * It complies with RFC 792 and 4443 regarding the number of bytes
>     in the invoking packet field.
>   * It does not modify the invoking packet field.

It would be great if others could look into this, and report their
findings, too.  It can be as simple as starting Wireshark and then
traceroute on an Internet-connected laptop (that's what I did).

> However, your finding that a LINUX-based NAT box modifies the invoking
> packet field is significant. Given this finding, I don't think that the
> Destination Unreachable or Traceroute options are viable. This leaves us
> only with the solution described in draft-ietf-6man-icmpv6-reflection.

Payload addresses translated by NAT seem to be common enough for STUN
[RFC8489] to have added an additional attribute XOR-MAPPED-ADDRESS to
avoid problems with the original MAPPED-ADDRESS attribute.  The latter
could be translated by NAT.  Section 14.2 of RFC 8489[1] ends with the
following paragraph:

   Note: XOR-MAPPED-ADDRESS and MAPPED-ADDRESS differ only in their
   encoding of the transport address.  The former encodes the transport
   address by XOR'ing it with the magic cookie.  The latter encodes it
   directly in binary.  RFC 3489 originally specified only MAPPED-
   ADDRESS.  However, deployment experience found that some NATs rewrite
   the 32-bit binary payloads containing the NAT's public IP address,
   such as STUN's MAPPED-ADDRESS attribute, in the well-meaning but
   misguided attempt to provide a generic Application Layer Gateway
   (ALG) function.  Such behavior interferes with the operation of STUN
   and also causes failure of STUN's message-integrity checking.

The XOR-MAPPED-ADDRESS attribute was added to STUN in RFC 5389 from 2008,
as noted in section 19 of that RFC[2].

[1]: https://www.rfc-editor.org/rfc/rfc8489#section-14.2
[2]: https://www.rfc-editor.org/rfc/rfc5389#section-19

Best regards,
Erik