[L2sm] R: Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)

Fioccola Giuseppe <giuseppe.fioccola@telecomitalia.it> Thu, 05 April 2018 15:23 UTC

Return-Path: <giuseppe.fioccola@telecomitalia.it>
X-Original-To: l2sm@ietfa.amsl.com
Delivered-To: l2sm@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 45FD612DA46; Thu, 5 Apr 2018 08:23:24 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.611
X-Spam-Level:
X-Spam-Status: No, score=-2.611 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H2=-0.001, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 1zAAGL-9tX7S; Thu, 5 Apr 2018 08:23:21 -0700 (PDT)
Received: from mx04.telecomitalia.it (mx04.telecomitalia.it [217.169.121.24]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 9C17A12DA41; Thu, 5 Apr 2018 08:23:20 -0700 (PDT)
X-AuditID: d9a97918-303ff70000004340-dd-5ac63f66914a
Received: from TELMBXB02RM001.telecomitalia.local ( [10.14.252.27]) (using TLS with cipher ECDHE-RSA-AES256-SHA384 (256/256 bits)) (Client did not present a certificate) by mx04.telecomitalia.it () with SMTP id 65.11.17216.66F36CA5; Thu, 5 Apr 2018 17:23:18 +0200 (CEST)
From: Fioccola Giuseppe <giuseppe.fioccola@telecomitalia.it>
To: Adam Roach <adam@nostrum.com>, The IESG <iesg@ietf.org>
CC: "adrian@olddog.co.uk" <adrian@olddog.co.uk>, "draft-ietf-l2sm-l2vpn-service-model@ietf.org" <draft-ietf-l2sm-l2vpn-service-model@ietf.org>, "l2sm-chairs@ietf.org" <l2sm-chairs@ietf.org>, "l2sm@ietf.org" <l2sm@ietf.org>
Thread-Topic: [L2sm] Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)
Thread-Index: AQHTzKHMiqhRJnImTUucPftXrVyEHqPyQbWw
Date: Thu, 5 Apr 2018 15:23:18 +0000
Message-ID: <8c26daeb315842b2931dabbf0d0008e8@TELMBXB02RM001.telecomitalia.local>
References: <152290733531.25806.5249338277589945345.idtracker@ietfa.amsl.com>
In-Reply-To: <152290733531.25806.5249338277589945345.idtracker@ietfa.amsl.com>
Accept-Language: it-IT, en-US
Content-Language: it-IT
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-exchange-transport-fromentityheader: Hosted
x-originating-ip: [10.14.252.250]
x-ti-disclaimer: Disclaimer1
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFjrOKsWRmVeSWpSXmKPExsXCxfdHWjfN/liUwavjGhZ7/i5it/jRc4PZ oudxI5PFjD8TmS0e7LzIZnHn5UtGBzaPJUt+MnnM2vmExWPF5pWMAcxRDYw2iXl5+SWJJakK KanFybZKLpnFyTmJmbmpRQohqTmpyfm5SgqZKbZKxkoKBTmJyam5qXkltkqJBQWpeSlKdlwK GMAGqCwzTyE1Lzk/JTMv3VbJM9hf18LC1FLXUMkusDS1uCRfITe1uDgxPT0zXyE1Yb1gxqYl v1kKbmlWLFw0k6WB8YJGFyMnh4SAicSf6U9Yuhi5OIQEpjJJXF8wnRUkwSZgI3Hw1Qk2EFtE wFridPNJZpAiZoEnjBLv+7aBJYQFMiTu/ZnK3sXIAVSUJbH1cTBEvZHEhJdrwOawCKhItO7d wApSwisQKHH1Kx9IWEjAV2JT/w8mEJtTwE/i7dOPYDajgKzEhN2LGEFsZgFxiRfTT7BD3Ckg sWTPeWYIW1Ti5eN/rBC2gcTWpftYIGxFiUmnnkLFZSQWHpkMtpZZQFNi/S59iJGKElO6H4KN 5BUQlDg58wnLBEaxWUi2zULomIWkYxaSjgWMLKsYRXMrDEz0SiCRl1mSmJOZqJdZsokRmFpu rqyU2MHYvdb5EKMAB6MSD+9i62NRQqyJZcWVuYcYJTiYlUR4I7SAQrwpiZVVqUX58UWlOanF hxh9gME1kVlKNDkfmPbySuINTSwsDY0tLIwMLcxMcQgrifOqqwLNEkgHpq7s1NSC1CKYcUwc nFINjMmLpr0XrNzsZ+18OFji5jnTsnyBf2xaov55hT/uy/5+dXXT+teZqkoXJsQet+EzXnT7 yMTPUcvXP3vFFX5y29H7Xv61D27dKDAsYCyoiKneOt1QKlBxffzji0qWZZeFJ8le7rBPre/I 5LGy22U4Y7PSP+az7XETo5hWX8uz8VhYEHDZP8BKSYmlOCPRUIu5qDgRAHHKw61aAwAA
Archived-At: <https://mailarchive.ietf.org/arch/msg/l2sm/e3OPi3g0napNVS8CycZfW83UNck>
Subject: [L2sm] R: Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)
X-BeenThere: l2sm@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: "The Layer Two Virtual Private Network Service Model \(L2SM\)" <l2sm.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/l2sm>, <mailto:l2sm-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/l2sm/>
List-Post: <mailto:l2sm@ietf.org>
List-Help: <mailto:l2sm-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/l2sm>, <mailto:l2sm-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 05 Apr 2018 15:23:24 -0000

Hi Adam,
Thanks for your opinion of the document.
My answers inline tagged as [GF]

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: L2sm [mailto:l2sm-bounces@ietf.org] Per conto di Adam Roach
Inviato: giovedì 5 aprile 2018 07:49
A: The IESG
Cc: adrian@olddog.co.uk; draft-ietf-l2sm-l2vpn-service-model@ietf.org; l2sm-chairs@ietf.org; l2sm@ietf.org
Oggetto: [L2sm] Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)

Adam Roach has entered the following ballot position for
draft-ietf-l2sm-l2vpn-service-model-09: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)


Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-l2sm-l2vpn-service-model/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to everyone who worked on this document. I have a handful of comments.

---------------------------------------------------------------------------

§5:

>    +--rw sites
>    +--rw site* [site-id]
>    +--rw site-id                                string

It's possible that I don't understand the intended structure here, or that I'm misreading the tree diagram, but it seems to me that this should be represented
as:

     +--rw sites
     |  +--rw site* [site-id]
     |     +--rw site-id                          string

[GF]: Yes, we will fix it.
---------------------------------------------------------------------------


§7:

>  Example of generated PE configuration:
>
>  !
>  bridge-domain 1
>   member Ethernet0/0 service-instance 100
>   member vsi one
>
>  !
>  l2 router-id 198.51.100.1
>  !
>
>  interface Ethernet0/0
>   no ip address
>   service instance 100 ethernet
>  encapsulation dot1q 100
>   !
>
>  !
>  router bgp 1
>   bgp log-neighbor-changes
>   neighbor 198.51.100.4 remote-as 1
>   neighbor 198.51.100.4 update-source Loopback0
>   !
>   address-family l2vpn vpls
>    neighbor 198.51.100.4 activate
>    neighbor 198.51.100.4 send-community extended
>    neighbor 198.51.100.4 suppress-signaling-protocol ldp
>   exit-address-family
>
>  !
>  interface vlan 100 <-- Associating the Attachment
>    no ip address       Circuit with the MAC-VRF at the PE
>    xconnect vsi PE1-VPLS-A
>  !
>  vlan 100
>    state active

Please update this example to use IPv6 (or a mix of IPv4 and IPv6). See https://www.iab.org/2016/11/07/iab-statement-on-ipv6/ for guidance.

[GF]: it makes sense. We will update this example.
---------------------------------------------------------------------------

§8:

> feature lacp {
>   description
>     " Enables LACP capability in a VPN. "; }

Nit: the spacing around the description here seems odd.

[GF]: Ok, We will fix it.

> identity pwe3 {
>   base service-type;
>   description
>     "Pseudo-Wire Emulation Edge to
>      Edge(PWE3)Service type. .";
> }

Nit: the punctuation here seems odd. Add spaces around "(PWE3)", and eliminate the trailing period.

[GF]: Ok, We will fix it.


>     leaf bum-overall-rate {
>       type uint32;
>       units "bps";
>       description
>         "overall rate for BUM.";
>     }

Given bandwidth trends, limiting this value to 4 Gbps seems to be potentially problematic. Consider a larger integer type.

[GF]: Good suggestion, will do.


_______________________________________________
L2sm mailing list
L2sm@ietf.org
https://www.ietf.org/mailman/listinfo/l2sm

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.