[L2sm] Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)

Adam Roach <adam@nostrum.com> Thu, 05 April 2018 05:48 UTC

Return-Path: <adam@nostrum.com>
X-Original-To: l2sm@ietf.org
Delivered-To: l2sm@ietfa.amsl.com
Received: from ietfa.amsl.com (localhost [IPv6:::1]) by ietfa.amsl.com (Postfix) with ESMTP id 4E6B1124234; Wed, 4 Apr 2018 22:48:55 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit
From: Adam Roach <adam@nostrum.com>
To: "The IESG" <iesg@ietf.org>
Cc: draft-ietf-l2sm-l2vpn-service-model@ietf.org, Adrian Farrel <adrian@olddog.co.uk>, l2sm-chairs@ietf.org, adrian@olddog.co.uk, l2sm@ietf.org
X-Test-IDTracker: no
X-IETF-IDTracker: 6.77.1
Auto-Submitted: auto-generated
Precedence: bulk
Message-ID: <152290733531.25806.5249338277589945345.idtracker@ietfa.amsl.com>
Date: Wed, 04 Apr 2018 22:48:55 -0700
Archived-At: <https://mailarchive.ietf.org/arch/msg/l2sm/urV50RJhojwT5_DCfvgak_pN7ho>
Subject: [L2sm] Adam Roach's No Objection on draft-ietf-l2sm-l2vpn-service-model-09: (with COMMENT)
X-BeenThere: l2sm@ietf.org
X-Mailman-Version: 2.1.22
List-Id: "The Layer Two Virtual Private Network Service Model \(L2SM\)" <l2sm.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/l2sm>, <mailto:l2sm-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/l2sm/>
List-Post: <mailto:l2sm@ietf.org>
List-Help: <mailto:l2sm-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/l2sm>, <mailto:l2sm-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 05 Apr 2018 05:48:55 -0000

Adam Roach has entered the following ballot position for
draft-ietf-l2sm-l2vpn-service-model-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-l2sm-l2vpn-service-model/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to everyone who worked on this document. I have a handful of comments.

---------------------------------------------------------------------------

§5:

>    +--rw sites
>    +--rw site* [site-id]
>    +--rw site-id                                string

It's possible that I don't understand the intended structure here, or that I'm
misreading the tree diagram, but it seems to me that this should be represented
as:

     +--rw sites
     |  +--rw site* [site-id]
     |     +--rw site-id                          string


---------------------------------------------------------------------------


§7:

>  Example of generated PE configuration:
>
>  !
>  bridge-domain 1
>   member Ethernet0/0 service-instance 100
>   member vsi one
>
>  !
>  l2 router-id 198.51.100.1
>  !
>
>  interface Ethernet0/0
>   no ip address
>   service instance 100 ethernet
>  encapsulation dot1q 100
>   !
>
>  !
>  router bgp 1
>   bgp log-neighbor-changes
>   neighbor 198.51.100.4 remote-as 1
>   neighbor 198.51.100.4 update-source Loopback0
>   !
>   address-family l2vpn vpls
>    neighbor 198.51.100.4 activate
>    neighbor 198.51.100.4 send-community extended
>    neighbor 198.51.100.4 suppress-signaling-protocol ldp
>   exit-address-family
>
>  !
>  interface vlan 100 <-- Associating the Attachment
>    no ip address       Circuit with the MAC-VRF at the PE
>    xconnect vsi PE1-VPLS-A
>  !
>  vlan 100
>    state active

Please update this example to use IPv6 (or a mix of IPv4 and IPv6). See
https://www.iab.org/2016/11/07/iab-statement-on-ipv6/ for guidance.

---------------------------------------------------------------------------

§8:

> feature lacp {
>   description
>     " Enables LACP capability in a VPN. ";
> }

Nit: the spacing around the description here seems odd.


> identity pwe3 {
>   base service-type;
>   description
>     "Pseudo-Wire Emulation Edge to
>      Edge(PWE3)Service type. .";
> }

Nit: the punctuation here seems odd. Add spaces around "(PWE3)", and eliminate
the trailing period.



>     leaf bum-overall-rate {
>       type uint32;
>       units "bps";
>       description
>         "overall rate for BUM.";
>     }

Given bandwidth trends, limiting this value to 4 Gbps seems to be potentially
problematic. Consider a larger integer type.