Re: [Mip4] 3344bis clarification on identifying the FA's SA

Pete McCann <mccap@lucent.com> Mon, 24 January 2005 16:41 UTC

Received: from ietf-mx.ietf.org (ietf-mx.ietf.org [132.151.6.1]) by ietf.org (8.9.1a/8.9.1a) with ESMTP id LAA28387 for <mip4-web-archive@ietf.org>; Mon, 24 Jan 2005 11:41:03 -0500 (EST)
Received: from megatron.ietf.org ([132.151.6.71]) by ietf-mx.ietf.org with esmtp (Exim 4.33) id 1Ct7XY-0002VS-0o for mip4-web-archive@ietf.org; Mon, 24 Jan 2005 11:58:12 -0500
Received: from localhost.localdomain ([127.0.0.1] helo=megatron.ietf.org) by megatron.ietf.org with esmtp (Exim 4.32) id 1Ct7B0-0004fb-CP; Mon, 24 Jan 2005 11:34:54 -0500
Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org) by megatron.ietf.org with esmtp (Exim 4.32) id 1Ct73l-0000sG-Cy for mip4@megatron.ietf.org; Mon, 24 Jan 2005 11:27:25 -0500
Received: from ietf-mx.ietf.org (ietf-mx.ietf.org [132.151.6.1]) by ietf.org (8.9.1a/8.9.1a) with ESMTP id LAA27359 for <mip4@ietf.org>; Mon, 24 Jan 2005 11:27:22 -0500 (EST)
Received: from ihemail2.lucent.com ([192.11.222.163]) by ietf-mx.ietf.org with esmtp (Exim 4.33) id 1Ct7KH-0001zZ-BG for mip4@ietf.org; Mon, 24 Jan 2005 11:44:30 -0500
Received: from nwsgpa.ih.lucent.com (h135-1-121-22.lucent.com [135.1.121.22]) by ihemail2.lucent.com (8.12.11/8.12.11) with ESMTP id j0OGQnUt009060; Mon, 24 Jan 2005 10:26:50 -0600 (CST)
Received: from mccap-1.lucent.com by nwsgpa.ih.lucent.com (8.11.7p1+Sun/EMS-1.5 sol2) id j0OGQn208075; Mon, 24 Jan 2005 10:26:49 -0600 (CST)
Received: from [127.0.0.1] (helo=MCCAP-1.lucent.com) by mccap-1.lucent.com with esmtp (Exim 4.04) id IATXOL-000544-00; Mon, 24 Jan 2005 11:26:45 -0500
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <16885.8644.146401.668240@gargle.gargle.HOWL>
Date: Mon, 24 Jan 2005 10:26:44 -0600
From: Pete McCann <mccap@lucent.com>
To: Kent Leung <kleung@cisco.com>
Subject: Re: [Mip4] 3344bis clarification on identifying the FA's SA
In-Reply-To: <4.3.2.7.2.20050120110108.02b3f568@mira-sjcm-2.cisco.com>
References: <4.3.2.7.2.20050119151642.02b41798@mira-sjcm-2.cisco.com> <41B76050.8080709@levkowetz.com> <4.3.2.7.2.20050120110108.02b3f568@mira-sjcm-2.cisco.com>
X-Mailer: VM 7.17 under 21.5 (beta14) "cassava" XEmacs Lucid
X-Spam-Score: 0.0 (/)
X-Scan-Signature: 8de5f93cb2b4e3bee75302e9eacc33db
Content-Transfer-Encoding: 7bit
Cc: mip4@ietf.org, Henrik Levkowetz <henrik@levkowetz.com>
X-BeenThere: mip4@ietf.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Mobility for IPv4 <mip4.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/mip4>, <mailto:mip4-request@ietf.org?subject=unsubscribe>
List-Post: <mailto:mip4@ietf.org>
List-Help: <mailto:mip4-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/mip4>, <mailto:mip4-request@ietf.org?subject=subscribe>
Sender: mip4-bounces@ietf.org
Errors-To: mip4-bounces@ietf.org
X-Spam-Score: 0.0 (/)
X-Scan-Signature: a8a20a483a84f747e56475e290ee868e
Content-Transfer-Encoding: 7bit

Hi, all,

Kent Leung writes:
 > Hi Henrik.
 > 
 > At 01:33 AM 1/20/2005 +0100, Henrik Levkowetz wrote:
 > 
 > 
 > >I suspect that the reason this has not been raised before is that before
 > >we introduced NAT traversal into the equation, it was an unstated
 > >assumption that the source IP address and the CoA address would be the same.
 > 
 > KL>
 > 
 > Actually, RFC 2002/3344 states to use the egress interface's IP address as the
 > source IP address of the RRQ  (sect. 3.7.2.2).  When RFC 3519 was introduced,
 > the mandate for the addressed to be the same was added.

Clearly, this only applies when using an FA-located CoA, right?
For Co-located CoA (in an R-bit environment) the FA must relay the
message with a different source IP address and CoA.

 > >Indeed, it is this assumption which is the base for detection of NATs in
 > >3519 - if src address and CoA address differ, then you say "Ah, this
 > >packet has gone through a NAT".
 > 
 > KL>
 > 
 > Yes.  There has been contention on this matching address requirement.
 > Excerpt from "[issue44] RFC 3344 - Source Address of the RRQ  & FHAE
 > issues" thread:
 > 
 > >Keeping RFC3344 text as is presently enables a vendor/operator to use
 > >different IP addresses for the signaling control and the data forwarding
 > >plane which might be useful in a number of configurations and operational
 > >environments. In addition, removing the general assumption that the outgoing
 > >source IP address is associated with the outgoing interface (a fairly common
 > >IP configuration) and replacing it with a nailed up source address because of
 > >a bug in NAT Traversal, may well cause us future problems.
 > 
 > There was general agreement to untie this link in 3519bis to allow the
 > source IP address to be the egress interface's for NAT Traversal case.
 > 
 > 
 > >So one way of clearing up the ambiguity could be the text you propose;
 > >another could be to clearly state that the FA sends the reply with the
 > >source address equal to the Care-of Address, typically through the
 > >interface having this address.
 > 
 > KL>
 > 
 > See above.  I think we should not force this binding of addresses.
 > 
 > 
 > >There may be other ones too, and I'm not sure which is the best way to go
 > >here.
 > >
 > >One question which pops into my head, though, is why base this on the src
 > >address, in preference to the CoA?  It would be interesting to hear your
 > >reasoning here.  Which one we pick may impact a 3519bis (NAT traversal)
 > >document more or less...

Just to amplify the choice quotes that Kent prints below: the source
IP address is really all that you have to go on when registering a
co-located CoA via the FA.  I don't think we should be adding logic
that checks the 'D' bit before deciding what to use as the index to
the SA.

For the NAT case, the right solution might be to program the SAs into
the HA with the IP address of the NAT.  This is sort of like logically
extending the FA to include an extra interface which happens to be on
another box.

-Pete

 > KL>
 > 
 > Good question.  Just to point out it's not just me.
 > 
 > >At 09:39 AM 12/15/2004 -0600, Pete McCann wrote:
 > >But the FA can be identified from its source IP address in the RRQ
 > >(absent NAT considerations).
 > 
 > At 01:21 PM 12/17/2004 -0800, Charles E.Perkins wrote:
 > >Up until now, I have thought that the mobility security association
 > >was selected based on the source IP address of the IP packet,
 > >since it was a security association for a network-layer protocol.
 > 
 > Since RFC was ambiguous on how exactly to identify
 > the FA, I came up with logic that works in all cases.  However,
 > it became apparent during the discussion on deregistration of
 > previous CoA using FHAE that source IP address of packet
 > works while the CoA will not.
 > 
 > Kent


-- 
Mip4 mailing list: Mip4@ietf.org
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/