Re: [Mip4] 3344bis clarification on identifying the FA's SA
Kent Leung <kleung@cisco.com> Thu, 20 January 2005 19:42 UTC
Received: from ietf-mx.ietf.org (ietf-mx.ietf.org [132.151.6.1]) by ietf.org (8.9.1a/8.9.1a) with ESMTP id OAA28235 for <mip4-web-archive@ietf.org>; Thu, 20 Jan 2005 14:42:00 -0500 (EST)
Received: from megatron.ietf.org ([132.151.6.71]) by ietf-mx.ietf.org with esmtp (Exim 4.33) id 1CriRe-0008FJ-12 for mip4-web-archive@ietf.org; Thu, 20 Jan 2005 14:58:18 -0500
Received: from localhost.localdomain ([127.0.0.1] helo=megatron.ietf.org) by megatron.ietf.org with esmtp (Exim 4.32) id 1Cri7F-000432-5o; Thu, 20 Jan 2005 14:37:13 -0500
Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org) by megatron.ietf.org with esmtp (Exim 4.32) id 1Cri4r-0003If-Fp for mip4@megatron.ietf.org; Thu, 20 Jan 2005 14:34:49 -0500
Received: from ietf-mx.ietf.org (ietf-mx.ietf.org [132.151.6.1]) by ietf.org (8.9.1a/8.9.1a) with ESMTP id OAA27864 for <mip4@ietf.org>; Thu, 20 Jan 2005 14:34:43 -0500 (EST)
Received: from sj-iport-3-in.cisco.com ([171.71.176.72] helo=sj-iport-3.cisco.com) by ietf-mx.ietf.org with esmtp (Exim 4.33) id 1CriKZ-00083q-0G for mip4@ietf.org; Thu, 20 Jan 2005 14:51:01 -0500
Received: from sj-core-4.cisco.com (171.68.223.138) by sj-iport-3.cisco.com with ESMTP; 20 Jan 2005 12:40:57 +0000
X-BrightmailFiltered: true
X-Brightmail-Tracker: AAAAAA==
Received: from mira-sjc5-b.cisco.com (IDENT:mirapoint@mira-sjc5-b.cisco.com [171.71.163.14]) by sj-core-4.cisco.com (8.12.10/8.12.6) with ESMTP id j0KJX51M017993; Thu, 20 Jan 2005 11:33:05 -0800 (PST)
Received: from kleung-w2k01.cisco.com (dhcp-128-107-163-211.cisco.com [128.107.163.211]) by mira-sjc5-b.cisco.com (MOS 3.4.5-GR) with ESMTP id BAV01266; Thu, 20 Jan 2005 11:33:04 -0800 (PST)
Message-Id: <4.3.2.7.2.20050120110108.02b3f568@mira-sjcm-2.cisco.com>
X-Sender: kleung@mira-sjcm-2.cisco.com
X-Mailer: QUALCOMM Windows Eudora Version 4.3.2
Date: Thu, 20 Jan 2005 11:33:03 -0800
To: Henrik Levkowetz <henrik@levkowetz.com>
From: Kent Leung <kleung@cisco.com>
Subject: Re: [Mip4] 3344bis clarification on identifying the FA's SA
In-Reply-To: <41EEFC3F.9000808@levkowetz.com>
References: <4.3.2.7.2.20050119151642.02b41798@mira-sjcm-2.cisco.com> <41B76050.8080709@levkowetz.com> <41B76050.8080709@levkowetz.com> <4.3.2.7.2.20050119151642.02b41798@mira-sjcm-2.cisco.com>
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"; format="flowed"
X-Spam-Score: 0.0 (/)
X-Scan-Signature: c3a18ef96977fc9bcc21a621cbf1174b
Cc: mip4@ietf.org
X-BeenThere: mip4@ietf.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: Mobility for IPv4 <mip4.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/mip4>, <mailto:mip4-request@ietf.org?subject=unsubscribe>
List-Post: <mailto:mip4@ietf.org>
List-Help: <mailto:mip4-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/mip4>, <mailto:mip4-request@ietf.org?subject=subscribe>
Sender: mip4-bounces@ietf.org
Errors-To: mip4-bounces@ietf.org
X-Spam-Score: 0.0 (/)
X-Scan-Signature: 386e0819b1192672467565a524848168
Hi Henrik.
At 01:33 AM 1/20/2005 +0100, Henrik Levkowetz wrote:
>I suspect that the reason this has not been raised before is that before
>we introduced NAT traversal into the equation, it was an unstated
>assumption that the source IP address and the CoA address would be the same.
KL>
Actually, RFC 2002/3344 states to use the egress interface's IP address as the
source IP address of the RRQ (sect. 3.7.2.2). When RFC 3519 was introduced,
the mandate for the addressed to be the same was added.
>Indeed, it is this assumption which is the base for detection of NATs in
>3519 - if src address and CoA address differ, then you say "Ah, this
>packet has gone through a NAT".
KL>
Yes. There has been contention on this matching address requirement.
Excerpt from "[issue44] RFC 3344 - Source Address of the RRQ & FHAE
issues" thread:
>Keeping RFC3344 text as is presently enables a vendor/operator to use
>different IP addresses for the signaling control and the data forwarding
>plane which might be useful in a number of configurations and operational
>environments. In addition, removing the general assumption that the outgoing
>source IP address is associated with the outgoing interface (a fairly common
>IP configuration) and replacing it with a nailed up source address because of
>a bug in NAT Traversal, may well cause us future problems.
There was general agreement to untie this link in 3519bis to allow the
source IP address to be the egress interface's for NAT Traversal case.
>So one way of clearing up the ambiguity could be the text you propose;
>another could be to clearly state that the FA sends the reply with the
>source address equal to the Care-of Address, typically through the
>interface having this address.
KL>
See above. I think we should not force this binding of addresses.
>There may be other ones too, and I'm not sure which is the best way to go
>here.
>
>One question which pops into my head, though, is why base this on the src
>address, in preference to the CoA? It would be interesting to hear your
>reasoning here. Which one we pick may impact a 3519bis (NAT traversal)
>document more or less...
KL>
Good question. Just to point out it's not just me.
>At 09:39 AM 12/15/2004 -0600, Pete McCann wrote:
>But the FA can be identified from its source IP address in the RRQ
>(absent NAT considerations).
At 01:21 PM 12/17/2004 -0800, Charles E.Perkins wrote:
>Up until now, I have thought that the mobility security association
>was selected based on the source IP address of the IP packet,
>since it was a security association for a network-layer protocol.
Since RFC was ambiguous on how exactly to identify
the FA, I came up with logic that works in all cases. However,
it became apparent during the discussion on deregistration of
previous CoA using FHAE that source IP address of packet
works while the CoA will not.
Kent
--
| | Kent Leung
:|: :|: IP Mobility Development
:|||: :|||: IOS Technologies Division
:|||||||: :|||||||: Voice: 408.526.5030
.:|||||||||:.:|||||||||:. Fax: 408.525.1653
c i s c o S y s t e m s Email: kleung@cisco.com
--
Mip4 mailing list: Mip4@ietf.org
Web interface: https://www1.ietf.org/mailman/listinfo/mip4
Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/
- [Mip4] DRAFT Minutes from MIP4 meeting in Washing… Henrik Levkowetz
- Re: [Mip4] DRAFT Minutes from MIP4 meeting in Was… Alexandru Petrescu
- [Mip4] 3344bis clarification on identifying the F… Kent Leung
- Re: [Mip4] 3344bis clarification on identifying t… Henrik Levkowetz
- RE: [Mip4] 3344bis clarification on identifying t… Fredrik Johansson
- RE: [Mip4] 3344bis clarification on identifying t… Kent Leung
- Re: [Mip4] 3344bis clarification on identifying t… Kent Leung
- Re: [Mip4] 3344bis clarification on identifying t… Pete McCann
- Re: [Mip4] 3344bis clarification on identifying t… Kent Leung