Return-Path: <gregimirsky@gmail.com>
X-Original-To: mpls@ietfa.amsl.com
Delivered-To: mpls@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1])
 by ietfa.amsl.com (Postfix) with ESMTP id 129C812956B;
 Tue, 30 May 2017 21:29:57 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.699
X-Spam-Level: 
X-Spam-Status: No, score=-2.699 tagged_above=-999 required=5
 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
 DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001,
 RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001]
 autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key)
 header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44])
 by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
 with ESMTP id A25pHxPD7OmZ; Tue, 30 May 2017 21:29:54 -0700 (PDT)
Received: from mail-io0-x22a.google.com (mail-io0-x22a.google.com
 [IPv6:2607:f8b0:4001:c06::22a])
 (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
 (No client certificate requested)
 by ietfa.amsl.com (Postfix) with ESMTPS id 28D45129B4C;
 Tue, 30 May 2017 21:29:53 -0700 (PDT)
Received: by mail-io0-x22a.google.com with SMTP id o12so9312393iod.3;
 Tue, 30 May 2017 21:29:53 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; 
 h=mime-version:in-reply-to:references:from:date:message-id:subject:to
 :cc; bh=vIpN6NuOAg+1gj5dAhyaEePJpGe/aksfkZfRdFRkIp0=;
 b=O00LiUD5FYhvBWT4YulTDMiYhzsYSlCPI/a/UN9Yhj32ovVEcnzXB3yCVBPt9syhvv
 gSzY6dc3Z7uzBlGx/lDRUv2TFXJNqtHxm0FGb6c+IxQjvMQVT2OchDY5VZSFjvneQ7Gk
 XvOHnlcfYUNsAaK3lksw5raMAofDbNKTkvJuPP5wuqNCX1JeVW5rFDdZaK/QxxiehZDg
 EWrZ8uzoyERrSIwtsSH07b8czRR5q6ki9spaSx9JXJwalLTnARsEApBuFEPnCTK7bv69
 rEYYvEtM/95kGy2yrTjkQNYEm8GPmq9eZRhZxHTOsXULLGdyz1Seqcr9dyJZIqwlft20
 9osA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
 d=1e100.net; s=20161025;
 h=x-gm-message-state:mime-version:in-reply-to:references:from:date
 :message-id:subject:to:cc;
 bh=vIpN6NuOAg+1gj5dAhyaEePJpGe/aksfkZfRdFRkIp0=;
 b=D1+oB3NqIf0lka6PG5bUYCQjEXzzf4QhcY7WBGOTqx1E8JGesR/c1TpTdqpAhmY+uS
 xqI3oCiDiHA/c+GoJP4r0fVv9eBm7pD+6/5CPNPFiDCDVDKuMMKNLglHHz69SZKt326/
 16GnqUV2wgJMh2KqzApnRh7TFq46OS/KhGHPpPjH0j1JUuy/Mddmah+TZoiKHs4t+wDU
 iyF+rPmOdM5VbkMCWpARDRLYr4JGPHWqua4lhIA+7zwp4iiDjVxs2EfqeSTyfIA5DZIG
 fQczoWmob1iwgXMIjXeyvZflIm8nALuMWzoTfQptUtW3/ZGTdVAna3S3exWigOoWdOd+
 1nqg==
X-Gm-Message-State: AODbwcBxjDcgx099NWVeOL/7rvAIJSpPyYsNpd7JCRhHZH5Bt2tUQouL
 t7JzlgVjlZ0aoUjY1kBEjgkxqseAiw==
X-Received: by 10.157.82.87 with SMTP id q23mr10271477otg.52.1496204993147;
 Tue, 30 May 2017 21:29:53 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.157.52.246 with HTTP; Tue, 30 May 2017 21:29:52 -0700 (PDT)
In-Reply-To: <18E37CDD-D0D0-4BE3-99AF-44E5BADCAD5D@cisco.com>
References: <db3adc45477f4e44ac48f1fb449a1850@HE105662.emea1.cds.t-internal.com>
 <D67BA178-765D-4B14-BFA5-8AC18C329D45@cisco.com>
 <CA+RyBmXS8VeEU08mZcese1eM_xqRUQHF88EWrTddTiQhdSpROQ@mail.gmail.com>
 <18E37CDD-D0D0-4BE3-99AF-44E5BADCAD5D@cisco.com>
From: Greg Mirsky <gregimirsky@gmail.com>
Date: Wed, 31 May 2017 12:29:52 +0800
Message-ID: <CA+RyBmXz=sFcgKxn5Pb5d6dPvY=7CWvfwgqsj88nH=fbyNEVSQ@mail.gmail.com>
To: Carlos Pignataro <cpignata@cisco.com>
Cc: "n.leymann@telekom.de" <N.Leymann@telekom.de>, mpls <mpls@ietf.org>, 
 "mpls-chairs@ietf.org" <mpls-chairs@ietf.org>
Content-Type: multipart/alternative; boundary="f403043c4bec20bb5b0550ca5fac"
Archived-At: <https://mailarchive.ietf.org/arch/msg/mpls/1mLwQb-5B7qksJT2JTNJPhhkST8>
Subject: Re: [mpls] WGLC for draft-ietf-mpls-bfd-directed
X-BeenThere: mpls@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: Multi-Protocol Label Switching WG <mpls.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mpls>,
 <mailto:mpls-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mpls/>
List-Post: <mailto:mpls@ietf.org>
List-Help: <mailto:mpls-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mpls>,
 <mailto:mpls-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 31 May 2017 04:29:57 -0000

--f403043c4bec20bb5b0550ca5fac
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Hi Carlos,
we clearly have different interpretation of what operational simplicity
means. Of course, someone may come up with mechanism to monitor the reverse
path of the BFD session that was set according to BFD Reverse Path TLV but
I don't see that neither necessary, nor helpful because that may hide from
an operator real failure.
Regarding the number of sub-TLVs in BFD Reverse Path TLV. I can assume that
authors followed in the path of reasoning set by RFC 4379 (now RFC 8029).
RFC 8029 defines procedures to verify correlation between the MPLS data
plane and control plane. In example in Section 3.2 we see that listing all
FECs is optional and it is perfectly valid to include single FEC that
characterizes the outer MPLS label. Using the same approach in RFC 7110, in
my opinion, was not only right but necessary. But for case of controlling
the reverse direction of a BFD session that seems unnecessary.
Additionally, RFC 7110 allows operator to pass the right for the final
selection of the return path for Echo Reply to the egress node, to the
responder. That may be useful for Echo Request/Reply as the egress returns
information on how it concluded the selection process based on received
Reply Path TLV. For BFD Reverse Path TLV, egress uses Return Code and
Return Sub-code in Echo Reply to indicate whether the requested path is
available to the egress node. If the path is not available, then the
operator may send another request in LSP Ping using BFD Reverse Path TLV.

Regards,
Greg

On Sat, May 27, 2017 at 5:14 AM, Carlos Pignataro <cpignata@cisco.com>
wrote:

> Greg,
>
> Anytime =E2=80=94 I wanted to reply so that there was at least one non-au=
thor
> message about it.  You and I have very different views on what is a
> technical concern.
>
> For example this comment describes a specific technical concern:
> * =E2=80=9CExactly one sub-TLV MUST be included in the Reverse Path TLV.=
=E2=80=9D
>
> Basically, the document says that the return path cannot have a FEC Stack
> (e.g., nested FECs or a Tunnel or...). It is not clear why.
> Basically it flattens MPLS to one label on return.
>
> In contrast, RFC 7110 allows for multiple FECs:
>
>    Reply Path:  It is used to describe the return path that an echo
>       reply will be send along.  It is variable in length and can
>       contain zero, one or more Target FEC sub-TLVs [RFC4379].
>
> A second technical issue:
> * =E2=80=9C This approach assumes that FECs do not ever change=E2=80=A6.=
=E2=80=9D
>
> I find the response of =E2=80=9Cpunt it to the operator=E2=80=9D complete=
 unsatisfactory.
> We are trying to reduce OpEx, not build tools that put the burden on
> operators.
>
> Basically, the root cause stems from the fact that RFC 7110 uses a return
> path construct for a response immediate sent and elicited by the reply,
> whereas your draft attempts to mimic the method but for a protocol in whi=
ch
> there is a bootstrapping, and after that, no mechanism for update althoug=
h
> the underlying network can change.
>
> This proposal as it is right now, basically makes an existing protocol
> more brittle than it was before, and the network operations more complex.
>
> Another technical concern, the description in Section 4. And then there=
=E2=80=99s
> also the indication of IPR but a conflicting message from one of the
> authors.
>
> Please note I was not making specific suggestions =E2=80=94 technical or
> editorial. Just pointing out that there are technical issues with this
> document.
>
> Technically.
>
> =E2=80=94 Carlos.
>
> On May 25, 2017, at 10:26 AM, Greg Mirsky <gregimirsky@gmail.com> wrote:
>
> Dear Carlos,
> thank you for taking two minutes to write the message. From it all I've
> found only one concern that, in my view, may be considered technical. Thu=
s
> I'll bring it to the forefront and will try to explain how the situation
> may be handled.
> You wrote:
> 1. This approach assumes that FECs do not ever change. A reverse path is
> instructed at setup/bootstrap with MPLS LSP Ping =E2=80=94 what happens i=
f paths
> change?!? If a return tunnel is suddenly deleted from underneath?
> I consider it to be the case that should be handled by properly operating
> the network rather then auto-discovering it and auto-recovering. I hardly
> believe that a tunnel may be "suddenly deleted" without the operator bein=
g
> aware of that. And if that is the case, then the operator may proactively
> re-signal return path for those BFD sessions that may be affected by the
> planned change in the network. Even more, BFD sessions to decrease chance
> of receiving false negative during period the remote BFD peer switches to
> new recommended path.
>
> Thank you for the editorial suggestion to consider renaming the section.
> We'll discuss and share our proposal to improve the wording.
>
> Others may decide to respond to the rest of your message. There's nothing
> of technical substance, as I see it.
>
> Regards,
> Greg
>
> On Wed, May 24, 2017 at 11:36 PM, Carlos Pignataro (cpignata) <
> cpignata@cisco.com> wrote:
>
>> Nic,
>>
>> I do not support advancing this document in its current form. It has man=
y
>> technical deficiencies, some of which are listed and described below.
>>
>> I also believe your WGLC note should have been much more detailed and
>> comprehensive.
>>
>> I believe this is the 3rd WGLC on this document, correct? (That gives a
>> new meaning to =E2=80=9CLast=E2=80=9D :-) If so, that should have also b=
een clarified in
>> the WGLC email, with a much more clear explanation and comprehensive set=
 of
>> details of how concerns were discussed and addressed.
>>
>> > The authors have updated draft-ietf-mpls-bfd-directed and think that
>> the draft is ready for WGLC.
>>
>> I am very concerned that there was no discussion on the list of any of
>> those changes.  The authors believe the draft is ready =E2=80=94 do you =
believe so
>> as well, Nic? Was a shepherd review performed and is that available?
>>
>> > Please note that draft-ietf-mpls-bfd-directed did not pass the
>> > previous working group last call, because of an IPR disclosure:
>>
>> Is that the 1st or 2nd WGLC? I think this statement is an
>> oversimplification. There were many technical concerns.
>>
>> Anyway, scanning through this document, some technical issues:
>>
>> 1. This approach assumes that FECs do not ever change. A reverse path is
>> instructed at setup/bootstrap with MPLS LSP Ping =E2=80=94 what happens =
if paths
>> change?!? If a return tunnel is suddenly deleted from underneath?
>> 2. =E2=80=9CCase of MPLS Data Plane=E2=80=9D =E2=80=94 is there any othe=
r non-MPLS case? This
>> points to the fact of lack of review and editorial sloppiness.
>> 3. =E2=80=9CExactly one sub-TLV MUST be included in the Reverse Path TLV=
.=E2=80=9D =E2=80=94 so
>> basically, no Tunnels can be return path?!?
>> 4. The =E2=80=9CUse Case Scenario=E2=80=9D uses 2119 language in a way t=
hat does not make
>> sense.
>>
>> Please note, this is not an exhaustive list, but a 2 minute scan through
>> the doc.
>>
>> Thanks!
>>
>> Carlos.
>>
>>
>> > On May 24, 2017, at 2:33 AM, n.leymann@telekom.de <N.Leymann@telekom.d=
e>
>> wrote:
>> >
>> > Dear Working Group,
>> >
>> > The authors have updated draft-ietf-mpls-bfd-directed and think that
>> the draft is ready for WGLC.
>> > Therefore this e-mail starts a WG LC which will end on the 7th of June=
.
>> >
>> > Please note that draft-ietf-mpls-bfd-directed did not pass the
>> > previous working group last call, because of an IPR disclosure:
>> >
>> >   https://datatracker.ietf.org/ipr/2892/
>> >
>> > The authors have updated the draft and they believe that the IPR is no
>> longer in scope.
>> > Please notify the list if you still think the IPR is an issue and
>> please state if you think it
>> > is OK to continue with the publication of this document.
>> >
>> >   Best regards
>> >
>> >     Nic
>> >
>> >
>> > _______________________________________________
>> > mpls mailing list
>> > mpls@ietf.org
>> > https://www.ietf.org/mailman/listinfo/mpls
>>
>> _______________________________________________
>> mpls mailing list
>> mpls@ietf.org
>> https://www.ietf.org/mailman/listinfo/mpls
>>
>
>
>

--f403043c4bec20bb5b0550ca5fac
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Hi Carlos,<div>we clearly have different interpretation of=
 what operational simplicity means. Of course, someone may come up with mec=
hanism to monitor the reverse path of the BFD session that was set accordin=
g to BFD Reverse Path TLV but I don&#39;t see that neither necessary, nor h=
elpful because that may hide from an operator real failure.<br></div><div>R=
egarding the number of sub-TLVs in BFD Reverse Path TLV. I can assume that =
authors followed in the path of reasoning set by RFC 4379 (now RFC 8029). R=
FC 8029 defines procedures to verify correlation between the MPLS data plan=
e and control plane. In example in Section 3.2 we see that listing all FECs=
 is optional and it is perfectly valid to include single FEC that character=
izes the outer MPLS label. Using the same approach in RFC 7110, in my opini=
on, was not only right but necessary. But for case of controlling the rever=
se direction of a BFD session that seems unnecessary.</div><div>Additionall=
y, RFC 7110 allows operator to pass the right for the final selection of th=
e return path for Echo Reply to the egress node, to the responder. That may=
 be useful for Echo Request/Reply as the egress returns information on how =
it concluded the selection process based on received Reply Path TLV. For BF=
D Reverse Path TLV, egress uses Return Code and Return Sub-code in Echo Rep=
ly to indicate whether the requested path is available to the egress node. =
If the path is not available, then the operator may send another request in=
 LSP Ping using BFD Reverse Path TLV.</div><div><br></div><div>Regards,</di=
v><div>Greg</div></div><div class=3D"gmail_extra"><br><div class=3D"gmail_q=
uote">On Sat, May 27, 2017 at 5:14 AM, Carlos Pignataro <span dir=3D"ltr">&=
lt;<a href=3D"mailto:cpignata@cisco.com" target=3D"_blank">cpignata@cisco.c=
om</a>&gt;</span> wrote:<br><blockquote class=3D"gmail_quote" style=3D"marg=
in:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style=3D"wo=
rd-wrap:break-word">Greg,<div><br></div><div>Anytime =E2=80=94 I wanted to =
reply so that there was at least one non-author message about it.=C2=A0 You=
 and I have very different views on what is a technical concern.</div><div>=
<br></div><div>For example this comment describes a specific technical conc=
ern:</div><div>* =E2=80=9CExactly one sub-TLV MUST be included in the Rever=
se Path TLV.=E2=80=9D</div><div><br></div><div>Basically, the document says=
 that the return path cannot have a FEC Stack (e.g., nested FECs or a Tunne=
l or...). It is not clear why.=C2=A0</div><div>Basically it flattens MPLS t=
o one label on return.</div><div><br></div><div>In contrast, RFC 7110 allow=
s for multiple FECs:</div><div><br></div><div><div>=C2=A0 =C2=A0Reply Path:=
 =C2=A0It is used to describe the return path that an echo</div><div>=C2=A0=
 =C2=A0 =C2=A0 reply will be send along.=C2=A0 It is variable in length and=
 can</div><div>=C2=A0 =C2=A0 =C2=A0 contain zero, one or more Target FEC su=
b-TLVs [RFC4379].</div></div><div><br></div><div>A second technical issue:<=
/div><div>* =E2=80=9C This approach assumes that FECs do not ever change=E2=
=80=A6.=E2=80=9D</div><div><br></div><div>I find the response of =E2=80=9Cp=
unt it to the operator=E2=80=9D complete unsatisfactory. We are trying to r=
educe OpEx, not build tools that put the burden on operators.</div><div><br=
></div><div>Basically, the root cause stems from the fact that RFC 7110 use=
s a return path construct for a response immediate sent and elicited by the=
 reply, whereas your draft attempts to mimic the method but for a protocol =
in which there is a bootstrapping, and after that, no mechanism for update =
although the underlying network can change.</div><div><br></div><div>This p=
roposal as it is right now, basically makes an existing protocol more britt=
le than it was before, and the network operations more complex.</div><div><=
br></div><div>Another technical concern, the description in Section 4. And =
then there=E2=80=99s also the indication of IPR but a conflicting message f=
rom one of the authors.</div><div><br></div><div>Please note I was not maki=
ng specific suggestions =E2=80=94 technical or editorial. Just pointing out=
 that there are technical issues with this document.</div><div><br></div><d=
iv>Technically.</div><span class=3D"HOEnZb"><font color=3D"#888888"><div><b=
r></div><div>=E2=80=94 Carlos.</div></font></span><div><div class=3D"h5"><d=
iv><br><div><blockquote type=3D"cite"><div>On May 25, 2017, at 10:26 AM, Gr=
eg Mirsky &lt;<a href=3D"mailto:gregimirsky@gmail.com" target=3D"_blank">gr=
egimirsky@gmail.com</a>&gt; wrote:</div><br class=3D"m_-1868353352990511809=
Apple-interchange-newline"><div><div dir=3D"ltr">Dear Carlos,<div>thank you=
 for taking two minutes to write the message. From it all I&#39;ve found on=
ly one concern that, in my view, may be considered technical. Thus I&#39;ll=
 bring it to the forefront and will try to explain how the situation may be=
 handled.</div><div>You wrote:</div><div><span style=3D"font-size:12.8px">1=
. This approach assumes that FECs do not ever change. A reverse path is ins=
tructed at setup/bootstrap with MPLS LSP Ping =E2=80=94 what happens if pat=
hs change?!? If a return tunnel is suddenly deleted from underneath?</span>=
<br></div><div><span style=3D"font-size:12.8px">I consider it to be the cas=
e that should be handled by properly operating the network rather then auto=
-discovering it and auto-recovering. I hardly believe that a tunnel may be =
&quot;suddenly deleted&quot; without the operator being aware of that. And =
if that is the case, then the operator may proactively re-signal return pat=
h for those BFD sessions that may be affected by the planned change in the =
network. Even more, BFD sessions to decrease chance of receiving false nega=
tive during period the remote BFD peer switches to new recommended path.</s=
pan></div><div><span style=3D"font-size:12.8px"><br></span></div><div><span=
 style=3D"font-size:12.8px">Thank you for the editorial suggestion to consi=
der renaming the section. We&#39;ll discuss and share our proposal to impro=
ve the wording.</span></div><div><span style=3D"font-size:12.8px"><br></spa=
n></div><div><span style=3D"font-size:12.8px">Others may decide to respond =
to the rest of your message. There&#39;s nothing of technical substance, as=
 I see it.</span></div><div><span style=3D"font-size:12.8px"><br></span></d=
iv><div><span style=3D"font-size:12.8px">Regards,</span></div><div><span st=
yle=3D"font-size:12.8px">Greg</span></div></div><div class=3D"gmail_extra">=
<br><div class=3D"gmail_quote">On Wed, May 24, 2017 at 11:36 PM, Carlos Pig=
nataro (cpignata) <span dir=3D"ltr">&lt;<a href=3D"mailto:cpignata@cisco.co=
m" target=3D"_blank">cpignata@cisco.com</a>&gt;</span> wrote:<br><blockquot=
e class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;border-left:1px #ccc sol=
id;padding-left:1ex">Nic,<br>
<br>
I do not support advancing this document in its current form. It has many t=
echnical deficiencies, some of which are listed and described below.<br>
<br>
I also believe your WGLC note should have been much more detailed and compr=
ehensive.<br>
<br>
I believe this is the 3rd WGLC on this document, correct? (That gives a new=
 meaning to =E2=80=9CLast=E2=80=9D :-) If so, that should have also been cl=
arified in the WGLC email, with a much more clear explanation and comprehen=
sive set of details of how concerns were discussed and addressed.<br>
<span><br>
&gt; The authors have updated draft-ietf-mpls-bfd-directed and think that t=
he draft is ready for WGLC.<br>
<br>
</span>I am very concerned that there was no discussion on the list of any =
of those changes.=C2=A0 The authors believe the draft is ready =E2=80=94 do=
 you believe so as well, Nic? Was a shepherd review performed and is that a=
vailable?<br>
<span><br>
&gt; Please note that draft-ietf-mpls-bfd-directed did not pass the<br>
&gt; previous working group last call, because of an IPR disclosure:<br>
<br>
</span>Is that the 1st or 2nd WGLC? I think this statement is an oversimpli=
fication. There were many technical concerns.<br>
<br>
Anyway, scanning through this document, some technical issues:<br>
<br>
1. This approach assumes that FECs do not ever change. A reverse path is in=
structed at setup/bootstrap with MPLS LSP Ping =E2=80=94 what happens if pa=
ths change?!? If a return tunnel is suddenly deleted from underneath?<br>
2. =E2=80=9CCase of MPLS Data Plane=E2=80=9D =E2=80=94 is there any other n=
on-MPLS case? This points to the fact of lack of review and editorial slopp=
iness.<br>
3. =E2=80=9CExactly one sub-TLV MUST be included in the Reverse Path TLV.=
=E2=80=9D =E2=80=94 so basically, no Tunnels can be return path?!?<br>
4. The =E2=80=9CUse Case Scenario=E2=80=9D uses 2119 language in a way that=
 does not make sense.<br>
<br>
Please note, this is not an exhaustive list, but a 2 minute scan through th=
e doc.<br>
<br>
Thanks!<br>
<span class=3D"m_-1868353352990511809HOEnZb"><font color=3D"#888888"><br>
Carlos.<br>
</font></span><div class=3D"m_-1868353352990511809HOEnZb"><div class=3D"m_-=
1868353352990511809h5"><br>
<br>
&gt; On May 24, 2017, at 2:33 AM, <a href=3D"mailto:n.leymann@telekom.de" t=
arget=3D"_blank">n.leymann@telekom.de</a> &lt;<a href=3D"mailto:N.Leymann@t=
elekom.de" target=3D"_blank">N.Leymann@telekom.de</a>&gt; wrote:<br>
&gt;<br>
&gt; Dear Working Group,<br>
&gt;<br>
&gt; The authors have updated draft-ietf-mpls-bfd-directed and think that t=
he draft is ready for WGLC.<br>
&gt; Therefore this e-mail starts a WG LC which will end on the 7th of June=
.<br>
&gt;<br>
&gt; Please note that draft-ietf-mpls-bfd-directed did not pass the<br>
&gt; previous working group last call, because of an IPR disclosure:<br>
&gt;<br>
&gt;=C2=A0 =C2=A0<a href=3D"https://datatracker.ietf.org/ipr/2892/" rel=3D"=
noreferrer" target=3D"_blank">https://datatracker.ietf.org/<wbr>ipr/2892/</=
a><br>
&gt;<br>
&gt; The authors have updated the draft and they believe that the IPR is no=
 longer in scope.<br>
&gt; Please notify the list if you still think the IPR is an issue and plea=
se state if you think it<br>
&gt; is OK to continue with the publication of this document.<br>
&gt;<br>
&gt;=C2=A0 =C2=A0Best regards<br>
&gt;<br>
&gt;=C2=A0 =C2=A0 =C2=A0Nic<br>
&gt;<br>
&gt;<br>
</div></div><div class=3D"m_-1868353352990511809HOEnZb"><div class=3D"m_-18=
68353352990511809h5">&gt; ______________________________<wbr>______________=
___<br>
&gt; mpls mailing list<br>
&gt; <a href=3D"mailto:mpls@ietf.org" target=3D"_blank">mpls@ietf.org</a><b=
r>
&gt; <a href=3D"https://www.ietf.org/mailman/listinfo/mpls" rel=3D"noreferr=
er" target=3D"_blank">https://www.ietf.org/mailman/l<wbr>istinfo/mpls</a><b=
r>
<br>
______________________________<wbr>_________________<br>
mpls mailing list<br>
<a href=3D"mailto:mpls@ietf.org" target=3D"_blank">mpls@ietf.org</a><br>
<a href=3D"https://www.ietf.org/mailman/listinfo/mpls" rel=3D"noreferrer" t=
arget=3D"_blank">https://www.ietf.org/mailman/l<wbr>istinfo/mpls</a><br>
</div></div></blockquote></div><br></div>
</div></blockquote></div><br></div></div></div></div></blockquote></div><br=
></div>

--f403043c4bec20bb5b0550ca5fac--

