Re: [mpls] MPLS-RT review of draft-mirsky-mpls-p2mp-bfd-14
Greg Mirsky <gregimirsky@gmail.com> Thu, 16 September 2021 00:00 UTC
Return-Path: <gregimirsky@gmail.com>
X-Original-To: mpls@ietfa.amsl.com
Delivered-To: mpls@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7968E3A0965; Wed, 15 Sep 2021 17:00:19 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.097
X-Spam-Level:
X-Spam-Status: No, score=-2.097 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id FkYkJzJ0sZoQ; Wed, 15 Sep 2021 17:00:12 -0700 (PDT)
Received: from mail-ed1-x52a.google.com (mail-ed1-x52a.google.com [IPv6:2a00:1450:4864:20::52a]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id DBFF93A095E; Wed, 15 Sep 2021 17:00:08 -0700 (PDT)
Received: by mail-ed1-x52a.google.com with SMTP id h17so9901733edj.6; Wed, 15 Sep 2021 17:00:08 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20210112; h=mime-version:references:in-reply-to:from:date:message-id:subject:to :cc; bh=l8wcq2I7QKZbYzNsRazKaU0HqTlxYHj2kwuMe1YPHgc=; b=KfEETtCdJ02/aCB/Oy5dQUsnpYTe3hRqAtmHqicUO53VWei4+DBdb8klOGIRSu1/GU y9147I6yIRC2c04wpWPvluyl5r4btpVtCuFdf4SYUg6H+3wJsitJyyjez32+O1JjpN1R RVisaDDyVL3KhXAasmV/tAYzzDGuTk6prJAK0v+qeORt/ckTjCcoYVY9dBudbT9ttSx3 vE1KW0ScFffX3D/ITzdieNTvyhfplNjyQUZ6npm4TDHe5q1mg51mSou39cHgPs3QWyz6 7+/3y22JPEaRlE575trIjCIBImE3jxQ0CaeWRY+oxrDoKJsaIxLOIEzhgcejkvqjSUoL ZY6w==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20210112; h=x-gm-message-state:mime-version:references:in-reply-to:from:date :message-id:subject:to:cc; bh=l8wcq2I7QKZbYzNsRazKaU0HqTlxYHj2kwuMe1YPHgc=; b=Zxl+gexgHbwCAqEsD7CepfuBzcSvuRR6xDL7RS5xfmBEhw6QltyssZYz4JE6OHKwPj 6IZR1rTjL8JoqyIxQGVe3goggYdKa9f9ybe9CD5jyFZ1rHMd6FNO66QTWo+KzHS1B2Kz FUcf4p1UetfKZ/cIQFM0BKVSpYvDesFE6Pjjt24A2cFj0NkynG75Hzt2+qw8Dp2qcGtY 4/DxuD1qei0V79ADX5KMIpu9f+YssqKKduQ9AlrHQmZwxcr3rDNWQrZSB3VGr1tESBBZ IShHMn53P13EVu6usoRac/hKeAMTWMQJUtoTI1zd78VzbCIk0mvyi8ihnAl/v3NqqITn VVPw==
X-Gm-Message-State: AOAM531B/6dmkawnx6a9t59vTlXj6F221uqtWNcmmwFqLhy9l6G+YAY1 4YqoY+iocI0jGK2QkMeJxmJi7Ikbw30rXKVbTf8=
X-Google-Smtp-Source: ABdhPJxpoqc9ZYhcQ0P2+i9tGTMK3iVbpQD7SwZbF/D/gpqieOsNhYfjCDXb1i/u9dBryf7lLnOokKCYpi1NXh4K+Uk=
X-Received: by 2002:a17:907:8309:: with SMTP id mq9mr2804581ejc.561.1631750404752; Wed, 15 Sep 2021 17:00:04 -0700 (PDT)
MIME-Version: 1.0
References: <0d8b35d0-ccc3-30b0-b37c-28228b505404@pi.nu> <CO1PR05MB8314360D5669CBF4E857AEB0D5DB9@CO1PR05MB8314.namprd05.prod.outlook.com>
In-Reply-To: <CO1PR05MB8314360D5669CBF4E857AEB0D5DB9@CO1PR05MB8314.namprd05.prod.outlook.com>
From: Greg Mirsky <gregimirsky@gmail.com>
Date: Wed, 15 Sep 2021 16:59:53 -0700
Message-ID: <CA+RyBmUv-Z92WeWPVz3YQm_p_O_egfegU1XTGG85vMdLLuEY2Q@mail.gmail.com>
To: Shraddha Hegde <shraddha@juniper.net>
Cc: Loa Andersson <loa@pi.nu>, Mach Chen <mach.chen@huawei.com>, "draft-mirsky-mpls-p2mp-bfd@ietf.org" <draft-mirsky-mpls-p2mp-bfd@ietf.org>, Italo Busi <Italo.Busi@huawei.com>, "Rakesh Gandhi (rgandhi)" <rgandhi@cisco.com>, "mpls-chairs@ietf.org" <mpls-chairs@ietf.org>, "mpls@ietf.org" <mpls@ietf.org>
Content-Type: multipart/alternative; boundary="0000000000003cc77205cc117fcb"
Archived-At: <https://mailarchive.ietf.org/arch/msg/mpls/L6fuUkMizt7nCoehaP0IqenGMNs>
Subject: Re: [mpls] MPLS-RT review of draft-mirsky-mpls-p2mp-bfd-14
X-BeenThere: mpls@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: Multi-Protocol Label Switching WG <mpls.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mpls>, <mailto:mpls-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mpls/>
List-Post: <mailto:mpls@ietf.org>
List-Help: <mailto:mpls-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mpls>, <mailto:mpls-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 16 Sep 2021 00:00:20 -0000
Hi Shraddha, thank you for your kind words supporting this work. I greatly appreciate your comments and suggestions. Please find my answers below under the GIM>> tag. I'll be glad to apply and submit the updates proposed below if you find them acceptable. Regards, Greg On Wed, Sep 15, 2021 at 12:17 AM Shraddha Hegde <shraddha@juniper.net> wrote: > Hi Authors, > > I have been selected as one of the MPLS-RT reviewers of > draft-mirsky-mpls-p2mp-bfd-14. > > I think that the document is coherent, is it useful (i.e., it addresses a > real need for operational networks), and it is technically sound. > GIM>> Thank you > > > I have few comments that can be addressed either before or after WG > adoption. > > 1. Introduction > > The introduction section specifies "Multiprotocol > Label Switching (MPLS) point-to-multipoint (p2mp) Label Switched > Paths (LSPs)" as the scope of the document. > It would be good to state explicitly > whether this draft applies to SR P2MP or not. > GIM>> Would the following update in Abstract and Introduction be helpful: OLD TEXT: This document describes procedures for using Bidirectional Forwarding Detection (BFD) for multipoint networks to detect data plane failures in Multiprotocol Label Switching (MPLS) point-to-multipoint (p2mp) Label Switched Paths (LSPs). NEW TEXT: This document describes procedures for using Bidirectional Forwarding Detection (BFD) for multipoint networks to detect data plane failures in Multiprotocol Label Switching (MPLS) point-to-multipoint (p2mp) Label Switched Paths (LSPs) and Segment Routing (SR) point-to- multipoint policies with SR-MPLS data plane. > > 2. > IP Encapsulation of Multipoint BFD > > Is there a reason why entropy label is specified with "SHOULD" > and the UDP source port mechansim is a "MAY".? > If there is a preference, the reason for that preference should be > clearly described. > GIM>> As discussed in the Motivation section RFC 6790, generating entropy information at the ingress LSR has clear advantages compared to when a transit LSR infers entropy using MPLS label stack or payload information. I propose adding that as the following text in Section 3.1: NEW TEXT: The Motivation section [RFC6790] lists several advantages of generating the entropy value by an ingress Label Switching Router (LSR) compared to when a transit LSR infers entropy using the information in the MPLS label stack or payload. Thus this specification further clarifies that: > > 3. section 4.1 > For the benefit of the reader, Describe how the LSP Ping messages > are constructed. > GIM>> This specification does not change procedures defined in RFC 8029, RFC 6425 and RFC 8287 (adding RFC 8287 as Normative reference). Would adding references as below be acceptable: NEW TEXT: For the case of p2mp MPLS LSP, the Target FEC TLV MUST use sub-TLVs defined in Section 3.1 [RFC6425]. For the case of p2mp SR policy with SR-MPLS data plane, an implementation of this specification MUST follow procedures defined in [RFC8287]. > > > 4. section 4.1 > Does the presence of BFD discriminator TLV indicate that the LSP > ping > is for bootstrapping the P2MP BFD session?. Would be good to > clarify that. > GIM>> You are right, the presence of the BFD Discriminator TLV in an LSP echo request is to bootstrap a BFD session. This specification uses the BFD Discriminator TLV as it is defined in RFC 5884 but only recommends using "Do not reply" value in the Reply mode field. The second paragraph in Section 4.1 is intended to provide information to an implementor who have chosen to use LSP Ping (with the next text as proposed above): LSP Ping, as defined in [RFC6425], MAY be used to bootstrap MultipointTail. If LSP Ping is used, it MUST include the Target FEC TLV and the BFD Discriminator TLV defined in [RFC5884]. For the case of p2mp MPLS LSP, the Target FEC TLV MUST use sub-TLVs defined in Section 3.1 [RFC6425]. For the case of p2mp SR policy with SR-MPLS data plane, an implementation of this specification MUST follow procedures defined in [RFC8287]. Setting the value of Reply Mode field to "Do not reply" [RFC8029] for the LSP Ping to bootstrap MultipointTail of the p2mp BFD session is RECOMMENDED. Indeed, because BFD over a multipoint network uses BFD Demand mode, the LSP echo reply from a tail has no useful information to convey to the head, unlike in the case of the BFD over a p2p MPLS LSP [RFC5884]. Would appreciate if you suggest a specific text. Regards, Greg > > Rgds > Shraddha > > > Juniper Business Use Only > > -----Original Message----- > From: Loa Andersson <loa@pi.nu> > Sent: Thursday, July 22, 2021 3:28 PM > To: Mach Chen <mach.chen@huawei.com>; Italo Busi <Italo.Busi@huawei.com>; > Rakesh Gandhi (rgandhi) <rgandhi@cisco.com>; Shraddha Hegde < > shraddha@juniper.net> > Cc: draft-mirsky-mpls-p2mp-bfd@ietf.org; mpls-chairs@ietf.org > Subject: MPLS-RT review of draft-mirsky-mpls-p2mp-bfd-14 > > [External Email. Be cautious of content] > > > Mach, Italo, Rakesh, and Shraddha, > > You have been selected as MPLS-RT reviewers for > draft-mirsky-mpls-p2mp-bfd-14 > > Note to authors: You have been CC'd on this email so that you can know > that this review is going on. However, please do not review your own > document. > > Reviews should comment on whether the document is coherent, is it useful > (ie, is it likely to be actually useful in operational networks), and is > the document technically sound? We are interested in knowing whether the > document is ready to be considered for WG adoption (ie, it doesn't have to > be perfect at this point, but should be a good start). > > Reviews should be sent to the document authors, WG co-chairs and WG > secretary, and CC'd to the MPLS WG email list. If necessary, comments may > be sent privately to only the WG chairs. > > If you have technical comments you should try to be explicit about what > *really* need to be resolved before adopting it as a working group > document, and what can wait until the document is a working group document > and the working group has the revision control. > > Next week is IETF week, so we'd like to set the dead-line two weeks after > the conclusion of the IETF 111. > > Can you review the document by August 13, 2021? > > > Thanks, Loa > (as MPLS WG chair) > > -- > > Loa Andersson email: loa@pi.nu > Senior MPLS Expert loa.pi.nu@gmail.com > Bronze Dragon Consulting phone: +46 739 81 21 64 >
- Re: [mpls] MPLS-RT review of draft-mirsky-mpls-p2… Shraddha Hegde
- Re: [mpls] MPLS-RT review of draft-mirsky-mpls-p2… Greg Mirsky