[mpls] Re: Working Group Last Call for draft-ietf-mpls-spring-lsp-ping-path-sid (was Re: Working Group Last Call on draft-xp-mpls-spring-lsp-ping-path-sid)

Greg Mirsky <gregimirsky@gmail.com> Wed, 14 August 2024 22:05 UTC

Return-Path: <gregimirsky@gmail.com>
X-Original-To: mpls@ietfa.amsl.com
Delivered-To: mpls@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 3E4B8C15106E; Wed, 14 Aug 2024 15:05:52 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -7.095
X-Spam-Level:
X-Spam-Status: No, score=-7.095 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_HI=-5, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_KAM_HTML_FONT_INVALID=0.01, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id lUJoZFUUoLkd; Wed, 14 Aug 2024 15:05:48 -0700 (PDT)
Received: from mail-pj1-x1033.google.com (mail-pj1-x1033.google.com [IPv6:2607:f8b0:4864:20::1033]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 186D8C169404; Wed, 14 Aug 2024 15:05:48 -0700 (PDT)
Received: by mail-pj1-x1033.google.com with SMTP id 98e67ed59e1d1-2cd5e3c27c5so221969a91.3; Wed, 14 Aug 2024 15:05:48 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1723673147; x=1724277947; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=AnzCb0k0wGkpVCP3YWNI/YHTz8B4dPn5ZNo1g+RiQVY=; b=EzzidNPz/GLPLI1VqV24sZZoTdT/TRNhM5RJpF34gyil61QuWq3mu+HgCY0TuivhXU 0taA9I9kJt6e8WHRxCjvqoG3jvOjMM+ERZmU5HQ/SNZvAecbUFAte0GALqaUrzhR3u+j NkUs1uWMwvoa2/WEXWr0TlDBTAf27Z6n599VPH8mXNblveVd7znMT1ZoCgsX/HW/P0wy huJeqNmEvqXZ8sDojhyPAbi640oJuSiLz84SOLBObxmny0liIsN5NQpG7laKGZobiGd9 SpliQpbsBmlJWj/Gk+7zEBpVJmUH6YjomkJ9EJ6Y/4/eCkGr47aG54Ca5fAmrI1SsLAg iW5g==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1723673147; x=1724277947; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=AnzCb0k0wGkpVCP3YWNI/YHTz8B4dPn5ZNo1g+RiQVY=; b=oKhcXaH7m1fbH4kM93U2jI3cGZrxDxc4INRo/upcGZttOgl7BxhsSDrcREA7URBt3W Ngx2/13PYBZKtBcLv/ak+YFS7CLW3iT7/zLPUUazWeFQ1Wh96ZUc59am6Z9q/zoIzyEO fF1CckJdhLrz/BCYDhA84PtWmSHTaHKXOlNI9LFuwlH34vT8F08JMxuLyewyarigKzoZ ZL5zdAP0humFBP/V53i0JAtaTn6oXFuEjCgGcHX8wau/pyKF07pEiENMUO6w2/21Kvj7 9VZrvei8KmPfRxPZYUvI2jUVZUn3YBuX7VwxaE1eIK4yHnXQNee6ubdjXssGUHGW0r0c hfOg==
X-Forwarded-Encrypted: i=1; AJvYcCWVCpFHNNVBARYIBeoRkTH6aetknjVMoCd+zu2yBCQvX4Nf/G/Q5clGtEG1evTDWqtnPp8CfgmkoDGcp5j8LNfZ//VBj+9gMknGsJBxr5HJPlesKl2oey7+y+ajMYTIH3RuNrazZuqJ9OUPgnx1B1XTHaVLdwZgzARjO1H/rOgHnQvHm59k6Q==
X-Gm-Message-State: AOJu0YyMgU823t/2qV8Q4BGWAB8nXwnYajLSvHQzB6L3zAyXfx0IYATp kIoXlcCIVM+v+jbHq5dRv/mMgYyMue7hMKJcOeI0O+GyfHAv/oAfXe193+C4anT3chRzZIoO5wJ TLr8n3XmgUDtnrwnd4tGY+JhWWy0=
X-Google-Smtp-Source: AGHT+IH1s4lbpTVSy4NVj9tJA0isAYy2gQ9XFQruEO3yyePInB7nT9ef8zGvUTNgC64QLEJb2wccrHRSi93qrJSvT1I=
X-Received: by 2002:a17:90a:3d44:b0:2d3:c87e:b888 with SMTP id 98e67ed59e1d1-2d3c87eba08mr390402a91.27.1723673147187; Wed, 14 Aug 2024 15:05:47 -0700 (PDT)
MIME-Version: 1.0
References: <CA+RyBmWxyELaCxmjV1wbaE_=+7vpPM3RFjhjwNWL4YOBb2P4Cw@mail.gmail.com> <20240814111220256LT7_OeDFpO5Bqo_cTJvix@zte.com.cn>
In-Reply-To: <20240814111220256LT7_OeDFpO5Bqo_cTJvix@zte.com.cn>
From: Greg Mirsky <gregimirsky@gmail.com>
Date: Wed, 14 Aug 2024 15:05:36 -0700
Message-ID: <CA+RyBmXVQkJou_3chKPQ4fS=bL7U4Y9YZES=WJOXUDs8q=m1qQ@mail.gmail.com>
To: xiao.min2@zte.com.cn
Content-Type: multipart/alternative; boundary="000000000000a5a97e061fabed1a"
Message-ID-Hash: JB4RWTRIG4KHFTN3C7L3NNRSIVVA277D
X-Message-ID-Hash: JB4RWTRIG4KHFTN3C7L3NNRSIVVA277D
X-MailFrom: gregimirsky@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-mpls.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: mpls@ietf.org, mpls-chairs@ietf.org, draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [mpls] Re: Working Group Last Call for draft-ietf-mpls-spring-lsp-ping-path-sid (was Re: Working Group Last Call on draft-xp-mpls-spring-lsp-ping-path-sid)
List-Id: Multi-Protocol Label Switching WG <mpls.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/mpls/NTttA8bnUMI4cKSWtPFaZImWl5M>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mpls>
List-Help: <mailto:mpls-request@ietf.org?subject=help>
List-Owner: <mailto:mpls-owner@ietf.org>
List-Post: <mailto:mpls@ietf.org>
List-Subscribe: <mailto:mpls-join@ietf.org>
List-Unsubscribe: <mailto:mpls-leave@ietf.org>

Hi Xiao Min,
thank you for an opportunity to clarify my position on the WG LC of this
draft. Please find my notes below tagged GIM>>.

Regards,
Greg

On Tue, Aug 13, 2024 at 8:12 PM <xiao.min2@zte.com.cn> wrote:

> Hi Greg,
>
>
> Thank you for the continued discussion.
>
> Please see inline.
> Original
> *From: *GregMirsky <gregimirsky@gmail.com>
> *To: *肖敏10093570;
> *Cc: *tsaad.net@gmail.com <tsaad.net@gmail.com>;mpls@ietf.org <
> mpls@ietf.org>;mpls-chairs@ietf.org <mpls-chairs@ietf.org>;
> draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org <
> draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org>;
> *Date: *2024年08月14日 00:00
> *Subject: **Re: [mpls] Working Group Last Call for
> draft-ietf-mpls-spring-lsp-ping-path-sid (was Re: Working Group Last Call
> on draft-xp-mpls-spring-lsp-ping-path-sid)*
> Hi Xiao Min,
> I've reviewed the new version. My conclusions of the discussion and
> updates:
>
>    -
>
>    I believe that a protocol specification (or enhancement of a protocol)
>    must enable an implementor to develop operational and interoperable
>    product. I don't see that the current version of the draft reaches to that
>    level in many instances that I pointed out in my review.
>
>    [XM]>>> It seems to me that your major concern is that unless the
>    referenced control protocol extensions for path segment, such as PCEP and
>    BGP extensions, are all published, this document can't be progressed. I've
>    argued that's not necessary and explained the reason. RFCs 9545 and 9256
>    have provided all the information needed to encode the new sub-TLVs defined
>    in this document.
>
> GIM>> The issue of not listing essential references as Normative is one
but notmain of my concerns with this document. I believe that a
specification of a protocol or protocol extension, i.e., the document that
is the basis for an implementation, must explicitly list, document each and
every step of the processing to be implemented by a developer. References
are not sufficient replacement to explicit documentation of the processing
that MUST, SHOULD, or MAY be taken. For example, if value of field Headend
must be validated, I expect the document to explicitly name how that
validation value is obtained, i.e., which field in PCEP or BGP NLRI must be
used. And that goes step by step throughout the process.

>
>    -
>
>    I find that the update regarding the applicability of SR Policy's
>    PSID, SR Candidate Path's PSID, and SR Segment List's PSID sub-TLVs:
>
> When a sub-TLV defined in this document is carried in Reverse-Path Target
> FEC Stack TLV (Type 16) or Reply Path TLV (Type 21), it MUST be sent by an
> endpoint in an echo reply. The headend MUST perform validity checks as
> described above without setting the return code. If any of the validations
> fail, then the headend MUST drop the echo reply and SHOULD log and/or
> report an error.
>
> introduces a new issue. I believe that RFC 7110 defines Return Path TLV to
> be used by the sender of an MPLS LSP echo request, not by the sender of
> echo reply as suggested in the new text.
> [XM]>>> In Section 5.3 of RFC 7110, it says "When sending the echo reply,
> a Reply Path TLV that identifies the return path MUST be carried".
>
>
> In summary, my concerns are not addressed and new issues introduced by the
> latest update. I don't support progressing the draft in its current form.
>
> [XM]>>> Before progressing this document, we could wait for the
> publications of documents describing all kinds of control protocol
> extensions for path segment. But I don't see much value for that wait.
>
GIM>> As I explained above, listing essential documents as Normative
references is not the main of my concerns with this draft.

>
> Cheers,
>
> Xiao Min
>
>
> Regards,
> Greg
>
> On Mon, Aug 12, 2024 at 8:27 PM <xiao.min2@zte.com.cn> wrote:
>
>> Hi Greg,
>>
>>
>> I've posted a new version of this draft, attempting to address your
>> comments. Link as below.
>>
>>
>> https://datatracker.ietf.org/doc/html/draft-ietf-mpls-spring-lsp-ping-path-sid-02
>>
>> Please see inline with [XM-2]>>>.
>> Original
>> *From: *GregMirsky <gregimirsky@gmail.com>
>> *To: *肖敏10093570;
>> *Cc: *tsaad.net@gmail.com <tsaad.net@gmail.com>;mpls@ietf.org <
>> mpls@ietf.org>;mpls-chairs@ietf.org <mpls-chairs@ietf.org>;
>> draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org <
>> draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org>;
>> *Date: *2024年08月13日 06:18
>> *Subject: **Re: [mpls] Working Group Last Call for
>> draft-ietf-mpls-spring-lsp-ping-path-sid (was Re: Working Group Last Call
>> on draft-xp-mpls-spring-lsp-ping-path-sid)*
>> Hi Xiao Min,
>> thank you for your response. Please find my follow-up notes below tagged
>> GIM>>.
>>
>> Regards,
>> Greg
>>
>> On Mon, Aug 12, 2024 at 2:21 AM <xiao.min2@zte.com.cn> wrote:
>>
>>> Hi Greg,
>>>
>>>
>>> Thanks for your review and thoughtful comments.
>>>
>>> Please see inline with [XM]>>>.
>>> Original
>>> *From: *GregMirsky <gregimirsky@gmail.com>
>>> *To: *Tarek Saad <tsaad.net@gmail.com>;
>>> *Cc: *mpls@ietf.org <mpls@ietf.org>;MPLS Working Chairs <
>>> mpls-chairs@ietf.org>;draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org
>>> <draft-ietf-mpls-spring-lsp-ping-path-sid@ietf.org>;
>>> *Date: *2024年08月09日 08:40
>>> *Subject: **Re: [mpls] Working Group Last Call for
>>> draft-ietf-mpls-spring-lsp-ping-path-sid (was Re: Working Group Last Call
>>> on draft-xp-mpls-spring-lsp-ping-path-sid)*
>>>
>>> Hi Tarek,
>>>
>>> I read the current version of the draft, and I have a number of
>>> questions for the authors and the WG. Please kindly consider my notes below
>>> as WG LC comments:
>>>
>>>    -
>>>
>>>    LSP Ping is intended to verify consistency between the data and
>>>    control planes at the destination node. Unlike IP/MPLS, SR-MPLS doesn't
>>>    create a state related to an SR Policy on the egress LSR. If so, what
>>>    problem can be solved using the extensions proposed in this draft to the
>>>    Target FEC Stack TLV?
>>>
>>>    [XM]>>> For MPLS Path Segment Identifier defined in RFC 9545, the
>>>    egress LSR needs to create a state, please refer to Figure 3, 4, 5, and 6
>>>    of draft-ietf-pce-sr-path-segment.
>>>
>>> GIM>> Thank you for clarifying the case when PSID is distributed using
>> PCEP. What is the case with the BGP SR Policy?
>>
>> [XM-2]>>> Please refer to draft-ietf-idr-sr-policy-path-segment.
>>
>>>
>>>
>>>    -
>>>
>>>    From reading Section 4, it appears that the context of PSID is
>>>    derived from the sub-TLV's. Does that mean the same PSID value may be used
>>>    as SR Policy's PSID, Candidate Path's PSID, and Segment List's PSID? If
>>>    that is not the case, should the egress LSR be aware of the context of the
>>>    received PSID without the assistance of the PSID FEC sub-TLV?
>>>
>>>    [XM]>>> No, that's not the case. The egress LSR uses the PSID FEC
>>>    sub-TLV to perform validation, before that, the egress LSR is aware of the
>>>    context of the received PSID.
>>>
>>> GIM>> That is not how the validation of the new sub-TLV is described in
>> Section 4. If the SR Policy's, SR Candidate Path's, and SR Segment List's
>> PSIDs are all unique, then the egress must verify that the received PSID
>> label and the new sub-TLV are in sync with the view in the egress' control
>> plane.
>>
>> [XM-2]>>> Sorry but I don't catch your point. It seems to me Section 4
>> describes the needed PSID FEC validation procedures.
>>
>>
>>
>>>    -
>>>
>>>    The intention of the validation is to ensure that the ingress LSR
>>>    and the egress LSR have the same understanding.
>>>
>>>
>>>
>>>
>>>    -
>>>
>>>    SR Policy's PSID sub-TLV validation is described as follows:
>>>
>>> +  Validate that the signaled or provisioned headend, color
>>>
>>> and end-point for the PSID, matches with the
>>>
>>> corresponding fields in the received SR Policy's PSID
>>>
>>> sub-TLV.
>>>
>>>    -
>>>
>>>
>>>    -
>>>
>>>       Can you give an example of signaled SR Policy PSID's Headend,
>>>       Color, and Endpoint values? Which document defines such a signaling
>>>       mechanism?
>>>
>>>       [XM]>>> Please refer to draft-ietf-pce-sr-path-segment.
>>>
>>> GIM>> I don't think that is how the document can be published. The
>> document must clearly describe the source of information used to validate
>> new sub-TLV.
>>
>> [XM-2]>>> I believe this document has done its job by referencing the
>> source of information.
>>
>>
>>
>>>    -
>>>
>>>       This step appears underdeveloped, which may cause
>>>       interoperability issues between implementations.
>>>
>>>       [XM]>>> Note that draft-ietf-pce-sr-path-segment is not a
>>>       normative reference. RFC 9545 and RFC 9256 provide the necessary context on
>>>       the relationship between PSID and SR Policy.
>>>
>>> GIM>> If that is the case, please map fields in this sub-TLV to RFC 9545
>> and 9256. Otherwise, make draft-ietf-pce-sr-path-segment Normative (as
>> well as all documents referenced in Section 4 as essential to the
>> validation processing) and map these fields to IEs defined in
>> draft-ietf-pce-sr-path-segment.
>>
>> [XM-2]>>> IMHO it's appropriate to have RFC 9545 and RFC 9256 as
>> normative references and have other specific control protocol extensions as
>> informative references, because the specific encodings of control protocols
>> won't affect this document.
>>
>>>
>>>
>>>    -
>>>
>>>    Can you clarify how the endpoint of the SR Policy validates the
>>>    Headend if the value of the Protocol-Origin field is either PCE or BGP SR
>>>    Policy?
>>>
>>>    [XM]>>> As said above, the endpoint has a state of the PSID. It
>>>    knows the mapping between the PSID and the headend.
>>>
>>> GIM>> AFAICS, draft-ietf-pce-segment-routing-policy-cp does not identify
>> Headend but only Endpoint. Similarly, SR Policy defined in BGP doesn't
>> identify the Headend. (Note that I-D.ietf-idr-segment-routing-te-policy is
>> outdated and the draft has been replaced).
>>
>> [XM-2]>>> Please refer to draft-ietf-pce-sr-path-segment and
>> draft-ietf-idr-sr-policy-path-segment.
>>
>>
>>
>>>    -
>>>
>>>    -
>>>
>>>    The new sub-TLVs are attributed to the "Sub-TLVs for TLV Types 1,
>>>    16, and 21" registry in the IANA Consideration section. However, the
>>>    document specifies using new sub-TLVs only for TLV Type 1 (Target FEC
>>>    Stack). It appears that the new sub-TLVs are left underspecified for TLVs
>>>    16 (Reverse-path Target FEC Stack) and 21 (Reply Path).
>>>
>>>    [XM]>>> Good catch. After thinking about it, I believe the new
>>>    sub-TLVs can also be carried in TLVs 16 and 21 of echo reply when the echo
>>>    reply carries PSID. In this case, considering the PSID FEC validation is
>>>    almost the same to what's specified in Section 4, I propose to add some
>>>    clarification text to Section 4 stating that the PSID FEC validation also
>>>    applies to TLVs 16 and 21 of echo reply, does that make sense?
>>>
>>> GIM>> I believe the WG must discuss this because it could impact TLVs 16
>> and 21.
>>
>> [XM-2]>>> I checked draft-ietf-mpls-sr-epe-oam which is in RFC editor's
>> queue, and I didn't find any text clarifying how to apply the new sub-TLVs
>> to TLVs 16 and 21. However, I believe it's helpful to the
>> reader/implementer if some clarification text can be added, so a new
>> paragraph was added to the end of Section 4 of this document.
>>
>>
>> Best Regards,
>>
>> Xiao Min
>>
>>>
>>> Cheers,
>>>
>>> Xiao Min
>>>
>>>
>>> Although LSP Ping is developed by the MPLS WG, the proposed new
>>> enhancements are clearly related to SR-MPLS. I cannot recall this proposal
>>> being vetted by the SPRING WG. It seems that in the spirit of cooperation
>>> of the Routing Area, comments from the experts in the SPRING WG would
>>> be welcomed.
>>>
>>>
>>>
>>> Regards,
>>>
>>> Greg
>>>
>>> On Tue, Aug 6, 2024 at 10:13 AM Tarek Saad <tsaad.net@gmail.com> wrote:
>>>
>>>> Hi WG,
>>>>
>>>>
>>>>
>>>> I am correcting a mistake to reference to the WG adopted draft (as
>>>> opposed to the individual draft for the same document). Sorry for the
>>>> confusion.
>>>>
>>>>
>>>>
>>>> Regards,
>>>>
>>>> Tarek
>>>>
>>>>
>>>>
>>>> *From: *Tarek Saad <tsaad.net@gmail.com>
>>>>
>>>> *Date: *Tuesday, August 6, 2024 at 9:53 AM
>>>> *To: *mpls@ietf.org <mpls@ietf.org>
>>>> *Cc: *MPLS Working Chairs <mpls-chairs@ietf.org>,
>>>> draft-xp-mpls-spring-lsp-ping-path-sid@ietf.org <
>>>> draft-xp-mpls-spring-lsp-ping-path-sid@ietf.org>
>>>> *Subject: *Working Group Last Call on
>>>> draft-xp-mpls-spring-lsp-ping-path-sid
>>>>
>>>> Dear WG,
>>>>
>>>>
>>>>
>>>> This email starts a two-week working group last call for
>>>> draft-ietf-mpls-spring-lsp-ping-path-sid
>>>> <https://datatracker.ietf.org/doc/draft-ietf-mpls-spring-lsp-ping-path-sid/>
>>>> .
>>>>
>>>>
>>>>
>>>> Please indicate your support or concern for this draft. If you are
>>>> opposed to the progression of the draft to RFC, please articulate your
>>>> concern. If you support it, please indicate that you have read the latest
>>>> version, and it is ready for publication in your opinion. As always, review
>>>> comments and nits are most welcome.
>>>>
>>>>
>>>>
>>>> Please send your comments to the mpls wg mailing list (mpls@ietf.org)
>>>>
>>>> If necessary, comments may be sent unidirectional to the WG chairs.
>>>>
>>>>
>>>>
>>>> Note, currently there are no IPR disclosures
>>>> <https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-xp-mpls-spring-lsp-ping-path-sid>
>>>> against this document.
>>>>
>>>>
>>>>
>>>> This poll runs until August 20, 2024.
>>>>
>>>>
>>>>
>>>> Thank you,
>>>>
>>>> Tarek (for the MPLS WG co-chairs)
>>>>
>>>>
>>>> _______________________________________________
>>>> mpls mailing list -- mpls@ietf.org
>>>> To unsubscribe send an email to mpls-leave@ietf.org
>>>>
>>>
>>>
>>
>