[mpls] Re: WG last call: draft-ietf-mpls-rfc6374-sr
xiao.min2@zte.com.cn Wed, 22 May 2024 09:13 UTC
Return-Path: <xiao.min2@zte.com.cn>
X-Original-To: mpls@ietfa.amsl.com
Delivered-To: mpls@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id DBA20C1CAF3B for <mpls@ietfa.amsl.com>; Wed, 22 May 2024 02:13:53 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.892
X-Spam-Level:
X-Spam-Status: No, score=-1.892 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_BLOCKED=0.001, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, UNPARSEABLE_RELAY=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id MVEAE7qaOhPE for <mpls@ietfa.amsl.com>; Wed, 22 May 2024 02:13:47 -0700 (PDT)
Received: from mxhk.zte.com.cn (mxhk.zte.com.cn [63.216.63.35]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id AA94DC157937 for <mpls@ietf.org>; Wed, 22 May 2024 02:13:40 -0700 (PDT)
Received: from mxct.zte.com.cn (unknown [192.168.251.13]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mxhk.zte.com.cn (FangMail) with ESMTPS id 4VklwK5F0pz6G3wT for <mpls@ietf.org>; Wed, 22 May 2024 17:13:37 +0800 (CST)
Received: from mse-fl2.zte.com.cn (unknown [10.5.228.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mxct.zte.com.cn (FangMail) with ESMTPS id 4Vklvh2vrTz4x5pd; Wed, 22 May 2024 17:13:04 +0800 (CST)
Received: from njy2app03.zte.com.cn ([10.40.13.14]) by mse-fl2.zte.com.cn with SMTP id 44M9Cr1R019417; Wed, 22 May 2024 17:12:53 +0800 (+08) (envelope-from xiao.min2@zte.com.cn)
Received: from mapi (njy2app04[null]) by mapi (Zmail) with MAPI id mid201; Wed, 22 May 2024 17:12:55 +0800 (CST)
Date: Wed, 22 May 2024 17:12:55 +0800
X-Zmail-TransId: 2afc664db717ffffffffb48-4fb35
X-Mailer: Zmail v1.0
Message-ID: <20240522171255808Yq8ueT9fQBZoDjrdxJ1Zm@zte.com.cn>
In-Reply-To: <CAMZsk6ed1SJ4=gZ2hxCqDb5kn3pA7vSUNSo1K9Vj9-ZaPp-u3g@mail.gmail.com>
References: BL3PR11MB573171FBC34AB345727E8A32BFED2@BL3PR11MB5731.namprd11.prod.outlook.com,20240517142424513B7H7H0lFgAOdkfLovjTMs@zte.com.cn,CAMZsk6ed1SJ4=gZ2hxCqDb5kn3pA7vSUNSo1K9Vj9-ZaPp-u3g@mail.gmail.com
Mime-Version: 1.0
From: xiao.min2@zte.com.cn
To: rgandhi.ietf@gmail.com
Content-Type: multipart/mixed; boundary="=====_001_next====="
X-MAIL: mse-fl2.zte.com.cn 44M9Cr1R019417
X-Fangmail-Anti-Spam-Filtered: true
X-Fangmail-MID-QID: 664DB741.002/4VklwK5F0pz6G3wT
Message-ID-Hash: U5ZC5Q5JMU5YP6ARJFD2VPVWWANF2KU3
X-Message-ID-Hash: U5ZC5Q5JMU5YP6ARJFD2VPVWWANF2KU3
X-MailFrom: xiao.min2@zte.com.cn
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-mpls.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: mpls@ietf.org
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-sr
List-Id: Multi-Protocol Label Switching WG <mpls.ietf.org>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mpls>
List-Help: <mailto:mpls-request@ietf.org?subject=help>
List-Owner: <mailto:mpls-owner@ietf.org>
List-Post: <mailto:mpls@ietf.org>
List-Subscribe: <mailto:mpls-join@ietf.org>
List-Unsubscribe: <mailto:mpls-leave@ietf.org>
Hi Rakesh, Thank you for the replies. Snipping to the unresolved comments, please see inline with [XM-3]>>>. Original From: RakeshGandhi <rgandhi.ietf@gmail.com> To: 肖敏10093570; Cc: rgandhi@cisco.com <rgandhi@cisco.com>;mpls@ietf.org <mpls@ietf.org>; Date: 2024年05月22日 10:09 Subject: Re: [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-sr Hi Xiao Min, Thank you for your comments. Please see replies inline with <RG3>.... On Fri, May 17, 2024 at 2:24 AM <xiao.min2@zte.com.cn> wrote: Hi Rakesh, Thank you for the response. Please see inline with [XM-2]>>>. Original From: RakeshGandhi(rgandhi) <rgandhi@cisco.com> To: 肖敏10093570;rgandhi.ietf@gmail.com <rgandhi.ietf@gmail.com>; Cc: mpls@ietf.org <mpls@ietf.org>; Date: 2024年05月16日 21:20 Subject: Re: [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-sr Hi Xiao Min, Thank you for your comments. Please see replies inline with <RG2>… From: xiao.min2@zte.com.cn <xiao.min2@zte.com.cn> Date: Tuesday, May 14, 2024 at 11:08 PM To: rgandhi.ietf@gmail.com <rgandhi.ietf@gmail.com> Cc: mpls@ietf.org <mpls@ietf.org> Subject: [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-sr Hi Rakesh, Thank you for the reply. Please see inline. Original From: RakeshGandhi <rgandhi.ietf@gmail.com> To: 肖敏10093570; Cc: tony.li@tony.li <tony.li@tony.li>;mpls@ietf.org <mpls@ietf.org>; Date: 2024年05月15日 06:07 Subject: Re: [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-sr Hi Xiao Min, Thank you for the review comments. Please see replies inline with <RG>... On Tue, May 7, 2024 at 4:24 AM <xiao.min2@zte.com.cn> wrote: Hi all, I've read the latest version of the draft, which introduces two new TLVs - Return Path TLV and Block Number TLV. With regard to the Return Path TLV, its usage is clear to me, RFC 9503 defines a similar STAMP TLV extension. However, to the Block Number TLV, its usage is not clear to me. The first paragraph of section 7.2 seems to combine this TLV with Alternate-Marking Method defined in RFC 9341, though I can't figure out how they're combined. <RG> RFC 9341, Section 3.1, first paragraph defines packet loss measurement using block number (copied text below). "The basic idea is to virtually split traffic flows into consecutive blocks: each block represents a measurable entity unambiguously recognizable by all network devices along the path. By counting the number of packets in each block and comparing the values measured by different network devices along the path, it is possible to measure if packet loss occurred in any single block between any two points." <RG> This draft defines Block number TLV to carry the above block number associated with the traffic counters. "The packet loss measurement using Alternate-Marking Method defined in [RFC9341] MAY use Block Number (BN) for data correlation for the data traffic flow under measurement. To be able to correlate the transmit and receive traffic counters of the matching Block Number, the Block Number of the traffic counters is carried in the LM query and response messages." [XM]>>> As far as I know, the existing implementations of Alternate-Marking Method rely on the external NMS/controller, which is responsible for the correlation of data (e.g., counter of the same block of packets) collected from each node along the path. As specified in section 4.3 of RFC 9341, a protocol-based distributed solution is also possible, and I believe that's the case for this document. Then, I still have several comments as below. <RG2> Yes, this is protocol-based distributed solution as defined in RFC9341. * This draft is not clear on how the LM query sending node decides the Block Number. In one existing implementation I know, the node calculates the Block Number as the modulo of the node's absolute time since PTP epoch and the marking period. Also note that in the data planes of Alternate-Marking Method, whether RFC 9343 or draft-ietf-mpls-inband-pm-encapsulation, there is no any kind of Block Number field. <RG2> It is up to the implementation on how to assign and increment block number to the block of packets. The procedure for block number-based loss is defined in RFC9343, section 3.1. As described in RFC 9343, implementation details of the block number are out of scope. Do you mean the draft-ietf-mpls-rfc6374-sr should indicate this? [XM-2]>>> The draft-ietf-mpls-rfc6374-sr should specify how to calculate the block number, because the two endpoints exchanging LM messages must use the same method to calculate the block number. Take it for example, if the LM query sending node calculates the Block Number as the modulo of the node's absolute time since *PTP epoch* and the marking period, while the LM response sending node calculates the Block Number as the modulo of the node's absolute time since *NTP epoch* and the marking period, then the mechanism specified in this draft doesn't work. <RG3> The responder derives the block number of the RX counter from the data traffic, e.g. data traffic using the method in draft-ietf-mpls-inband-pm-encapsulation. <RG3> For example, when using 1 bit for loss marking defined in draft-ietf-mpls-inband-pm-encapsulation, querier and responder would have two sets of TX and RX counters, one set for marking 0 and one set for marking 1. <RG3> Querier can change the marking based on local policy (out of scope of the document). <RG3> LM query would carry the counters for marking 1 (which is not changing) while data traffic is using marking 0 and vice versa. [XM-3]>>> In order to understand your solution described above, I have some questions as below. * Do you mean that the LM query carries the TX counter of the block immediately before the block LM query falls into? * Is there an assumption that the LM query interval is the same as the data traffic coloring period? * Is there still requirement for time synchronization between the LM querier and the LM responder? Cheers, Xiao Min Original From: TonyLi <tony.li@tony.li> To: mpls <mpls@ietf.org>; Date: 2024年04月30日 23:52 Subject: [mpls] WG last call: draft-ietf-mpls-rfc6374-sr _______________________________________________ mpls mailing list mpls@ietf.org https://www.ietf.org/mailman/listinfo/mpls [WG chair hat: on] Hi all, This starts a 2 week working group last call on draft-ietf-mpls-rfc6374-sr. This last call ends at 12:01PM PDT, Tues. May 14th. Please send all comments to the mailing list. Thanks, Tony _______________________________________________ mpls mailing list -- mpls@ietf.org To unsubscribe send an email to mpls-leave@ietf.org
- [mpls] WG last call: draft-ietf-mpls-rfc6374-sr Tony Li
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Zafar Ali (zali)
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Stefano Salsano
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Gyan Mishra
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Greg Mirsky
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Jaganbabu Rajamanickam
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… Xufeng Liu
- Re: [mpls] WG last call: draft-ietf-mpls-rfc6374-… song.xueyan2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Mach Chen
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi (rgandhi)
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Rakesh Gandhi
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiao.min2
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Pier Luigi Ventre
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Tony Li
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Tony Li
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Tony Li
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… xiong.quan
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Sagar Soni (sagsoni)
- [mpls] Re: WG last call: draft-ietf-mpls-rfc6374-… Sagar Soni (sagsoni)