[mpls] Consensus poll on Design directive for the MPLS Open DT
Loa Andersson <loa@pi.nu> Tue, 24 August 2021 08:35 UTC
Return-Path: <loa@pi.nu>
X-Original-To: mpls@ietfa.amsl.com
Delivered-To: mpls@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id EA4A43A1577; Tue, 24 Aug 2021 01:35:55 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.897
X-Spam-Level:
X-Spam-Status: No, score=-1.897 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, SPF_HELO_NONE=0.001, SPF_NONE=0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 6Fi7ds6Xc9nS; Tue, 24 Aug 2021 01:35:46 -0700 (PDT)
Received: from pipi.pi.nu (pipi.pi.nu [83.168.239.141]) (using TLSv1.1 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id CF66F3A1573; Tue, 24 Aug 2021 01:35:45 -0700 (PDT)
Received: from [192.168.0.2] (c83-250-146-169.bredband.tele2.se [83.250.146.169]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) (Authenticated sender: loa@pi.nu) by pipi.pi.nu (Postfix) with ESMTPSA id E79CD3496A6; Tue, 24 Aug 2021 10:35:41 +0200 (CEST)
From: Loa Andersson <loa@pi.nu>
To: "mpls@ietf.org" <mpls@ietf.org>
Cc: "pals-chairs@ietf.org" <pals-chairs@ietf.org>, "mpls-chairs@ietf.org" <mpls-chairs@ietf.org>, DetNet Chairs <detnet-chairs@ietf.org>
Message-ID: <6bee310a-0880-4a27-a562-2f048e3c4a6a@pi.nu>
Date: Tue, 24 Aug 2021 10:35:41 +0200
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"; format="flowed"
Content-Language: en-US
Content-Transfer-Encoding: 7bit
Archived-At: <https://mailarchive.ietf.org/arch/msg/mpls/__sVILLBabjK_fCUX8pyZrwHiS0>
Subject: [mpls] Consensus poll on Design directive for the MPLS Open DT
X-BeenThere: mpls@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: Multi-Protocol Label Switching WG <mpls.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/mpls>, <mailto:mpls-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/mpls/>
List-Post: <mailto:mpls@ietf.org>
List-Help: <mailto:mpls-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/mpls>, <mailto:mpls-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 24 Aug 2021 08:35:56 -0000
Working Group, Design Tean, The Open DT has discussed the relationship between GAL/G-ACh and the new methods for indicating and transporting ancillary data in and after the label stack. We have decided to give the MPLS Open DT the following design directive: ---------------------------- start --------------------------------- Following the discussion in the MPLS Open DT 2021-08-19 we have have decided to give the MPLS Indicator and Open Design team this design directive. RFC 5586 "MPLS Generic Associated Channel" (including the updates by RFC 7274, RFC 6423, RFC 7214, and RFC 7026) will not be changed by the MPLS Open Design Team. The associated channel (GAL/G-ACh) will continue to operate as specified. No changes should be made to the associated channel, without careful coordination with what will be specified by the MPLS Pen design team. The Open design team will continue define methods bases on indicators (e.g. FAI-style SPL) and ancillary data. A packet can not carry both the associated channel and the new methods for transporting ancillary data indicated by the FAI-style SPL, i.e. the GAL and the FAI-style SPL can not both be present in a label stack. The reason is that the way the ACH is specified there is a high risk of collision of "data after the BoS" specified by other methods. ---------------------end -------------------------------------------- The design team will start working according to this design directive, but for a period of two weeks we will comments on the directive. Please send comments to the MPLS wg mailing list (mpls@ietf.org) /Loa for the co-chairs -- Loa Andersson email: loa@pi.nu Senior MPLS Expert loa.pi.nu@gmail.com Bronze Dragon Consulting phone: +46 739 81 21 64
- [mpls] Consensus poll on Design directive for the… Loa Andersson
- Re: [mpls] Consensus poll on Design directive for… Haoyu Song
- Re: [mpls] Consensus poll on Design directive for… Loa Andersson
- Re: [mpls] Consensus poll on Design directive for… gregory.mirsky
- Re: [mpls] Consensus poll on Design directive for… Kireeti Kompella
- Re: [mpls] Consensus poll on Design directive for… Loa Andersson