[OPSAWG]Re: OPSAWG Digest, Vol 205, Issue 20

"Douglas Gash (dcmgash)" <dcmgash@cisco.com> Mon, 08 July 2024 08:48 UTC

Return-Path: <dcmgash@cisco.com>
X-Original-To: opsawg@ietfa.amsl.com
Delivered-To: opsawg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B0463C1840DB for <opsawg@ietfa.amsl.com>; Mon, 8 Jul 2024 01:48:50 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -12.042
X-Spam-Level:
X-Spam-Status: No, score=-12.042 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.148, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_NONE=0.001, T_SCC_BODY_TEXT_LINE=-0.01, T_SPF_HELO_PERMERROR=0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=cisco.com header.b="e92o+GKW"; dkim=pass (1024-bit key) header.d=cisco.com header.b="S87K6923"
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id LGaxnyaScGU5 for <opsawg@ietfa.amsl.com>; Mon, 8 Jul 2024 01:48:46 -0700 (PDT)
Received: from alln-iport-7.cisco.com (alln-iport-7.cisco.com [173.37.142.94]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id AB086C15170B for <opsawg@ietf.org>; Mon, 8 Jul 2024 01:48:46 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=62810; q=dns/txt; s=iport; t=1720428526; x=1721638126; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=6plE2A1M2MZwrlCeDJn6mr2VnuWnvK2+DSgLSSjJVCw=; b=e92o+GKWC6DU43TPdU5xGMlit+ZLhBIw8a2Mr270HgFwcPwH7em0Ttey VG96PLREH3SoGC5NmWXm+IwTI5FCipVCZ9+Vkv2VQonXT1wBl65UM/rkN MvdD1N92/7gQEFcqGZ3a5091ErI6v96ZJ84hg+S9cicfHVLxbjZYM0HR2 k=;
X-CSE-ConnectionGUID: Z+xajY3dSlCyM1BX/jflQg==
X-CSE-MsgGUID: OPhB+tA6RAK7htmxewt+Hg==
X-IPAS-Result: A0ACAAAVp4tmmIgNJK1RCRkBAQEBAQEBAQEBAQEBAQEBAQESAQEBAQEBAQEBAQEBQCWBGAIBAQEBAQsBgUAxKih6AoEKEkiIIQOFLYhuA5FEjEoUgREDVg8BAQENAQE7CQQBAYIpgl0CiRECJjYHDgECAgIBAQEBAwIDAQEBAQEBAQEBBQEBBQEBAQIBBwUUAQEBAQEBAQEeGQUOECeFdA2GXQEBAQECAQ4EGxMBASMUAQQLAgEIEQMBAhYLAQ0xHQgCBAENBQgaglkEAQElgXcUAw4jAwEQBqIJAYFAAoooeIE0gQGCDAEBBgQF2xsDglkJgUgBhHGDPwEkgTGIZycbgg2BFUKCaD6CYQICgRcNDhICBhQFBxINCwYBg1aCL4UfaIhIglcDIkGBToEJgR1GgwIPgiAQfH9XD4JjDhOCc38mC4Eci2FUdSIDJjMhAhEBVRMXCz4dAhYDGxQEMA8JCyYpBjkCEgwGBgZZNAkEIwMIBANCAyBxEQMEGgQLB3eBcYE0BBNHgTcGiWkMgwUCBSEEJYFJJ4ENF4J3S2yBHQKCYoFrDGGESoJGcWKBD4E+gWIBS4EYgWUwGyQLYYFVgQIiGAomHUADC209NQYOGwUEgTUFqEMENwKDAwUgSwECLBAmAQMNIgMRDgIgAmMLPR5BETqSRiSDD4t5R44GlQcKhBSKLoFhlVgXhAWBVqN7ZJhpIII0oGwZBYUDAgQCBAUCDwEBBoFuCikPgUxwFYMiCUkZD44hDQwJg1iFFMZEeAI5AgcLAQEDCYhuKnJgAQE
IronPort-PHdr: A9a23:vrRe/ROyADdUtRed5D8l6nfMWUAX0o4cdiYP4ZYhzrVWfbvmotLpP VfU4rNmi1qaFYnY6vcRk+PNqOigQm0P55+drWoPOIJBTR4LiMga3kQgDceJBFe9LavCZC0hF 8MEX1hgrDmgKUYAIM/lfBXJp2GqqzsbGxHxLw1wc+j+H4HblMSf3OGp8JqVaAJN13KxZLpoJ 0CupB7K/okO1JFvKKs61lPFo2AdfeNQyCIgKQeYng334YG7+5sLzg==
IronPort-Data: A9a23:J+o9uKsvVQu4adlwFv8rF4Q/XefnVFxeMUV32f8akzHdYApBsoF/q tZmKT+GM6yNMWv0Kdwgaorj8kwAsMLSytQ1SQJrpH89QX4SgMeUXt7xwmUckM+xwmwvaGo9s q3yv/GZdJhcokf0/0rrb/646yEhiMlkf5KkYMbcICd9WAR4fykojBNnioYRj5Vh6TSDK1vlV eja/YuHaTdJ5xYuajhIs/3b+Es11BjPkGpwUmIWNKgjUGD2zxH5PLpHTYmtIn3xRJVjH+LSb 47r0LGj82rFyAwmA9Wjn6yTWhVirmn6ZFXmZtJ+AsBOszAazsAA+v9T2Mk0NS+7vw60c+VZk 72hg3AfpTABZcUgkMxFO/VR/roX0aduoNcrKlDn2SCfItGvn3bEm51T4E8K0YIwyKVnCGN/r vAjLBscS0mpt6W0zraCRbw57igjBJGD0II3s3Vky3TSCuwrBMuFSKTR7tge1zA17ixMNa+BP IxCN3w2N1KZOEMn1lQ/UPrSmM+kjXzweiZYgFmUvqEwpWPUyWSd1ZC2aYKEI4HTGJ49ckCwg VrG1SflK08gHf/AySaA4n+zmqzvknauMG4VPOblrqEx2gL7KnYoIBoOTlKkrtG4h1KwHdVFJ CQpFjEGpKw28gmgScPwGkb+q3+ftRlaUN1VewEn1O2T4piX8w+bNzMIdTpqefl/nv9xRzIu7 1DcyrsFGgdTmLGSTHuc8JKdojWzJTUZIAc+icksE1NtDz7L/thbs/7fcuuPBpJZmTEcJN0d6 zmOqC57jLIJgItQka665lvAxTmro/AlrzLZBC2JAApJDSsgOOZJgrBED3CBvJ6sy67CEzG8U IAswZT20Qz3JcjleNaxaOsMBqq1wP2OLSfRh1Vid7F4qG38qyL/JdkLsWguTKuMDiriUWK3C KM0kV4PjKK/wFPzMcebnqroUZ1zlvm6fTgbfqmNN4QeCnSOSON31HozPRHLhT+FfLkEmqAkM pDTate3EXsfEuxmyjHwL9rxIpd1rh3SMVj7HMihpzz+iOL2TCfMFd8tbgDUBshnt/zsnekg2 4sFXyd8408BALSWj+i+2dN7EG3m2lBnXMuu95UOJ7TSSuekcUl4Y8LsLXoaU9UNt4xel/zD+ Te2XUow9bY1rSSvxdmiApy7VI7SYA==
IronPort-HdrOrdr: A9a23:NWGgRazd66ryGeJUD4qFKrPxY+gkLtp133Aq2lEZdPULSL36qy n+ppQmPEHP6Qr5AEtQ6OxoWJPtfZvdnaQFmLX5To3SLDUO2VHYY72KiLGSoQEIdBeOi9K1uZ 0QFJSWTeeAc2SS7vyKrjVQcexQvOVvmZrA7YyxvhIdKT2CKZsQkDuRYTzranGeMTM2f6bRY6 DsnfavyQDQH0g/X4CQPFVAde7FoNHAiZLhZjA7JzNP0mOzpALtwoTXVzyD0Dkjcx4n+9ofGG 7+/DDR1+GGibWW2xXc32jc49B9g9360OZOA8SKl4w8NijsohzAXvUgZ5Sy+BQO5M2/4lcjl9 fB5z06Od5o1n/Xdmap5TPwxgjb1io04XOK8y7avZKjm726eNsJMbsEuWtrSGqf16PmhqA77E t/5RPdi3OQN2KYoM2y3amRa/ggrDvGnZNrq59gs5UYa/peVFeUxrZvpn+81/w7bXnHwZFiH+ 90AM7G4vFKNVuccnDCp2FqhMehR3IpA369MwI/U+GuonBrdUpCvgAl7d1amm1F+IM2SpFC6e iBOqN0lKtWRstTaa5mHu8OTca+F2SIGHv3QS6vCEWiELtCN2PGqpbx7rlw7Oa2eIYQxJ93nJ jaSltXuWM7ZkqrA8yT259A9AzLXQyGLHnQ49Ab44I8tqz3RbLtPyHGQFcyk9G4q/FaGcHfU+ bbAuMePxYiFxqZJW9k5XyIZ3AJEwhqbCQ8gKdOZ26z
X-Talos-CUID: 9a23:gdfymGCWQj4gGNL6Exsk5EcWK5spSXn23VKJCX//C2htcbLAHA==
X-Talos-MUID: 9a23:d1NJaQTctInYCm/wRXTLvDFId9tBvZ6HKx8NjZAWttaYdgx/bmI=
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-core-3.cisco.com ([173.36.13.136]) by alln-iport-7.cisco.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 08 Jul 2024 08:48:45 +0000
Received: from rcdn-opgw-5.cisco.com (rcdn-opgw-5.cisco.com [72.163.7.169]) by alln-core-3.cisco.com (8.15.2/8.15.2) with ESMTPS id 4688mjpU006619 (version=TLSv1.2 cipher=DHE-RSA-AES256-GCM-SHA384 bits=256 verify=OK) for <opsawg@ietf.org>; Mon, 8 Jul 2024 08:48:45 GMT
X-CSE-ConnectionGUID: cxU+KV0RQwmixSLILwzsww==
X-CSE-MsgGUID: r5rfha79RdG06rKKi10VCQ==
Authentication-Results: rcdn-opgw-5.cisco.com; dkim=pass (signature verified) header.i=@cisco.com; spf=Pass smtp.mailfrom=dcmgash@cisco.com; dmarc=pass (p=reject dis=none) d=cisco.com
X-IronPort-AV: E=Sophos;i="6.09,191,1716249600"; d="scan'208,217";a="12864502"
Received: from mail-co1nam11lp2168.outbound.protection.outlook.com (HELO NAM11-CO1-obe.outbound.protection.outlook.com) ([104.47.56.168]) by rcdn-opgw-5.cisco.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 08 Jul 2024 08:48:44 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=PaiTfamSc/lxu53PJy4D/tg0lj0ENouMo4qZ/hrIMkYvpHnnPWTeea5goc1nZOVl9vUvSy+03brbMKgzCkceYTbqHmKGrFaHIYleXwxC52pWa7pAmwxdxaHJ3K0HI6QM2bxgKGgvP8j1HfNQRtqQH/xk4ooq0QqXsh8bX4wD2qnjn2+2vW3gIYhIplhagTozWCv0Ix2rQHsJH90WqsUBauUKalqgwx3/2kBMrKPmQOxGAYUKovqVEhZiEwxCYnwpOoLVIHlwwWMy0gVliQQC017Oid78TdoM+OMNkdyK46QYTes3jBc0OEV5/HuZ+jX8569KkQ0EvcmjsOSz6qVmXQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=6plE2A1M2MZwrlCeDJn6mr2VnuWnvK2+DSgLSSjJVCw=; b=h5gvMQzDooJau+OpBXneWCp005MxlkHjoB3wtJuf09ATrqaSLLfMZ6mepuh29ylDpCp5o5Y8tfk/vAzBhe5AEhFJpZ4QA9r/2GWmgr3mZyxOPSQdA0ZO75c8czO04xlaJMSDxyNsqTOfL+CwjHMMyGjd2ciDsBTh/d5MRcP89UNNR7U92Isl/s2JuwjfKPHnMy1Bi2nGwct+irkDCqWtpdLOPoe07KQMfqrLfPtGgdiZqOyFUJRY7nTie1+D3CWhYWykh5QXXkKLk6TOOxS+IlKFMhqW4f8Bl0xGxsmej7iUFDoaBYc4pbyyTl3zFmbEWT9WBZkgsDdIh4fWpbA+ZA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; s=selector1; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=6plE2A1M2MZwrlCeDJn6mr2VnuWnvK2+DSgLSSjJVCw=; b=S87K69234cnPY8qfBEGLPU890bS4Mftl4ZaPe35RFpmEbwyG/3SUxpLZmgJJ1WS7IczTk0FYtsfdzQeHUXxUWB0oSZHBpg4K4IHtlB+XTouxyHhLUeYLtdodFNrkaD5aGG3XVzUWbVpTkjhzfetkltsnIAmAWpefzJeQU9eX7j4=
Received: from BL3PR11MB6364.namprd11.prod.outlook.com (2603:10b6:208:3b7::12) by SA2PR11MB5065.namprd11.prod.outlook.com (2603:10b6:806:115::7) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.7741.35; Mon, 8 Jul 2024 08:48:42 +0000
Received: from BL3PR11MB6364.namprd11.prod.outlook.com ([fe80::a73b:129a:ecc1:34e6]) by BL3PR11MB6364.namprd11.prod.outlook.com ([fe80::a73b:129a:ecc1:34e6%3]) with mapi id 15.20.7741.033; Mon, 8 Jul 2024 08:48:41 +0000
From: "Douglas Gash (dcmgash)" <dcmgash@cisco.com>
To: "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, "Joe Clarke (jclarke)" <jclarke@cisco.com>, Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org" <opsawg@ietf.org>
Thread-Topic: OPSAWG Digest, Vol 205, Issue 20
Thread-Index: AQHayW1ii8V5kudTxkyZFG6VfJaTz7HoAMaFgASHvw8=
Date: Mon, 08 Jul 2024 08:48:41 +0000
Message-ID: <BL3PR11MB63647995AABAED8113F9DDBFB7DA2@BL3PR11MB6364.namprd11.prod.outlook.com>
References: <171958741031.6614.6192371628253402915@ietfa.amsl.com> <BL3PR11MB636498065CA94698B937E5CCB7DF2@BL3PR11MB6364.namprd11.prod.outlook.com>
In-Reply-To: <BL3PR11MB636498065CA94698B937E5CCB7DF2@BL3PR11MB6364.namprd11.prod.outlook.com>
Accept-Language: en-GB, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: BL3PR11MB6364:EE_|SA2PR11MB5065:EE_
x-ms-office365-filtering-correlation-id: ea1ca2f8-b456-493d-1c86-08dc9f2ac4bc
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|366016|376014|1800799024|38070700018;
x-microsoft-antispam-message-info: Th3HgsEQpBTvsOKEA/rvxqlcmzVswfBKrDM5ylnCeyfan/clCrTsOU+FIMgwQzufplc3nsR5LhgCq3wjwHzzBhgNb1zi+Gyw9e7y4UFz3U4R3r/rXuoZIczGwB+h+/a6ygtAplrS6WUAMUEqbEJOoPJotjZVxjMgFjaWVKyJBdDUdD+3ECpg6BPh2O23n5ylYzNsoRLw4E2QyaEztqTrGdrhqhwOWHnh5eHdSuH0d2qJvLn6rdTNuwu2apeuL3hRKD6q16uYyOQlwhTi1lbwyWWpJb1jbxksUNEF/hBqtU5AW37UoQvvdgzkJgwtUOOFWc2s8NAkv/kryFOqsfrF2NaIjDN3zmjabRWYHAYcX8vRfaVHJ9fkJl1QCwob7qIq3jS5ylTKihVuDG9v2LycxWyc+/ejjZGRw9WGhZvGh6lGJWlLPL1dXMlN/ncV0t5nbEiR2c8LbObnwS1cS5GKpH17JgYGVDN6iF37RZ74E4VS98kyPJFvgAdVPcEde4LWXWNP13UiqaXCan6Ua0MbIpviWDKXvTSx+WcBrcUARGYS8Vvjy/s+5YxS92X95r40JcExacxHEBnw/CXGkzMsUJAVntFijjq+JDuwJVBC5RTtvOGx8iEzzWZGNtqyHl0Y17dutvVhezIz+le131UO5ZgYuyMjqTOVb1uj4rhY2mbCscJ7uIWQr7CeBACGTAwypEbB3dSq4827PsorghcFZhEwlVCQAUVshn8O7n0wmAUDHdqBRfCbQzNftCjMqU0zqymeW1gcJjKWg1lnTo40TDpSbtA0JnfZNvY+Z/8TDmStSG60SHv/AckyKzXL0rBc1kPNVBKDjBk9mcmrDkJJxSzBWjpI9oV/lyk6CDTnD9fbuqeB+bRfhiQfrINXwmBPMiiYOlrRNKlHspM5iLJuBvEbYJ/+bJc4Zd7x0HLA4saTkKPTu5w6S2WCiF4QE+Eeb+iLjnu6bShxUZIjuAYq+niqzkJw41GZK+KcbBiu+ELh1PO/j2U5+mzZV99rCpn/U1zUGlxtprqLYZ69S159PKr4xHFsNxu2oXsW6e+SCF+RgOPP0+li1SM2I3LFC8UPlsjHW+oxtqO2LJRi5vrAlJW6SW7EjIH5CKQXWe3fkl/cWVnj15H+leNHy2BVplb8h02wi94vxEhOQibafvckiHQKbPr/iNmNKifSQmC0zaMSI+fnX5au+kykJq7pJhKFNXtMXn+oo5ajr+ZUYLXdXMKy8A16ZanWFI+ErNEzKuM7kIdNaG3BdJv++Wpt7J3+03nXvXmf9l11o8zq70UmfTsCVDEcQB0/yBG9QyZpJ5LCyxxVGGllpmqOWdoSglSeRPJJq7g4bDHXcgP4vuT/cIXMV/EyBNV1JKPed1UAr6s=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:BL3PR11MB6364.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(366016)(376014)(1800799024)(38070700018);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: 3mPk9ozuXbjeMSjzM2FF4k7eyDuW4AXr5CklnTM+LPjMT/pr+Dl7n5BJhsE8hnuzUDzthL0nDotXuaEr6YHQSitV8KcWMx7c6jlfLwAqO6khWOtnBtjvRL3yUrGF6CF9ZcNki1GUd1ae6j+AKr6Ub9EmxaYfkDzxqGGs9M/DqN8brO6GYg6fQ6G9x0yShuI1fuPg6HdlHGZHn0c6rk8Ny2caURNyKyVjhEzssCF2Ax3Bjx01q8MbTmPAUv4wDJAH148npxH5qjCXJ3dbHWUudxFMD0VM8e1GjvqS3jFPGBekqTR04fSA4ydypklK1wn+ovMiib67kJK6dVL+u0kfdyrYhQfmVP2CrVu7IA30+A7LgIgQ2hBxKFfRGMgIeS4+WWU0jII7BNItqosoKN6irsN4LPg0fjAlQd9CGPmZEROTSApD6BCyQzWuNHEOP7xZwKWzpoD3N+ixwj0ZzOihgrB0ThNC9BH6nGLOZKcBGzh5agf7IissGksygyhiDFQt2+JNBkmLdSfV68p85TX/w8ywvlCj84E/ygWkaTN0TP1sHn5YEsU5bw3V4ZKP2fE4+LPcXSIqVbs4adUvImxd0KAZEuhOc79aBfW3iz5nlXq7SqVLCE+8+T6pzBmhW1tVuvJgBpRX/CWJqo5jfnBp0BeIzgMmskhte4TzCjm8kzDMsIcw91JJuhW3EROs/g4aGk9QFO/AGANGYOf7icszXZMDZvNxZAa/3QU6HwU3J3XcykWkmxV0kybv0qA1nEExIxVkpRzB6TzldnIlndsDPvT4OoeecG6+naZMvBrvercZD4Kwi6zsnub94muO3dY+n97FY9rh6SMxEptpY4GX5Cg7eYVgLqE/28+iLxpv5CRZgbE97lCxKuXUF6mAvpDTquatZj0aNsI1e2CVejcD3AxiodrwuQejdv5uvGjDd+VQBZY91v2DjMCDfyzUGPRVtirV4MA5dlkSY2pthmEWticNaoFavm4bC6s9gNllO0BQLYfJ0vwIHonqi10+hncUP4Bs4knEMgUQ31qfrKGG1B8L6Kc7bSG5xlGdk5BkMtGrk95xsplWCm9aXY3NzANPt/7iuDYQDkzVEdjPWZuawPUbVHs6iIwokOyrPmdzOK6CfIu1T/95O5kM4h+uyw0m52typbQPtYNHnPVc3n7C29Y2TlJna2/LpPTx2c8AejbKPIlQ9a9LzkiqHODOnwUNzOcgUeGon5JjvJtFy4rPiaNu8vaZCVmN+RJGsobOcJg4t/gQg5YS5eKr44fax6qOJZkeJ2gKfLUXBtpeq9xE3cYXI/HA7+JEw6IvAtCM3b3V3RQdySZl9JBniOfAnHVylMLdOJQJy1kbvOlcakIIuuFXhrGVFlMpEprG0VUkMhUm8YZZ8VrHO7RQyqSIMxmo1IR1qLpDMkjfUiEK2eSbF7Kb/BFmB2HenwkCMCwdUqSa9aZzU29FMd47VQvG4qog69xoAto707VBdSP8ymd18jNmWCxoEHbUIu5i6JAuxiRuOdwyxLdX4Q0jRduLkvhOSQ7rvU3l1NT6WSI2fktnAyf7z4GiifAoTaDjXiIIg8P7Qi8Bx5IIkGNXh7CpHxWiaRrCB7pJJDHSDEoHrB1iWyQucuO1+2vQysmzD6by7nnxI6OrvQIAnEfSitDM+4edDoAE/IjOaG+mioR5MO0DtA==
Content-Type: multipart/alternative; boundary="_000_BL3PR11MB63647995AABAED8113F9DDBFB7DA2BL3PR11MB6364namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: BL3PR11MB6364.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: ea1ca2f8-b456-493d-1c86-08dc9f2ac4bc
X-MS-Exchange-CrossTenant-originalarrivaltime: 08 Jul 2024 08:48:41.7554 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: p0VjtTmavKacnxNSr9lT0I25aNGYuL7eR/6HzOEugB4R72xhfYJoTD8bF3OOq8JXzU/L2rS7XRQU7/xx/T3lpA==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: SA2PR11MB5065
X-Outbound-SMTP-Client: 72.163.7.169, rcdn-opgw-5.cisco.com
X-Outbound-Node: alln-core-3.cisco.com
Message-ID-Hash: OJ6PQAIWUHGOXRSI6UUINGARQIF7U5YE
X-Message-ID-Hash: OJ6PQAIWUHGOXRSI6UUINGARQIF7U5YE
X-MailFrom: dcmgash@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-opsawg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: John Heasly <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [OPSAWG]Re: OPSAWG Digest, Vol 205, Issue 20
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/OjB-ukhSCGL2gFbfKtHAEkFgoFE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/opsawg>
List-Help: <mailto:opsawg-request@ietf.org?subject=help>
List-Owner: <mailto:opsawg-owner@ietf.org>
List-Post: <mailto:opsawg@ietf.org>
List-Subscribe: <mailto:opsawg-join@ietf.org>
List-Unsubscribe: <mailto:opsawg-leave@ietf.org>

Dear Opsawg et al,

1) Discussion on External  PSK (Related to part of Mohamed’s point 2 below).

Our distillation of the thrust of Alan’s main advice is: The doc needs to either commit to fully documenting external PSK and its ramifications or preclude it. The truth is, our doc merely  says: TLS T+ implementations may support External PSK, and leaves it there.

Background: as this doc has evolved, we have temporized on the topic for the first TLS version of T+. On one side: we were not convinced External PSKs are quite established in TLS 1.3. On the other side they would be very useful for operators. But now  It seems that PSKs have become better established, through the work of Alan et al, so we may consider to document use of External for this initial doc, rather than adding later supplement to cover external PSK. It does mean through that there may be another round or two to bring in the needed details.

So now would be a good point to gauge the opinion of the group. Based upon where the doc is in the process, and what changes should be applied to it at this time::

1) Should we revert the doc to say:  “External PSK should not be used now.  A supplement will follow to address how PSK can be used properly”
Or
2) Keep the option for External PSKs to be used as now, and Commit to a few rounds of revisions to document to fully flesh out its support.

Authors would be happy either way, probably on balance we would prefer second option,



If we went for option 2), then below is an outline of the responses which we believe would cover External PSK:



Note: “RADIUS and TLS-PSK” Provides a wealth of recommendations on PSKs.



  1.  a new section will be added specific to PSKs  include the following items, mainly  gleaned from “RADIUS and TLS-PSK”, (note that TLS 1.2 related issues have been filtered out)

General:

·         It is RECOMMENDED that systems follow the directions of [RFC9257<https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257>] Section 4

·         PSK length recommendations for both implementation and operations

·         Fortunately, as we have already removed the MD5 obfuscation,  we do not have issues in sharing Shared secrets and PSKs
PSK Identity:

·         RFC9257<https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257> 6.1 to be used for PSK  identities

·         PSK Identity length recommendations for both implementations and operations.
Per Client Sharing

·         PSK must be unique per client as configured on server

·         PSK Identities must be unique per client as configured on server

(Of course references will be updated to acknowledge this doc)


  1.  The Tacacss draft doc mentions identity specifically in the context of Certificates. This will be clarified that it applies only to certificate based, and for PSK it has its own guidance as above.


The following changes are not directly related to External PSK and will be resolved anyway:

2) Resumption elements from RFC9190 (Related to the balance of Mohamed’s point 2 below).

References from RFC9190. The doc primarily adresses the use of TLS as an EAP option, which has extra concerns as it is used for authorization information. The concerns that were apprehended form the text are listed below with our  evaluation of relevance when used for the tacacss security wrapper.


1.      Authorization on resumption mased on cached data rather than the data in the resumption:

a.      Regarded: Not Relevant as the data is not used for authorization for tacacss

2.      Verification of certificates revoked during the period since the last “New Session Ticket Message”

a.      Regarded: Relevant, and we will update. RFC 8446 is not silent on this topic, so we will prefer to cover this by  refererence to section 4.6.1 which says:

         Note that in principle it is possible to continue issuing new tickets
               which indefinitely extend the lifetime of the keying material
               originally derived from an initial non-PSK handshake (which was most
               likely tied to the peer's certificate).  It is RECOMMENDED that
               implementations place limits on the total lifetime of such keying

         material; these limits should take into account the lifetime of the
               peer's certificate, the likelihood of intervening revocation, and the
               time since the peer's online CertificateVerify signature.


3.      Maximum lifetime:

a.      Regarded Relevant, we will update by reference to its coveragein RFC 8446

4.      “time-of-check time-of-use” issues

a.      Regarded: Not Relevant as the data is not used for authorization for tacacss

5.      Re evaluation of authorization on resumption:

a.      Regarded: Not Relevant as the data is not used for authorization for tacacss


3) Regarding 3) below, thanks for the catch, We’re proposing the following change:

Current:

   To ensure separation of TACACS+ traffic that uses TLS from that which
   does not (Section 5.3), they will be deployed on different ports.
   Due to the widespread use of default port number settings in numerous
   existing TACACS+ client configurations, a well-known system TCP/IP
   port number will be requested from IANA.  Client implementations can
   ensure traffic is kept separate.  The designated port number is [TBD]
   (Section 7) with the service name [TBDN] (Section 7).

Proposal:

   To ensure separation of TACACS+ traffic that uses TLS from that which
   does not (Section 5.3), they must be deployed on different server ports.
   Further, because of the widespread use of default port number
   settings in numerous existing TACACS+ client configurations, a well-
   known system TCP/IP port number is assigned: the designated port
   number is [TBD] (Section 7) with the service name [TBDN] (Section 7).
   This way the client can ensure that TLS and non TLS traffic are
   separated even where default ports are omitted from its server connection
   configuration.




Date: Fri, 28 Jun 2024 13:36:42 +0000
From: mohamed.boucadair@orange.com
Subject: [OPSAWG]Re: WG LC: draft-ietf-opsawg-tacacs-tls13
To: Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org"
        <opsawg@ietf.org>
Cc: "uta@ietf.org" <uta@ietf.org>, "Joe Clarke (jclarke)"
        <jclarke=40cisco.com@dmarc.ietf.org>
Message-ID: <DU2PR02MB10160C69E1AF8E95168D5CC6A88D02@DU2PR02MB10160.eu
        rprd02.prod.outlook.com>
Content-Type: text/plain; charset="iso-8859-1"

Hi all,

FWIW, we had an offline discussion with Alan and the authors to clarify the concerns.

I'm reporting the main outcome of that discussion, fwiw:

(1) Alan  agreed that:

* It is good practice to leverage existing standards
* Repeating details isn't useful

(2) Still, the key comment from Alan is:

>   My point was that the RFCs I referenced had substantial text over
> and above 8446 / 9525.  I asked that the authors double- check the
> documents I mentioned, to see how these issues were addressed.  The
> result was a few minor changes.

The shepherd agrees that this is a reasonable comment that should be adequately addressed.

The authors engaged to have a look into the various RFCs cited by Alan and grab applicable items to tacacs+ context. It would be helpful to share the rationale for the items that they picked vs. those they considered as not relevant.

(3) As a bonus, Alan provided the following comments and summary

==
Some grammar / clarity comments:


Section 3.1:
...
To ensure separation of TACACS+ traffic that uses TLS from that which does not (Section 5.3), they will be deployed on different ports. Due to the widespread use of default port number settings in numerous existing TACACS+ client configurations, a well-known system TCP/IP port number will be requested from IANA ...

  The text is ambiguous: "will" be requested?  When?  Does this document allocate the port?

  The usual text is to say "port TBD has been assigned for this protocol".


 In short:  I'm not objecting to the publication of this document.  My concern is that it doesn't give a lot of guidance to implementing TACACS+ over TLS.  I can see basic implementations working, just by wrapping TACACS+ in TLS.  But the operational considerations outlined above will have to be discovered piece-meal by implementors.
==


Cheers,
Med
***************************************