[OPSAWG]Re: OPSAWG Digest, Vol 205, Issue 20

"Joe Clarke (jclarke)" <jclarke@cisco.com> Mon, 08 July 2024 12:51 UTC

Return-Path: <jclarke@cisco.com>
X-Original-To: opsawg@ietfa.amsl.com
Delivered-To: opsawg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 4116AC14F739 for <opsawg@ietfa.amsl.com>; Mon, 8 Jul 2024 05:51:57 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -12.041
X-Spam-Level:
X-Spam-Status: No, score=-12.041 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.148, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_NONE=0.001, T_SCC_BODY_TEXT_LINE=-0.01, T_SPF_HELO_PERMERROR=0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=cisco.com header.b="bL7meRFa"; dkim=pass (1024-bit key) header.d=cisco.com header.b="lAxLVH7S"
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ZmhqeZdB_wLu for <opsawg@ietfa.amsl.com>; Mon, 8 Jul 2024 05:51:52 -0700 (PDT)
Received: from rcdn-iport-1.cisco.com (rcdn-iport-1.cisco.com [173.37.86.72]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id BC3F5C14F705 for <opsawg@ietf.org>; Mon, 8 Jul 2024 05:51:52 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=43668; q=dns/txt; s=iport; t=1720443112; x=1721652712; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=GMYgmt44VcqV+EUCgHDsWhLDOctB7HZnoo2ZS1M7qsE=; b=bL7meRFakPLZ2TAQQC+BfatqdUuENwOUr8WD39GkULFTEnnS0im+acY6 s9wS5ZHKg/9X8l/skdkzNfssZ+pEtx1n9hCTZh3xFKvbWQDHdeEZuel5Q /ch/Mpjd1nU0m63KyVelejBcNQZP8UngG5xcxtwqI40YivVjAIkxZmElu M=;
X-CSE-ConnectionGUID: kE4Se+2QQRio+BtIbKiTsA==
X-CSE-MsgGUID: QImwh4HzTwWV0HzOHCmVEw==
X-IPAS-Result: A0ADAAAH4ItmmJldJa1RCRkBAQEBAQEBAQEBAQEBAQEBAQESAQEBAQEBAQEBAQEBQCWBGAIBAQEBAQsBgUAxKih6AoEKEkiIIQOFLYhuA4thhWOMShSBEQNWDwEBAQ0BATsJBAEBgimCXQKJEQImNgcOAQICAgEBAQEDAgMBAQEBAQEBAQEFAQEFAQEBAgEHBRQBAQEBAQEBAR4ZBQ4QJ4V0DYZdAQEBAQIBDgQbEwEBIxQBBAsCAQgRAwECFgsBDSARHQgCBAENBQgaglkEAQElgXcUAw4jAwEQBqIFAYFAAoooeIE0gQGCDAEBBgQF2xsDCoJPCYFIAYgSHgEkgTGIZycbgUlEgRVCgmg+gh9CAgKBFw0FAQgKAQcCBhQFBxINCwYBg1aCL4UfaIZ9gQRHglcDIkGBToEJgR1GgwIPghULEFgFH39XD4JjDhOCc38mC4Eci2FUdSIDJjMhAhEBVRMXCz4dAhYDGxQEMA8JCyYpBjkCEgwGBgZZNAkEIwMIBANCAyBxEQMEGgQLB3eBcYE0BBNHgTcGiWkMgwUCBSEEJYFJJ4ENF4J3S2yBHQKCYoFrDGGESoJGcWKBD4E+gWIBS4EYgWUwGyQLYYFVgQIiGAomHUADC209NQYOGwUEgTUFqEMENwKDAwUgSwECLBAmAQMNIgMRDgIgAmMLPRsDFSwRCy+SRiQwgl8Bi3hHjgaUFnEKhBSKLoFhjy6GKheEBYFWo3tkmGkggjSPI5FJGQWFAwIEAgQFAg8BAQaBbgsoD1xwcBWDIglJGQ+OIQwBDAmDWIUUxmt4AjkCBwsBAQMJiG4qcmABAQ
IronPort-PHdr: A9a23:ZbIxJhBjku+YkfzKC/lbUyQVpxdPi9zP1kY98JErjfdJaqu8us6kN 03E7vIrh1jMDs3X6PNB3vLfqLuoGXcB7pCIrG0YfdRSWgUEh8Qbk01oAMOMBUDhav+/Ryc7B 89FElRi+iLzKlBbTf73fEaauXiu9XgXExT7OxByI7H3EYrblce6/+uz4JbUJQ5PgWn1bbZ7N h7jtQzKrYFWmd54J6Q8wQeBrnpTLuJRw24pbV7GlBfn7cD295lmmxk=
IronPort-Data: A9a23:FuRWBajwI3UH3Cdlo4pzNgU/X161ahAKZh0ujC45NGQN5FlHY01je htvWWmBbvuCZmLxfIx3O4m2/B8P6p7RyoJrGVdk/H8zHy5jpJueD7x1DKtf0wB+jyHnZBg6h ynLQoCYdKjYdleF+1HwdOGn9SQhvU2xbuKUIPbePSxsThNTRi4kiBZy88Y0mYcAbeKRW2thg vus5ZWOULOZ82QsaD5MtPrT8EkHUMna4Vv0gHRvPZing3eG/5UlJMp3Db28KXL+Xr5VEoaSL 87fzKu093/u5BwkDNWoiN7TKiXmlZaLYGBiIlIPM0STqkAqSh4ai87XB9JAAatjsAhlqvgqo Dl7WTNcfi9yVkHEsLx1vxC1iEiSN4UekFPMCSDXXcB+UyQqflO0q8iCAn3aMqUb17pMDCIUz MUiKTdORAyijcG3/KmSH7wEasQLdKEHPasFsX1miDreF/tjG9bIQr7B4plT2zJYasJmRKmFI ZFGL2s0Kk2dOHWjOX9PYH46tOWjgnDlcDBwo1OOrq1x6G/WpOB0+OK3YICMJYLQHK25mG6hh 2fZ/zjZEC0FC+LH6Sii0lmpuMLQyHaTtIU6T+DgqaUw3zV/3Fc7DwUNXES0ifi0lkD4XMhQQ 3H44QI0pqQ0sUesVNS4BVuzoWWPuVgXXN84//AGBB+lyYeI2AvaXFE9dD9GK/Y6lcUVRAAx/ wrc9z/2PgBHvLqQQHOb076bqzKuJCQYRVPugwdaFWPpBPG9+ekOYgLzczp1LEKiYjTI9dzY2 TuGqm01gK8eyJRN3KSg9leBiDWpznQocuLXzluKNo5GxlolDGJAW2BOwQODhRqnBN3FJmRtR FBex6CjABkmVPlhbhClTuQXB62O7P2YKjDailMHN8B+rmX9pyL7JNsBuWEWyKJV3iAsJGGBj Kj75F052XOvFCL2BUOKS9vrUp1xnPKI+SrND6mNMIomjmdNmP+vp3w2OhXKgAgBYWAnkLo0P t+AYN2wAHMBQaVhx3zeegvu+eFD+8zK/kuKHcqT503+idK2PSfJIZ9bawHmRr5is8u5TPD9r ow32z2ikUsPCYUTo0D/rOYuELz9BSFhXs+p9pwKKbTrz8gPMDhJNsI9CIgJIuRNt69UjezPu Hq6XydlJJDX3BUr9S3ihqhfVY7S
IronPort-HdrOrdr: A9a23:6POGSq076DFPjZPKuvN/7QqjBf1xeYIsimQD101hICG9Lfbo9P xGzc566farslcssSkb6KG90cm7LU819fZOkPAs1MSZLXnbUQqTXc5fBO7Zsl/d8kLFh5NgPM tbAs9D4ZjLfCZHZKXBkUeF+rQbsaW6GcmT7I+0oQYJPGVXguNbnnhE422gYzVLrXx9dOAE/e 2nl7F6TlSbCBIqR/X+LEMoG8LEoNrGno/nZxkpOz4LgTPlsRqYrJTBP1y9xBkxbxNjqI1OzY HCqWPEz5Tml8v+5g7X1mfV4ZgTssDm0MF/CMuFjdVQAinwiy6zDb4RG4GqjXQQmqWC+VwqmN 7Dr1MLJMJo8U7ceWmzvF/ExxTg6jAz8HXvoGXowkcL4PaJBg7SOfAxwb6xQSGprHbIe+sMlp 6j6ljp8qa/yymwxRgVqeK4Dy2C3XDE0kbK2dRj/UC3F7FuKYO4aeckjRlo+FBqJlOg1Kk3VO ZpF83S//BQbBeTaG3YpHBmxJi2Um00BQrueDlJhiW56UkfoJlC9TpS+OUP2nMbsJ4tQZhN4O rJdqxuibFVV8cTKaZwHv0IT8e7AnHEBUukChPfHX33UKUcf37doZ/+57s4oOmsZZwT1ZM33J DMSklRu2I+c1/nTceOwJpI+BbQR3jVZ0Wh9uhOo5xi/rHsTrviNiOODFgojsu7uv0aRtbWXv 6iUagmSsML7VGeb7qh8zeOLKW6c0NuJfH9kuxLL26zng==
X-Talos-CUID: 9a23:v1P0U2iBsThLomBqt+sl1Q+p4TJucVCB93qTeXaBM2duC5eJaFWz+Z9/up87
X-Talos-MUID: 9a23:hp8rWgnGdlaBwjIkkRijdnpbFcJ34/iOGnwSrqtem9ujFQd1BRqC2WE=
X-IronPort-Anti-Spam-Filtered: true
Received: from rcdn-core-2.cisco.com ([173.37.93.153]) by rcdn-iport-1.cisco.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 08 Jul 2024 12:51:51 +0000
Received: from rcdn-opgw-2.cisco.com (rcdn-opgw-2.cisco.com [72.163.7.163]) by rcdn-core-2.cisco.com (8.15.2/8.15.2) with ESMTPS id 468CppLb024865 (version=TLSv1.2 cipher=DHE-RSA-AES256-GCM-SHA384 bits=256 verify=OK) for <opsawg@ietf.org>; Mon, 8 Jul 2024 12:51:51 GMT
X-CSE-ConnectionGUID: Wmshlmi2TEGMO7M4dI2qDQ==
X-CSE-MsgGUID: LVk9QZcKSXm1B4FwRC5Ycg==
Authentication-Results: rcdn-opgw-2.cisco.com; dkim=pass (signature verified) header.i=@cisco.com; spf=Pass smtp.mailfrom=jclarke@cisco.com; dmarc=pass (p=reject dis=none) d=cisco.com
X-IronPort-AV: E=Sophos;i="6.09,191,1716249600"; d="scan'208,217";a="17741446"
Received: from mail-dm6nam04lp2041.outbound.protection.outlook.com (HELO NAM04-DM6-obe.outbound.protection.outlook.com) ([104.47.73.41]) by rcdn-opgw-2.cisco.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 08 Jul 2024 12:51:50 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=H6LkkR1JOuzZno45k55NfQ8BDTTSHRiCdVRIBSG4EixrB1oNJicRMUpJ7JDQ4UmBDwbVS5ShD6ppiSMEaTQeMUEZU/F5LeKSZw2U5z595mXgx7yqHxVI8JkpkNHyz1LJx9gn99RRt4oDK64Z4qWfKcXYmchCWB76Y/jCT36fC5c/8F0lGxnZvMOSyCr542M7wNnsIiyMy38B2Wn1tm0e2mrIsHhbeXGkgOadhrK0Ge34opNo6Kvoy8ngO6Lzt4NTvR5iTADic2zR2PuCkjzyM1yP/T0tfNBO8Vy3DOFgiE6IHhFnHCHh0Bs8gDpPrhzZyPqzy8lwoVdSmA7RBCsbZw==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=GMYgmt44VcqV+EUCgHDsWhLDOctB7HZnoo2ZS1M7qsE=; b=jlJVSfVCMOyc218yZEczbLZoRYjaln9xu2rEdMPIC3HwuSlEMh44S52Mq3ZUZLfLRNjhSjdAFsNNeSKg9gKPoQaOToLCoPdfs6iJHatFMRFJZH7w357MUWuJsvAHBcc+XeM3QzPpNZXYA0kOfp5S+7DS8v+DLi5BZ7cdE2Fml8/UCc920wRxcO9VYgn4+D3jCgooBLJxnNEArY0OAuSEcmyFAt9r6oACBqCovdwyxjrJeyCnT5T0f5t42grS470CSMGuUO7rSoiBcDJgSPPHKNPpL/b1kHFtOm2/I6sBmFyLkjO47bh0QrXk1TmmIh9qbATXhS7XIKiVFr7fMwHf3w==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; s=selector1; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=GMYgmt44VcqV+EUCgHDsWhLDOctB7HZnoo2ZS1M7qsE=; b=lAxLVH7Sk4EgQC1Y17C0SRrxtLO0nypXlX46GuqsrlcQHqqzZocbEZHBB2QdShxncOOZlJKRJhkx04UJ3kcIgMP8D167Ru5G6FXe4cOXWUjuLqG8HUyq8OqWjECFfCN8QLWhTLbzicbZCYwFsYbXXOmv1Se6CvzyH+4alu33lLY=
Received: from BN9PR11MB5371.namprd11.prod.outlook.com (2603:10b6:408:11c::11) by MW3PR11MB4556.namprd11.prod.outlook.com (2603:10b6:303:5b::21) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.7741.35; Mon, 8 Jul 2024 12:51:48 +0000
Received: from BN9PR11MB5371.namprd11.prod.outlook.com ([fe80::971b:f067:bf9b:efce]) by BN9PR11MB5371.namprd11.prod.outlook.com ([fe80::971b:f067:bf9b:efce%3]) with mapi id 15.20.7741.033; Mon, 8 Jul 2024 12:51:48 +0000
From: "Joe Clarke (jclarke)" <jclarke@cisco.com>
To: "Douglas Gash (dcmgash)" <dcmgash@cisco.com>, "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org" <opsawg@ietf.org>
Thread-Topic: OPSAWG Digest, Vol 205, Issue 20
Thread-Index: AQHayW1ii8V5kudTxkyZFG6VfJaTz7HoAMaFgASHvw+AAE2c3A==
Date: Mon, 08 Jul 2024 12:51:48 +0000
Message-ID: <BN9PR11MB53710A4CB9124CB9D0BCDAEBB8DA2@BN9PR11MB5371.namprd11.prod.outlook.com>
References: <171958741031.6614.6192371628253402915@ietfa.amsl.com> <BL3PR11MB636498065CA94698B937E5CCB7DF2@BL3PR11MB6364.namprd11.prod.outlook.com> <BL3PR11MB63647995AABAED8113F9DDBFB7DA2@BL3PR11MB6364.namprd11.prod.outlook.com>
In-Reply-To: <BL3PR11MB63647995AABAED8113F9DDBFB7DA2@BL3PR11MB6364.namprd11.prod.outlook.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: BN9PR11MB5371:EE_|MW3PR11MB4556:EE_
x-ms-office365-filtering-correlation-id: fb167c49-cad5-473f-5621-08dc9f4cbb38
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|366016|1800799024|376014|38070700018;
x-microsoft-antispam-message-info: RllmUGgSVmG4GbxbCl/2EDFpxCiq4yJpgCEEmGaI+c5ANqulNAuihp77qG1EMEX8H07UyHCw8EgIYAiSh+PSWO0NWq2YAoWqN5zwUG5LL+e0kkjQhbGwfnqvWbinM0emXkbqw39VS5G9KK0L1XGGVE0p8WhRvT4TaJtZ0pnyaVC6XDWcooFVUBPjuJlUiFqL1/qFTenfZJBu/ypHXLS1BnCyFWbNd9LZ2JCa7TZ3nwDrcl8cTdnssDgUkeUz/O0Xml00O//oYxwBqBce75QWbEECTO3TcQJCMVs9NmxY1gkauVKDpQqvmCiJNoLNvem6FvX2/cusSJntK7SReJpQMfHFF2Jnj78dVwNwRcM6onfGn8dNY6F91Uyf0skam5O8QKZcKtBap3OkW1jk5M09T/sf7YcevwczKX9iVCgBG7xmgGWgzzTtHKs/Jf5M0Ox4KfDOOKae4mlaU0rmY8N1FGCbJSv8h3LtHwLmT7BlatPS9/mRGcK13qe8hp5xrmmrjI1wJuUjKMuCHTYtqyhcy7flkJtgVgMv49VFIwjUP6W7rYxC6XH5l6kjPfqUm7IpyngTQ10GOROLdxbJtOejbIjAkEJ7NoQDHWf6Nlhtq8jdGuDQ7Ok291kVG6MC6/pJyL+s9qRZQQ92n5kv8nIpA9fctWNGzr3LlIrg96z/3ME/6wHpK4hFRZmIiQI/au2O6MM5oFd6iOklpiXH/etdtmvqllEdZIZXyJczAEzzJWjpngMi6HJmFetEOmp9rPosPNc8o7ZlvwsOivBJ03pCyNUivb3jeGOuvT9TqrXTxRCVdvHPp0DSFLxGEk2Yp9ZETsRotzHQxj5zH+S4bbYTG3t4ya3vYKTfnQxWF4PLmi01lt0GjDk6agTLajpxHQiacHdXixf7knNcTqBk05Z2hmb1Jtuk/Eqmx7ZrOXmr9mqnCcva7xW5oPOKBwF8G6lWaj8sIJ3GeUHmDw+zJ6JQ1MWc4g1p6u7GlLTtZ6F26kestd4r6bGlNBF1TwiHlezVVv2QNmGcqszp/3UmnIUf5RVZwcrrCaYyLfuI9/RdyeCbrisk7ib7V9OsYE3gzY0fepWmwffD6aKbtUHsy5ccKM9Zn1u0RHXrRA3cS12D5n1CrLg5atrgH8W/vj0weD1xgUcsRgqPUdwWDHn7ndn6PXU9729jf1GHS/6sTMw7Z8eJpIg8mwjWFgmqNJHlMOqGFOO52iT8nd9gT45M9pbpKEE3E7U/I2ee0tsrSLxrgd5m8DlBUEEgYPIKddN3bat3Zd5IGI2swSIcO/mAivx+xG2wy9oHHIj3UPFQhALJuKFy/j+b8netyJfVxROtsTmv9yulBzRjvayydIw3CFuRrMFyiXXQockc/kaafWYK4UU=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:BN9PR11MB5371.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(366016)(1800799024)(376014)(38070700018);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: TfCYPvxJCYMUtipgCRhavXS8OI0+Lw0gSQZSpKuq0EiB7ATgnIy6rVQytC5IsSS1qyDNVk08yAzT82YuoD6h9OObB8VwBO7C8O7TQ2sNH84P9TwrxGs8zqeTDdeHKnD9TSY/zGsJt4zm/LYA5bMwUIDAowesYrXmJUTDh2EOY4u0YfZDLL/EPPa2/Bp3xAxcLxG6cGMLuJAfpxSRH52vcYnpM4zRwohOnnU80rw6OniMIkPgRFr4KWfVcGY1IFYalbjDN2D73SXDOIPFFPsu9stSS6yTZPRn1n9bOV3wPcvV+vgAAZ7ia+9kTrHcfW2dLTLV+sD6sx0V2nC1j5n6o+UbUs2Lom1eu4lJMYZnDFqGoxeizasvVM0owQujhDQag7ELuJL3g65VWtRmoLiLLxDrcdO9q2JU8T5NPTIduUzAiISVJs1lFz9w3z1gNTvRoiqqnwahodUjer2+Bc0TUjxscUb/56Si2rvarmb/PbYaUQHYLb7lpqZlKzpw1JnVvd6z+rLyndnpZirHui4/fi9PphFbgU6m06/Z1/Sygt7NGuCQpIx3zbdZeb0PZXrKnL6pq5brq6veb5tgAYN76CxBcyc1fAwDZBhACjR29az9hOenXO+nAKFNcamdzdVCFUYyP/35TR8OvoszAVXlqIzCrMvH5tsp3Al4er/vqg6zVJuYtGUr1QTaFPFplGbT9UVUBKMtAOFi8MXr+oEXfuvMobiDxoql3EbHnwLdlPLTnpZEkK/qUSwnb093M0bdYscNw7Wl4q9tDhyJO2+fGs0C73/mWpKlLk+HdHYWwIMPDVqUrSNrKURL3NebHNqZlRhHPloEO1iix1tscS/pXymKCA58jcuH3Jdkcg6m0Dhcs8ZDC/JxBurwTILNgZgKM9ESQsZiAXBlDsG3dCVTCXUOXWiwIx0GEBDi7IWkEHMjxTNGNSqs9qNFlP46259j4HCtAkpy/nQPwvxjM8XcaYrd4fK8hYwqfP4TQwTgLpFuC0h1ZW96lHbUjnmW4ZkaEz9omRQE2Xoj1wKIssjRtm8NnqnaZiyTVF7UnQG0NaO83wdVmfS4w8db7wjwWwjGdQb6vqB3c46vC7zkNSgcqkBNVbcGj6AdZtG0cVUjpAi7I/ifE4lAEq1fxzk12SCaPktA+vNISZ8EzwY98n990eO6Mitg+3TAElWot3gELrMRXoA+uusy6ep2sUDp8IjPLEaLTCFZDwJRNlMlpOQUAnVKbc4f3dxK6hFi+1BJ+Z2DvNzrd4anUlkNmtYQWuTGqVvop/ptiY/DwcmezK/nkx16n2ULrFcBiX7pBSr1K88F6+Gkia/CL+sujosDDH6htUlz6ftglTvFjjjC/j4+G1ecjXS/qnMM22w3mopXhC/g+2vn+dfFjCbdXspSTbA2heY9UnL+21j7wCV5DINU+rkmPBV9DDDc0STI8+Dkijp+EvLaV4JmHaWJAeRYZHngoDqygNn+IOrLVWh/Ys4K4DopZRkWtfE7sIeyZO0vPcyg5mkjXMhR174RxscrrxaI/OvOKJ3OWQf22pPXowjCdDLY5DCAjS866mhNi+3qBe14PQ6LIzcfHqFa+jJWh7cvcFlfcLp+KjJvwn9eepG3sql9clxapBwSGdqt+PHN4osMvsn6F9wvKU+TQT7gczw/knGtR/oMxssrbjleMyCOCw==
Content-Type: multipart/alternative; boundary="_000_BN9PR11MB53710A4CB9124CB9D0BCDAEBB8DA2BN9PR11MB5371namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: BN9PR11MB5371.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: fb167c49-cad5-473f-5621-08dc9f4cbb38
X-MS-Exchange-CrossTenant-originalarrivaltime: 08 Jul 2024 12:51:48.6891 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: JrmXKpNl3q5MOblmexVVFR+mRzH6dZPFZlzsz85I/FOeask/oOvwhPEWETKSI1iU1rdIYYofphgRZuOueDSRkg==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MW3PR11MB4556
X-Outbound-SMTP-Client: 72.163.7.163, rcdn-opgw-2.cisco.com
X-Outbound-Node: rcdn-core-2.cisco.com
Message-ID-Hash: Z77QTOWVVIGXQXFC2XWWNI4FKC44UD2D
X-Message-ID-Hash: Z77QTOWVVIGXQXFC2XWWNI4FKC44UD2D
X-MailFrom: jclarke@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-opsawg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: John Heasly <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [OPSAWG]Re: OPSAWG Digest, Vol 205, Issue 20
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/V2NqMTShI-fHAOvOx6yVrNzUBQI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/opsawg>
List-Help: <mailto:opsawg-request@ietf.org?subject=help>
List-Owner: <mailto:opsawg-owner@ietf.org>
List-Post: <mailto:opsawg@ietf.org>
List-Subscribe: <mailto:opsawg-join@ietf.org>
List-Unsubscribe: <mailto:opsawg-leave@ietf.org>

I am speaking as a contributor and user of TACACS+ in general.  I am not personally implementing a T+ server or this draft.

I think fully supporting and documenting external PSKs would be generally useful and would possibly aid in the adoption of this new modality for T+.  I would be in favor of option 2.  I would also like to hear from people like Rod Persky and Marc Huber who mentioned possible implementations.

===

As a chair, I’m glad to see this email this morning.  Going into today I was a bit conflicted as to how to decide this WG LC.  We received some feedback, but nothing overwhelming to point to consensus.  I was thinking to push it back to the WG to settle on this and look to do another WG LC.  It seems you preempted me.  Additionally, I did not receive any replies to the renewed IPR call.  We want to make sure all IPR has been disclosed (if there is any) prior to WG LC conclusion.

Joe

From: Douglas Gash (dcmgash) <dcmgash@cisco.com>
Date: Monday, July 8, 2024 at 04:48
To: mohamed.boucadair@orange.com <mohamed.boucadair@orange.com>, Joe Clarke (jclarke) <jclarke@cisco.com>, Alan DeKok <aland@deployingradius.com>, opsawg@ietf.org <opsawg@ietf.org>
Cc: Thorsten Dahm <thorsten.dahm@gmail.com>, John Heasly <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
Subject: Re: OPSAWG Digest, Vol 205, Issue 20
Dear Opsawg et al,

1) Discussion on External  PSK (Related to part of Mohamed’s point 2 below).

Our distillation of the thrust of Alan’s main advice is: The doc needs to either commit to fully documenting external PSK and its ramifications or preclude it. The truth is, our doc merely  says: TLS T+ implementations may support External PSK, and leaves it there.

Background: as this doc has evolved, we have temporized on the topic for the first TLS version of T+. On one side: we were not convinced External PSKs are quite established in TLS 1.3. On the other side they would be very useful for operators. But now  It seems that PSKs have become better established, through the work of Alan et al, so we may consider to document use of External for this initial doc, rather than adding later supplement to cover external PSK. It does mean through that there may be another round or two to bring in the needed details.

So now would be a good point to gauge the opinion of the group. Based upon where the doc is in the process, and what changes should be applied to it at this time::

1) Should we revert the doc to say:  “External PSK should not be used now.  A supplement will follow to address how PSK can be used properly”
Or
2) Keep the option for External PSKs to be used as now, and Commit to a few rounds of revisions to document to fully flesh out its support.

Authors would be happy either way, probably on balance we would prefer second option,



If we went for option 2), then below is an outline of the responses which we believe would cover External PSK:



Note: “RADIUS and TLS-PSK” Provides a wealth of recommendations on PSKs.



1.      a new section will be added specific to PSKs  include the following items, mainly  gleaned from “RADIUS and TLS-PSK”, (note that TLS 1.2 related issues have been filtered out)

General:

It is RECOMMENDED that systems follow the directions of [RFC9257<https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257>] Section 4

PSK length recommendations for both implementation and operations

Fortunately, as we have already removed the MD5 obfuscation,  we do not have issues in sharing Shared secrets and PSKs
PSK Identity:

RFC9257<https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257> 6.1 to be used for PSK  identities

PSK Identity length recommendations for both implementations and operations.
Per Client Sharing

PSK must be unique per client as configured on server

PSK Identities must be unique per client as configured on server

(Of course references will be updated to acknowledge this doc)


2.      The Tacacss draft doc mentions identity specifically in the context of Certificates. This will be clarified that it applies only to certificate based, and for PSK it has its own guidance as above.


The following changes are not directly related to External PSK and will be resolved anyway:

2) Resumption elements from RFC9190 (Related to the balance of Mohamed’s point 2 below).

References from RFC9190. The doc primarily adresses the use of TLS as an EAP option, which has extra concerns as it is used for authorization information. The concerns that were apprehended form the text are listed below with our  evaluation of relevance when used for the tacacss security wrapper.


Authorization on resumption mased on cached data rather than the data in the resumption:

Regarded: Not Relevant as the data is not used for authorization for tacacss

Verification of certificates revoked during the period since the last “New Session Ticket Message”

Regarded: Relevant, and we will update. RFC 8446 is not silent on this topic, so we will prefer to cover this by  refererence to section 4.6.1 which says:

         Note that in principle it is possible to continue issuing new tickets
               which indefinitely extend the lifetime of the keying material
               originally derived from an initial non-PSK handshake (which was most
               likely tied to the peer's certificate).  It is RECOMMENDED that
               implementations place limits on the total lifetime of such keying

         material; these limits should take into account the lifetime of the
               peer's certificate, the likelihood of intervening revocation, and the
               time since the peer's online CertificateVerify signature.


Maximum lifetime:

Regarded Relevant, we will update by reference to its coveragein RFC 8446

“time-of-check time-of-use” issues

Regarded: Not Relevant as the data is not used for authorization for tacacss

Re evaluation of authorization on resumption:

Regarded: Not Relevant as the data is not used for authorization for tacacss


3) Regarding 3) below, thanks for the catch, We’re proposing the following change:

Current:

   To ensure separation of TACACS+ traffic that uses TLS from that which
   does not (Section 5.3), they will be deployed on different ports.
   Due to the widespread use of default port number settings in numerous
   existing TACACS+ client configurations, a well-known system TCP/IP
   port number will be requested from IANA.  Client implementations can
   ensure traffic is kept separate.  The designated port number is [TBD]
   (Section 7) with the service name [TBDN] (Section 7).

Proposal:

   To ensure separation of TACACS+ traffic that uses TLS from that which
   does not (Section 5.3), they must be deployed on different server ports.
   Further, because of the widespread use of default port number
   settings in numerous existing TACACS+ client configurations, a well-
   known system TCP/IP port number is assigned: the designated port
   number is [TBD] (Section 7) with the service name [TBDN] (Section 7).
   This way the client can ensure that TLS and non TLS traffic are
   separated even where default ports are omitted from its server connection
   configuration.




Date: Fri, 28 Jun 2024 13:36:42 +0000
From: mohamed.boucadair@orange.com
Subject: [OPSAWG]Re: WG LC: draft-ietf-opsawg-tacacs-tls13
To: Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org"
        <opsawg@ietf.org>
Cc: "uta@ietf.org" <uta@ietf.org>, "Joe Clarke (jclarke)"
        <jclarke=40cisco.com@dmarc.ietf.org>
Message-ID: <DU2PR02MB10160C69E1AF8E95168D5CC6A88D02@DU2PR02MB10160.eu
        rprd02.prod.outlook.com>
Content-Type: text/plain; charset="iso-8859-1"

Hi all,

FWIW, we had an offline discussion with Alan and the authors to clarify the concerns.

I'm reporting the main outcome of that discussion, fwiw:

(1) Alan  agreed that:

* It is good practice to leverage existing standards
* Repeating details isn't useful

(2) Still, the key comment from Alan is:

>   My point was that the RFCs I referenced had substantial text over
> and above 8446 / 9525.  I asked that the authors double- check the
> documents I mentioned, to see how these issues were addressed.  The
> result was a few minor changes.

The shepherd agrees that this is a reasonable comment that should be adequately addressed.

The authors engaged to have a look into the various RFCs cited by Alan and grab applicable items to tacacs+ context. It would be helpful to share the rationale for the items that they picked vs. those they considered as not relevant.

(3) As a bonus, Alan provided the following comments and summary

==
Some grammar / clarity comments:


Section 3.1:
...
To ensure separation of TACACS+ traffic that uses TLS from that which does not (Section 5.3), they will be deployed on different ports. Due to the widespread use of default port number settings in numerous existing TACACS+ client configurations, a well-known system TCP/IP port number will be requested from IANA ...

  The text is ambiguous: "will" be requested?  When?  Does this document allocate the port?

  The usual text is to say "port TBD has been assigned for this protocol".


 In short:  I'm not objecting to the publication of this document.  My concern is that it doesn't give a lot of guidance to implementing TACACS+ over TLS.  I can see basic implementations working, just by wrapping TACACS+ in TLS.  But the operational considerations outlined above will have to be discovered piece-meal by implementors.
==


Cheers,
Med
***************************************