[OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-opsawg-discardmodel-14: (with DISCUSS and COMMENT)
"Eric Vyncke (evyncke)" <evyncke@cisco.com> Thu, 23 July 2026 14:35 UTC
Return-Path: <evyncke@cisco.com>
X-Original-To: opsawg@mail2.ietf.org
Delivered-To: opsawg@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 3A64B11D7F64B; Thu, 23 Jul 2026 07:35:41 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1784817341; bh=ncQ0js2JynuvaMQgpbNOCCpV7BB6GuKPq84OMPsV1uk=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=B2FEZePxKB9e98YK0nf6G86w69zqfcBK8wH3g6e9Izs/vRb39o1kCWciUIvB+gjuO bDX6IFmD+TI0+32FygkCrs6/WBer0ncDG75Xfi1eAFWHaM7MSvRI/IZu9dafQeH8pa t9Jia1fhbd8y/rwspFQRrpUpCf0IJxfMPiDP47kc=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.885
X-Spam-Level:
X-Spam-Status: No, score=-11.885 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id CNgEvXx5UtGv; Thu, 23 Jul 2026 07:35:39 -0700 (PDT)
Received: from alln-iport-5.cisco.com (alln-iport-5.cisco.com [173.37.142.92]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 0466111D7F4A4; Thu, 23 Jul 2026 07:35:29 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=71064; q=dns/txt; s=iport01; t=1784817330; x=1786026930; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=bmFzaz7STKYY9ta2tvFsobFXy29lmh2TrHlZ4Mvr6K4=; b=C/FcPMZ5EAY6QbNZoL+X2HBKvRejO2SqDa2/98yj/GMDSVVTtzL5cgNz lSKCQ2WXG9Cmafv43bUOHBBQfVfXCHFbj8eGHlKpUxaNP80JdhdIrwyzu iWmks/byJ3+CARyLUDg617XoJwf8W9MxO+B06xcAksB3vHxnF16W7wQik qY7mklke87wL+4hpjJ8axLDXsAkc4QgqHsIusBzgMFiVGZKNf6oDN5FeN a3Oo0qfFubgpZWLd8+pX//HnOZnBy6CHnHNsg5tP9OQEMZfp8GG71044j nU+bedFEcB/Qzbf6vPO+9AapInMZb36qEFlE3+avLrku+/HCSLJVm8uJx Q==;
X-CSE-ConnectionGUID: tCtrqX+fTDGHe7UPkZE46Q==
X-CSE-MsgGUID: SBpNHpO6TyGHOAM3juLFWQ==
X-IPAS-Result: A0CKAAALJmJq/44QJK1QAQkdAQEBAQkBEgEFBQFlgRkGAQsBgTwxKimBCoEhSYgjA4UrhliCIQOBE4pRhWaJcoJfFIFqDwEBAQ0CNB0EAQGFBQKNWgImNgcOAQIEAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4ZPDYZaAQEBAQIBEggBTBIFCwIBCBEBAgECFgsBBgcgERQDBggCBA4FCA4MgmGCHR0DECcDAQIOBrZIAYE9AooqeIE0gQGDWgIBBAcCAkAB2RkNgl4GFIE5AYU+gn0gASqBNYIJgXYZGymDMIEIJxuBSUQ0YUKBZ0o4PoIfQgEBAgEXfxIBAQYBAwEGASMeFgmDVoIwBIINFXoSG4E/gWUlfUqDY4kOUnIiAyYzLAFVExcLBwWBI0MDgQYjSwUtHYEjIR0XFh5YGwcFEiAqQUUjA0EmEDgLQwWBVgKBfD8jHwM5f4EwdUp3LWkBAhAXSjgkg0kCgR0DC209NxQZAwSBNQWMeEkZI4FECQEQLS4GAQE8FhAECwkHAgULAgkDEAIEAgISAwskBwIBBwYWDAYrFQgKAwoBBAETBQIPAycRKZJhCQoKAjGCZgGMK0eBNYIhikOTWQtCcQqEHYwhjz4Ehi4XhASNFIcDkWpnmQiOCoQJkVEOCw2FDgIEAgQFAhABAQY2gTkOJ2k/GQUMB3AVGiGCMwEBATFTGQ+DPIpxFhx4AQiCQ4UTxHN5AgkyAgcCBw4DC5FoAQUidmABAQ
IronPort-PHdr: A9a23:2PKZdBwRENwBBSfXCzPsngc9DxPP8539OgoTr50/hK0LK+Ko/o/pO wrU4vA+xFPKXICO8/tfkKKWqKHvX2Uc/IyM+G4Pap1CVhIJyI0WkgUsDdTDCBjTJ//xZCt8F 8NHPGI=
IronPort-Data: A9a23:RBLoVKIzDvUgOj+CFE+Rx5QlxSXFcZb7ZxGr2PjKsXjdYENS1zVWy 2MaDW6HOPbYYmanfoskYdux9x9TuJ6Ey9ZrGlQd+CA2RRqmiyZq6fd1j6vUF3nPRiEWZBs/t 63yUvGZcoZsCCSa/kvxWlTYhSEU/bmSQbbhA/LzNCl0RAt1IA8skhsLd9QR2uaEuvDnRVnQ0 T/Oi5eHYgH9hGQvajt8B5+r8XuDgtyj4Fv0gXRmDRx7lAe2v2UYCpsZOZawIxPQKqFIHvS3T vr017qw+GXU5X8FUrtJRZ6iLyXm6paLVeS/oiI+t5qK23CulQRuukoPD8fwXG8M49m/c3+d/ /0W3XC4YV9B0qQhA43xWTEAe811FfUuFLMqvRFTvOTLp3AqfUcAzN1yJ10sJL1b9NpbLkFDq sEgKwIgMk660rfeLLKTEoGAh+wqKM3teYdasXZ6wHSBULAtQIvIROPB4towMDUY358VW62AI ZNHL2MzNnwsYDUXUrsTIJ8gjeGjhXTXeDxDo1XTrq0yi4TW5FMhj+SxaYeMIrRmQ+1utF6+h nrhoVjoLTE9HfnEyyeh3E2V07qncSTTHdh6+KeD3vJwiVOPg20eFBNTUkOgqOa2z0K/QNlWM UAR/SYjqYAz+VClCN7nUHWQoXOfsTYdVsZeVeog52mlzbLP6hmWQ2MERz9bc/QnudM4Azsw2 TehmMvyDCNgmLyYVXzb8a2bxQ5eIgAcKWsEICtBRgwf7py7/cc4jwnESZBoF6vdYsDJJAwcC gui9UAWr74SlsUMka68+Dj6b/iE/fAlkiZdCt3rY1+Y
IronPort-HdrOrdr: A9a23:OwqoDqpC3tqMbMgyVVJi4wMaV5sWLNV00zEX/kB9WHVpm5Oj5q OTdaUgtSMc1gxxZJh5o6H/BEDhex/hHZ4c2/h2AV7QZniWhILIFvAs0WKM+UybJ8STzJ846U 4kSdkANDSSNyk1sS+Z2njELz9I+rDum87Y55a6854ud3AXV0gK1XYBNu/vKDwMeOAwP+tAKH Pz3LshmxOQPV4sQoCQAH4DU+Lfp9vNuq7HTHc9bSIP2U2ltx/tzKT1PSS5834lPg9n8PMP4G LFmwv26uGZte2nyhjT7mnX755HstrswNlOCaW3+4kowzPX5TqAVcBEYfmvrTo1qOag5BIBi9 /XuSotOMx19jf4Yny1iQGF4Xii7B8er1vZjXOIi3rqpsL0ABggDdBauI5fehzFr2I9odBH1r 5R1W7xjesUMfqAplW52zH7bWAsqqOGmwtlrQfVtQ0HbWIqUs4UkWXYxjIMLH5PJlOg1GltKp gfMCiV3ockTbrdVQGYgkBfhPqxQ380AhCKBmIGusCTznxquUoR9TpD+CTa9U1wqK7UjPJ/lr n5G7Utm7dUQsAMa6VhQO8HXMusE2TIBQnBKWSIPD3cZes60l/22tbKCY8OlaqXUY1NyIF3lI XKUVteu2J3c0XyCdeW1JkO9hzWWm2yUTnk18kbvvFCy/HBbauuNTfGREElksOmrflaCsrHW+ yrMJYTB/P4N2PhFYtAwgW7UZhPLnsVVtETp78AKh+zi9OOLpevuv3Qcf7VKraoGTE4WnnnCn 9GRzT3LNUo1DHjZpY5ummmZ5rAQD2JwXsrKtmuw8EDjIwWcpZBugIJiVK//KiwWE9/W4QNDT 9DHI8=
X-Talos-CUID: 9a23:YifAPG/wQ4t2XPwPqwaVv1I/Bto8Qj7T8Fv/A0LnNF5qepDJF2bFrQ==
X-Talos-MUID: 9a23:pWqgvwgRoeXeTlp3zIICv8MpD+1wxYS2Lx4xgLomnOChbi5tHxmitWHi
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-05.cisco.com ([173.36.16.142]) by alln-iport-5.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 23 Jul 2026 14:35:28 +0000
Received: from alln-opgw-1.cisco.com (alln-opgw-1.cisco.com [173.37.147.229]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-05.cisco.com (Postfix) with ESMTPS id 8825E18000153; Thu, 23 Jul 2026 14:35:28 +0000 (GMT)
X-CSE-ConnectionGUID: kxfZKN3xQ3GSpyk59VrMAg==
X-CSE-MsgGUID: gc3mUNJXSQaedRrdbPV/Aw==
Authentication-Results: alln-opgw-1.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.25,180,1779148800"; d="scan'208,217";a="81449968"
Received: from mail-centralusazon11011022.outbound.protection.outlook.com (HELO DM5PR21CU001.outbound.protection.outlook.com) ([52.101.62.22]) by alln-opgw-1.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 23 Jul 2026 14:35:28 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=wNzHooP97L/XHYxDnEzOnq3yPc3kZnlxZNmrBQkJfsQayzUxk8oWouGDJFsrxUGPXJKxX+JhVROHJo1ccmF/PAHQcXsA0PQtADwXvcTJ7gAKewVmAZcnsEJXuKI25mZNpmxjBzSo2wowX9P9O7jF+ZTAfrgnez2BdqsTACy59x+YCA9aGmBYgd5DlT5Qeu9v5Asdyzzu/FXIgkVQWSBXGgMJVDaXUonrm1G+IrTybM15MGNWD6/kIE4/7XFls4PffGNRqN1KgkJHbmptghlwuslJ5ci0yZueqFyyuX/WlJ+i9GVXl1G7uBL0jemzj9NvPROMps3/3MRFlBtkqOL4ZA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=bmFzaz7STKYY9ta2tvFsobFXy29lmh2TrHlZ4Mvr6K4=; b=Ent8ONA2XEU3xlfYTBlIybDiF3xr5hRPlTtfuaaI+YEeMwzO0Hdj8XO1NqiLg9wtUMGywmnBFmKhPgoXgjL8mgHP8hSYW46Zrzt8UVj4BvnymguZumPcdQibQrhFuU1zAHgy5HZIAOhXr2fLQOcrJ4TQkzdrK3xFjtgvv5CKqFspB3f2tSMOcP2O/TZmcO3Oe/JU2aVeB68Gkn8qP/daJWJo+csa74sz61RJjfQUEf8d89Pnjq6cWYFGyRYgWLPUSmavyeSkGM2l+8HgjujehZFxWOFiwE9v3fwcM7cgzjhElfKVLreVRa00c5zvBJQdZzZa/Ye0Po7vpF5ULlrPhg==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from PH0PR11MB4966.namprd11.prod.outlook.com (2603:10b6:510:42::21) by DM6PR11MB4706.namprd11.prod.outlook.com (2603:10b6:5:2a5::15) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.245.10; Thu, 23 Jul 2026 14:35:25 +0000
Received: from PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::258a:9418:efab:8cb8]) by PH0PR11MB4966.namprd11.prod.outlook.com ([fe80::258a:9418:efab:8cb8%6]) with mapi id 15.21.0245.010; Thu, 23 Jul 2026 14:35:25 +0000
From: "Eric Vyncke (evyncke)" <evyncke@cisco.com>
To: John Evans <john.evans.uk@gmail.com>
Thread-Topic: Éric Vyncke's Discuss on draft-ietf-opsawg-discardmodel-14: (with DISCUSS and COMMENT)
Thread-Index: AQHdD5ffYpMfw2Hi10en49MsQEv5PrZ7FoIAgAAnahQ=
Date: Thu, 23 Jul 2026 14:35:25 +0000
Message-ID: <PH0PR11MB49666F6DC39B5FE291B009B6A9C02@PH0PR11MB4966.namprd11.prod.outlook.com>
References: <178342742376.424690.12602158437257159285@dt-datatracker-57b5d8f849-zrqfx> <CAH_ay3OMdAHA3fNLFk6S_AY3s-MtorHc=MjHmW4e7-5sGYOyLQ@mail.gmail.com> <CAH_ay3OEWTogMxs=339WMhu5w4dN7rHdvCJhTyp_VsaLX+X86Q@mail.gmail.com>
In-Reply-To: <CAH_ay3OEWTogMxs=339WMhu5w4dN7rHdvCJhTyp_VsaLX+X86Q@mail.gmail.com>
Accept-Language: fr-BE, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: PH0PR11MB4966:EE_|DM6PR11MB4706:EE_
x-ms-office365-filtering-correlation-id: e519faf2-624d-455c-38e5-08dee8c7a274
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|23010399003|376014|366016|3023799007|56012099006|38070700021|11063799006|13003099007|10067099003|22082099003|18002099003|6133799003|4143699003|8096899003;
x-microsoft-antispam-message-info: E+Yx/pVWx0xXZC6cmUxsUXOSeZcDaahjW8vioBPW+htsgllVOBNP9awcrBH9scE8kC3jGaSKvg784fePdfn2S4cpO60MGIXiXQu6JwIeZbU3gSy0wIRKEB1FJ3hArTc/klhTDIe7WcA2In0RHIAbTuFxhZZN8I+9qhS33Xrh7u0bqOi6Oa7nm30rZOKVZLQtBvxMcbPD8dvrHR3nRkyPJtKsnNzrvHY3Pr6U+i7nVCwsX0po6seJ9IAJsUnzbMQK+JFWqCN5WoBJ/dbwk1WPaGtBhW0oMSpqc4+VZs41AcpvH3VY4H6EB7HlxvaaCoURPUJPiFX8/vJapyU8kfP5e2plLgI+9w+ct+SODAgN4F3INaThUd3LAndv1hOPB/PfO7b3p8yTvG0KeqWE6lYTpWCVDZ08fmioYcbSmhprmtkJxQxuHKneyxbFLTfJ+X35o4DsafY8Bhd9JmecT0GjPp06E+Rh0BeVTuHDiGgzIEU2ABoSYd/QS1AF/qXo/R44xtiiRvbqduOxkU1gxlM2CbubleGHVo37G4kl9edrwyYi6A5V9KoBsGQ8ao2QvyNJJO8haiYvBv2WjJ/zj3v4PUVvsku5mEgVVWikSufv9FWRwrO3EUepaRDVTYNAempf/KFBqcoNHE8OEO/tzKQxUKSJaHvyHMWeWuSabn6iBjsKNQNgTO5sadsawLlIbVirVDMWlMcMZkvAna0loojHKO9AD6ZP+ZDxdO6ZMcr1ClM=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:PH0PR11MB4966.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(23010399003)(376014)(366016)(3023799007)(56012099006)(38070700021)(11063799006)(13003099007)(10067099003)(22082099003)(18002099003)(6133799003)(4143699003)(8096899003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: 8Q+Un9ijnXj+4nRlrM9qYO2zT2+54DzyCfGOOPK6YXy0X1qBkxI4OweTwVoU8a1KA5RCbjQQYQgdz8Lnj7MWStSc3/BQatO9agGw75x3pmo/ZWajQU90KjwEwQJ9MPyt5VJjTym2vh0su1DsaMUcfQ4653+/Hk34r26/kcVYcO6ksuUm5Mwhk5Kffsebn7FZlZECm+oAY83fLFTXe8JZS1IKryzk9w8qzg2Myws1yo2CddDZNp3yvTjL3n2K8BlT9QccNVFyX8R0QMJZW3Kaz0pG+tBbbfHzLxC+Ivdx5DPddEhAQK0FFBGjyeAQANzhZIaP1rNro+KL1LfisBosmRsv+41ZnDlIQ+KTzdAksUmWGCLvZXunoryfjizy83BXIgnrTyXVLPvkBWkkZrmTwJaT3hKMgiC6EZHAsEytmlHbya9kglGlYFQxuX9xyhAoxIcoeiV0Gy0v7S9/xobluI5E6ljTrvtfpzdS6NvXRukz3XUPho70FwI4Ipk9v6jsSPbSs/XYNu48Gf84O4VLytWa4Bd2WkMWtHw+QIFUvNCtZbxiW5gOKNced4IcNydwsmBooLzQVG2ainshnbXiYuePXricFWlxj5kPAFaR8tKJfdOQkJq1jVThlIXEN833nS3HH9cH3LiuP56s8cdK53L/5HiYVw4tpvF4+zpZBelwtnT85HNB07s7iinQcRExl6h/hEisp4thfaJ04PL0NiJ1uxo/M8/HN5eCiDLFbu1f20qZxP2DpPWzVKcbwVN3ww606nfDAoj4MvmEBUsmONzY6RSgPezr51oMY/PHSNrHcUxkm9K/dbtM1lSW0CAnSCTbbL1XVwKbOtLuWJPVSklWFXlm9xMrQ55WOwlAyPWhnMhWtwIPhjn/heEMkia716EC0rzZhWULbK2d25HuBIAOdhMA1BH4/Jm2Hw2zqFkcONnV4f9X1yqkyDNYj8H2RcNn9wABCo54iltDKA60yyp9qhsvmA/UdRcy5QMONxNzYHExTh/RYQEcYTh7ujhvTu17Z7L/W4nBlatBsbpKRUcUGB40b0YRzKKv5GKeobRyJdeyN2rvhC3N8iviPtgVoy1y8txy6UV/MKq22HfIaulcR0pabM4fzCvgaR/5hQkp2prHH5RibdOYrvxbdbBFthIAWvPBLhAVgh3pSZI1VRNeGHs9dkYdtl5iQHMX+EcvdLEbvWusCskZvgOlkDOHs8iIvrtK3dw376r7gxo0lKruDvCtCEFjB9xfSR30c9gepvlhfbcKAEYvC9l5S/ZVuzJweatm06Flq6NcEoslYULxkwZQVUKL2kbUNPDDPyCWIPI0BFzm4JI4IwovgCeAzNK01g626mfp+69W2LfARGQiE+aduni93kOmRO6p3Mb7FBycIIYW6KV+8YrvSMLOw/9CHVh8PcrWLNGVOyWy+Q8s3cjFJfH9PwKjfCL90Kv6hMXnttOB25j2fO4PnTG4xWBdsNFj5pQo9cpgI92xr4NwHW/lni7rfVcA5D/GSTq0Bg9o9dVADmcmb5NUpcSgriMteFbyh7b0DA7l/rz8oKUqJWGFaRwRDA/APh8I56qLPOog5xmVueWCb7My/R5AeyI6dH8JBHdMpZXbTYA2caIoQIZkv+IIje73D3s/VddKhSZ7EWott3oWY6XqMug5oHNtAfoJk01+gWZH82KlUb2Yre6iq88w3FQbQ7z6OSjnZYb1LJwW7zerTNfH5B34k1kQDRUeB8Rtdmmtk4mWKw==
Content-Type: multipart/alternative; boundary="_000_PH0PR11MB49666F6DC39B5FE291B009B6A9C02PH0PR11MB4966namp_"
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: khRvKc4OzrypENExuMki7zC0flSncJ42O/bvG1M4XQvS5I3ju8GooEhY5xYTE+MEbpOh+RCfzMqfBahogYr+QppJU9uZilvGSRd5fOhtC6t9rq6ZRo9uA1f88wex6qFAnaVCl2vCgYKKm/Nto4AUuVmJC8P0lbeajVThk7ELpgx7YIJ7sP6zkbYnu54sgie11XLDAXlDhVRNtCiYapPmfXH3ldT/s/TRL0RAmUtuYVExDxDMpb0d6mjWzoQBDAuQBM0RzYWWQW/zC29AAezV7SD/LX1/jHB7mGHZBTaFuniw+B/KQwS3NHKLVnORi6GqKiUSc6ClVpg06G4oyfzq9g==
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: PH0PR11MB4966.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: e519faf2-624d-455c-38e5-08dee8c7a274
X-MS-Exchange-CrossTenant-originalarrivaltime: 23 Jul 2026 14:35:25.4711 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: LWM+nFJ/gPpt6U+pIL7ReOOIvHvZF3Im4+1m4UYlP1dtI6AO/sTCLKDErjWQ/VJNG+Fjach2YaeK3/xHFs4Syw==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: DM6PR11MB4706
X-Outbound-Client-TLS: ANONYMOUS;alln-opgw-1.cisco.com [173.37.147.229];TLSv1.3;TLS_AES_256_GCM_SHA384;256
X-Outbound-SMTP-Client: 173.37.147.229, alln-opgw-1.cisco.com
X-Outbound-Node: alln-l-core-05.cisco.com
Message-ID-Hash: DACIVKDA7MAFOWT35VFIU56WV6B3AJ7S
X-Message-ID-Hash: DACIVKDA7MAFOWT35VFIU56WV6B3AJ7S
X-MailFrom: evyncke@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-opsawg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: The IESG <iesg@ietf.org>, "cpignata@gmail.com" <cpignata@gmail.com>, "draft-ietf-opsawg-discardmodel@ietf.org" <draft-ietf-opsawg-discardmodel@ietf.org>, "opsawg-chairs@ietf.org" <opsawg-chairs@ietf.org>, "opsawg@ietf.org" <opsawg@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-opsawg-discardmodel-14: (with DISCUSS and COMMENT)
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/ciFl0KEmuREBGCaw-fMpj3lXF48>
List-Archive: <https://mailarchive.ietf.org/arch/browse/opsawg>
List-Help: <mailto:opsawg-request@ietf.org?subject=help>
List-Owner: <mailto:opsawg-owner@ietf.org>
List-Post: <mailto:opsawg@ietf.org>
List-Subscribe: <mailto:opsawg-join@ietf.org>
List-Unsubscribe: <mailto:opsawg-leave@ietf.org>
Thank you John for your reply with explanations and the revised I-D. I am afraid that my DISCUSS #2 still hold as the even if the mtu-exceeded has moved out of the rx container it is still in the errors-l3-rx whose description is `Layer 3 ingress packet error discard counters.`. Same for DISCUSS #3 it is still unclear whether only the router that needs to process the next SID count this packet error or all SR-aware routers on the path. I am not convinced by the explanation of DISCUSS#5 as some text would have been welcome IMHO. Thank you also for acting on Carlos' int-dir review. Regards, -éric From: John Evans <john.evans.uk@gmail.com> Date: Thursday, 23 July 2026 at 14:01 To: Eric Vyncke (evyncke) <evyncke@cisco.com> Cc: The IESG <iesg@ietf.org>; cpignata@gmail.com <cpignata@gmail.com>; diego.r.lopez@telefonica.com <diego.r.lopez@telefonica.com>; draft-ietf-opsawg-discardmodel@ietf.org <draft-ietf-opsawg-discardmodel@ietf.org>; opsawg-chairs@ietf.org <opsawg-chairs@ietf.org>; opsawg@ietf.org <opsawg@ietf.org> Subject: Re: Éric Vyncke's Discuss on draft-ietf-opsawg-discardmodel-14: (with DISCUSS and COMMENT) Hi Éric, Thanks again for your review. We've published -15, which incorporates the changes discussed. Summary against each point: DISCUSS: 1. checksum-error IPv4/IPv6 ambiguity: Fixed. The leaf description now states the counter is applicable only to IPv4; IPv6 has no internet-layer header checksum. 2. mtu-exceeded placement and semantics: Fixed. mtu-exceeded has moved out of the rx container and is now a separate container with fragmentation-not-permitted and fragmentation-permitted-not-performed counters, distinguishing whether the forwarding node was permitted to fragment (with references to RFC 791 and RFC 8200). As discussed, no-route remains on ingress since without a route there is no egress interface to attribute to. On the multicast case: per requirement 2, discards are attributed to the interface where they occur, so replications discarded on m egress interfaces account on each of those interfaces. 3. invalid-sid scope: As discussed, only SR-aware routers processing the SID increment this counter; the references to RFC 8402/8660/8754/8986 have been added to the leaf. 4. parity-error specificity: Fixed. The description now states this means the ASIC detected corruption in an internal memory, table, buffer, or metadata structure while processing the packet, and dropped it rather than forwarding using potentially bad state; a device-internal error, not a property of the packet. 5. DDoS double counting: As discussed, the model has a no-double-counting principle (requirement 8): a discard increments exactly one subclass, so ACL- or null-route-mitigated attacks report under those counters, and the dos counter covers vendor heuristic-based DoS protection. The leaf now reads DoS rather than DDoS, per Christopher's related comment. 6. Layer-4 ACL: The acl leaf description now covers Layer 3 and higher-layer ACLs, so these are in scope of the model rather than a limitation. 7. Encapsulation/decapsulation discards: As discussed, tunnel processing falls under forwarding; missing tunnel forwarding state is semantically no-route from an operator's perspective, and requirement 13 states attribution relates to the outer header at the point of discard. 8. INT-directorate review: Carlos's points are now addressed; the summary is in the thread with Carlos [https://mailarchive.ietf.org/arch/msg/opsawg/YMALJRc6CraKCVdVd3Mx7IGc-rI/] with the GTSM/RFC 5082/RFC 6192 clarification in the next revision. COMMENTs: 9. IM in YANG rather than UML/ER: The working group conclusion is now stated in the new Design Rationale section (Section 4): YANG with RFC 8791 structure extensions keeps the model abstract per RFC 3444 while supporting different DM realizations (YANG, IPFIX) and lossless translation to the YANG DM. This is also consistent with draft-ietf-opsawg-rfc5706bis, which explicitly allows YANG structure extensions for information models. 10. On the "cynical" point: that is in fact the intent: the IM exists so the same classification can be realized in IPFIX and flow-level discards correlated with device- and interface-level discards. The Introduction now says this explicitly, and draft-evans-opsawg-ipfix-discard-class-ie shows the IPFIX realization. 11. ttl-expired naming: Kept, as the class covers IPv4 TTL, IPv6 Hop Limit, and MPLS TTL expiry; the description now states all three explicitly. 12. Additional errors-l2-tx leaves and IPv6 extension headers: Not added, consistent with the granularity rationale now in Section 4: subtypes are included where deployment experience shows they map to distinct mitigation actions, and new subtypes can be added by future augmentation without affecting existing implementations. 13. invalid-label under l2: Kept under l3. An invalid label is a lookup failure, and the same operational action applies as for an L3 lookup failure, so it belongs in the same class; errors/l2/rx isolates problems to the L2 domain (upstream device or link). Reporting label lookup failures under l2 would trigger the wrong mitigation. Diff: https://author-tools.ietf.org/iddiff?url1=draft-ietf-opsawg-discardmodel-14&url2=draft-ietf-opsawg-discardmodel-15 Please let us know if there's anything we missed. Thanks, John On Thu, 9 Jul 2026 at 12:40, John Evans <john.evans.uk@gmail.com<mailto:john.evans.uk@gmail.com>> wrote: Hi Eric, Thank you for your feedback. I have replied to Carlos's comments - copied below. On your other comments: > ### Section 4.1 > is ambiguous as there is no check-sum in the IPv6 header. Now clarified: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/blob/0e94aa53e555c438828a92cdc7fbe7cd999f3385/yang/ietf-packet-discard-reporting-common.yang#L375 > MTU exceeded does not happen when receiving a packet but when transmitting > (i.e., after forwarding) a packet on (an)other interface(s). The egress interface is the constraint, however, the practical implementation that we see across vendors is that the discards occur on ingress, once the egress interface has been determined. Operationally, the mitigation can be ambiguous (is the MTU too small or the packet too big). We have changed the model to move mtu-exceeds from under /rx: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/91/changes > Same for "no-route". No route discards have to be on ingress as there is no route to be able to determine the egress interface. > `leaf invalid-sid` it is unclear whether only routers whose address is the > destination address have to count or other routers in the path (which should > not check) also have to count. Only SR-aware routers will increment this when encountered. > "The number of packets discarded due to parity errors."` does it mean that the > device CPU experimented a parity error during the receiving/forwarding of the > packet ? Please be specific. A parity error means that the ASIC detected corruption in an internal memory, table, buffer, or metadata structure used while processing the packet, and dropped the packet rather than forwarding it using potentially bad state. It does not mean the packet had an L2 CRC error, bad IP checksum, invalid header, or protocol error. It is not a property of the packet on the wire. It is a device-internal forwarding error. We updated the description to clarify: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/122/changes > I wonder how to ``"The number of packets discarded due to Distributed > Denial-of-Service (DDoS) protection policies."` as many DDoS are mitigated by > routing to a null-route or layer-3 ACL, which are different counters. Should it > be counted twice ? We have a design principle of not double counting discards. In this example, we would report it as ACL or null route discards as only the network operator knows the intent of that ACL or null route and can make the association. A number of vendors have implemented heuristics to identify and discard DDoS traffic, which is what this class is intended for. > ### Lack of layer-4 ACL > I am puzzled by the absence in the model and in the text about layer-4 ACL We have updated the description accordingly: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/114/changes > ### Lack of encapsulation/decapsulation discard > Probably due a misreading of mine, but I see no discard counters when > en/decapsulating a tunneled packet ? This was a point of discussion and we decided not to define dedicated encap/decap discard classes: tunnel processing falls under forwarding, so when the required forwarding state is missing, semantically it is the same as no-route from an operator's perspective. Section 5.3 requirement 13 also says that tunnel endpoint attribution relates to the outer header. > ### Lack of addressing the INT-directorate review > As I second most of Carlos Pignataro's int-dir review, I am elevating them to a > DISCUSS level: please address Carlos' issues. I have replied to Carlos's comments - copied below. > To be pendantic, I am really surprised (dare I say shocked) by the use of a > data modeling language to specify an information model rather than UML or ER > diagrams. See also RFC 3444. This was a point of much discussion in the working group, the conclusion of which is noted in Section 4: The IM is defined using YANG [RFC7950], with Data Structure Extensions [RFC8791], allowing the model to remain abstract and decoupled from specific implementations in accordance with [RFC3444]. This abstraction supports different DM implementations, such as YANG or IPFIX [RFC7011], while ensuring consistency across implementations. Please note that draft-ietf-opsawg-rfc5706bis also says: While an Information Model is typically described in English text (or sometimes UML) to define the conceptual management requirements, authors may choose to express it using YANG Data Structure Extensions [.RFC8791] as described in Section 5.3.1. Using YANG for the Information Model can make it easier to link abstract concepts to concrete data types in the corresponding Data Model, helping maintain consistency between high-level design and practical deployment. > If I was cynical, I would hint that it is more to have more implementations > having 'something' like the information while not implementing exactly the YANG > data model... But, this is only my personal feeling. That is exactly the point, i.e. so that we can represent the same information model in ipfix and correlate discards at the device or interface level with the impacted flows. Please also see: https://datatracker.ietf.org/doc/html/draft-evans-opsawg-ipfix-discard-class-ie-02. > While I am sure that some people will disagree with me (hence a COMMENT and not > a DISCUSS), `leaf invalid-label ` should be in errors-l2-rx as MPLS is more a > layer-2 (e.g., labels are valid only on a link) especially when a label is > flagged as 'invalid'. Our approach has been to define the classification scheme working backwards from the operations actions that we need to take, so there is a clean mapping from class to action. errors-l2-rx essentially isolates the problem to the L2 domain; adding invalid-label to the class would break that isolation. > s/leaf ttl-expired/leaf hop-limit-expired/ after all we are in 2026. Because the class is intended to cover IPv4 TTL expiry, IPv6 Hop Limit expiry, and MPLS TTL expiry I propose keeping ttl-expired as the established operational counter name and have updated the description to say explicitly that it reports packets discarded because the packet lifetime expired during forwarding, including IPv4 TTL, IPv6 Hop Limit, and MPLS TTL expiry: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/123/changes > `grouping errors-l2-tx ` would benefit from more leaves (e.g., interface down, > no carrier, exceeded transmission attemps, buffer full, ...). > Should something more specific about IPv6 extension headers be added in > addition of `leaf invalid-packet ` ? As per the reply to Carlos: We took the current level of discard taxonomy granularity as a design decision. The intent was to provide enough classification to support common operational mitigation decisions. This is discussed in Section 6.4.1: 1. The number and granularity of discard classes defined in the IM represent a compromise. It aims to provide sufficient detail to enable appropriate automated actions while avoiding excessive detail, which may hinder quick problem identification. Additionally, it helps to limit the quantity of data produced per interface, constraining the data volume and device CPU impacts. While further granularity is possible, the defined schema has generally proven to be sufficient for the task of mitigating unintended packet loss. cheers John --- Reply to Carlos: Hi Carlos, Thank you for your feedback. 1. No ICMP generation/suppression signal tied to discard events. ... Recommend either modeling ICMP-sent/suppressed state explicitly, or stating the omission is a deliberate scope decision with rationale. It was a design decision to report the key discards and not the protocol interactions associated with discards. We have updated the draft to clarify: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/78/changes 2. Address-family model does not cleanly represent MPLS/SRv6 traffic, only its discards. We treated this as a deliberate modelling trade-off rather than an omission. There are many possible ways to define the tree, including a protocol-rooted or address-family-rooted hierarchy where MPLS, SR-MPLS, IPv4, IPv6, and SRv6 each have their own traffic and discard subtrees. The current model instead keeps forwarding family and causal discard class largely orthogonal. This is discussed in 6.2.2 2. There are many possible ways to define the discard classification tree. For example, an approach is to use a multi-rooted tree, rooted in each protocol. Instead, a better approach is to define a tree where protocol discards and causal discard classes are accounted for orthogonally. This decision reduces the number of combinations of classes and has proven sufficient for determining mitigation actions. That said, if operators find that the current all identity loses useful information for mitigation or RCA, a future augmentation could add more specific address-family identities such as mpls, sr-mpls, and srv6, while preserving the current causal discard taxonomy. 3. `mtu-exceeded` does not distinguish DF-driven discard (IPv4 DF=1, IPv6 always) from fragmentable IPv4 (DF=0). We have added this - please see: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/91/changes 4. The discard taxonomy (Section 4.2) is not fully 1:1 with the YANG identities. Internet-area instances of this gap: We took the current level of discard taxonomy granularity as a design decision. The intent was to provide enough classification to support common operational mitigation decisions, while avoiding a protocol-specific tree. This is discussed in Section 6.4.1: the model deliberately treats protocol context and discard cause as largely orthogonal, rather than defining a separate leaf for every protocol-specific discard mechanism. 1. The number and granularity of discard classes defined in the IM represent a compromise. It aims to provide sufficient detail to enable appropriate automated actions while avoiding excessive detail, which may hinder quick problem identification. Additionally, it helps to limit the quantity of data produced per interface, constraining the data volume and device CPU impacts. While further granularity is possible, the defined schema has generally proven to be sufficient for the task of mitigating unintended packet loss. Nonetheless, we agree that the examples you list are useful candidates for further discussion and for possible future augmentation of the module. 5. `checksum-error` (errors-l3-rx) does not note that IPv4 has a header checksum and IPv6 does not (RFC 791 vs. RFC 8200) -- applicability by address family could be stated. Added: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/blob/0e94aa53e555c438828a92cdc7fbe7cd999f3385/yang/ietf-packet-discard-reporting-common.yang#L375 6. `invalid-sid` lacks an informative reference to SRv6 architecture (RFC 8402 / RFC 8986). Added: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/blob/0e94aa53e555c438828a92cdc7fbe7cd999f3385/yang/ietf-packet-discard-reporting-common.yang#L470 7. No neighbor-resolution-failure (ARP/ND unresolved) discard subtype; doesn't map cleanly to `no-route` or `internal`. Added: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/85/changes 8. Foundational IP references (RFC 791, RFC 8200) are absent despite heavy dependence on IP-layer semantics (TTL, header validity, MTU). RFC 4884, RFC 5082, RFC 6192, RFC 5085, and RFC 8029 should also be added as informative references if the comments are useful. That's OK per the IESG statement on the matter: https://datatracker.ietf.org/doc/statement-iesg-iesg-statement-normative-and-informative-references-20060419/. Especially, this part "It is not considered necessary to cite basic specifications that may be safely assumed to be known to practitioners (for example, RFC 791 need not be cited in every specification that mentions IPv4)." 9. Section 1 scope reads "limited to reporting packet loss at Layer 3 and frames discarded at Layer 2" but MPLS/SRv6 discard reasons are present throughout; please tighten the scope statement. Tightened: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/pull/78/changes 10. `invalid-vlan`/`invalid-mac` are Ethernet-specific; note applicability for non-Ethernet L2 technologies. Noted: https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/blob/0e94aa53e555c438828a92cdc7fbe7cd999f3385/yang/ietf-packet-discard-reporting-common.yang#L330 https://github.com/o-pylypenko/draft-ietf-opsawg-discardmodel/blob/0e94aa53e555c438828a92cdc7fbe7cd999f3385/yang/ietf-packet-discard-reporting-common.yang#L338 On Tue, 7 Jul 2026 at 13:30, Éric Vyncke via Datatracker <noreply@ietf.org<mailto:noreply@ietf.org>> wrote: Éric Vyncke has entered the following ballot position for draft-ietf-opsawg-discardmodel-14: Discuss When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.) Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ for more information about how to handle DISCUSS and COMMENT positions. The document, along with other ballot positions, can be found here: https://datatracker.ietf.org/doc/draft-ietf-opsawg-discardmodel/ ---------------------------------------------------------------------- DISCUSS: ---------------------------------------------------------------------- # Éric Vyncke INT AD comments for draft-ietf-opsawg-discardmodel-14 CC @evyncke Thank you for the work put into this document. Please find below some blocking DISCUSS points, some non-blocking COMMENT points/nits (replies would be appreciated even if only for my own education). Other thanks to Carlos Pignataro, the Internet directorate reviewer (at my request), please consider this int-dir review (Ready with issues): https://datatracker.ietf.org/doc/review-ietf-opsawg-discardmodel-14-intdir-telechat-pignataro-2026-07-03/ (and I have yet to read a reply by the authors) I hope that this review helps to improve the document, Regards, -éric Note: this ballot comments follow the Markdown syntax of https://github.com/mnot/ietf-comments/tree/main, i.e., they can be processed by a tool to create github issues. ## DISCUSS (blocking) As noted in https://datatracker.ietf.org/doc/statement-iesg-handling-ballot-positions-20220121/, a DISCUSS ballot is a request to have a discussion on the points below; I really think that the document would be improved with a change here, but can be convinced otherwise. ### Section 4.1 ``` leaf checksum-error { type yang:counter64; description "The number of received packets discarded due to a checksum error."; } ``` is ambiguous as there is no check-sum in the IPv6 header. Be specific and states that it only applies to IPv4/MPLS. ``` leaf mtu-exceeded { type yang:counter64; description "The number of received packets discarded due to MTU exceeded."; } ``` MTU exceeded does not happen when receiving a packet but when transmitting (i.e., after forwarding) a packet on (an)other interface(s). Same for "no-route". The problem is even more complex when the forwarded packet is a multicast one where it can be forwarded on n egress interfaces but cannot for m egress interfaces. `leaf invalid-sid` it is unclear whether only routers whose address is the destination address have to count or other routers in the path (which should not check) also have to count. `"The number of packets discarded due to parity errors."` does it mean that the device CPU experimented a parity error during the receiving/forwarding of the packet ? Please be specific. I wonder how to ``"The number of packets discarded due to Distributed Denial-of-Service (DDoS) protection policies."` as many DDoS are mitigated by routing to a null-route or layer-3 ACL, which are different counters. Should it be counted twice ? ### Lack of layer-4 ACL I am puzzled by the absence in the model and in the text about layer-4 ACL support as they are often used. There should be at least some text in the introduction and abstract about this limitation. ### Lack of encapsulation/decapsulation discard Probably due a misreading of mine, but I see no discard counters when en/decapsulating a tunneled packet ? And/or how it can be differentiated from a forwarding operation. ### Lack of addressing the INT-directorate review As I second most of Carlos Pignataro's int-dir review, I am elevating them to a DISCUSS level: please address Carlos' issues. ---------------------------------------------------------------------- COMMENT: ---------------------------------------------------------------------- ## COMMENTS (non-blocking) ### Section 4 (and its sub-section) To be pendantic, I am really surprised (dare I say shocked) by the use of a data modeling language to specify an information model rather than UML or ER diagrams. See also RFC 3444. Even more 'data model' flavour are the specific data types such as `type yang:counter64;`, which clearly belongs to a data model and not an information model. Suggest renaming section 4 as a YANG *data* model (as well as changing the title & abstract to remove 'information model'). If I was cynical, I would hint that it is more to have more implementations having 'something' like the information while not implementing exactly the YANG data model... But, this is only my personal feeling. ### Section 4.1 s/leaf ttl-expired/leaf hop-limit-expired/ after all we are in 2026. `grouping errors-l2-tx ` would benefit from more leaves (e.g., interface down, no carrier, exceeded transmission attemps, buffer full, ...). Should something more specific about IPv6 extension headers be added in addition of `leaf invalid-packet ` ? While I am sure that some people will disagree with me (hence a COMMENT and not a DISCUSS), `leaf invalid-label ` should be in errors-l2-rx as MPLS is more a layer-2 (e.g., labels are valid only on a link) especially when a label is flagged as 'invalid'.
- [OPSAWG]Éric Vyncke's Discuss on draft-ietf-opsaw… Éric Vyncke via Datatracker
- [OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-o… John Evans
- [OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-o… John Evans
- [OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-o… Eric Vyncke (evyncke)
- [OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-o… John Evans
- [OPSAWG]Re: Éric Vyncke's Discuss on draft-ietf-o… Eric Vyncke (evyncke)