[OPSAWG]Re: OPSAWG Digest, Vol 205, Issue 20

Marc Huber <Marc.Huber@web.de> Tue, 09 July 2024 19:49 UTC

Return-Path: <Marc.Huber@web.de>
X-Original-To: opsawg@ietfa.amsl.com
Delivered-To: opsawg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id BCC87C1CAF58 for <opsawg@ietfa.amsl.com>; Tue, 9 Jul 2024 12:49:54 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.103
X-Spam-Level:
X-Spam-Status: No, score=-2.103 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_MSPIKE_H3=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_BLOCKED=0.001, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=web.de
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id iflweIhowEeb for <opsawg@ietfa.amsl.com>; Tue, 9 Jul 2024 12:49:50 -0700 (PDT)
Received: from mout.web.de (mout.web.de [212.227.15.4]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-256) server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 5E70BC15199D for <opsawg@ietf.org>; Tue, 9 Jul 2024 12:49:50 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=web.de; s=s29768273; t=1720554565; x=1721159365; i=marc.huber@web.de; bh=ISIQr3jPAW/+YNjj3zeG00HnldcEpeHptTCa80wB5XE=; h=X-UI-Sender-Class:Message-ID:Date:MIME-Version:Subject:To:Cc: References:From:In-Reply-To:Content-Type: Content-Transfer-Encoding:cc:content-transfer-encoding: content-type:date:from:message-id:mime-version:reply-to:subject: to; b=SvWhYqDTOeChJj8Zz2yHnVrd8k2MWkxV81JqapUP4V/PasT5bvGgc/7WdCzwFTkK YdmNnfi+IB2U7yZ9OdbnZ/GbFHIU/FISpCA2KCcR+qOKykOGVdfqw5co/2ewa3opm GocM1XciuMLunhid6ChMaHMZNL8huZEBKzNXOZ+ayk3nhQilrExgUP6XjfCSNAlST cwQmCyMnSmkiUkl/RHuLvleSinOmIv4QWwE4IBe22CXeIG3m7V9l9W8hC8lLhdVLJ 3R/oPwUfGYBQq/FJ//uf9RM/33iS8MhcfPduKIaIAzomupbdyhZIvqSs/dVhxbYMz XJ24HIjtdKAd9nsZNQ==
X-UI-Sender-Class: 814a7b36-bfc1-4dae-8640-3722d8ec6cd6
Received: from [172.16.0.4] ([91.2.88.220]) by smtp.web.de (mrweb005 [213.165.67.108]) with ESMTPSA (Nemesis) id 1MLifk-1siwDN3EXY-00JB9p; Tue, 09 Jul 2024 21:49:25 +0200
Message-ID: <452b2532-ba4f-4fc1-b878-b1965d4e25c1@web.de>
Date: Tue, 09 Jul 2024 21:49:23 +0200
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
To: "Joe Clarke (jclarke)" <jclarke@cisco.com>, "Douglas Gash (dcmgash)" <dcmgash@cisco.com>, "mohamed.boucadair@orange.com" <mohamed.boucadair@orange.com>, Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org" <opsawg@ietf.org>
References: <171958741031.6614.6192371628253402915@ietfa.amsl.com> <BL3PR11MB636498065CA94698B937E5CCB7DF2@BL3PR11MB6364.namprd11.prod.outlook.com> <BL3PR11MB63647995AABAED8113F9DDBFB7DA2@BL3PR11MB6364.namprd11.prod.outlook.com> <BN9PR11MB53710A4CB9124CB9D0BCDAEBB8DA2@BN9PR11MB5371.namprd11.prod.outlook.com>
From: Marc Huber <Marc.Huber@web.de>
In-Reply-To: <BN9PR11MB53710A4CB9124CB9D0BCDAEBB8DA2@BN9PR11MB5371.namprd11.prod.outlook.com>
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: quoted-printable
X-Provags-ID: V03:K1:rRzXyDNuD94tlu9IM7TbywYS/7fPD06XGcXYo9aRd7rjNFS3+JF s75FQ3oO5q38GInh3ffrGulk1tu8sNjWI8PwH5rwW3stIexcWNcANNGKKkgsi7nEjPiub/e n3eZJwZRwxX2Tl2Pe6K0IUZ0Qv1MBbKBD7HEPBtrfn55CKWeM/5eMyjiAOD8wHx3nR9TzHU z4veSc3d1sqsxzk9ofWug==
UI-OutboundReport: notjunk:1;M01:P0:QcxhIAIQUXs=;Xvz8gn0wiJO7w6ByGnWni2fSrc2 +vDi/gglEyBE0pfcysjSk1L21xRRe8tDl9b8hmyNRjDFHeGXR4bPvWOi+Tuz/s5KrqQmjWa71 UZuQwuHc7l93sHeNZogzhQHpfRmNXMTKI9zgau38DD0qHpjWxoHVPy7cClzMGUbYgRN5gdso0 UMjQAzDGWU3syYiASOvz5RdNH8S+sABhQlaq3HmndVDovxMZu0q3lsOnhyzk2tWVZxgtxJJpu Wntw8thZ6Czi+NNEbJcvPO1fkbF3nu4JOS5FIrCR0DAW5sCSYsI4iYQ5AMdp4FY1GNscCrQh3 ibWXcJxPwbpQ0KaKnwnzXVA09d+dIlS0S709C8U+Ya03WwodK+1DwVCQ971D7tTFLEziOUh55 gYo3Nr1pc631vRSbD7q9YSGDtWJmYkog94u94oxNPfbNI9LDCYSU0fl2fC6rJyA4pzO5AGdA6 kjWbsct4sXHH+TQFfwQAVKAHRH6I1yerxcqe2VTPbXRgMwhKGzQRud9KN9/bT7Wp66Nbpxjf9 AP1qRbKhm7aDSINGya2xQku2MSYBesy61oEVYMIAviYLEQ2pnqvMQuPOJKpFlpWavycZcX6Zr 7aKl10pmw6m7wmSH91jheIHZlkVR7YNn2AspSxik5APlf4bFGlbk9jCRZHoaUKJUvvXoWVbZp YAE0WHEMUANm4ybbdR0ZH+4OT6tJ3Ushvo6yTldib2zRNn1nO71x/Tg85DcGvHJrv/2n3/lyg JJbDA483Hc4nzATvjQQsWIjNKJKVWc4LsTueqVCO0UEOcKpMM1sHOG5WyjyHnN4CRTnRUFGGb 7POsVMh5mJu2P6yIfoveM/sAB6DSTQRToqA8GmdyfpqQM=
Message-ID-Hash: Z5FESCW7ELVAAUBQKMDJYNDJVIV27CGB
X-Message-ID-Hash: Z5FESCW7ELVAAUBQKMDJYNDJVIV27CGB
X-MailFrom: Marc.Huber@web.de
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-opsawg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: John Heasly <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
X-Mailman-Version: 3.3.9rc4
Precedence: list
Subject: [OPSAWG]Re: OPSAWG Digest, Vol 205, Issue 20
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/lQOOjW4Bb-LyhYSu_7DJf9gyoeE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/opsawg>
List-Help: <mailto:opsawg-request@ietf.org?subject=help>
List-Owner: <mailto:opsawg-owner@ietf.org>
List-Post: <mailto:opsawg@ietf.org>
List-Subscribe: <mailto:opsawg-join@ietf.org>
List-Unsubscribe: <mailto:opsawg-leave@ietf.org>

Hi,

I'm in favor of keeping the the "external PSK" option. Just like with
IPSec, PSKs are easier to handle than certificates for most
installations. PSKs simpifiy lab setups, make getting started easier,
and are pretty robust -- no time dependency, and no need for renewals
(right now I'm not quite sure whether the latter's a pro or con).

I don't know about compliance-relevant standards (FIPS?), there might be
conflicts.

On the network access device it might seem advisable to store the PSKs
in some system-only "private storage" (similiar to SNMPv3 credentials or
cert private keys).

Cheers,

Marc


On 08.07.2024 14:51, Joe Clarke (jclarke) wrote:
>
> I am speaking as a contributor and user of TACACS+ in general.  I am
> not personally implementing a T+ server or this draft.
>
> I think fully supporting and documenting external PSKs would be
> generally useful and would possibly aid in the adoption of this new
> modality for T+.  I would be in favor of option 2. I would also like
> to hear from people like Rod Persky and Marc Huber who mentioned
> possible implementations.
>
> ===
>
> As a chair, I’m glad to see this email this morning.  Going into today
> I was a bit conflicted as to how to decide this WG LC.  We received
> some feedback, but nothing overwhelming to point to consensus.  I was
> thinking to push it back to the WG to settle on this and look to do
> another WG LC.  It seems you preempted me.  Additionally, I did not
> receive any replies to the renewed IPR call.  We want to make sure all
> IPR has been disclosed (if there is any) prior to WG LC conclusion.
>
> Joe
>
> *From: *Douglas Gash (dcmgash) <dcmgash@cisco.com>
> *Date: *Monday, July 8, 2024 at 04:48
> *To: *mohamed.boucadair@orange.com <mohamed.boucadair@orange.com>, Joe
> Clarke (jclarke) <jclarke@cisco.com>, Alan DeKok
> <aland@deployingradius.com>, opsawg@ietf.org <opsawg@ietf.org>
> *Cc: *Thorsten Dahm <thorsten.dahm@gmail.com>, John Heasly
> <heas@shrubbery.net>, Andrej Ota <andrej@ota.si>
> *Subject: *Re: OPSAWG Digest, Vol 205, Issue 20
>
> Dear Opsawg et al,
>
> 1) Discussion on External  PSK (Related to part of Mohamed’s point 2
> below).
>
> Our distillation of the thrust of Alan’s main advice is: The doc needs
> to either commit to fully documenting external PSK and its
> ramifications or preclude it. The truth is, our doc merely  says: TLS
> T+ implementations may support External PSK, and leaves it there.
>
> Background: as this doc has evolved, we have temporized on the topic
> for the first TLS version of T+. On one side: we were not convinced
> External PSKs are quite established in TLS 1.3. On the other side they
> would be very useful for operators. But now  It seems that PSKs have
> become better established, through the work of Alan et al, so we may
> consider to document use of External for this initial doc, rather than
> adding later supplement to cover external PSK. It does mean through
> that there may be another round or two to bring in the needed details.
>
> So now would be a good point to gauge the opinion of the group. Based
> upon where the doc is in the process, and what changes should be
> applied to it at this time::
>
> 1) Should we revert the doc to say: “External PSK should not be used
> now.  A supplement will follow to address how PSK can be used properly”
>
> Or
>
> 2) Keep the option for External PSKs to be used as now, and Commit to
> a few rounds of revisions to document to fully flesh out its support.
>
> Authors would be happy either way, probably on balance we would prefer
> second option,
>
> If we went for option 2), then below is an outline of the responses
> which we believe would cover External PSK:
>
> Note: “RADIUS and TLS-PSK” Provides a wealth of recommendations on PSKs.
>
> 1.a new section will be added specific to PSKs  include the following
> items, mainly  gleaned from “RADIUS and TLS-PSK”, (note that TLS 1.2
> related issues have been filtered out)
>
> General:
>
> It is RECOMMENDED that systems follow the directions of [RFC9257
> <https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257>]
> Section 4
>
> PSK length recommendations for both implementation and operations
>
> Fortunately, as we have already removed the MD5 obfuscation,  we do
> not have issues in sharing Shared secrets and PSKs
>
> PSK Identity:
>
> RFC9257
> <https://www.ietf.org/archive/id/draft-dekok-radext-tls-psk-01.html#RFC9257>
> 6.1 to be used for PSK  identities
>
> PSK Identity length recommendations for both implementations and
> operations.
>
> Per Client Sharing
>
> PSK must be unique per client as configured on server
>
> PSK Identities must be unique per client as configured on server
>
> (Of course references will be updated to acknowledge this doc)
>
> 2.The Tacacss draft doc mentions identity specifically in the context
> of Certificates. This will be clarified that it applies only to
> certificate based, and for PSK it has its own guidance as above.
>
> The following changes are not directly related to External PSK and
> will be resolved anyway:
>
> 2) Resumption elements from RFC9190 (Related to the balance of
> Mohamed’s point 2 below).
>
> References from RFC9190. The doc primarily adresses the use of TLS as
> an EAP option, which has extra concerns as it is used for
> authorization information. The concerns that were apprehended form the
> text are listed below with our  evaluation of relevance when used for
> the tacacss security wrapper.
>
> Authorization on resumption mased on cached data rather than the data
> in the resumption:
>
> Regarded: Not Relevant as the data is not used for authorization for
> tacacss
>
> Verification of certificates revoked during the period since the last
> “New Session Ticket Message”
>
> Regarded: Relevant, and we will update. RFC 8446 is not silent on this
> topic, so we will prefer to cover this by  refererence to section
> 4.6.1 which says:
>
>          Note that in principle it is possible to continue issuing new
> tickets
>
>                which indefinitely extend the lifetime of the keying
> material
>
>                originally derived from an initial non-PSK handshake
> (which was most
>
>                likely tied to the peer's certificate).  It is
> RECOMMENDED that
>
> implementations place limits on the total lifetime of such keying
>
>          material; these limits should take into account the lifetime
> of the
>
>                peer's certificate, */the likelihood of intervening
> revocation/*, and the
>
>                time since the peer's online CertificateVerify signature.
>
> Maximum lifetime:
>
> Regarded Relevant, we will update by reference to its coveragein RFC 8446
>
> “time-of-check time-of-use” issues
>
> Regarded: Not Relevant as the data is not used for authorization for
> tacacss
>
> Re evaluation of authorization on resumption:
>
> Regarded: Not Relevant as the data is not used for authorization for
> tacacss
>
> 3) Regarding 3) below, thanks for the catch, We’re proposing the
> following change:
>
> Current:
>
>    To ensure separation of TACACS+ traffic that uses TLS from that which
>
>    does not (Section 5.3), they will be deployed on different ports.
>
>    Due to the widespread use of default port number settings in numerous
>
>    existing TACACS+ client configurations, a well-known system TCP/IP
>
>    port number will be requested from IANA.  Client implementations can
>
>    ensure traffic is kept separate.  The designated port number is [TBD]
>
>    (Section 7) with the service name [TBDN] (Section 7).
>
> Proposal:
>
>    To ensure separation of TACACS+ traffic that uses TLS from that which
>
>    does not (Section 5.3), they must be deployed on different server
> ports.
>
>    Further, because of the widespread use of default port number
>
>    settings in numerous existing TACACS+ client configurations, a well-
>
>    known system TCP/IP port number is assigned: the designated port
>
>    number is [TBD] (Section 7) with the service name [TBDN] (Section 7).
>
>    This way the client can ensure that TLS and non TLS traffic are
>
>    separated even where default ports are omitted from its server
> connection
>
>    configuration.
>
>
> Date: Fri, 28 Jun 2024 13:36:42 +0000
> From: mohamed.boucadair@orange.com
> Subject: [OPSAWG]Re: WG LC: draft-ietf-opsawg-tacacs-tls13
> To: Alan DeKok <aland@deployingradius.com>, "opsawg@ietf.org"
>         <opsawg@ietf.org>
> Cc: "uta@ietf.org" <uta@ietf.org>, "Joe Clarke (jclarke)"
> <jclarke=40cisco.com@dmarc.ietf.org>
> Message-ID: <DU2PR02MB10160C69E1AF8E95168D5CC6A88D02@DU2PR02MB10160.eu
>         rprd02.prod.outlook.com>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi all,
>
> FWIW, we had an offline discussion with Alan and the authors to
> clarify the concerns.
>
> I'm reporting the main outcome of that discussion, fwiw:
>
> (1) Alan  agreed that:
>
> * It is good practice to leverage existing standards
> * Repeating details isn't useful
>
> (2) Still, the key comment from Alan is:
>
> >   My point was that the RFCs I referenced had substantial text over
> > and above 8446 / 9525.  I asked that the authors double- check the
> > documents I mentioned, to see how these issues were addressed.  The
> > result was a few minor changes.
>
> The shepherd agrees that this is a reasonable comment that should be
> adequately addressed.
>
> The authors engaged to have a look into the various RFCs cited by Alan
> and grab applicable items to tacacs+ context. It would be helpful to
> share the rationale for the items that they picked vs. those they
> considered as not relevant.
>
> (3) As a bonus, Alan provided the following comments and summary
>
> ==
> Some grammar / clarity comments:
>
>
> Section 3.1:
> ...
> To ensure separation of TACACS+ traffic that uses TLS from that which
> does not (Section 5.3), they will be deployed on different ports. Due
> to the widespread use of default port number settings in numerous
> existing TACACS+ client configurations, a well-known system TCP/IP
> port number will be requested from IANA ...
>
>   The text is ambiguous: "will" be requested?  When?  Does this
> document allocate the port?
>
>   The usual text is to say "port TBD has been assigned for this
> protocol".
>
>
>  In short:  I'm not objecting to the publication of this document.  My
> concern is that it doesn't give a lot of guidance to implementing
> TACACS+ over TLS.  I can see basic implementations working, just by
> wrapping TACACS+ in TLS.  But the operational considerations outlined
> above will have to be discovered piece-meal by implementors.
> ==
>
>
> Cheers,
> Med
> ***************************************
>