Re: [OPSAWG] New I-D -> Guidelines for Charactering "OAM"

Carlos Pignataro <cpignata@gmail.com> Mon, 08 January 2024 02:34 UTC

Return-Path: <cpignata@gmail.com>
X-Original-To: opsawg@ietfa.amsl.com
Delivered-To: opsawg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 927A0C14F683 for <opsawg@ietfa.amsl.com>; Sun, 7 Jan 2024 18:34:53 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.105
X-Spam-Level:
X-Spam-Status: No, score=-2.105 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01, URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([50.223.129.194]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 3ysJlKBVacsS for <opsawg@ietfa.amsl.com>; Sun, 7 Jan 2024 18:34:49 -0800 (PST)
Received: from mail-ej1-x631.google.com (mail-ej1-x631.google.com [IPv6:2a00:1450:4864:20::631]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id AAD20C14F61F for <opsawg@ietf.org>; Sun, 7 Jan 2024 18:34:49 -0800 (PST)
Received: by mail-ej1-x631.google.com with SMTP id a640c23a62f3a-a271a28aeb4so122218866b.2 for <opsawg@ietf.org>; Sun, 07 Jan 2024 18:34:49 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1704681288; x=1705286088; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=f4KduhPbVbLILtnw9XFVP+iPegTrTPUTJiTe++VI1II=; b=BTPyvcpUBMPecTyPRNciMEpfaJO1VR98GY+3czd1O8xp72Fz8NZf4f7YFJZyUk5Emu hyeVwO9WOdgzf4DyANokv3sa2FxcbfwoYNGDsCzAoJ9ySHmOqaGXocfWjFAIXYMepoAH F5MdqMLrrFateURW9jN938J/f8bSfpUv1DGRSj4XlIQr/Izq0jf1z6XjtogwVsQAoJV8 jFk2qUzYR/G5wRXGG6jDwGXE5jWzkv2ZpeiO5bVwqRXVdQKtx2QmLkEpTYHFFoOZiYxM KRAKj3IpVTZteRizqktll9gcVL7TtoEw0D6ZBPW4v/HhD8ahtsBFJsk5BavAFl/vvcBO TkLA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1704681288; x=1705286088; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=f4KduhPbVbLILtnw9XFVP+iPegTrTPUTJiTe++VI1II=; b=Jr3emWYUlzRKFhSCfgvbuGHJiWSNVI6KjZglV6gFHy/E9JKbDZ/Ndo2XwMMIUocqvU hNDWPXQFApQ8KAPXuJ9Q8i8WTfOqxZZP3oVFW5W5bLT8gIuoSGqUY4c3nRt56Sutoojk QPj11CBIaLd9Thd6flv4uB1ipjO6n66ki9oGum53eMXdVO2A+o/4IIfwiUES5Z96xs9S P9fE3RYy4Tb1YqBuMi0Uj+Tvqcap3E1lpL4Mw+FXfIQspEFASwvTUysMJ0KxW41UyG4X H1JGshnig1ynzxAceGxOjUS4NLyIPExRTzZ+X4JPDLbzHP/UqUfsVEGkaxOU15RDPiVD ktbg==
X-Gm-Message-State: AOJu0Yxa9GqBz9oQ/aBYEd0bYGc2dkOTO5RII7zydtUsfz14Kgsc1AI/ 86Q3eFFeb/SCYganOMC0EM5hWmu0nz8ZCeynR6yrXbKPt00=
X-Google-Smtp-Source: AGHT+IEjDNfFCXXvebMYcqQ5lmU/e7SOiIE8d21wLFTD28WmKdXgj/VCDGeJFwkbO5AflMxQEYpAp+TKMFwTfSA/hc4=
X-Received: by 2002:a17:906:6a81:b0:a28:87e8:b5d9 with SMTP id p1-20020a1709066a8100b00a2887e8b5d9mr1389497ejr.20.1704681287610; Sun, 07 Jan 2024 18:34:47 -0800 (PST)
MIME-Version: 1.0
References: <CACe62MncZZOzad8Z25+6rx3LwKFUuL073A_G4yVTqT9z8XntcA@mail.gmail.com> <3572.1704657289@obiwan.sandelman.ca>
In-Reply-To: <3572.1704657289@obiwan.sandelman.ca>
From: Carlos Pignataro <cpignata@gmail.com>
Date: Sun, 07 Jan 2024 21:34:36 -0500
Message-ID: <CACe62MmSe1_+mL651-rrj3HqiD37Npw3QL4q0vP7L9gMJS9P3A@mail.gmail.com>
To: Michael Richardson <mcr+ietf@sandelman.ca>
Cc: Ops Area WG <opsawg@ietf.org>
Content-Type: multipart/alternative; boundary="0000000000009a73b6060e660a17"
Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/rAIQ1Z-F17Mk6hIJuAjtRzDAga8>
Subject: Re: [OPSAWG] New I-D -> Guidelines for Charactering "OAM"
X-BeenThere: opsawg@ietf.org
X-Mailman-Version: 2.1.39
Precedence: list
List-Id: OPSA Working Group Mail List <opsawg.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/opsawg>, <mailto:opsawg-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/opsawg/>
List-Post: <mailto:opsawg@ietf.org>
List-Help: <mailto:opsawg-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/opsawg>, <mailto:opsawg-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 08 Jan 2024 02:34:53 -0000

Many thanks Michael for the review and useful feedback!

Please find some follow-ups inline.

On Sun, Jan 7, 2024 at 2:54 PM Michael Richardson <mcr+ietf@sandelman.ca>
wrote:

>
> Carlos Pignataro <cpignata@gmail.com> wrote:
>     > We would appreciate feedback and input on this position, which aims
> at
>     > updating the guidelines for the "OAM" acronym, with unambiguous
> guidelines
>     > for their modifiers.
>
>     > Guidelines for Charactering "OAM":
>     >
> https://datatracker.ietf.org/doc/draft-pignataro-opsawg-oam-whaaat-question-mark/
>
>     > Look forward to input and comments to make this more clear and
> effective!
>
> Thank you for the interesting read.
> What do you want to do with this document?
> You say publish it to update RFC6291, but I wonder if revising 6291 might
> be
> better.  In particular, SDN maybe has changed the landscape enough that not
> everyone still has the common understandings.
>

Thank you investing time in review and share feedback!

Our initial intention is to have this document published as a BCP updating
RFC6291 (a BCP), because the two documents are well demarcated in scope
(one about the noun, one about the adjective). RFC6291 stood the test of a
decade+, even without errata.

The more practical approach, considering the above, seems to progress this
document as an RFC and use the same BCP 161 (as RFC6291) -- not sure how to
signal that in the I-D.

Other thoughts?


>
> On this topic, RFC8994, we added qualifications "virtual out-of-band" and
> we
> debated a lot about whether it was in-band or out-of-band!!! Because the
> ACP
> is an overlay network, it is not tied up with the in-band traffic or
> addressing, but it is also not free from depending upon it.
>

And that is, indeed, the issue. On a separate off-list thread, we were
wondering if ICMP is out of band or in band, given different definitions
(in data plane, in packet flow)

Net-net: "there is no band" -- Neo.
And then different discussions and contexts mean different (incompatible)
things for "in-band".

Also RFC 8994 uses the M for Management instead of Maintenance (and this is
sensible to me since it's a management autoconfigured, authenticated,
secure layer, kinda)

   for autonomic functions.  It also serves as a "virtual out-of-band
   channel" for Operations, Administration, and Management (OAM)
   communications over a network that provides automatically configured,




>
> Path-Congruent is a nice technically accurate term.
> I'm just sure that congruent is a term that is easy to say.  It's very
> grade
> 9 geometry class. ("Congruent triangles")
> Probably it's also the case the native english speakers, if they do not
> know
> the term well, will assume something inaccurate, while non-native speakers
> will go
> look it up.
>

Very open to other suggestions -- we opted for optimizing technical
accuracy in descriptiveness. (Carlos, a non-native English speaker, who
looks up words in his native languages too)


>
> Section 3 also has some nice new terms, and I suspect that they are really
> useful in a number of arenas, including up-coming proof-of-transit work.
>

Once again, indeed! PoT is another clear target in our mind.


>
> Nits:
> * OAM is not expanded in the introduction, and the RFC6191 reference needs
> to
> come earlier.
> * Section 2 starts off talking about history, and then gets into defining
> new
> terms.  I thought I was going to learn more about in-band/out-of-band from
> a
> military radio point of view, and/or SS7 vs 2600Hz.
>

Thank you -- all fixed.

We'd welcome a citation from radio and/or SS7 telephony!

Thanks!

Carlos.


>
> --
> Michael Richardson <mcr+IETF@sandelman.ca>   . o O ( IPv6 IøT consulting )
>            Sandelman Software Works Inc, Ottawa and Worldwide
>