Inter-area routes reachable via multiple areas

Liu Yu <liu_yu@HUAWEI.COM> Wed, 10 September 2003 03:22 UTC

Received: from cherry.ease.lsoft.com (cherry.ease.lsoft.com [209.119.0.109]) by ietf.org (8.9.1a/8.9.1a) with ESMTP id XAA18569 for <ospf-archive@LISTS.IETF.ORG>; Tue, 9 Sep 2003 23:22:50 -0400 (EDT)
Received: from PEAR.EASE.LSOFT.COM (209.119.0.19) by cherry.ease.lsoft.com (LSMTP for Digital Unix v1.1b) with SMTP id <0.00B666BF@cherry.ease.lsoft.com>; Tue, 9 Sep 2003 23:22:53 -0400
Received: from PEACH.EASE.LSOFT.COM by PEACH.EASE.LSOFT.COM (LISTSERV-TCP/IP release 1.8e) with spool id 54608217 for OSPF@PEACH.EASE.LSOFT.COM; Tue, 9 Sep 2003 23:17:50 -0400
Received: from 61.144.161.41 by WALNUT.EASE.LSOFT.COM (SMTPL release 1.0i) with TCP; Tue, 9 Sep 2003 23:07:49 -0400
Received: from liuyu18957n (huawei.com [172.17.1.62]) by mta0.huawei.com (iPlanet Messaging Server 5.2 HotFix 0.8 (built Jul 12 2002)) with ESMTPA id <0HKZ00K919YJB5@mta0.huawei.com> for OSPF@PEACH.EASE.LSOFT.COM; Wed, 10 Sep 2003 11:06:21 +0800 (CST)
MIME-version: 1.0
X-MIMEOLE: Produced By Microsoft MimeOLE V5.50.4927.1200
X-Mailer: Microsoft Outlook Express 5.50.4927.1200
Content-type: text/plain; charset="utf-8"
Content-transfer-encoding: base64
X-Priority: 3
X-MSMail-priority: Normal
References: <20030731211437.48158.qmail@web13503.mail.yahoo.com> <3F298E33.5010100@redback.com>
Message-ID: <005301c37748$908baf50$938a6e0a@liuyu18957n>
Date: Wed, 10 Sep 2003 11:06:43 +0800
Reply-To: Mailing List <OSPF@PEACH.EASE.LSOFT.COM>
Sender: Mailing List <OSPF@PEACH.EASE.LSOFT.COM>
From: Liu Yu <liu_yu@HUAWEI.COM>
Subject: Inter-area routes reachable via multiple areas
Comments: To: acee@REDBACK.COM
To: OSPF@PEACH.EASE.LSOFT.COM
Precedence: list
Content-Transfer-Encoding: base64

Hi! all

I notice that the clause in  RFC 2328 16.4 (3) is just for external route.
How about "inter-area routes"? RFC 2328 does not explicitly state this 
one! Just choose the "the path whose associated area has the
largest OSPF Area ID "?? Maybe every one has his own implentation.


thanks!


----- Original Message ----- 
From: "Acee Lindem" <acee@REDBACK.COM>
To: <OSPF@PEACH.EASE.LSOFT.COM>
Sent: Friday, August 01, 2003 5:46 AM
Subject: Re: ASBR reachable via multiple areas


> Rob,
> 
> You are correct - I missed that clause in 16.4 (3) when
> re-reading. I should have checked my implementation before
> replying. I can't envision why installing an equal-costs
> routes through multiple areas using the same 16.4.1 selection
> rules could cause a routing loop or other problem.
> 
> Thanks,
> Acee
> 
> ROB PATH wrote:
> > --- Acee Lindem <acee@REDBACK.COM> wrote:
> >
> >>Igor Miroshnik wrote:
> >>
> >>>All,
> >>>
> >>>   RFC 1583 states: "AS boundary router's routing
> >>
> >>table entry must indicate a set of paths which
> >>
> >>>utilize a single area." (16.1)
> >>>   Why not utilize all equal-cost paths through
> >>
> >>different areas?
> >>
> >>Hi Igor,
> >>
> >>I believe you can calculate equal cost paths through
> >>multiple
> >>areas - read section 16.4 and 16.4.1 in RFC 2328
> >>(which
> >>obsoletes RFC 2178 which obsoletes RFC 1583).
> >>
> >>
> >
> >
> > The section 16.4 in RFC 2328 does not explicitly state
> > that equal cost paths through multiple areas could be
> > utilized (say for load balancing purposes).
> >
> > It rather states that when there are multiple
> > least cost paths available in the routing
> > table, the path whose associated area has the
> > largest OSPF Area ID is chosen.
> >
> > Also section 16.4.1 refers to section 16.4 for
> > choosing a path based on cost, when there are
> > multiple paths of equal highest preferences.
> >
> > So it essentially means that multiple equal cost
> > inter-area paths are not utilized.
> >
> > Thanks,
> >     Rob.
> >
> >
> >
> >>
> >>>   Thanks,
> >>>   Igor
> >>>
> >>
> >>
> >>--
> >>Acee
> >
> >
> >
> > =====
> > Rob Path
> > E-Mail : rob_path@yahoo.com
> >
> > __________________________________
> > Do you Yahoo!?
> > Yahoo! SiteBuilder - Free, easy-to-use web site design software
> > http://sitebuilder.yahoo.com
> >
> 
> 
> --
> Acee