[Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
Dhruv Dhody <dd@dhruvdhody.com> Mon, 13 October 2025 13:39 UTC
Return-Path: <dd@dhruvdhody.com>
X-Original-To: pce@mail2.ietf.org
Delivered-To: pce@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 7184B7275556 for <pce@mail2.ietf.org>; Mon, 13 Oct 2025 06:39:06 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.897
X-Spam-Level:
X-Spam-Status: No, score=-1.897 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=dhruvdhody-com.20230601.gappssmtp.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id h5eemuC7-Qd1 for <pce@mail2.ietf.org>; Mon, 13 Oct 2025 06:39:00 -0700 (PDT)
Received: from mail-oi1-x232.google.com (mail-oi1-x232.google.com [IPv6:2607:f8b0:4864:20::232]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id E9BC87275540 for <pce@ietf.org>; Mon, 13 Oct 2025 06:39:00 -0700 (PDT)
Received: by mail-oi1-x232.google.com with SMTP id 5614622812f47-43f63005ea5so140611b6e.2 for <pce@ietf.org>; Mon, 13 Oct 2025 06:39:00 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=dhruvdhody-com.20230601.gappssmtp.com; s=20230601; t=1760362740; x=1760967540; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=u3eAE8KfagfzAnl2ge+g7BNG3TnUcDfmnh/1OO6JRTc=; b=2AMxf3slO20zkGfvjkHvN5H/aBwi4llUvzJESIMlOidSXvLQbNk94Xq2pRXU2MhqiN 2yPRkj3+QlvQIxIIMSPW6lx0Vp3vXCKQ0rd+TIUFpmOR3FJRzcY7cZHyjRkMASb2PitV e7OnQ7S7is1+znp1ye+DDQAZi7RwRRH0RzKE82viIYxBUyCXvEeMm/BJQlsWozrX34Zh ChIzeSU+lhbQUdoYJLqCW2w73YAHeHEcwqza7SycNSXxuwoljQ6vDz7obk0tgki2VaAP W+sQjY5Xzc2hHHes1V1GbPNK0XFmZzO/QQUH0O+VoEIYitXt6fmyQB/cbJ7vyXcz3gSK V9sA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1760362740; x=1760967540; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=u3eAE8KfagfzAnl2ge+g7BNG3TnUcDfmnh/1OO6JRTc=; b=mCAUNKHw2jL5GvRbFQOkJAlcINDmkIwlFS2hHjVOkQjnGbrR8t2QlHayeIur8nx08L daMCqEPrPjqmentJ7TmD1c67crLPb8XGX/TAOcgVMSOOeHYGUtL0WjBlKgR6VkjIeTx6 o090nas0lm0tiv0ER2nWgWy9qdEv0gt2hMohWtWKcIeaTebxsrbyAes5OD5RsMtWE4yX aB0Cyvl4ZfHd6YgUs+WPI03AOAzSIjlmiTN3pv83BySM6uN1FNnpRQ2JiIbYe2dhX1PA VTwxPsSkC3HAjs/cuw58qPi/wbRFR6/Jme1J25v7VbWZaJpH01BPH1oFcDY2Re4cozAZ unMQ==
X-Forwarded-Encrypted: i=1; AJvYcCU+LK2HFriu6LTD/vKmY+orAbcCesKbBfHU8RI888IE9zAliRtg9EYbbxvKPX83As5qnBo=@ietf.org
X-Gm-Message-State: AOJu0Ywlav90H0lIh5p/x4FaH4cHHLUxYYJ10xqECMsaFZbCq4N0ju6S dDCdv8x4fJaxmy3602DgIvTRBnVssZBe7qd5Fvh4v+IYIyuO8CJ+0sbS8GIy+0Gh/7MZBSvYJp3 yvhbak1NhfLXXHsTJJl5y/ET0YL88QDCYhw+fUCniMw==
X-Gm-Gg: ASbGnctslPM5EQJpkBPwbNtQlkwgYeN0gRlAV2mvhH0/HhvXaeKkje5+WvFjJTJza66 LnAPw6m0rHJGRyZgXzRreC03s7mXyYbWuqjAyGSbj+uTqzlQ1h9ym99K/m8igDWp4br2gYINKOt H0wm/GqBu0eE3GCg5UeQXk4YYoFSI2HpOD83G/JEZ9ugci0AZAOtkQCouHwzJu5QvJsQ6BwMrvP enCrnN/k4lhRqDdiXKlgW64yGHPVG0xEW5zRJJ/hI/K33mFZ6ffhb4/rMZzc7BLa4/deN2krE1q 3hfQU8iwkx7oNsmPzlBWm8ABcoCw60O6yvxQS64d5KQ2L1lNKDA3yLlwE5bvOvFTE6wuU2nv1uN OEXr9s1jW833EZ2WlFHxuJp92kPxnigVXEtTcJKGEBP22F7o2jslp21MyQLLF
X-Google-Smtp-Source: AGHT+IFyexMuK4RJis+cMG0kottfzy82IBKB0G/g0EIJOV5vHJu0TiFV+MMJY5EXFSsKjnv72yPuSWIm7V//7ciUYiM=
X-Received: by 2002:a05:6808:10d2:b0:43f:1826:3127 with SMTP id 5614622812f47-4417b3e9515mr4818980b6e.8.1760362740145; Mon, 13 Oct 2025 06:39:00 -0700 (PDT)
MIME-Version: 1.0
References: <176000592968.239612.4429182568224091262@dt-datatracker-6c6cdf7f94-h6rnn> <CAH6gdPytMa5s9JMfLBgm+J8j7tkN0bAshHL8n3L6_2AXkUTyOg@mail.gmail.com>
In-Reply-To: <CAH6gdPytMa5s9JMfLBgm+J8j7tkN0bAshHL8n3L6_2AXkUTyOg@mail.gmail.com>
From: Dhruv Dhody <dd@dhruvdhody.com>
Date: Mon, 13 Oct 2025 19:08:24 +0530
X-Gm-Features: AS18NWDA58IIpQKs12t22p1z1JYERu5JRjUTTlc4WR_R4sA7GaArXXsnbiuQgDc
Message-ID: <CAP7zK5apnH+au4PcDwVqYtUQ=5xCjJ0_XoY9x6qgA06+PckOVg@mail.gmail.com>
To: Ketan Talaulikar <ketant.ietf@gmail.com>
Content-Type: multipart/alternative; boundary="000000000000cd712706410a636f"
Message-ID-Hash: RNNRKPZ6LN7ZVYI4U7FE6RJZF3WP7KZH
X-Message-ID-Hash: RNNRKPZ6LN7ZVYI4U7FE6RJZF3WP7KZH
X-MailFrom: dd@dhruvdhody.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-pce.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Deb Cooley <debcooley1@gmail.com>, The IESG <iesg@ietf.org>, draft-ietf-pce-sid-algo@ietf.org, pce-chairs@ietf.org, pce@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
List-Id: Path Computation Element <pce.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/pce/DluN8tQB32ygH4W2GfikC1Zy3BY>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pce>
List-Help: <mailto:pce-request@ietf.org?subject=help>
List-Owner: <mailto:pce-owner@ietf.org>
List-Post: <mailto:pce@ietf.org>
List-Subscribe: <mailto:pce-join@ietf.org>
List-Unsubscribe: <mailto:pce-leave@ietf.org>
Hi Ketan, Deb, The authors can also add an additional reference to - https://datatracker.ietf.org/doc/draft-ietf-pce-pceps-tls13/ alongside RFC8253. It is in the RFC editor queue. Thanks! Dhruv On Mon, Oct 13, 2025 at 6:15 PM Ketan Talaulikar <ketant.ietf@gmail.com> wrote: > Hi Deb, > > The current text in Section 9, reads as follows: > > Hence, securing the PCEP session using Transport Layer Security (TLS) [ > RFC8253 > <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC8253>] is > RECOMMENDED as per the recommendations and best current practices described > in [RFC9325 > <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC9325>] > . > > So, it does cover RFC9325 that you have pointed out. There isn't an update > of RFC8253 that is available, and so hopefully this is adequate indication > of the shift to TLS 1.3? > > Thanks, > Ketan > > > On Thu, Oct 9, 2025 at 4:02 PM Deb Cooley via Datatracker < > noreply@ietf.org> wrote: > >> Deb Cooley has entered the following ballot position for >> draft-ietf-pce-sid-algo-26: No Objection >> >> When responding, please keep the subject line intact and reply to all >> email addresses included in the To and CC lines. (Feel free to cut this >> introductory paragraph, however.) >> >> >> Please refer to >> https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ >> for more information about how to handle DISCUSS and COMMENT positions. >> >> >> The document, along with other ballot positions, can be found here: >> https://datatracker.ietf.org/doc/draft-ietf-pce-sid-algo/ >> >> >> >> ---------------------------------------------------------------------- >> COMMENT: >> ---------------------------------------------------------------------- >> >> Thank you for the secdir review by Alexey Melnikov. >> >> Section 9: RFC 8253 is outdated because of the publication of TLS1.3 >> (RFC8446). Consider listing BCP 195 vice RFC 9325 to ensure the most >> recent >> guidance for the implementation of TLS. >> >> >> >>
- [Pce] Deb Cooley's No Objection on draft-ietf-pce… Deb Cooley via Datatracker
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Ketan Talaulikar
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Dhruv Dhody
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Ketan Talaulikar
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Samuel Sidor (ssidor)
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Deb Cooley