[Pce] Re: Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions
"Samuel Sidor (ssidor)" <ssidor@cisco.com> Thu, 30 October 2025 09:01 UTC
Return-Path: <ssidor@cisco.com>
X-Original-To: pce@mail2.ietf.org
Delivered-To: pce@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id D0F347EC2323; Thu, 30 Oct 2025 02:01:49 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.886
X-Spam-Level:
X-Spam-Status: No, score=-11.886 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H3=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id KSBiHcpPMFsf; Thu, 30 Oct 2025 02:01:49 -0700 (PDT)
Received: from alln-iport-4.cisco.com (alln-iport-4.cisco.com [173.37.142.91]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 020C37EC2311; Thu, 30 Oct 2025 02:01:48 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=18937; q=dns/txt; s=iport01; t=1761814909; x=1763024509; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=E9jOKW+UvfDO/4pYRvN4p4QyMiOu4zMpwGk0GBpekec=; b=TeU7D6+pVpqU1WEOMVV70YDEOYsNTgdgRZe9F8xclLNihCcXKKMF7KK0 QxXvEzspWTKIPB5YJkw6NYJNGXQ+QTY4xUflLCsV4bd+tpmpFM0O7AclB YWvs8aKNbY2Mq/esAocfhsrkFYy0BCOIG2Fik6mE8+ME8H46zHsFk2rmm OjkkGR7FW4mJDAd4KaLZxvLtDgviSfI4MReheO0bd692qwR+TQuVJ5KLN trKxVcm3Mp6bXh+c3d+XqeM2cXPyxAPoIT6G8YCbP8TJ2/ji5nrVgfZqq ReFXENfLrSstqQnXqqCdAjn8N5gd69NqW5VcYPHmp1V7jEmD2Wq9X9lXw w==;
X-CSE-ConnectionGUID: WYqa75lWSxW5GLk1IbY2cA==
X-CSE-MsgGUID: F4DSMOOoS7i9qxOi0LbW8w==
X-IPAS-Result: A0BWBQAuKANp/4sQJK1QCh4BPAwCCxUlgSuBPTFSB4IJEkmIIAOFLIh4A5FKhXmGV4F/DwEBAQ0CUQQBAYUHAoxSAiY2Bw4BAgQBAQEBAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4ZchloBAQEBAxIVUhACAQgOAwMBAi8xHQgCBA4FCBqEflYDAQKkDQGBQAKKK3iBATOBAeAmgUqIUQEqgTSJBicbgUlEgRVCgmg+hBYFKgUZg3WCLwSCDRV6FB2GDHiBMEeIIgaHK1JyIgMmMywBVRMXCwcFgSBDA4ELI0sFLR2BJCIfGBFgVECDSRALBmgPBoESGUkCAgIFAkA6gWgGHAYfEgIDAQICOlcNgXcCAgSCG36CFQ+JEwMLbT0UIxQbBQSBNQWSXVuCXBlqBBRWRjs1Rh8LEZMDj2eOX5NZgT4KhByiDReEBI0TmG1nmQaCWKBrRQGFDQIEAgQFAhABAQaBbwE0gVlwFYMiUhkPji0WzzF4PAIHCwEBAwmRa4F8AQE
IronPort-PHdr: A9a23:4iPJxR9NIbTptP9uWBDoyV9kXcBvk7zwOghQ7YIolPcVNK+i5J/le kfY4KYlgFzIWNDD4ulfw6rNsq/mUHAd+5vJrn0YcZJNWhNEwcUblgAtGoiEXGXwLeXhaGoxG 8EqaQ==
IronPort-Data: A9a23:C1VAhKDF5y00nBVW/1riw5YqxClBgxIJ4kV8jS/XYbTApD4rgzYGx mMXCziFOPrcZTTyedhxPIy+pEgFvceBzoRiOVdlrnsFo1CmBibm6XV1Cm+qYkt+++WaFBoPA /02M4eGdIZuCCaF/H9BC5C5xVFkz6aEW7HgP+DNPyF1VGdMRTwo4f5Zs7ZRbrVA357gUmthh fuo+5eCYQf+g2YtWo4pw/vrRC1H7ayaVAww5jTSVdgT1HfCmn8cCo4oJK3ZBxPQXolOE+emc P3Ixbe/83mx109F5gSNy+uTnuUiG9Y+DCDW4pZkc/HKbitq+kTe5p0G2M80Mi+7vdkmc+dZk 72hvbToIesg0zaldO41C3G0GAkmVUFKFSOuzXWX6aSuI0P6n3TE/MR3BR5rObIj6tkqLkVNr N0SGWoGR0XW7w626OrTpuhEj8AnKozveYgYoHwllWufBvc9SpeFSKLPjTNa9G5v3YYVQ7CHO YxAMmsHgBfoO3WjPn8ME5Mym/2AjXjkeDoeo1WQzUYyyzaLlFEpiuO1brI5fPSkGeluu2G/o VmZ/jXgEjYbbPiV9mqapyfEaujn2HmTtJgpPLGi//B2xVye2mJWEBYbEFC6u/Kki1L7QM5OL 0FR4iEjte0/5FCmSML8WBujiH+JohBaXMBfe8Ui4wyly6fI7UCeHGdsc9JaQNUisMlzQXkh0 UWE2ouzQzduq7aSD3ma8994sA+PBMTcFkdbDQcsRgoe6N6lq4Y25i8jhP46eEJpprUZwQ3N/ g0=
IronPort-HdrOrdr: A9a23:MCED6qN8v0fnScBcT7z255DYdb4zR+YMi2TDiHoBKiC9I/b5qy nxppUmPEfP+UgssREb9expOMG7MBXhHO1OkPgs1NaZLUbbUQSTXftfBOfZslnd8mjFh5FgPM RbAuZD4b/LfCVHZK/BiWHSfadDsby6GeKT9JvjJhxWPHhXgtRbnnxE43GgYzVLrWd9dP0EPa vZzPBq4xCnfnMaZNm6AH4qY8jvzuegqLvWJTQ9K1oC8gehsROEgYSWL/Gf5HgjegIK5Y1n3X nOkgT/6Knmmeq80AXg22ja6IkTsMf9y/NYbfb8yvQ9G3HJsEKFdY5hU7qNsHQeu+e08msnl9 HKvlMJI9lz0XXMZWu4yCGdmDUIkQxeqUMK+2XoxUcLkvaJAw7SzPAxw76xRyGprnbIeusMiZ 6jkVjp76a/Rimw7BgVr+K4JC2C0HDE4EbLVYUo/iZiuUx0Us4LkaUPuExSC5sOByT89cQuF/ RvFtjV4LJMfUqddG2xhBgk/DWAZAV6Iv69eDlIhuWFlzxN2HxpxUoRw8IS2n8G6ZImUpFBo+ DJKL5hmr1CRtIfKfsVPpZMfeKnTmjWBR7cOmObJlrqUKkBJnLWspbypLE4/vujdpAExIY73J 7BTFRbv2gvfF+GM7zC4LRbthTWBGmtVzXkzc9To5B/p73nXbLudTaOTVg/+vHQ6sn3wverLc pbFKgmdMMLd1GebLphzkn7Qd1IJXEVTc0SvcxTYSP9niviEPyfitDm
X-Talos-CUID: 9a23:0wSwmWzd7XHx++QHsvf3BgUrK9ksLSDZ80zAHBKXLWUwabekE1S5rfY=
X-Talos-MUID: 9a23:Yde+zgapncyLV+BTmWPAvxRFE8BTvKX/EVAqkM0isfbUKnkl
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-02.cisco.com ([173.36.16.139]) by alln-iport-4.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 30 Oct 2025 09:01:48 +0000
Received: from alln-opgw-3.cisco.com (alln-opgw-3.cisco.com [173.37.147.251]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-02.cisco.com (Postfix) with ESMTPS id 1037818000187; Thu, 30 Oct 2025 09:01:48 +0000 (GMT)
X-CSE-ConnectionGUID: OjQVOJXdRa+UkNjkNZ1TsQ==
X-CSE-MsgGUID: urqWRL3CSN6qr/tm7Z8YaA==
Authentication-Results: alln-opgw-3.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.19,266,1754956800"; d="scan'208,217";a="35359211"
Received: from mail-dm2pr0701cu00101.outbound.protection.outlook.com (HELO DM2PR0701CU001.outbound.protection.outlook.com) ([40.93.13.65]) by alln-opgw-3.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 30 Oct 2025 09:01:47 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=EUezcrc3E2yFn5ukjBXmWFMNrGDpYck2+3AtxvWSEdtDofbOzuEtioALTAVoPpbvr0yIdkbLZTnne7zln0yyPnkcaDC5qXgw0CLDA4PQCN1MrMjQYghG2K8gLOINSrPtgkeilNnsvQbv8r9WOqONRIbFFau6MWCkS8+fwicd/TqN45NIC6CxYLF/QFMEqCEN20X3kXxQ2gRM9KdNPq3EBugZqH1hrdnjjf1NhNnVxYSPey8cC9AZrhs9SCeUFG3ufm6/RM4ImLORvRD6nnTWPDPfrQSQ9ZTJL3/a0Syqhu/LJhMCPpC3JbYYLPs1C95vdsNzcEefHdBXd5os1gR2qA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=E9jOKW+UvfDO/4pYRvN4p4QyMiOu4zMpwGk0GBpekec=; b=tOrcTT6f5b300dC2OlfTpvLLud3806HlQRWessr2/AUw2mLUvG6rbbZqj/elhaGc5RtnP7OS8VBFigqGI1UYXQ6epaLTyum3E425LiHFB3SyUao3PiwCzDKpTYaowcxE1PEJiOS42TBx6cX0Razk+0leSQgX7IDjyv/UAFUGZAYJvT4azOTh9Aa16svaXU5OeUmpnrZXgz5sWUrKqLOTIM2NdR4dy6X+ibqw27Fk50F7+n+TK3WzpKD7EwwYPcKqdklOeQtTSbKfSCuit1GHNuudxnDHnP982Ie0QUrk7Vu1sy9hCoQM6fNHPAlypSyaZKWuyLJy3b96gZq7qpyGcA==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from IA0PR11MB7792.namprd11.prod.outlook.com (2603:10b6:208:409::16) by MN0PR11MB6036.namprd11.prod.outlook.com (2603:10b6:208:377::11) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9275.13; Thu, 30 Oct 2025 09:01:46 +0000
Received: from IA0PR11MB7792.namprd11.prod.outlook.com ([fe80::385b:609e:4289:5e04]) by IA0PR11MB7792.namprd11.prod.outlook.com ([fe80::385b:609e:4289:5e04%5]) with mapi id 15.20.9275.011; Thu, 30 Oct 2025 09:01:46 +0000
From: "Samuel Sidor (ssidor)" <ssidor@cisco.com>
To: Dhruv Dhody <dd@dhruvdhody.com>
Thread-Topic: Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions
Thread-Index: AQHcSXF3gc2YVjCj7EqVx0cw76ba1rTaWxij
Date: Thu, 30 Oct 2025 09:01:46 +0000
Message-ID: <IA0PR11MB7792F763E73CD5A8B4F98B63D0FBA@IA0PR11MB7792.namprd11.prod.outlook.com>
References: <CAP7zK5bLJEv=16ziB=maRhtg2BJnurZVBkxd2q8NgXG88=9Y6A@mail.gmail.com>
In-Reply-To: <CAP7zK5bLJEv=16ziB=maRhtg2BJnurZVBkxd2q8NgXG88=9Y6A@mail.gmail.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: IA0PR11MB7792:EE_|MN0PR11MB6036:EE_
x-ms-office365-filtering-correlation-id: a16c7771-9211-4449-a1fa-08de1792f413
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|366016|1800799024|376014|38070700021|7053199007|8096899003;
x-microsoft-antispam-message-info: EpEsnOv67C/w/og+uvAvGGsmPzo/ruEfLwEoTF6oAW5NNdFweAavtmA0XILWlGVDXDIfT++wFNOtbJd24/b5gDbeWR+IUpeKDoNmeBxKoruytiLpqKiDE+2CsvWNoAr7/n4UITKzyjhd5OmfWLAX/BskiSeJNtOMvRhLlHeu74HWSddAyQodTaB6FhdnxkQiIFUV62r1gdL7hDpCVnu6Cf4wyc5v0Os8UULOwZax+bQRJbcFBwH+QbERYlCo2Hx4EXuW4a631p+jq1eq4N3ywGXk4Ql7VYM13yCOj7j5cZWLKIfH/RAGsxDx/gXGyUVYGoSdk5LOswQiDyLh/rzqmmRpLevtRHIR0xVueX8w77DB0/iKhrHsME1Sr5RLchDB3HExh5mr65dLhmWqIoCDYr+TfiidvYknlTQCcXgX+pbP9rjCuD0xG55uwkIf2hFQEv0hQr0/M54X4HqMEhHywTl1c9XU2lBdhybkd8bKrfey548FM3tZvGzWiaAdtCDx5Nr1gaSrOfBjoWAEzklQgXkN2LvRhw+PLc8KVR4E2ZIV5ejHeBSVgjigoLyOZH04eTHDOMNz79FUhg4yNGMcQiadhO1QPsaMyy9bDoQjpv8DYYM2PTGDCq2xDCdiZk2XVy73kfiLjx0PoDyKxSpEvZWDK5eBAv05fKscvcsJz9zqs4MmyUogqL9HMPD8Tq2ocM79VNUWqqS/uDeU/aVDs3i1JBE3W9LkhUqXx0AbAmPZFTFTaDpedx2LnD6hU4ie4dEehtAMkTVVLZzcE0QedIhl1E0J3VyVtMIyteubdapxi6C6YLVnEwMvI49b4pFq7T0vK07uvxat/ybsxXIkgamcPMiB813Y7f/6/DZgjLb6Xd1WXCLhHnzbdj8glDIfuGODSCN2RSRVqN8FEw+Jtyfp+GZU8j2B9TMkDD6oNizYbkfSsWntUGB2mn5sH6EajspysLzLbZ4zb8qHK8RDqszvWEou/HzWtEQ/E6/KIL5oDt+8xblpkWPLzYWiy/PfGoxf9EKecCdy0roBXe3r5wnxrL9g2bf3yZ4Enjeph+Vhuxk9cKQ3uY1mrHH9TaF/zIe6bXuT5Gx8DSxNVoZbEG8vvn7usnceK8LWc6Xo2xSidJFPE4bjW5NkV6XrrXdKu9fcOet9rth2sP5N3NHH3MsPEwjeC2yRwKvLjSbPymX3RNRBWqY1ofeT3YXkVGW5vPC+dMOCZPXEqiv/w6H0Md5GEd/Xmv332NYjKJf6t2JR4xwUIgw3XqRRuC2kBLeJdfw0ahtzP6I9KLejVLq2YaugnQr2OfWu7BQ2zUvgueXKnK/QEniRv1w17xz9OQNpq/USzGM9dVCzmsWjdw+PKxvudcmYdwaOkN7r/UBto0MvUbEmg93MXeEAcx6d8oJubsAkpnFqKXnPHTGXeF2cVsvJfmn9knYlFXwtvTGnRW7lyjfvKkuo83GFyJcK0xwUVQW+0Cm57P2MVH7cz27MUzAHOnG93SaBwNaJ7XF6iKsUEq8W5Qzrwtgb83wSpC7+
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:IA0PR11MB7792.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(366016)(1800799024)(376014)(38070700021)(7053199007)(8096899003);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: DP3txh3S89bah+QHEyJGWNa34F+4gg0KES4sT1Yax3Eurdt+p1BhoCHFQWKFQgfoJ3thfsTBRIJ648fGnlkWiVBVJXJhTH3UafLxdtr5B6fbE67EA9Qn5MsjIzJdyGwLiQiNXULKVsr4ud2Fnkxr63uX2rnL645VajxwfZfO/J87iCRVorVvMUaA4MJarDKIaG0RFQTDbZSCCJLi9V0ksQ8OQDmoW+VyCrVpC2kqUEe5dGKaFnAc2kWgCWuMY6oxhgkgvJcvM9Urbqh5Z8HqTGpnMC76unlNlO1Gy1cx5Ja8L9sr4uJyU79o5bw+p41oGVURPdjYj7vsfR641SqEHdb47IB+JtZisCrkIfKYUXbgU4tpUByL1rYte9v+/WfwX21pNUs3aHltt0AjJozxo0UBerp4aj+XbeE51gq0ACtPDdXZGrif1kbsXEIoNjvBTPMKcYtCyhBHyocF+ZWvDU5SEvz6IsRH+UXh1viGnNhSDq0VZZHFelDPjkO7Ff2iQcvz2bQHuNTnEgGaou1F9eAuAXLg8Ml2Tcq63kyL6nGigChBbfd5YK148QklASiZNPppU2W2dlguK+X9UDYsLAfA5W8RGuV77wXgp4v06HqKkr0EOnzJORM2Ugq8Ev/eejbcJc/+icHMiiNyuIkx2OFl0iculj4Icfca+RvscAL2SBvrGqOw7YSj50t8zivqHF22U0ePSv0/yHfHo7PNeGNM2aRFS32j/1JZW33kyaMkkz0qup4OTLCf00FU8btPdsR6u31H2aTJbLA8w+U0SHuYdyjtE5Y9+0KceWgS8TcsQJ9BlAijnvhMVuWPwQwL1CpAAmWDSCOWjam302KiLpW524kZhZkKUNHHDrK9BPwy9rgfThClDrFUSMadnRUoRVElCxStAZpBD5MuSsK7MSLFA1PthT2Ql1CMKlPXNh3Oz60/uWSezmMxdbcwuvjHExwhMC3J0PsxAs8RTI0sBIc/wOhfFTVrQEy74fMvw+T+bdeVKNNJ/F6nRRafsFHOAERFpShAw5Sup2GefoFgEo3wFidv6+c6c1t04bjGTvf68pevT5VSnemRGCiCZyCkhLkfXW/RfGMh5hJCjW4ZpUbm5oNDpPO/i6H4gT0pgxJHHr/eWyjnm6FC3f8VpOJc53ynY5KdRc2mkMAZ1iM5Q2aUsXyTjycItVbqgUC+kqE0BtMc0wg7q6A346ehFd6BCwNnySrmhnHf3w8A75NoYuwNhA15+AuVBELTeekncZ1QUV07yXRStiZ5EYoo32ssn/2/CpwfsGr2ff5KF9GBevNoMPuWwLW0ih6bKyzcQpMZwLmNNesqoie7yJemi74gPXs1QLMSGgKBdxEJRDyTpo6V4GMjrhzcjE5/02PUxxL7X0O4yRD7VCszzcsm5ORFRazUQ7/ZFmqVi9Dvl6wkJPPP9rmT9Tp0KRm3YhmTt5wyhCZWaIvGUMg1Nopug6VNN8jIpcx8hj56mLDklcKhBkpUqLHSPvtWO34oInFQQwZ8qSM3A28rw6J1fFlqMeoBbdigR5FDbMXzwkxwbjA6R98oM8V8P/84rLA3nbV0OZZCEZu/OzXAntfiWugo6wQ7
Content-Type: multipart/alternative; boundary="_000_IA0PR11MB7792F763E73CD5A8B4F98B63D0FBAIA0PR11MB7792namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: IA0PR11MB7792.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: a16c7771-9211-4449-a1fa-08de1792f413
X-MS-Exchange-CrossTenant-originalarrivaltime: 30 Oct 2025 09:01:46.0257 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: v36z7YdcaFflDqHU6KhG6pOHEIR6lTF9cuA0hPCIzMU1FLydlcR6FS+mWaKmnKfoae6frL3S/HDthFDa88OR7A==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: MN0PR11MB6036
X-Outbound-SMTP-Client: 173.37.147.251, alln-opgw-3.cisco.com
X-Outbound-Node: alln-l-core-02.cisco.com
Message-ID-Hash: DEOAR2QMHD6ZH6YBYKPN3VRYRVXD37C4
X-Message-ID-Hash: DEOAR2QMHD6ZH6YBYKPN3VRYRVXD37C4
X-MailFrom: ssidor@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-pce.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "pce@ietf.org" <pce@ietf.org>, "draft-ietf-pce-circuit-style-pcep-extensions@ietf.org" <draft-ietf-pce-circuit-style-pcep-extensions@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Pce] Re: Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions
List-Id: Path Computation Element <pce.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/pce/FfnSqiqwlotvD-ofcZF6wsa4eHE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pce>
List-Help: <mailto:pce-request@ietf.org?subject=help>
List-Owner: <mailto:pce-owner@ietf.org>
List-Post: <mailto:pce@ietf.org>
List-Subscribe: <mailto:pce-join@ietf.org>
List-Unsubscribe: <mailto:pce-leave@ietf.org>
Thanks a lot Dhruv for review and comments, Please find inline responses marked with <S> for some of them (rest of them are clear and I’ll update the draft based on those). Regards, Samuel From: Dhruv Dhody <dd@dhruvdhody.com> Date: Thursday, 30 October 2025 at 08:47 To: draft-ietf-pce-circuit-style-pcep-extensions@ietf.org <draft-ietf-pce-circuit-style-pcep-extensions@ietf.org> Cc: pce@ietf.org <pce@ietf.org> Subject: Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions Hi Authors, I have done the Shepherd review of the I-D. Once the update is posted, I will send this to the AD. # Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions ## Minor - Abstract uses the term "distinct hop requirements" where the term is not used anywhere in this or SPRING document. - In "[RFC8664] introduces the concept of Segment Routing Policy (SR Policy)" - this should be RFC 9256. If you want to talk about RFC 8664, say that it introduces SR to PCEP. - Section 2, also add SR terms like SR Policy, SID etc - Section 3, directly jumps to extension. It would benefit from some initial summary text before all the details, example - ```` This section specifies the PCEP extensions that enable a PCC and PCE to support Circuit-Style (CS) SR policies. These extensions build on the base PCEP [RFC5440], the Stateful PCE extensions [RFC8231], and the Segment Routing (SR) Policy extensions [RFC9603]. The mechanisms defined here allow a PCC or PCE to: * indicate the requirement for strict paths, * signal path persistency by disabling recomputation for specific paths, * identify and control behavior specific to Circuit-Style SR policies. Unless explicitly stated, the procedures of existing PCEP messages and objects remain unchanged. The following subsections describe the specific object formats, TLVs, and flag definitions introduced to realize this functionality. ```` - Figure 1, shift the numbers 0,1,2... to right by 1 space, they need to correspond to - and not + - Section 3.3, this text - "If this flag is cleared, then the PCE SHOULD recompute the path if the original path is invalidated."; can we add 'according to local policy' as we use in other PCE RFC? Also in section 4.2, you use MAY for this flag, be consistent. - Section 4.1, no need to use BCP14's MAY in "Existing O flag in RP object MAY be used to indicate similar behavior in PCReq and PCRep messages as described in as described in Section 7.4.1 of [RFC5440]." as this is about existing behavior. Further "If the O flag is set to 1 for both stateful and stateless messages for SR paths introduced in [RFC8664]...", this is unclear to me. Why both..and? Suppose the O flag in RP was not set during PCReq but set in PCRpt in TLV would the PCE not process it? <S> I will also fix typo in 1st statement in the comment “as described in as described”. For “both” - it was meant in a way that if O flag is set in any of them. I’ll update statement to make it clear. - Section 4.2, "The presence of the TLV blocks path recomputation.." is conflicting with Section 3.3 "the PCE MUST NOT recompute the path in cases specified by flags.." - I think flags need to be set to block recomputation and it should not be just the presence of the TLV. <S> Intended state is: * TLV included with no flag set -> re-computation is allowed if original path is invalidated or if operator explicitly requested it -> blocked otherwise (e.g. PCE cannot re-compute if better path exists, but original one is still valid) * TLV included with P flag set -> re-computation is not allowed even if path is invalidated * TLV included with F flag set -> re-computation triggered by operator is not also not allowed Will it be more clear if statement in section 3.3 is updated to something like: “If this TLV is included in the LSPA object, the PCE MUST limit path recomputation for the LSP as specified by the flags in this TLV and the procedures in Section 4.2." - Section 4.2, "For example, if the same path can be encoded using Adjacency, Binding, Prefix, or other SIDs, then PCE MAY switch between various representations of the same path", the use of MAY inside a sentence that starts for example, is not ideal. <S> I’ll drop “For example”. - Section 4.2, "The only exception is an explicit request from the operator to recompute the path." it would be clearer to explicitly state how operator request recomputation. <S> I can add something like: “The mechanism for an operator to trigger such a request (e.g., via a Command-Line Interface (CLI) or a northbound API on the PCE) is implementation-specific and outside the scope of this document.” - Section 4.2, do we need error handling in case the flags are set but PCE still tries to recompute/update a new path? <S> Sure, I can add something like this to section 4.2 and define new PCError in IANA section: “A PCC that receives a PCUpd message with a modified path for an LSP, where such an update is blocked by flags in the PATH-RECOMPUTATION TLV (e.g., the F flag is set), it MUST reject the update and maintain the existing path for the LSP. The PCC MUST also send a PCErr message to the PCE with Error-Type=19 ("Invalid Operation") and a new Error-Value, "Path update is blocked by recomputation constraint”." ## Nits - s/This document proposes a set of extensions/This document specifies a set of extensions/ - s/[RFC8664] introduces the concept of Segment Routing Policy (SR Policy) Thanks! Dhruv
- [Pce] Shepherd Review of draft-ietf-pce-circuit-s… Dhruv Dhody
- [Pce] Re: Shepherd Review of draft-ietf-pce-circu… Samuel Sidor (ssidor)
- [Pce] Re: Shepherd Review of draft-ietf-pce-circu… Dhruv Dhody
- [Pce] Re: Shepherd Review of draft-ietf-pce-circu… Samuel Sidor (ssidor)
- [Pce] Re: Shepherd Review of draft-ietf-pce-circu… Dhruv Dhody
- [Pce] Re: Shepherd Review of draft-ietf-pce-circu… Samuel Sidor (ssidor)
- [Pce] Re: Shepherd Review of draft-ietf-pce-circu… Dhruv Dhody