[Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
Deb Cooley <debcooley1@gmail.com> Mon, 13 October 2025 14:36 UTC
Return-Path: <debcooley1@gmail.com>
X-Original-To: pce@mail2.ietf.org
Delivered-To: pce@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 03E7F727D67F for <pce@mail2.ietf.org>; Mon, 13 Oct 2025 07:36:40 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.848
X-Spam-Level:
X-Spam-Status: No, score=-1.848 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_ENVFROM_END_DIGIT=0.25, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 0NoQKFza7M4Y for <pce@mail2.ietf.org>; Mon, 13 Oct 2025 07:36:39 -0700 (PDT)
Received: from mail-pl1-x631.google.com (mail-pl1-x631.google.com [IPv6:2607:f8b0:4864:20::631]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 6BAC0727D66E for <pce@ietf.org>; Mon, 13 Oct 2025 07:36:39 -0700 (PDT)
Received: by mail-pl1-x631.google.com with SMTP id d9443c01a7336-2698384978dso29778765ad.0 for <pce@ietf.org>; Mon, 13 Oct 2025 07:36:39 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1760366198; x=1760970998; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=b8e8+rZ4C3/Dp5oLCP/ulCQXQJC235+qRt139PIX+UM=; b=FpNQsFhUKjth5eaCIZDpP6Yt1HQm3vrRa/e1+t3AWBKRS+7WI6JVkZ+djd/jvznn3j z+yN217PJl/MbmMOp9IKOIXvYfty2NIDneacF7qTDHDEKH195LrOMIZ78Nb1rXNqftvZ 9c+BbzkJFDja3HP1D3rQZYyysMRFUuZldhLYfmx2u0rgmvf2gEAAHnPgIrjnalu/YLc7 yiXOAaCJgjmCUXguAhBMoOG3M6WyFzTGip3iGriA0qR/NocCI1OH12vY2/4NJrweExNA zd+GsVOy4Nfrylba1k/0Bv6a0BQj1jmdhQIURA6xfwXoj2mbeL3XQk0jmZSvqZDTSV5n VZsw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1760366198; x=1760970998; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=b8e8+rZ4C3/Dp5oLCP/ulCQXQJC235+qRt139PIX+UM=; b=Bc8vYOtay4y07PYr9E971Mg1Y5r/kpSXgZNqSVXQx2RCEyJxRge+VNCyZal9bHf7kK QsFg5drW9UeLktx3OjfH+AjpMqDj89kdPKo2eCMBfsp5nGpfGX/ivhmMQAdig22C/NUt UxRBVz1qJFo3yzorOBPst3bOX30FL/icj9G1HGcqnlvPf7xqUYYF4Iw3PEz6ObPWK8eF LYEcLOHRdE3qkXtggCfNziypXfmz31A53dXzjJlIaPG0uqn3kOYHLZlStpLo/4zmNHGO 9/oCb1Uoa8LQ55Z2CqtlESfw0dPxXyftPyAd1kWMqIhIIMGxCRlPxXGCBu/qGaegiWMJ Y6iA==
X-Forwarded-Encrypted: i=1; AJvYcCV5tsLYArCd4vOUj+5hvVU1vFqPwa30fIzb73pCJnAT/lcfhz4CMLGGgeQtjWHGPYDmlco=@ietf.org
X-Gm-Message-State: AOJu0Yyfnx4YHHBaZqr55mnscX+kStA6DbXaRSD3SC9LAIVJ2O4+4m06 xmxuu0eht9NfK/pem2yb/WdozkMzoXObkWLNcsTYohS9KroR8C2l9hJ/no0UKsHMjvUCEoQknwU 4SZ0UxoY92XeEbMV4v6QT63DsoMpULQ==
X-Gm-Gg: ASbGncuKOcGjOjqyCb91BVrQYg7HH3Kbx4dLjEmte/xNLdzbVAMsaUqhhXsicfMOlge PMC+D1moaCJ43YMvPeyRKATXM/wwqD8SjEQCjQzjsNOBkguQtWGHneju5gWQoqgHMxQfsLGs4+x KocWKl44kPJCdCw8vekXWIhyFJtqeuc4EuRuPWfvLb9vm7tRbz2XnTS6LAldwSSfZYiYAWgI5DD GMbMY+JeYBNBrz/D34r/AqNuaT4BnotnH46x8Xn64VSf5fsZnnw5S8I4KjaPi7molqeBA==
X-Google-Smtp-Source: AGHT+IE5JKXBZP7j3iW2l+/CuSdNIxdrm0wFcVGjXovHTh6URh4mvcBv97F9+xFPyh2EmOuMyrp2rCtH4hrL396mFKw=
X-Received: by 2002:a17:902:f609:b0:282:2c52:5094 with SMTP id d9443c01a7336-290272c31d0mr276362675ad.37.1760366198396; Mon, 13 Oct 2025 07:36:38 -0700 (PDT)
MIME-Version: 1.0
References: <176000592968.239612.4429182568224091262@dt-datatracker-6c6cdf7f94-h6rnn> <CAH6gdPytMa5s9JMfLBgm+J8j7tkN0bAshHL8n3L6_2AXkUTyOg@mail.gmail.com> <CAP7zK5apnH+au4PcDwVqYtUQ=5xCjJ0_XoY9x6qgA06+PckOVg@mail.gmail.com> <IA0PR11MB77920319EAAB2108D1309FAED0EAA@IA0PR11MB7792.namprd11.prod.outlook.com>
In-Reply-To: <IA0PR11MB77920319EAAB2108D1309FAED0EAA@IA0PR11MB7792.namprd11.prod.outlook.com>
From: Deb Cooley <debcooley1@gmail.com>
Date: Mon, 13 Oct 2025 10:36:25 -0400
X-Gm-Features: AS18NWAVSOxKT9z9bD2czcjk-SHUAWEGDFmxiKYSTIG87cDsm45tLE4r9Mb2nMc
Message-ID: <CAGgd1OfrGtngQ35tKfq6mar4pU7wCYKzAThx6dc-qiy3T5cp5Q@mail.gmail.com>
To: "Samuel Sidor (ssidor)" <ssidor@cisco.com>
Content-Type: multipart/alternative; boundary="000000000000ee1c1406410b31e2"
Message-ID-Hash: ENRQFAA5WLZKP642M3GWTZ6AOAZS4TLA
X-Message-ID-Hash: ENRQFAA5WLZKP642M3GWTZ6AOAZS4TLA
X-MailFrom: debcooley1@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-pce.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: The IESG <iesg@ietf.org>, "draft-ietf-pce-sid-algo@ietf.org" <draft-ietf-pce-sid-algo@ietf.org>, "pce-chairs@ietf.org" <pce-chairs@ietf.org>, "pce@ietf.org" <pce@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
List-Id: Path Computation Element <pce.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/pce/WBCj6PTukDJSME8kxoQbjKTJaeA>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pce>
List-Help: <mailto:pce-request@ietf.org?subject=help>
List-Owner: <mailto:pce-owner@ietf.org>
List-Post: <mailto:pce@ietf.org>
List-Subscribe: <mailto:pce-join@ietf.org>
List-Unsubscribe: <mailto:pce-leave@ietf.org>
A good plan! That draft has the 8446bis draft also referenced (so the most up to date version of TLS 1.3). There is also a UTA draft that will be part of BCP 195 eventually which deprecates the old versions of TLS, but I don't think we have to go crazy here. What you have proposed is perfect. TYVM Deb On Mon, Oct 13, 2025 at 10:31 AM Samuel Sidor (ssidor) <ssidor@cisco.com> wrote: > Thanks Deb, Dhruv, Ketan for comment and discussion. > > I'll update last statement in “Security Considerations” to: > > “Hence, securing the PCEP session using Transport Layer Security (TLS) [ > RFC8253 > <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC8253> > ][I-D.ietf-pce-pceps-tls13 > <https://www.ietf.org/archive/id/draft-ietf-pce-pcep-extension-pce-controller-sr-11.html#I-D.ietf-pce-pceps-tls13>] > is RECOMMENDED as per the recommendations and best current practices > described in [RFC9325 > <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC9325> > ]." > > Regards, > Samuel > > *From: *Dhruv Dhody <dd@dhruvdhody.com> > *Date: *Monday, 13 October 2025 at 15:39 > *To: *Ketan Talaulikar <ketant.ietf@gmail.com> > *Cc: *Deb Cooley <debcooley1@gmail.com>, The IESG <iesg@ietf.org>, > draft-ietf-pce-sid-algo@ietf.org <draft-ietf-pce-sid-algo@ietf.org>, > pce-chairs@ietf.org <pce-chairs@ietf.org>, pce@ietf.org <pce@ietf.org> > *Subject: *Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: > (with COMMENT) > > Hi Ketan, Deb, > > The authors can also add an additional reference to - > https://datatracker.ietf.org/doc/draft-ietf-pce-pceps-tls13/ > alongside RFC8253. > It is in the RFC editor queue. > > Thanks! > Dhruv > > On Mon, Oct 13, 2025 at 6:15 PM Ketan Talaulikar <ketant.ietf@gmail.com> > wrote: > > Hi Deb, > > The current text in Section 9, reads as follows: > > Hence, securing the PCEP session using Transport Layer Security (TLS) [ > RFC8253 > <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC8253>] is > RECOMMENDED as per the recommendations and best current practices described > in [RFC9325 > <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC9325> > ]. > > So, it does cover RFC9325 that you have pointed out. There isn't an update > of RFC8253 that is available, and so hopefully this is adequate indication > of the shift to TLS 1.3? > > Thanks, > Ketan > > > On Thu, Oct 9, 2025 at 4:02 PM Deb Cooley via Datatracker < > noreply@ietf.org> wrote: > > Deb Cooley has entered the following ballot position for > draft-ietf-pce-sid-algo-26: No Objection > > When responding, please keep the subject line intact and reply to all > email addresses included in the To and CC lines. (Feel free to cut this > introductory paragraph, however.) > > > Please refer to > https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ > for more information about how to handle DISCUSS and COMMENT positions. > > > The document, along with other ballot positions, can be found here: > https://datatracker.ietf.org/doc/draft-ietf-pce-sid-algo/ > > > > ---------------------------------------------------------------------- > COMMENT: > ---------------------------------------------------------------------- > > Thank you for the secdir review by Alexey Melnikov. > > Section 9: RFC 8253 is outdated because of the publication of TLS1.3 > (RFC8446). Consider listing BCP 195 vice RFC 9325 to ensure the most recent > guidance for the implementation of TLS. > > > >
- [Pce] Deb Cooley's No Objection on draft-ietf-pce… Deb Cooley via Datatracker
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Ketan Talaulikar
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Dhruv Dhody
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Ketan Talaulikar
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Samuel Sidor (ssidor)
- [Pce] Re: Deb Cooley's No Objection on draft-ietf… Deb Cooley