[Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)

Ketan Talaulikar <ketant.ietf@gmail.com> Mon, 13 October 2025 13:44 UTC

Return-Path: <ketant.ietf@gmail.com>
X-Original-To: pce@mail2.ietf.org
Delivered-To: pce@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 1A0C37276BA2 for <pce@mail2.ietf.org>; Mon, 13 Oct 2025 06:44:18 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Va5c4BHKaU8G for <pce@mail2.ietf.org>; Mon, 13 Oct 2025 06:44:17 -0700 (PDT)
Received: from mail-pg1-x530.google.com (mail-pg1-x530.google.com [IPv6:2607:f8b0:4864:20::530]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 124D67276A67 for <pce@ietf.org>; Mon, 13 Oct 2025 06:43:30 -0700 (PDT)
Received: by mail-pg1-x530.google.com with SMTP id 41be03b00d2f7-b6271ea39f4so2830551a12.3 for <pce@ietf.org>; Mon, 13 Oct 2025 06:43:30 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1760363009; x=1760967809; darn=ietf.org; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:from:to:cc:subject:date:message-id:reply-to; bh=8b5cTqUeHMCoWHbwpvxrhSU+c2CqwJ0elIzxgBCzhhQ=; b=MFcLZ2KexuDWy19TAgBQLSujXFDc9w4ImhWPIXYxxZ68eSfHkG1g8NBognE9CfAO37 9Ju8fiRJIMGxCI8ZRhl1cApwMv3Nc++hL9HhaGYKlGD/WGQRXoJPYGE4CIPKB+nAAp06 01dGPcE69i0YRTKMQNr2zsX7OYS0CzKiuOs3ZNsF3P0uI4W0UjL/SA7PIbp2XMVXqNt0 Jc2Jf18I2s2CXHMT0AkI9jGj2ispZ0/L9yJJHOpuJB42h4LMajjgL8WAl9MpHgRzsF1m +tpWEQZD5THK3ZezIfUZMMwP2kp1OYjtxNevzlsd/x+aNOK9X8XxAmwaJ7lKT2xEj4A0 xDsw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1760363009; x=1760967809; h=cc:to:subject:message-id:date:from:in-reply-to:references :mime-version:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=8b5cTqUeHMCoWHbwpvxrhSU+c2CqwJ0elIzxgBCzhhQ=; b=Xg6ER3B+F+FPaNZghMkbYbF+4I5k9MpVodY2S3FV1n9vKn/BaqvFqWyKFrGyrfl/o2 vqyxZLaZtmDdgkVrpXXslmkFpj7tQbjWWDBQKbBJ8YxC6RLm7BAsB55BJPEeRXhR8YUH 84e/pmfFHgS/yl4cO7S5D7RtrOzvqICgdZt6Jf06ZVzi4fIMI5Xc+ryk4v1Cdu9ABEMu E5mjiX0+gYpEQi0kHX4G1noZoeGtOzM7xwlWSyn23w7RA70YgvIQE7wQPUIgaAS/ErCm Zls7ai0aB2YhyzgKXb2wOjEN9i3UJkKTbb9Xq6qhMQx5MP21i1SEcfCv5S2wXisLG3r/ dkGA==
X-Forwarded-Encrypted: i=1; AJvYcCV1a2prXy20pnETItFm0qC66HG+0yYbZDQ0dpVYntNtfVpagYoriLg/9uDi7pe2oTQORlA=@ietf.org
X-Gm-Message-State: AOJu0YyqOJZZB9zGMhK487Ac4kYbwwkHw9YWY+i2iqkmVAfIPaVMpFdu 8sml9LdPMEZHkS6Tg4JwgQZxYOOyBu3QMNQo18erkf/yMhUushcqDLl/Bh8l9AkwUjTF4m1gnit v0X4h6uGCUlHhmcj8QZk8IlWI1vrdmio=
X-Gm-Gg: ASbGncuwWVqRdY+VxZx8thu7GtcEEDl+YmYlDqVIWlSpP61AbyflsQ9rYkZ7B9DGEHC q58lMDJRADGXp8hb6m26hMx9fEDRFyUVJkByv4Ph2AGBYdCnEgf9HWsbUd7qdT8KFJeRfSsq4UQ K+UvOMW5aJZWc9zXL+Jf70Ldkg2enJiiagrky6CBRqva3ThT2cZYp0DgJ0V1+2+dNa+OSmsYUL2 H6s+wj6G1Fh8Th8VfzyPtr8CROFsn2Y3JT8VN/OKxwz9QiDKf3gK7n1GqnYk4Kq0Xab
X-Google-Smtp-Source: AGHT+IG389+E0+ji3sxWqXvrvpfH3hEhWI7khmpOMlnmYULJnX+O7TOKjoHZ6WdLfdxtvCbrraQFO1XkxuzfGLFW1OQ=
X-Received: by 2002:a17:903:3c2c:b0:24e:81d2:cfda with SMTP id d9443c01a7336-290272500c7mr239692055ad.0.1760363008907; Mon, 13 Oct 2025 06:43:28 -0700 (PDT)
MIME-Version: 1.0
References: <176000592968.239612.4429182568224091262@dt-datatracker-6c6cdf7f94-h6rnn> <CAH6gdPytMa5s9JMfLBgm+J8j7tkN0bAshHL8n3L6_2AXkUTyOg@mail.gmail.com> <CAP7zK5apnH+au4PcDwVqYtUQ=5xCjJ0_XoY9x6qgA06+PckOVg@mail.gmail.com>
In-Reply-To: <CAP7zK5apnH+au4PcDwVqYtUQ=5xCjJ0_XoY9x6qgA06+PckOVg@mail.gmail.com>
From: Ketan Talaulikar <ketant.ietf@gmail.com>
Date: Mon, 13 Oct 2025 19:13:17 +0530
X-Gm-Features: AS18NWCmr1BxlClWMxTlc7q3X_QyV173lAfePw-7BSbYzyGZCoYk4XNsfmlWi80
Message-ID: <CAH6gdPyLu=1+xn+R2Ckqjyxp_k4pe2OsehnJdcJK2b0oU7Ffew@mail.gmail.com>
To: Dhruv Dhody <dd@dhruvdhody.com>
Content-Type: multipart/alternative; boundary="000000000000d25c8906410a7332"
Message-ID-Hash: PD67XGI5KN6TTYALVX5T2COGZUR5KY3W
X-Message-ID-Hash: PD67XGI5KN6TTYALVX5T2COGZUR5KY3W
X-MailFrom: ketant.ietf@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-pce.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Deb Cooley <debcooley1@gmail.com>, The IESG <iesg@ietf.org>, draft-ietf-pce-sid-algo@ietf.org, pce-chairs@ietf.org, pce@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
List-Id: Path Computation Element <pce.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/pce/Zkyxt5w5AH_J7HM0DkMFh6hAIkQ>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pce>
List-Help: <mailto:pce-request@ietf.org?subject=help>
List-Owner: <mailto:pce-owner@ietf.org>
List-Post: <mailto:pce@ietf.org>
List-Subscribe: <mailto:pce-join@ietf.org>
List-Unsubscribe: <mailto:pce-leave@ietf.org>

Hi Dhruv,

I missed that one. Yes, adding that reference would be perfect.

Thanks,
Ketan


On Mon, Oct 13, 2025 at 7:09 PM Dhruv Dhody <dd@dhruvdhody.com> wrote:

> Hi Ketan, Deb,
>
> The authors can also add an additional reference to -
> https://datatracker.ietf.org/doc/draft-ietf-pce-pceps-tls13/
> alongside RFC8253.
> It is in the RFC editor queue.
>
> Thanks!
> Dhruv
>
> On Mon, Oct 13, 2025 at 6:15 PM Ketan Talaulikar <ketant.ietf@gmail.com>
> wrote:
>
>> Hi Deb,
>>
>> The current text in Section 9, reads as follows:
>>
>> Hence, securing the PCEP session using Transport Layer Security (TLS) [
>> RFC8253
>> <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC8253>
>> ] is RECOMMENDED as per the recommendations and best current practices
>> described in [RFC9325
>> <https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC9325>
>> ].
>>
>> So, it does cover RFC9325 that you have pointed out. There isn't an
>> update of RFC8253 that is available, and so hopefully this is adequate
>> indication of the shift to TLS 1.3?
>>
>> Thanks,
>> Ketan
>>
>>
>> On Thu, Oct 9, 2025 at 4:02 PM Deb Cooley via Datatracker <
>> noreply@ietf.org> wrote:
>>
>>> Deb Cooley has entered the following ballot position for
>>> draft-ietf-pce-sid-algo-26: No Objection
>>>
>>> When responding, please keep the subject line intact and reply to all
>>> email addresses included in the To and CC lines. (Feel free to cut this
>>> introductory paragraph, however.)
>>>
>>>
>>> Please refer to
>>> https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
>>> for more information about how to handle DISCUSS and COMMENT positions.
>>>
>>>
>>> The document, along with other ballot positions, can be found here:
>>> https://datatracker.ietf.org/doc/draft-ietf-pce-sid-algo/
>>>
>>>
>>>
>>> ----------------------------------------------------------------------
>>> COMMENT:
>>> ----------------------------------------------------------------------
>>>
>>> Thank you for the secdir review by Alexey Melnikov.
>>>
>>> Section 9:  RFC 8253 is outdated because of the publication of TLS1.3
>>> (RFC8446). Consider listing BCP 195 vice RFC 9325 to ensure the most
>>> recent
>>> guidance for the implementation of TLS.
>>>
>>>
>>>
>>>