[Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)

"Samuel Sidor (ssidor)" <ssidor@cisco.com> Mon, 13 October 2025 14:31 UTC

Return-Path: <ssidor@cisco.com>
X-Original-To: pce@mail2.ietf.org
Delivered-To: pce@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id C4111727C3C7; Mon, 13 Oct 2025 07:31:57 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -11.886
X-Spam-Level:
X-Spam-Status: No, score=-11.886 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIMWL_WL_HIGH=-0.001, DKIMWL_WL_MED=-0.001, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001, T_SPF_HELO_PERMERROR=0.01, USER_IN_DEF_DKIM_WL=-7.5] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=cisco.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 1bHDe_mfBhrC; Mon, 13 Oct 2025 07:31:57 -0700 (PDT)
Received: from alln-iport-2.cisco.com (alln-iport-2.cisco.com [173.37.142.89]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 21180727C358; Mon, 13 Oct 2025 07:31:45 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=cisco.com; i=@cisco.com; l=18154; q=dns/txt; s=iport01; t=1760365905; x=1761575505; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=XHEOkodedcj6O9c9WIvlx+LC+6gAAdEvCLsXdfkFSqM=; b=e+D1drNau/LfZlQlH1mcohE9+lCP9yd5aGrs5wkj7aI9r3HCkc1CjMCu QMXi9XtRGEJPED6zbWKYcBJx8WWFVVkyVCY0k05JwNE34/RVr+tUGVgLa nDAF9E31u2oWY91MVqNECpAkRnQcrUG15pkbNs5dJmtPCuSD6ZPtUge63 9LGH6ct3YII5izbky8cpLtz1NLdmHDfvnnaj1FNXWJG5UyY7i77MQlkxB gGyw882kElkuCMl3iaXZpZsX3DIl4Y2rt/cBs0Njr5Wzxx7zrK65KJ2z3 1QA9j1WB/snqtRc6g+emLr2GN99HFxJefAE0FI3s+BGgP3REDbbVwv9wa w==;
X-CSE-ConnectionGUID: b48YsynUTRaQHTd5rCPFdw==
X-CSE-MsgGUID: EzCJIsomRne5rLcMCm64hg==
X-IPAS-Result: A0BhAwCcC+1o/40QJK1aHAEBAQEBAQcBARIBAQQEAQFlgSuBPTFSB3uBIEmEVINMA4UsiHgDi2SLX4ZrgWsPAQEBDQJKBwQBAYUHAhaMMwImOBMBAgQBAQEBAwIDAQEBAQEBAQEBAQELAQEFAQEBAgEHBYEOE4ZPDYZaAQEBAQMSEVYQAgEIDgMDAQIoAwICAh4RFAkIAgQBDQUIGoJhgh0dAzYDAQIOBqItAYFAAooreoEygQGDbEHZEQ2CVQaBSogzHgEqgTQCDoF2gggbIIQ9JxuBSUSBFUKCaD6CH0IBAQIBgSgBEgEjHhaDJTqCLwSCDRV6FB2BaYQueYExR4E4i2xSciIDJjMsAVUTFwsHBYEgQwMqNC0jSwUtHYEnIiEeE2BUQINJEAsGaA8GgRMZSQICAgUCQjqBagYcBh8SAgMBAgI6Vw2BdwICBIIxgRKCKg+ESwMLbT03FBsFBIE1BZBmQhmCByaBCiYEDRUZFgJ/bBcRGQ6TJwqDIwFJi2COX5QmcQqEHIwejz0Ehi4XhASNE5htZ5kGIoI2izCECZFfhSYCBAIEBQIQAQEGgX8laXBwFYJuAQEBMVIZD44tFohxtE54AgE5AgcBCgEBAwmTZwEB
IronPort-PHdr: A9a23:ErHSFRJPf2El5tyBEdmcuVQyDhhOgF28FgcR7pxijKpBbeH4uZ/jJ 0fYo/5qiQyBUYba7qdcgvHN++D7WGMG6Iqcqn1KbpFWVhEEhMlX1wwtCcKIEwv6edbhbjcxG 4JJU1oNwg==
IronPort-Data: A9a23:gnTwham/9nqmh1zpRXe64aXo5gyBJ0RdPkR7XQ2eYbSJt1+Wr1Gzt xIfDG/SMvncNmPxfN9/Ydy2pE4G68LTx9dhTlE5+S8yH1tH+JHPbTi7wugcHM8zwunrFh8PA xA2M4GYRCwMZiaC4E/raP649CMUOZigHtLUEPTDNj16WThqQSIgjQMLs+Mii+aEu/Dha++2k Y20+py31GONgWYubztMsvnb8XuDgdyr0N8mlg1mDRx0lAe2e0k9VPo3Oay3Jn3kdYhYdsbSb /rD1ryw4lTC9B4rDN6/+p6jGqHdauePVeQmoiM+t5mK2nCulARrukoIHKZ0hXNsttm8t4sZJ OOhGnCHYVxB0qXkwIzxWvTDes10FfUuFLTveRBTvSEPpqHLWyOE/hlgMK05FYdEqtdsEGdzy cYRERAxYk2ZrNqYzK3uH4GAhux7RCXqFIobvnclyXTSCuwrBMifBa7L/tRfmjw3g6iiH96HO JFfMmQpNUqGOkEWUrsUIMpWcOOAnWL+fzpCgFmUvqEwpWPUyWSd1ZCwb4qEJ4HWHZU9ckCwi 3Dt3UXiBRQgMtHC0x6O11mp2LPPknauMG4VPPjinhJwu3Wf3GUdFFgXWEe15OGyhwulWt4aI kgb/QIvoLQ8skuxQbHVXhCjr1aFswISHd1KHIUS8AqAj6HU6geDHUAFQyJPLts8u6ceXTcn/ l6Eg92vAiZg2IB5UlqU8rOS6Df3Mi8PICpaOWkPTBAO5J/op4RbYg/zc+uP2ZWd17XdMTrx2 DuN6iM5gt0uYQQjjM1XIXivb+qQm6X0
IronPort-HdrOrdr: A9a23:ilWg3Kz/486P8bieFW1ZKrPxUegkLtp133Aq2lEZdPULSL36qy n+ppQmPEHP6Qr5AEtQ5+xoWJPtfZvdnaQFh7X5To3SLTUO2VHYY72KgrGSuQEIdxeOktK1kJ 0QDJSWa+eAQ2SS7/yKnTVQeuxIqLLogcLY4Ns2jU0dMT2CAJsQljuRfzzraXGeMzM2fabReq DsgfZvln6LQ1hSRMK9AXUOQujEoPP2tL+OW3Q7Li9iwjOjyRez5pDHMzXw5HojujV0rosKwC zgqUjU96+ju/a0xlv3zGnI9albn9Pn159qGNGMotJ9EEStti+YIKBaH5GStjE8p++irHwwls PXnhsmN8Nvr1vMY2COpwf30QWI6kds15ai8y7bvZLQm728eNsIMbsHuWufSGqe16MUhqA47E uM5RPBi3MYN2KZoM233am5a/gjrDvGnZNlq59Ts5SaOrFuMoO4auckjRhoOYZFEyTg5I89Fu 5ySMna+fZNaFufK2vUp2913bWXLz4O9zq9MwA/U/auonNrtWE8y1FdyN0Un38G+p54Q55Y5/ 7cOqAtkL1VVMcZYa90Ge9EGKKMeyDwaAOJNHjXLUXsFakBNX6Io5nr4K8t7OXvfJAT1pM9lJ nITVsdv28vfEDlD9GIwfRwg13waXT4WS6oxtBV5pB/tLG5TL33MTebQFRriMekq+V3OLyTZx 9yAuMhPxbOFxqYJW8S5XyKZ7BCbX0FFNYYstwnW1SIuKvwW//XX8TgAYLuGIY=
X-Talos-CUID: 9a23:lG27+WxpW825t0u0ZPbHBgUeRpAUaWzb8UvqKnaYNWo0UpatZ1OPrfY=
X-Talos-MUID: 9a23:zhs2IwnnIeB6zcac6+2QdnpPJuxKwr+pDXoLnMgcn8KhHikuZzeS2WE=
X-IronPort-Anti-Spam-Filtered: true
Received: from alln-l-core-04.cisco.com ([173.36.16.141]) by alln-iport-2.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 13 Oct 2025 14:31:44 +0000
Received: from alln-opgw-3.cisco.com (alln-opgw-3.cisco.com [173.37.147.251]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by alln-l-core-04.cisco.com (Postfix) with ESMTPS id CEFA0180004A7; Mon, 13 Oct 2025 14:31:43 +0000 (GMT)
X-CSE-ConnectionGUID: CEIfzr8ATU+9J4/H6E+lFQ==
X-CSE-MsgGUID: V6mA8ERcRA2u/eYO5zPcdg==
Authentication-Results: alln-opgw-3.cisco.com; dkim=pass (signature verified) header.i=@cisco.com
X-IronPort-AV: E=Sophos;i="6.19,225,1754956800"; d="scan'208,217";a="34545158"
Received: from mail-dm5pr08cu00400.outbound.protection.outlook.com (HELO DM5PR08CU004.outbound.protection.outlook.com) ([40.93.13.96]) by alln-opgw-3.cisco.com with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 13 Oct 2025 14:31:43 +0000
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=a+ETmHxVedvnQ18RfY+V3RvpnU2BiVIW0DG+c2L5AsXV+TouNo/jT7NXOGJKrDtoPFkOwf2rmn9sZeKuA4+YnVpYZnXnmx+VtZZNCt2s06PJknDt9Gt0JEBMl3rQAFssgrLU4p3gg3xK7a9Ke4esu86f4YUaeTunPigXmx7bNeLoMWGo+H8sPDd8lFCtHW/Bq8oKAHRPwwyXaAvAo6mEN4YKN9DvxJBLgM1IjFwl3vS4HwrwpVAjNnkypCtT4PlHHdoOiEug5v83peHmncqw7KDSFRKhExKBgo8iQ9cIWCtKvRDhk40RInEZn7iYpQ2r+wV9PoaQ/jssxuY6EBgS4A==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=XHEOkodedcj6O9c9WIvlx+LC+6gAAdEvCLsXdfkFSqM=; b=fB/cbeww+J5L2frJxKMBHS5hStwkjZmwJia/X9mz85BrHi/pUUh89GBfoZhRw39xp1EIbBWs5p7PVLDw5U2OTos3adBJgQVbcLCeJ7MZY9IqdHE9UeLo9yvUwiCsDQ8ByzhXq1OwvcGwLEnT7c8q3gMnELv7J6ghTitq83kiHINhu/YlKxnBj4VLdOaUK5e+MW8mvCpnzsEnU6sLFHsUF586zATautbnGOSaehYmqVxfJih7yvj2ONjYUf59USEeAwdhOe7DoiLXlIcbeRxZAaz5289dUSoPHS0YCvuwW4YHn9z2Tw7gRf85bdBO0P2NKR9uryhUkayIgSAGaH+pAg==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=cisco.com; dmarc=pass action=none header.from=cisco.com; dkim=pass header.d=cisco.com; arc=none
Received: from IA0PR11MB7792.namprd11.prod.outlook.com (2603:10b6:208:409::16) by PH0PR11MB5158.namprd11.prod.outlook.com (2603:10b6:510:3b::13) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.20.9203.13; Mon, 13 Oct 2025 14:31:41 +0000
Received: from IA0PR11MB7792.namprd11.prod.outlook.com ([fe80::385b:609e:4289:5e04]) by IA0PR11MB7792.namprd11.prod.outlook.com ([fe80::385b:609e:4289:5e04%5]) with mapi id 15.20.9203.009; Mon, 13 Oct 2025 14:31:41 +0000
From: "Samuel Sidor (ssidor)" <ssidor@cisco.com>
To: Dhruv Dhody <dd@dhruvdhody.com>, Ketan Talaulikar <ketant.ietf@gmail.com>
Thread-Topic: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
Thread-Index: AQHcOQgDeSARJW+JJE+wd4U2m6mHZLTADHKAgAAOyQCAAA2IJg==
Date: Mon, 13 Oct 2025 14:31:41 +0000
Message-ID: <IA0PR11MB77920319EAAB2108D1309FAED0EAA@IA0PR11MB7792.namprd11.prod.outlook.com>
References: <176000592968.239612.4429182568224091262@dt-datatracker-6c6cdf7f94-h6rnn> <CAH6gdPytMa5s9JMfLBgm+J8j7tkN0bAshHL8n3L6_2AXkUTyOg@mail.gmail.com> <CAP7zK5apnH+au4PcDwVqYtUQ=5xCjJ0_XoY9x6qgA06+PckOVg@mail.gmail.com>
In-Reply-To: <CAP7zK5apnH+au4PcDwVqYtUQ=5xCjJ0_XoY9x6qgA06+PckOVg@mail.gmail.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-reactions: allow
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: IA0PR11MB7792:EE_|PH0PR11MB5158:EE_
x-ms-office365-filtering-correlation-id: b8c74b8d-c637-4cfc-b434-08de0a6539f4
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|1800799024|376014|366016|8096899003|7053199007|38070700021|13003099007;
x-microsoft-antispam-message-info: B0dUxUXsmP3cDKUATDGryhD+6C01u9N3bqVEvdvncGx1W389vfnNaW2cHTgiBBo4oLgPPS9w1t1eusDWJnuF4ZBQuk/9HB2kRrqiI9joTUYbekzlgd+qPU5gfOmgz5PN814ehdzAmLP8WkWL+IjFLCvcTjAzgp3JORxG9F5lXTtLgOjchka57c9qiv+f8grPvPwpCUZPNNMaGNP5qVEfbBugP78U8aLiK80iISUdQ2GeGo1+0vsZpWGJ6iiJwpwtLUzHMmNzZdaWuItX4NgbKxMUJzzQJ04LWdITCi4m0ykcAs6Bw7aP1ojlm8aGRqDJkS+KLxP4ppFZkx2mTaKsiCkefZe3ZZEFh6BFA+lxzv3DR7SpcGE+PwwK2WjMAtSEVst4Wo3ql1VsaTeil9ON62ApbzZOq5ZyCdIK8c7eEHtXOHs+c6wdLX7CKtu2/mTBM3Oga8uc3Ax1Z8yBzYA1fYLdcPgMh+zokoT+sc+bR0CayfIGqAxtaUE0AGsub3IViTNDBTDygwGkRCuLWkO9s19pJkBX3sq1ODPtyCXUp5V7dZ3+mcxsTmwHFGDL5hAAQdKNsemzrprnMV/x4IXI3rbMWf/Ez3Dr3oLcut/V7rGNm95MQ1imwekiy4JZsf7AJVio68i9La+FWn+mzbM6rdkb03Lg0pOj6E3lDXoHqp77Gp+qqCM/8J6ZGK7GjHt+S3ygORkAK80KHByu6UbVM+gO2u7OZnEZIH+KSI+wgl7r+NZxsdCMhlbXcIdgfH2hMJZLjP26Rj/julqzZvwM5NuVBcivffFjIGVF4JeHhvmr+q2rCCnL0pyl9rCoyKs1bMCbst35fC95SlrVx2/uR8GnMllIrjbJxanNUFaiu5rNyKwcFxKyIdp3tObjrjTZ/BqgvNHmnwccr2qha1q6rFfc2UNoF3IkZjsRN/GvWF2Pk0+9cdR1g0i7gU+fReMi11ElM/mKi0QwRRYl6vbIJZe3acwI3xRMmhfWHDVs7tda+HoHe6ByaJk52QoK163bML7oy4UePaNBQlLLhFa/AxF5CGGcahV7kLjzkWdElVMWjcq1i89Z94Pm6+DvnRDGRhadKSDJz6L49QQjQtnSQ5eLm4XPsWTbOJq1FhtPEO763i1IUdthbxYEpX4xkXBcb5q6WThkJY2mrgGcw3rLXHVX5L+eyTgRdBMuqf45axYXpNPUSseagprWPS4ZuQ18VM+CIAkBVO0rgXDFmB+C7auO18Sktpo23FWxe8iHsjuLNoiDxrGy/qb+CeFyfacMZdrrqq09D2CAgTv2+GKxoKpC5BPQiw4gtdrXPIdqXWsuyayfFqgo0H7BAn7c6NKq1QIT2U0o39QC+hmVRScBXM5/043NZi7r38yXz7EryG/pWbbwI/Z/yd8JsHM5Tz98hB++4oLe4zYJNb6WWZOQIcLddr9QtPOCNNPZwzhNntHWDay5ZuUUCXFIVPt4agrh3oToZKz8KX72TgDK2tZeWxzOa/380UD8jLP7Cf5iNtmuILxL/+wQNLXxpAF7H143F+tD2pQ/DYr2PlmWm+y56g==
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:IA0PR11MB7792.namprd11.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(1800799024)(376014)(366016)(8096899003)(7053199007)(38070700021)(13003099007);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: luPiuWnljA2QSCVlWisyuZejH8U9nfc1LLCi134knE5QLGfk1BzuFp2QFBx5dBxgtRMQfBXowERsJgUF6J797ltM1Wg940ZDTPPtN9EYNeDyUs0YeoeMlFK/+hMC9H9qN/13/1Ylf1+ccdGcZ/8Jd6+nIVzjmVNydiCdH76Ls5+MX4ntU5bc7ufVE1YxP0i+Fv5msOgVx0R7s/5j0MaIo2l942f1p7SMwgN2+roqnIjH30A7rdaMkfRD5FpTz1Xp8DvvS5LoyvIWtE5uP1OfjoUkLD2QEdhCAs9Jcrb8vbE47ejkokTa/w4crk66XSw1C1VIKyKU1c+7wpTYv3t+Cxpz1LlEfREvplhMAKuOSnrVhTDad7NWTZ71FEZiX8Q5PYhawAWvclTTKvrhsU3Nb5mGIHnrTefZm3kwVQWM7FC5tOsp09m8zf3O1CYH6GDBMML2y0K1RcQesp5UW2aYXCwBRnB2WyZthD4Fow1kG4hAuyxPjwvh7Zhn1Em+yz7Q9lVbJAE2jldoHuddR8ufd60TYUZgcx6tVpcNl/cMTJJ7BcWM3WLgB9xqbMHqNj8cPsfMahfUvUnmk++ga3r3BKhXbB+vezcdZQ8lHB4sDkUT/9n90tpXYGDYsuGuS0M7BGaaYBimnOdI4WyeVwx+3WDJPgjIm98GN+3ucNZUwpxm+eZWKnn/JiHGRPccnfFDe7rn87NH5bSQXAgpWsm4M/zW0QALj4bc0H5cRuL0nAiu+YZG6ek6/jsAHwVK5v/pQXVz3lZbVNPYqqmdKyoh+wFLUfdL/E/FeUFXE0ulzdpQMH+O5517MvHQGTsXrL63FeehBqh5kOyzTz+OcOTw4drKBW2y/E2p+L5ubDQCubIOUvM1ZOpao2/gYtQr7eUL043AHAeCJJtyoldxV2kUrhkx7zf5lnwD7RdvdSwSpDlEEkY22Lpj1OkXWCnCiEasdtvnLjYzQk+Lt0tdsEXFR64WLEdcpb8PmRlkMYCd9AtXEp8eaGXidO2tUoJxBH7zYyCayD/x3bhmx6FNPqhspBvDiUGtRcPY8/SJ7HP+HyzjHpV42atfhKjN8evSWmcGD0eMIC2ZZJ55LFTHEAqdSnk/H+327ymjwqwOb7YS5Zzl8PqUduXcvTgpv6OwPJtXUhht2wPDP0I76T+2YB7ZTiIsEXpO2ZoZmG6DpcYFpD+CA0Rc8rzcdkfU7BsShKVBXvqDDtAToGhy5JTXDimI9AQCpGPM0tGo/ffBA0MlcGdGIcE2n6BdAh51DXCBePziScyASgPoAl7DXkYGpl2aFuCGnMbrbKWnReDgDMHGEIk8jQMkgaOcCct9wuQ3w298icXbdziP/gqyiuqULJdtOMhcsfzV1vmmJTdR5Wx4g3m8IVi7B5prMO/t5gYVQNfp1ie/A6J3VoeVfMZM+8/dOfxC2+sxASLFyIl+bYW387wKYDeTiKVwMBv2HoMkx6Hoy6d5WZ6H4DB0cRGMQrnTjlniLRTSRwg3+Bf8DM1Mcee5aL5YRQlwSkzzk/WCbD0tPA6X8ovAOwuRJyRGLva+tuP6m8t2Tg7er7Av4IU+ysqGBDqh7VxkMlC6CXCVdqp2XMiqNDFLMmPXEouxXWtlOA==
Content-Type: multipart/alternative; boundary="_000_IA0PR11MB77920319EAAB2108D1309FAED0EAAIA0PR11MB7792namp_"
MIME-Version: 1.0
X-OriginatorOrg: cisco.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: IA0PR11MB7792.namprd11.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: b8c74b8d-c637-4cfc-b434-08de0a6539f4
X-MS-Exchange-CrossTenant-originalarrivaltime: 13 Oct 2025 14:31:41.3459 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 5ae1af62-9505-4097-a69a-c1553ef7840e
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: y0i8AhNfdAhnMcMtpGZxLY/Wv81vqbpEqFf3GNBBZukd1vqUdCT4Dd8A4s6nn8g+ZJQ2kY2arulvn+Sbk0zY1w==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: PH0PR11MB5158
X-Outbound-SMTP-Client: 173.37.147.251, alln-opgw-3.cisco.com
X-Outbound-Node: alln-l-core-04.cisco.com
Message-ID-Hash: I44NEOAZDQL2PFN7NBMEU5PZ2LIKK4Z4
X-Message-ID-Hash: I44NEOAZDQL2PFN7NBMEU5PZ2LIKK4Z4
X-MailFrom: ssidor@cisco.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-pce.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: Deb Cooley <debcooley1@gmail.com>, The IESG <iesg@ietf.org>, "draft-ietf-pce-sid-algo@ietf.org" <draft-ietf-pce-sid-algo@ietf.org>, "pce-chairs@ietf.org" <pce-chairs@ietf.org>, "pce@ietf.org" <pce@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Pce] Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)
List-Id: Path Computation Element <pce.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/pce/peJmCznOznM2Et_75Athik-ZiKE>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pce>
List-Help: <mailto:pce-request@ietf.org?subject=help>
List-Owner: <mailto:pce-owner@ietf.org>
List-Post: <mailto:pce@ietf.org>
List-Subscribe: <mailto:pce-join@ietf.org>
List-Unsubscribe: <mailto:pce-leave@ietf.org>

Thanks Deb, Dhruv, Ketan for comment and discussion.

I'll update last statement in “Security Considerations” to:

“Hence, securing the PCEP session using Transport Layer Security (TLS) [RFC8253<https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC8253>][I-D.ietf-pce-pceps-tls13<https://www.ietf.org/archive/id/draft-ietf-pce-pcep-extension-pce-controller-sr-11.html#I-D.ietf-pce-pceps-tls13>] is RECOMMENDED as per the recommendations and best current practices described in [RFC9325<https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC9325>]."

Regards,
Samuel

From: Dhruv Dhody <dd@dhruvdhody.com>
Date: Monday, 13 October 2025 at 15:39
To: Ketan Talaulikar <ketant.ietf@gmail.com>
Cc: Deb Cooley <debcooley1@gmail.com>, The IESG <iesg@ietf.org>, draft-ietf-pce-sid-algo@ietf.org <draft-ietf-pce-sid-algo@ietf.org>, pce-chairs@ietf.org <pce-chairs@ietf.org>, pce@ietf.org <pce@ietf.org>
Subject: Re: Deb Cooley's No Objection on draft-ietf-pce-sid-algo-26: (with COMMENT)

Hi Ketan, Deb,

The authors can also add an additional reference to - https://datatracker.ietf.org/doc/draft-ietf-pce-pceps-tls13/ alongside RFC8253.
It is in the RFC editor queue.

Thanks!
Dhruv

On Mon, Oct 13, 2025 at 6:15 PM Ketan Talaulikar <ketant.ietf@gmail.com<mailto:ketant.ietf@gmail.com>> wrote:
Hi Deb,

The current text in Section 9, reads as follows:

Hence, securing the PCEP session using Transport Layer Security (TLS) [RFC8253<https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC8253>] is RECOMMENDED as per the recommendations and best current practices described in [RFC9325<https://www.ietf.org/archive/id/draft-ietf-pce-sid-algo-27.html#RFC9325>]

So, it does cover RFC9325 that you have pointed out. There isn't an update of RFC8253 that is available, and so hopefully this is adequate indication of the shift to TLS 1.3?

Thanks,
Ketan


On Thu, Oct 9, 2025 at 4:02 PM Deb Cooley via Datatracker <noreply@ietf.org<mailto:noreply@ietf.org>> wrote:
Deb Cooley has entered the following ballot position for
draft-ietf-pce-sid-algo-26: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-sid-algo/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the secdir review by Alexey Melnikov.

Section 9:  RFC 8253 is outdated because of the publication of TLS1.3
(RFC8446). Consider listing BCP 195 vice RFC 9325 to ensure the most recent
guidance for the implementation of TLS.