[Pce] Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions

Dhruv Dhody <dd@dhruvdhody.com> Thu, 30 October 2025 07:47 UTC

Return-Path: <dd@dhruvdhody.com>
X-Original-To: pce@mail2.ietf.org
Delivered-To: pce@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id EFF847EBCD6A for <pce@mail2.ietf.org>; Thu, 30 Oct 2025 00:47:24 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -1.897
X-Spam-Level:
X-Spam-Status: No, score=-1.897 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=dhruvdhody-com.20230601.gappssmtp.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Rtzb13SNbNY1 for <pce@mail2.ietf.org>; Thu, 30 Oct 2025 00:47:24 -0700 (PDT)
Received: from mail-oa1-x29.google.com (mail-oa1-x29.google.com [IPv6:2001:4860:4864:20::29]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 579D57EBCD63 for <pce@ietf.org>; Thu, 30 Oct 2025 00:47:24 -0700 (PDT)
Received: by mail-oa1-x29.google.com with SMTP id 586e51a60fabf-3c98f1c9973so83306fac.0 for <pce@ietf.org>; Thu, 30 Oct 2025 00:47:24 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=dhruvdhody-com.20230601.gappssmtp.com; s=20230601; t=1761810443; x=1762415243; darn=ietf.org; h=cc:to:subject:message-id:date:from:mime-version:from:to:cc:subject :date:message-id:reply-to; bh=YM0G+FRhMCpS9rSA8uvpBOtpAqzfF0tocqdLNsU++2o=; b=gc55atO5k076v1sycruZURo5GP3Ng82t1pWgpITZxx5n8gaLiAPsdlBteFOFAcmZfp A3OD/cdNKklQYYPJFUeDDvtf5eNfAB3kDbQxmQXGDJcNxZmU4PLWBV5X+1/kRyTMgwAL HpCGuoaoNJGDXfuCIcXgf4iSeS9M6zSwT8GJIypF7swwiiVNbD8Og/na9HvdFVwtVXVl h+u+q0+uL+K6WQ0ugQPSJjCkc/nAjzV9gTQjnGICNkXK2QWNIit5cLvIaRpzmWFJwvla au/Z3DBDLDctx3+jkXntIeLLhwN+qkghSZ9BgJ5aoBPu3om5UbYFPU3a+VUS80epNamr wJMA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1761810443; x=1762415243; h=cc:to:subject:message-id:date:from:mime-version:x-gm-message-state :from:to:cc:subject:date:message-id:reply-to; bh=YM0G+FRhMCpS9rSA8uvpBOtpAqzfF0tocqdLNsU++2o=; b=ih2dFf+E9O/n9vHVI43k9JXW2X0b0HgJdugoZLDkSoeQRUE5JtHbQnhM6zyY9DRX9K TAMmRGLq/r8JH+yHoQsKWzYQlloHvJCbjFWIfb9l+zcFCokiJm62Nk9rqRdN9FThDOGS pnMi3hPFaT3iCtKpupmY/uUWrfDxN/hH7sOZtG9jLuUq01TkpsDQ4HxBkX2YOuUvn/2g EoL1w+N1TXLrqr7yL4A2snJLlzFEUfWA0D51iDnBKS2d+NnrEytTfpQi3OLh7rCRiHf6 MUrgsEnxz9jdvymuMTs2E8h9hs9KIPAm62TlglX8DpkphjLWNDcbexSK58mvBT7CBu4x BhtQ==
X-Gm-Message-State: AOJu0Yyv4Lv5QAyaQzJ1/Mpa7/7cKZXYOOqOFaUPCVgVRlTtFsbe2crC fvTlGIrKnAxHj052goGi2VfUvclJGMzodPhbKs6SuDtyiV/PZS3nMDOXlERe3+5RI5tn4+1mzW9 RGWKIYBbFOf4yCc8OALWiNoDg+d4X0LFvVKmgYo82xA==
X-Gm-Gg: ASbGncvdlJTx6d9DDCLAlw9AxjW98mCEEy/bc5nHnzzw6hDm0u4QLp9Q3+DE7nlBXMz wppPqC6Y8H2KfFxrXjMQekSuWuZporznJzmG08f3JU+RLjBQVBHTqepNNMvOXVTe0rBSbZF1geo wvs7LmAuyzGDXpz1gqYvE3b8ahV4F/SuubzF6oXBT2EZ955PlXI/cQ7YDrCv1cjUtdLMoMtOGB4 0EqRiLSqA1Evp3gk+hS2aZyj/vyTXNNUQzTM5Ck3oCsDNr7EU/tSBNZU0jPEdqGA2QAzzKxjaKG zZoxbJCvfv6Yb9wBXNKM1JGGUM8UMgEEQlPVJY2WGX/0KOPMyxP1GYZAZS3XyRCehIfZV1yXB0a MmBofckp2ntP4G+lAEx1o9xWbj+P0bRCdG0nF38EGGX2+k8HVwqJIdUZLJiXB
X-Google-Smtp-Source: AGHT+IEF4AJAgIMRyDKFSb8SqZUdKIpgEDl+6jb3/DJYlw4lyUQyvZJR0DvoBlgTa/HBouIIc1QJTpQQioz0aaSdYtU=
X-Received: by 2002:a05:6870:d61e:b0:3d2:a5a:4334 with SMTP id 586e51a60fabf-3d749913700mr1385800fac.1.1761810443467; Thu, 30 Oct 2025 00:47:23 -0700 (PDT)
MIME-Version: 1.0
From: Dhruv Dhody <dd@dhruvdhody.com>
Date: Thu, 30 Oct 2025 07:46:47 +0000
X-Gm-Features: AWmQ_bmU596lHabkp-phDb9zIF7wE4LutdXxnsEXxR2A-LZEZfF8aFxR5uL1K2M
Message-ID: <CAP7zK5bLJEv=16ziB=maRhtg2BJnurZVBkxd2q8NgXG88=9Y6A@mail.gmail.com>
To: draft-ietf-pce-circuit-style-pcep-extensions@ietf.org
Content-Type: multipart/alternative; boundary="000000000000a5108f06425b75a3"
Message-ID-Hash: FFCH3SNRQV2YFVVZYG2T5TJ7QCJOWPDQ
X-Message-ID-Hash: FFCH3SNRQV2YFVVZYG2T5TJ7QCJOWPDQ
X-MailFrom: dd@dhruvdhody.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-pce.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: pce@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Pce] Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions
List-Id: Path Computation Element <pce.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/pce/zI9J0dpkKYMu2iMrfgESfaamwUc>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pce>
List-Help: <mailto:pce-request@ietf.org?subject=help>
List-Owner: <mailto:pce-owner@ietf.org>
List-Post: <mailto:pce@ietf.org>
List-Subscribe: <mailto:pce-join@ietf.org>
List-Unsubscribe: <mailto:pce-leave@ietf.org>

Hi Authors,

I have done the Shepherd review of the I-D. Once the update is posted, I
will send this to the AD.

# Shepherd Review of draft-ietf-pce-circuit-style-pcep-extensions

## Minor
- Abstract uses the term "distinct hop requirements" where the term is not
used anywhere in this or SPRING document.

- In "[RFC8664] introduces the concept of Segment Routing Policy (SR
Policy)" - this should be RFC 9256. If you want to talk about RFC 8664, say
that it introduces SR to PCEP.

- Section 2, also add SR terms like SR Policy, SID etc

- Section 3, directly jumps to extension. It would benefit from some
initial summary text before all the details, example -
````
This section specifies the PCEP extensions that enable a PCC and PCE to
support Circuit-Style (CS) SR policies.  These extensions build on the
base PCEP [RFC5440], the Stateful PCE extensions [RFC8231], and the
Segment Routing (SR) Policy extensions [RFC9603].  The mechanisms defined
here allow a PCC or PCE to:

  * indicate the requirement for strict paths,
  * signal path persistency by disabling recomputation for specific paths,
  * identify and control behavior specific to Circuit-Style SR policies.

Unless explicitly stated, the procedures of existing PCEP messages and
objects remain unchanged.  The following subsections describe the specific
object formats, TLVs, and flag definitions introduced to realize this
functionality.
````

- Figure 1, shift the numbers 0,1,2... to right by 1 space, they need to
correspond to - and not +

- Section 3.3, this text - "If this flag is cleared, then the PCE SHOULD
recompute the path if the original path is invalidated."; can we add
'according to local policy' as we use in other PCE RFC? Also in section
4.2, you use MAY for this flag, be consistent.

- Section 4.1, no need to use BCP14's MAY in "Existing O flag in RP object
MAY be used to indicate similar behavior in PCReq and PCRep messages as
described in as described in Section 7.4.1 of [RFC5440]." as this is about
existing behavior. Further "If the O flag is set to 1 for both stateful and
stateless messages for SR paths introduced in [RFC8664]...", this is
unclear to me. Why both..and? Suppose the O flag in RP was not set during
PCReq but set in PCRpt in TLV would the PCE not process it?

- Section 4.2, "The presence of the TLV blocks path recomputation.." is
conflicting with Section 3.3 "the PCE MUST NOT recompute the path in cases
specified by flags.." - I think flags need to be set to block recomputation
and it should not be just the presence of the TLV.

- Section 4.2, "For example, if the same path can be encoded using
Adjacency, Binding, Prefix, or other SIDs, then PCE MAY switch between
various representations of the same path", the use of MAY inside a sentence
that starts for example, is not ideal.

- Section 4.2, "The only exception is an explicit request from the operator
to recompute the path." it would be clearer to explicitly state how
operator request recomputation.

- Section 4.2, do we need error handling in case the flags are set but PCE
still tries to recompute/update a new path?


## Nits
- s/This document proposes a set of extensions/This document specifies a
set of extensions/

- s/[RFC8664] introduces the concept of Segment Routing Policy (SR Policy)

Thanks!
Dhruv