Re: [quicwg/base-drafts] Adds substantive descriptions of loss detection mechanisms (#801)
ianswett <notifications@github.com> Thu, 28 September 2017 14:31 UTC
Return-Path: <bounces+848413-a050-quic-issues=ietf.org@sgmail.github.com>
X-Original-To: quic-issues@ietfa.amsl.com
Delivered-To: quic-issues@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C4A711331E4 for <quic-issues@ietfa.amsl.com>; Thu, 28 Sep 2017 07:31:34 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.019
X-Spam-Level:
X-Spam-Status: No, score=-2.019 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, HTML_MESSAGE=0.001, RCVD_IN_MSPIKE_H4=-0.01, RCVD_IN_MSPIKE_WL=-0.01, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=github.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id yT8M1VMcr28w for <quic-issues@ietfa.amsl.com>; Thu, 28 Sep 2017 07:31:29 -0700 (PDT)
Received: from o4.sgmail.github.com (o4.sgmail.github.com [192.254.112.99]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id BA1D21331DD for <quic-issues@ietf.org>; Thu, 28 Sep 2017 07:31:27 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=github.com; h=from:reply-to:to:cc:in-reply-to:references:subject:mime-version:content-type:content-transfer-encoding:list-id:list-archive:list-post:list-unsubscribe; s=s20150108; bh=dCH5EFdSdKdOwYXliKHr4RqJAro=; b=XsE3UujCVyIwkTGA Fa2JmCe7nnNL682QVgY5s56N4d8ov5imYRpKtXThwZNM7sIhk5oGif/nrGIBV0IF R+rogHRudPm0b+zwEqHLYgVphVKz7+ZeNcDc+ZWxXpZHS2G8e2XGCD9OQn78pH8h Sf7zIJDBd1fgth6Ec1BUCUgVeDw=
Received: by filter0842p1mdw1.sendgrid.net with SMTP id filter0842p1mdw1-12570-59CD0759-2D 2017-09-28 14:29:45.460541102 +0000 UTC
Received: from github-smtp2b-ext-cp1-prd.iad.github.net (github-smtp2b-ext-cp1-prd.iad.github.net [192.30.253.17]) by ismtpd0021p1iad2.sendgrid.net (SG) with ESMTP id aZCj48GTSYuEZSi9w23Siw for <quic-issues@ietf.org>; Thu, 28 Sep 2017 14:29:45.424 +0000 (UTC)
Date: Thu, 28 Sep 2017 14:29:45 +0000
From: ianswett <notifications@github.com>
Reply-To: quicwg/base-drafts <reply+0166e4ab5cc5fafa75d4406a0bb0bbc1dfa0cc511f314e4b92cf0000000115e4c95892a169ce0f90cf76@reply.github.com>
To: quicwg/base-drafts <base-drafts@noreply.github.com>
Cc: Subscribed <subscribed@noreply.github.com>
Message-ID: <quicwg/base-drafts/pull/801/review/65854911@github.com>
In-Reply-To: <quicwg/base-drafts/pull/801@github.com>
References: <quicwg/base-drafts/pull/801@github.com>
Subject: Re: [quicwg/base-drafts] Adds substantive descriptions of loss detection mechanisms (#801)
Mime-Version: 1.0
Content-Type: multipart/alternative; boundary="--==_mimepart_59cd0759294c2_1f3ce3feb89df0f346344"; charset="UTF-8"
Content-Transfer-Encoding: 7bit
Precedence: list
X-GitHub-Sender: ianswett
X-GitHub-Recipient: quic-issues
X-GitHub-Reason: subscribed
X-Auto-Response-Suppress: All
X-GitHub-Recipient-Address: quic-issues@ietf.org
X-SG-EID: l64QuQ2uJCcEyUykJbxN122A6QRmEpucztpreh3Pak1jirM9xpDEw1GqAK2Hpf9qtKkPYGcNGC7fVO ZqINzs4fB0TbiMlKQCkIPqoLK8/OopLEtasbfgBh5IwQ7T+QdV8qnMJm0wbFCBrpnxu/rZ+8kcqTst 6Ohn9yE075zScBT3cDu+Z1jyLCwfcxsb8KbsWMyo2gMzNUii3oAEcYe6Gms6sN//pXsXRDj/AuYRTh 0=
Archived-At: <https://mailarchive.ietf.org/arch/msg/quic-issues/NOG6nYPJCHF7RhCKUb21LqwukyE>
X-BeenThere: quic-issues@ietf.org
X-Mailman-Version: 2.1.22
List-Id: Notification list for GitHub issues related to the QUIC WG <quic-issues.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/quic-issues>, <mailto:quic-issues-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/quic-issues/>
List-Post: <mailto:quic-issues@ietf.org>
List-Help: <mailto:quic-issues-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/quic-issues>, <mailto:quic-issues-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 28 Sep 2017 14:31:35 -0000
ianswett commented on this pull request.
Lots of comments, but I like the content and structure.
> - TCP's Tail Loss Probe.
-
- * If all else fails, a Retransmission Timeout (RTO) alarm is always set when
- any retransmittable packet is outstanding. When this alarm fires, all
- unacknowledged packets are marked as lost.
-
- * Instead of a packet threshold to tolerate reordering, a QUIC sender may use
- a time threshold. This allows for senders to be tolerant of short periods of
- significant reordering. In this mechanism, a QUIC sender marks a packet as
- lost when a larger packet number is acknowledged and a threshold amount of
- time has passed since the packet was sent.
-
- * Handshake packets, which contain STREAM frames for stream 0, are
- critical to QUIC transport and crypto negotiation, so a separate alarm
- period is used for them.
+QUIC uses both ack information and timeouts to detect lost packets, and this
Also, ack information and timeouts is correct, but not super-descriptive and it might be worth saying once that this is sender side, even though it's obvious to us. Maybe something like: "QUIC senders use both received acknowledgements and timeouts to detect and recover from lost packets. This section provides..."
> +
+## Computing the RTT estimate
+
+(To be filled)
+
+
+## Ack-based Detection
+
+Ack-based loss detection implements the spirit of TCP's Fast Retransmit
+{{!RFC5681}}, Early Retransmit {{!RFC5827}}, FACK, and SACK loss recovery
+{{!RFC6675}}. This section provides an overview of how these algorithms are
+implemented in QUIC.
+
+### Fast Retransmit
+
+An unacknowledged packet is marked as lost when an acknowledgment is received
Given I just had the conversation about "acknowledgement" and what it meant, do we need to clarify it somewhere in this doc?
> +## Ack-based Detection
+
+Ack-based loss detection implements the spirit of TCP's Fast Retransmit
+{{!RFC5681}}, Early Retransmit {{!RFC5827}}, FACK, and SACK loss recovery
+{{!RFC6675}}. This section provides an overview of how these algorithms are
+implemented in QUIC.
+
+### Fast Retransmit
+
+An unacknowledged packet is marked as lost when an acknowledgment is received
+for a packet that was sent a threshold number of packets (kReorderingThreshold)
+after the unacknowledged packet. Receipt of the ack indicates that a later
+packet was received, while kReorderingThreshold provides some tolerance for
+reordering of packets in the network.
+
+The RECOMMENDED value for kReorderingThreshold is 3.
RECOMMENDED initial value? Esp given you talk about changing it below.
> +{{!RFC6675}}. This section provides an overview of how these algorithms are
+implemented in QUIC.
+
+### Fast Retransmit
+
+An unacknowledged packet is marked as lost when an acknowledgment is received
+for a packet that was sent a threshold number of packets (kReorderingThreshold)
+after the unacknowledged packet. Receipt of the ack indicates that a later
+packet was received, while kReorderingThreshold provides some tolerance for
+reordering of packets in the network.
+
+The RECOMMENDED value for kReorderingThreshold is 3.
+
+We derive this default from recommendations for TCP loss recovery {{!RFC5681}}
+{{!RFC6675}}. It is possible for networks to exhibit higher degrees of
+reordering, causing a sender to spuriously detect losses. Spurious loss
nit: I think "detect spurious losses" reads a bit better, but I'm not sure.
> +{{!RFC6675}}. This section provides an overview of how these algorithms are
+implemented in QUIC.
+
+### Fast Retransmit
+
+An unacknowledged packet is marked as lost when an acknowledgment is received
+for a packet that was sent a threshold number of packets (kReorderingThreshold)
+after the unacknowledged packet. Receipt of the ack indicates that a later
+packet was received, while kReorderingThreshold provides some tolerance for
+reordering of packets in the network.
+
+The RECOMMENDED value for kReorderingThreshold is 3.
+
+We derive this default from recommendations for TCP loss recovery {{!RFC5681}}
+{{!RFC6675}}. It is possible for networks to exhibit higher degrees of
+reordering, causing a sender to spuriously detect losses. Spurious loss
Also, Spurious loss detection is sort of odd. I'd go with "Detecting spurious losses leads..."
> +reordering, causing a sender to spuriously detect losses. Spurious loss
+detection leads to unnecessary retransmissions and may result in degraded
+performance due to the actions of the congestion controller upon detecting
+loss. Implementers MAY use algorithms developed for TCP, such as TCP-NCR
+{{!RFC4653}}, to improve QUIC's reordering resilience, though care should be
+taken to map TCP specifics to QUIC correctly. Similarly, using time-based loss
+detection to deal with reordering, such as in PR-TCP, should be more readily
+usable in QUIC. Making QUIC deal with such networks is important open research,
+and implementers are encouraged to explore this space.
+
+### Early Retransmit
+
+Unacknowledged packets close to the tail may have fewer than
+kReorderingThreshold number of packets sent after them. Loss of such packets
+cannot be detected via Fast Retransmit. To enable ack-based loss detection of
+such packets, receipt of an acknowledgment for the last outstanding packet
Do you want to clarify that it's the last outstanding ackable packet?
Also, now that I read through this, it seems like it'd be worth doing early retransmit for any packets within kReorderingThreshold from the tail, but that's a sidethought.
> +loss. Implementers MAY use algorithms developed for TCP, such as TCP-NCR
+{{!RFC4653}}, to improve QUIC's reordering resilience, though care should be
+taken to map TCP specifics to QUIC correctly. Similarly, using time-based loss
+detection to deal with reordering, such as in PR-TCP, should be more readily
+usable in QUIC. Making QUIC deal with such networks is important open research,
+and implementers are encouraged to explore this space.
+
+### Early Retransmit
+
+Unacknowledged packets close to the tail may have fewer than
+kReorderingThreshold number of packets sent after them. Loss of such packets
+cannot be detected via Fast Retransmit. To enable ack-based loss detection of
+such packets, receipt of an acknowledgment for the last outstanding packet
+triggers the Early Retransmit process, as follows.
+
+If there are unacknowledged packets still pending, they ought to be
how about "still pending when the last ackable packet is acknowledged"
"ought to be" is sort of weak, how about "they must be declared lost." and drop the part about "since they are no subsequent packets to trigger a Fast Retransmit", since you say that in the preceding paragraph.
> +{{!RFC4653}}, to improve QUIC's reordering resilience, though care should be
+taken to map TCP specifics to QUIC correctly. Similarly, using time-based loss
+detection to deal with reordering, such as in PR-TCP, should be more readily
+usable in QUIC. Making QUIC deal with such networks is important open research,
+and implementers are encouraged to explore this space.
+
+### Early Retransmit
+
+Unacknowledged packets close to the tail may have fewer than
+kReorderingThreshold number of packets sent after them. Loss of such packets
+cannot be detected via Fast Retransmit. To enable ack-based loss detection of
+such packets, receipt of an acknowledgment for the last outstanding packet
+triggers the Early Retransmit process, as follows.
+
+If there are unacknowledged packets still pending, they ought to be
+retransmitted, since there are no subsequent packets to trigger a Fast
Here you use retransmitted, where in other cases you use "marked as lost" or "declared lost", which I think is better.
> +If there are unacknowledged packets still pending, they ought to be
+retransmitted, since there are no subsequent packets to trigger a Fast
+Retransmit. To compensate for the reduced reordering resilience, the sender
+SHOULD set an alarm for a small period of time. If the unacknowledged packets
+are not acknowledged during this time, then these packets are marked as lost.
+
+An endpoint SHOULD set the alarm such that a packet is marked as lost no earlier
+than 1.25 * max(SRTT, latest_RTT) since when it was sent.
+
+Using max(SRTT, latest_RTT) protects from the two following cases:
+
+* the latest RTT sample is lower than the SRTT, perhaps due to reordering where
+packet whose ack triggered the Early Retransit process encountered a shorter
+path;
+
+* the SRTT is lower than the latest RTT sample, perhaps due to a sustained
nit: I think it's easier to read if it's parallel and the latest RTT comes first in both statements, since you're mostly describing why the latest_rtt would have a smaller/larger value.
> +without the alarm. This observation led Linux TCP implementers to implement an
+alarm for TCP as well, and this document incorporates this advancement.
+
+
+## Timer-based Detection
+
+Timer-based loss detection implements the spirit of TCP's Tail Loss Probe
+and Retransmission Timeout mechanisms.
+
+### Tail Loss Probe
+
+The algorithm described in this section is an adaptation of the Tail Loss Probe
+algorithm proposed for TCP {{!I-D.draft-dukkipati-tcpm-tcp-loss-probe}}.
+
+A packet sent at the tail is particularly vulnerable to slow loss detection,
+since subsequent packets (and acks) are needed to trigger ack-based
How about "since acks of subsequent packets are needed..."
> +alarm when a tail packet is transmitted. When this alarm fires, a Tail Loss
+Probe (TLP) packet is sent to evoke an acknowledgement from the receiver.
+
+The alarm duration, or Probe Timeout (PTO), is set based on the following
+conditions:
+
+* If there is exactly one unacknowledged packet, PTO SHOULD be scheduled for
+ max(2*SRTT, 1.5*SRTT+kDelayedAckTimeout)
+
+* If there are more than one unacknowledged packets, PTO SHOULD be scheduled for
+ max(2*SRTT, 10ms).
+
+* If RTO is earlier, schedule a TLP alarm in its place. That is, PTO SHOULD be
+ scheduled for min(RTO, PTO).
+
+kDelayedAckTimeout is the worst case delayed ACK timer. When the is exactly one
worst case is a bit misleading, given alarms can go off late.
fix: "When there is"
> +
+* If there is exactly one unacknowledged packet, PTO SHOULD be scheduled for
+ max(2*SRTT, 1.5*SRTT+kDelayedAckTimeout)
+
+* If there are more than one unacknowledged packets, PTO SHOULD be scheduled for
+ max(2*SRTT, 10ms).
+
+* If RTO is earlier, schedule a TLP alarm in its place. That is, PTO SHOULD be
+ scheduled for min(RTO, PTO).
+
+kDelayedAckTimeout is the worst case delayed ACK timer. When the is exactly one
+unacknowledged packet, the alarm duration includes time for an acknowledgment to
+be received, and additionally, a kDelayedAckTimeout period to compensate for the
+delayed acknowledgment timer at the receiver.
+
+The RECOMMENDED value for kDelayedAckTimeout is 25ms.
As with Neal's new TCP proposal, QUIC should really have a default like 25ms, then allow negotiation. So maybe say "The RECOMMENDED default value for kDelayedAckTimeout is 25ms, though the transport allows for negotiation of different values."
> + scheduled for min(RTO, PTO).
+
+kDelayedAckTimeout is the worst case delayed ACK timer. When the is exactly one
+unacknowledged packet, the alarm duration includes time for an acknowledgment to
+be received, and additionally, a kDelayedAckTimeout period to compensate for the
+delayed acknowledgment timer at the receiver.
+
+The RECOMMENDED value for kDelayedAckTimeout is 25ms.
+
+A PTO value of at least 2*SRTT ensures that the ACK is overdue. Using a PTO of
+exactly 1*SRTT may generate spurious probes, and 2*SRTT is simply the next
+integral value of RTT.
+
+(TODO: These values of 2 and 1.5 are a bit arbitrary. Reconsider these.)
+
+If the Retransmission Timeout (RTO, {{rto}}) is smaller than the computed PTO,
It's a bit confusing that the RTO is a thing you do and a timeout value. Maybe call it RTO period when referring to the timeout value?
> +unacknowledged packet, the alarm duration includes time for an acknowledgment to
+be received, and additionally, a kDelayedAckTimeout period to compensate for the
+delayed acknowledgment timer at the receiver.
+
+The RECOMMENDED value for kDelayedAckTimeout is 25ms.
+
+A PTO value of at least 2*SRTT ensures that the ACK is overdue. Using a PTO of
+exactly 1*SRTT may generate spurious probes, and 2*SRTT is simply the next
+integral value of RTT.
+
+(TODO: These values of 2 and 1.5 are a bit arbitrary. Reconsider these.)
+
+If the Retransmission Timeout (RTO, {{rto}}) is smaller than the computed PTO,
+then a PTO is scheduled for the smaller RTO period.
+
+To reduce latency, it is RECOMMENDED that the sender send two sequential TLP
One could potentially read two sequential TLP packets as two packets in a row immediately. How about wording like "it is RECOMMENDED that the sender allow the TLP alarm to expire twice before setting an RTO alarm."
> +
+A PTO value of at least 2*SRTT ensures that the ACK is overdue. Using a PTO of
+exactly 1*SRTT may generate spurious probes, and 2*SRTT is simply the next
+integral value of RTT.
+
+(TODO: These values of 2 and 1.5 are a bit arbitrary. Reconsider these.)
+
+If the Retransmission Timeout (RTO, {{rto}}) is smaller than the computed PTO,
+then a PTO is scheduled for the smaller RTO period.
+
+To reduce latency, it is RECOMMENDED that the sender send two sequential TLP
+packets before setting an RTO alarm. When the first TLP packet is sent, the TLP
+alarm should be scheduled for a second TLP. On the second TLP packet, an RTO
+alarm should be scheduled {{rto}}.
+
+A TLP packet SHOULD carry new data when available. If new data is unavailable, a
is it worth acknowledging that flow control could prevent sending new data as well?
Maybe "A TLP packet SHOULD carry new data when possible. If new data is unavailable or new data cannot be sent due to flow control, ..."
> +
+(TODO: These values of 2 and 1.5 are a bit arbitrary. Reconsider these.)
+
+If the Retransmission Timeout (RTO, {{rto}}) is smaller than the computed PTO,
+then a PTO is scheduled for the smaller RTO period.
+
+To reduce latency, it is RECOMMENDED that the sender send two sequential TLP
+packets before setting an RTO alarm. When the first TLP packet is sent, the TLP
+alarm should be scheduled for a second TLP. On the second TLP packet, an RTO
+alarm should be scheduled {{rto}}.
+
+A TLP packet SHOULD carry new data when available. If new data is unavailable, a
+TLP packet MAY retransmit unacknowledged data to potentially reduce recovery
+time. Since a TLP packet is sent as a probe into the network prior to
+establishing any packet loss, prior unacknowledged packets SHOULD NOT be marked
+as lost.
as lost when the TLP packet is sent."
> +time. Since a TLP packet is sent as a probe into the network prior to
+establishing any packet loss, prior unacknowledged packets SHOULD NOT be marked
+as lost.
+
+A TLP packet MUST NOT be blocked by the sender's congestion controller. The
+sender MUST however count these bytes as additional bytes in flight, since a TLP
+adds network load without establishing packet loss.
+
+A sender will commonly not know that a packet being sent is a tail packet.
+Consequently, a sender may have to arm or adjust the TLP alarm on every sent packet.
+
+### Retransmission Timeout {#rto}
+
+A Retransmission Timeout (RTO) alarm is the final backstop for loss
+detection. The algorithm used in QUIC is based on the RTO algorithm for TCP
+{{!RFC5681}} and is additionally resilient to spurious RTOs.
since you mention spurious RTOs, maybe reference 5682 as well?
> +### Retransmission Timeout {#rto}
+
+A Retransmission Timeout (RTO) alarm is the final backstop for loss
+detection. The algorithm used in QUIC is based on the RTO algorithm for TCP
+{{!RFC5681}} and is additionally resilient to spurious RTOs.
+
+When the last TLP packet is sent, an alarm is scheduled for the RTO time. When
+this alarm fires, the sender sends two Retransmission Timeout (RTO) packets, to
+evoke acknowledgements from the receiver, and restarts the RTO alarm.
+
+Similar to TCP {{!RFC6298}}, the RTO alarm duration is set based on the
+following conditions:
+
+* When the final TLP packet is sent, RTO is set to max(SRTT + 4*RTTVAR, minRTO)
+
+* When an RTO alarm fires, RTO is set to twice its current value.
nit; "RTO is doubled." seems a bit less ambiguous.
> +the network prior to establishing any packet loss, prior unacknowledged packets
+SHOULD NOT be marked as lost.
+
+An RTO packet MUST NOT be blocked by the sender's congestion controller. A
+sender MUST however count these bytes as additional bytes in flight, since an
+RTO packet adds network load without establishing packet loss.
+
+
+### Handshake Timeout
+
+Handshake packets, which contain STREAM frames for stream 0, are critical to
+QUIC transport and crypto negotiation, so a separate alarm period is used for
+them.
+
+The initial flight has no prior RTT sample. A client SHOULD remember
+the previous RTT it observed when resumption is attempted and use that for an
This is mostly a good recommendation, but if the client changes networks, does it still apply?
> +
+
+### Handshake Timeout
+
+Handshake packets, which contain STREAM frames for stream 0, are critical to
+QUIC transport and crypto negotiation, so a separate alarm period is used for
+them.
+
+The initial flight has no prior RTT sample. A client SHOULD remember
+the previous RTT it observed when resumption is attempted and use that for an
+initial RTT value. If no previous RTT is available, the initial RTT defaults
+to 100ms.
+
+Endpoints MUST retransmit handshake frames if not acknowledged within a
+time limit. This time limit will start as the largest of twice the RTT value
+and MinTLPTimeout. Each consecutive handshake retransmission doubles the
MinTLPTimeout is not defined in this text, it's just used above as 10ms when calculating the TLP alarm.
> +sender MUST however count these bytes as additional bytes in flight, since an
+RTO packet adds network load without establishing packet loss.
+
+
+### Handshake Timeout
+
+Handshake packets, which contain STREAM frames for stream 0, are critical to
+QUIC transport and crypto negotiation, so a separate alarm period is used for
+them.
+
+The initial flight has no prior RTT sample. A client SHOULD remember
+the previous RTT it observed when resumption is attempted and use that for an
+initial RTT value. If no previous RTT is available, the initial RTT defaults
+to 100ms.
+
+Endpoints MUST retransmit handshake frames if not acknowledged within a
Currently we retransmit "all unacknowledged handshake frames", so we should probably say that?
--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/801#pullrequestreview-65854911
- [quicwg/base-drafts] Adds substantive description… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… ianswett
- Re: [quicwg/base-drafts] Adds substantive descrip… Lucas Clemente
- Re: [quicwg/base-drafts] Adds substantive descrip… ianswett
- Re: [quicwg/base-drafts] Adds substantive descrip… Martin Thomson
- Re: [quicwg/base-drafts] Adds substantive descrip… Martin Thomson
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… janaiyengar
- Re: [quicwg/base-drafts] Adds substantive descrip… ianswett
- Re: [quicwg/base-drafts] Adds substantive descrip… ianswett