Re: [regext] Significant change to sorting-and-paging

"James Galvin" <> Fri, 14 February 2020 14:52 UTC

Return-Path: <>
Received: from localhost (localhost []) by (Postfix) with ESMTP id B7BC51200EB for <>; Fri, 14 Feb 2020 06:52:51 -0800 (PST)
X-Virus-Scanned: amavisd-new at
X-Spam-Flag: NO
X-Spam-Score: -1.897
X-Spam-Status: No, score=-1.897 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, SPF_HELO_NONE=0.001, SPF_NONE=0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: (amavisd-new); dkim=pass (2048-bit key)
Received: from ([]) by localhost ( []) (amavisd-new, port 10024) with ESMTP id sUDKOoKqXwHY for <>; Fri, 14 Feb 2020 06:52:48 -0800 (PST)
Received: from ( [IPv6:2607:f8b0:4864:20::f2d]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by (Postfix) with ESMTPS id 56D90120041 for <>; Fri, 14 Feb 2020 06:52:48 -0800 (PST)
Received: by with SMTP id o18so4386013qvf.1 for <>; Fri, 14 Feb 2020 06:52:48 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20150623; h=from:to:cc:subject:date:message-id:in-reply-to:references :mime-version:content-transfer-encoding; bh=KMo2cyr+NDJxfT+slJt638mCI/XySLV4nh+rXfVyP5g=; b=GQTO5tBUL/aGCwp2JsvDpH4jMSWA8EGLrMYDiuHKG5qm63PXhkWOSSAzDtZiJIWFbO VWXEZYGXY19ppMumXYfiYXSZyuB7b7dtxN8lZKJp/57PyEChQ5GHrQ6cQQFlWD44JqJz Mw1S27eOvg8EXBmN6M4QYKG+T3NXPfB21hTJK5Q5Y3bfaM/2eVVVI6Qgqft8vLINvtSS aQORbtKRO59BlzgMfN94qTIQzobKVwxutEH6igcdY7HncvS3CMcP7dYNb1/oeZCBsLc2 DmsLIcJvtsmsRjtChPDt8iMuLAwHJ3W3uPRU5Q7RkYk7SmojLNu3WU0OOTE/ellz/z0H /1hQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20161025; h=x-gm-message-state:from:to:cc:subject:date:message-id:in-reply-to :references:mime-version:content-transfer-encoding; bh=KMo2cyr+NDJxfT+slJt638mCI/XySLV4nh+rXfVyP5g=; b=BCEvLAZSIZzgalVGqM1YoCogaTP6gIBYUy6eTAxjjX08JmNhqPyRvuO6b9tkqnv1SH tE4gG4J64RRmw88FCn691PKPatfTKcmQf8TGVnj/cKFCu/xSTyfUPd04gpDdoyIfLtWv iYCPxnFFe21vovqYfoDVC6bgV0qx4W2UKJXqBa3QMW9U2uaQWS4HnQEdfmNhNKSzoAFr A+pKe0x7eK+JKla6ylLrTU2nSvsMzeiAonIvlrhrKNztpUbRen5+73H7PlJuGWK4novs Rcx9BJ7kO32oOqjDoacc1+yMPvWdS0j4s8WLceDIOQChp5msYGCg/mMrN3Rnwss13lNu SBXw==
X-Gm-Message-State: APjAAAX+Y1fhAQuYsoY6jp1RklgW6jmPcdqzi8j1Nujdxk8+1ablkYvg c3GIs7jNPD7yEpVJ37WuKum3+cBrrm0=
X-Google-Smtp-Source: APXvYqxFXgPfhH+swhSfWLSMkSDgGG83Att7bFHZjo9OBlPElna/3zi0jXhFm/meZCAXhdJ3iI91lw==
X-Received: by 2002:a0c:e1ce:: with SMTP id v14mr2402272qvl.39.1581691967140; Fri, 14 Feb 2020 06:52:47 -0800 (PST)
Received: from [] ([2601:154:c202:9d20:c4ab:4d9:a8cc:7003]) by with ESMTPSA id g9sm3339758qkl.11.2020. (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Fri, 14 Feb 2020 06:52:46 -0800 (PST)
From: James Galvin <>
To: Mario Loffredo <>
Cc:, "Hollenbeck, Scott" <>, Maurizio Martinelli <>
Date: Fri, 14 Feb 2020 09:52:45 -0500
X-Mailer: MailMate (1.13.1r5671)
Message-ID: <>
In-Reply-To: <>
References: <>
MIME-Version: 1.0
Content-Type: text/plain; charset="UTF-8"; format="flowed"
Content-Transfer-Encoding: 8bit
Archived-At: <>
Subject: Re: [regext] Significant change to sorting-and-paging
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: Registration Protocols Extensions <>
List-Unsubscribe: <>, <>
List-Archive: <>
List-Post: <>
List-Help: <>
List-Subscribe: <>, <>
X-List-Received-Date: Fri, 14 Feb 2020 14:52:52 -0000

Comments inline below.

Important question for the working group, does anyone object to this 
document moving to working group last call?

On 10 Feb 2020, at 10:52, Mario Loffredo wrote:

> Hi Jim and Antoin,
> this mail is for asking your opinion about a significant change on 
> sorting-and-paging draft.
> According to the last version, "totalCount" is a member of the 
> "paging_metadata" object. However, the counting capability might be
> implemented by an RDAP server without implementing pagination as well.
> Such field was originally put inside "paging_metadata" because, in 
> many REST API implementations, it pertains the pagination information.
> In addition, by doing so, only two response extensions would have been 
> defined.
> For the sake of clarity, the authors think that it would be better to 
> put "totalCount" outside "paging_metadata". Basically, this would mean 
> to define a new
> rdapConformance tag (e.g. "count_level_0") and rename the field 
> accordingly (e.g. simply "count" or "count_all").

The chairs would prefer to evaluate the consensus of the working group.

We would prefer if folks who object to the choice you have made in the 
document would please speak up on the mailing list and make a technical 
argument against it.

Similarly, folks who support the choice you have made should speak up on 
the list in response to any objection.

> In authors' opinion, it might also be appropiate to rename the draft 
> to "counting-sorting-and-paging".

In general, it’s not necessary to rename a document.


Antoin and Jim

>  Even if the authors don't expect any relevant feedback since the 
> draft content would remain substantially the same, some time would be 
> needed for discussion before starting a last call.
> Does it sound reasonable for you?
> Many thanks in advance,
> Mario.
> -- 
> Dr. Mario Loffredo
> Systems and Technological Development Unit
> Institute of Informatics and Telematics (IIT)
> National Research Council (CNR)
> via G. Moruzzi 1, I-56124 PISA, Italy
> Phone: +39.0503153497
> Mobile: +39.3462122240
> Web:
> _______________________________________________
> regext mailing list