Re: [mpls] FW: New Version Notification for draft-ietf-bfd-rfc5884-bis-00.txt

Jeffrey Haas <jhaas@pfrc.org> Fri, 19 June 2026 19:59 UTC

Return-Path: <jhaas@pfrc.org>
X-Original-To: rtg-bfd@mail2.ietf.org
Delivered-To: rtg-bfd@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id A39051042D5B2; Fri, 19 Jun 2026 12:59:17 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1781899157; bh=thbEqv6O1w8S5yPcKYHA0R9xBAn1s+BaVOH7KzVkJ08=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=JxJV34RW6TNoNgPA91VK6QuktZhZQvnRhLsNwGKTitO22sfPrOUAmFfXZmHdSIT0Y yFXIm9Vj1o5iv684LmgNrQBkN97lSuEiPDXH03AzAw/Zom4+HsSDgDx4I+JOlUZ4Nz UsXbzuEhJ5dPIOdJAync/w5sJNKXH8KiMZ8g71Jw=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=pfrc.org
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id oOtZ_i9yf0zN; Fri, 19 Jun 2026 12:59:15 -0700 (PDT)
Received: from prospero.pfrc.org (prospero.pfrc.org [72.60.64.110]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256)) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id BCCD21042D5A8; Fri, 19 Jun 2026 12:59:15 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=pfrc.org; s=prospero20250622; t=1781899154; bh=thbEqv6O1w8S5yPcKYHA0R9xBAn1s+BaVOH7KzVkJ08=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=OkQ+dXeNjCItb89T6el7bNk0ckxbVrnoO+lMx+cdKYCta6U96ZA/6X1CKScH2uZj3 Q3/UIPYAz7UuK55LRvbISYCAAZbjJmX0y6XHtcRYiZIXNEH8vscEhJY8zauvSbisEX Bi94hXXVvLpmpdEKXVj8dEb2cycjXwQe5ZI95PjWzE3GROLvTg9a49KYALl4xRFlwC O21NYwJYkhO7UhmC2XGLr4ZWE2guaCwkdy3cWwjR+xlauEYDrO6HFrPVttSPzK4Qzh pzSbRkMjFl7GJY0CeBkJFDeIdSe3mCGgNLftEdc/nuCorfDWFK0Enn7ixkqHWlFlbr FgoejGLyaEeog==
Received: from [IPV6:2600:1702:80c0:8960:6841:41:1dc0:ee1a] (unknown [IPv6:2600:1702:80c0:8960:6841:41:1dc0:ee1a]) by prospero.pfrc.org (Postfix) with ESMTPSA id 9641C80087; Fri, 19 Jun 2026 19:59:14 +0000 (UTC)
Content-Type: multipart/alternative; boundary="------------9u8wUW0aXPm802PyqBM30Jt3"
Message-ID: <32ee5b43-17cc-4cd2-856e-998b2aaa586e@pfrc.org>
Date: Fri, 19 Jun 2026 15:59:12 -0400
MIME-Version: 1.0
User-Agent: Mozilla Thunderbird
Subject: Re: [mpls] FW: New Version Notification for draft-ietf-bfd-rfc5884-bis-00.txt
To: Greg Mirsky <gregimirsky@gmail.com>, "Vengada Prasad Govindan (venggovi)" <venggovi=40cisco.com@dmarc.ietf.org>
References: <178179354920.810381.11612191353857667328@dt-datatracker-f9b87776f-8pmmg> <DS0PR11MB6495F90C0634F57D304E36D5CDE32@DS0PR11MB6495.namprd11.prod.outlook.com> <CA+RyBmUgreZv2BxdGz2KJYEHqFb2UDcju=U-o_e3=cUV+0J9AA@mail.gmail.com>
Content-Language: en-US
From: Jeffrey Haas <jhaas@pfrc.org>
In-Reply-To: <CA+RyBmUgreZv2BxdGz2KJYEHqFb2UDcju=U-o_e3=cUV+0J9AA@mail.gmail.com>
Message-ID-Hash: SDOWPNZT3WNWDIBLRKNF3P6BU5GK5Z74
X-Message-ID-Hash: SDOWPNZT3WNWDIBLRKNF3P6BU5GK5Z74
X-MailFrom: jhaas@pfrc.org
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-rtg-bfd.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "rtg-bfd@ietf.org" <rtg-bfd@ietf.org>, "mpls@ietf.org" <mpls@ietf.org>, "bfd-chairs@ietf.org" <bfd-chairs@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
List-Id: "RTG Area: Bidirectional Forwarding Detection" <rtg-bfd.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/rtg-bfd/Dpurpc3KpyPfqx57ldspe1h0jDQ>
List-Archive: <https://mailarchive.ietf.org/arch/browse/rtg-bfd>
List-Help: <mailto:rtg-bfd-request@ietf.org?subject=help>
List-Owner: <mailto:rtg-bfd-owner@ietf.org>
List-Post: <mailto:rtg-bfd@ietf.org>
List-Subscribe: <mailto:rtg-bfd-join@ietf.org>
List-Unsubscribe: <mailto:rtg-bfd-leave@ietf.org>

Greg,

Thanks for the review for this round, and hopefully for the entire -bis 
effort as we move things to Internet standard.  Some partial responses:

On 6/19/26 15:02, Greg Mirsky wrote:
>
>   * As the 5884bis is the result of merging RFCs 5884 and 7726, should
>     the lists of authors also be merged?
>
My recommendation for the next round would be to update the author list 
with the union between the two drafts.

This will clearly push us well past the usual 5-author limit. We will be 
asking our AD to seek early advice about how we'll deal with this as 
part of publication.

>   * At some point, we need to update authors' affiliations and verify
>     contact information.
>
... and get them to respond to the last call.  I somewhat expect this 
part of the effort to be harder than gathering the implementation 
report.  Current practice for non-responsive authors involves moving 
them out of the author line into the contributors section.  However, 
we're interested in supplying appropriate credit to all involved.
>
>   * Should Abstract and Introduction stress that this specification is
>     applicable only to point-to-point LSP and PW, and BFD over a
>     point-to-multipoint LSP and PW is outside the scope?
>   * The Abstract notes that the 5884bis obsoletes RFC 5884 and 7726.
>     Should that, possibly in a more extended statement, be noted in
>     the Introduction?
>   * I believe that reference to LSP ping should be switched from RFC
>     4379 to RFC 8029.
>
In addition to our editors taking feedback from the list, we also have a 
github repository for each document where issues can be opened to track 
comments to conclusion.  The repository for this document is:

https://github.com/bfd-wg/draft-ietf-bfd-rfc5884-bis


>   * An address from an IPv4-mapped IPv6 address
>     range 0:0:0:0:0:FFFF:7F00:0/104 doesn't conform to the requirement
>     in RFC 8029:
>
Thanks for raising this point. I think it's likely to be a substantive 
discussion point for this -bis.

My personal opinion is that the change from the loopback network done in 
RFC 8029 was a mistake and has implications well outside of the BFD 
considerations.  Somewhat disturbing, this particular change happened 
after the prior BFD group review and wasn't flagged for explicit BFD 
working group review during the IESG review process.

I've flagged this previously to our AD and also in email conversations 
for the v6ops chairs since the new network are effectively de facto 
changes to the IPv6 host considerations.  I will also own up to not 
rigorously following up on this since my own discovery of this change 
happened in the midst of an IETF session and I forgot to do the 
followups in email.  Given my failures in better flagging this (Reshad 
may have taken different actions that we haven't discussed), let's 
consider this a fresh start on discussing the issue.  It might be worth 
spinning this point to its own thread.

>        2.  If an LSP is broken in such a way that it prematurely
>     terminates,
>
>            the diagnostic packet MUST NOT be IP forwarded.
>
>     That is because IPv6 has a single loopback address ::1, and
>     0:0:0:0:0:FFFF:7F00:0/104 range is routable. RFC 9780
>     <https://datatracker.ietf.org/doc/rfc9780/> defines
>     an IPv6 address from the Dummy IPv6 Prefix address block
>     100:0:0:1::/64 for precisely this use case.
>
Responding to the two core objections I would have raised during the 
8029 work:

1. The new dummy networks are just as routable.  What's worse is that 
the desired behavior of them would have resulted in a desire to mark 
these networks as "martian" addresses so that routing stacks avoid 
routing them.

2. The forwarding desire for these networks is that they are solely 
local.  The loopback address (IPv6) and loopback network (IPv4) didn't 
have this problem.  The IPv6 mapped network had mixed semantics that 
were perhaps inconsistently standardized. However, the new networks have 
no "magic" semantics beyond this RFC and implementing the "do not 
forward" semantic is an update to the IPv6 host considerations.  Did I 
miss updates in the various IPv6 working groups to standardize that?  I 
admit to not being able to follow them, but discussion with some of the 
relevant SMEs seemed to surprise them as well.

>   * The list in Section 3.1 - c) and d) should be separated.
>   * Perhaps s/LSP Ping includes extensive control plane
>     verification/LSP Ping ensures extensive control plane verification/
>   * a) and c) in the list in Section 3.2 need some beautification.
>   * Should we use consistent, e.g., alphabetical, marking of elements
>     in the lists?
>   * In Section 3.2, the last list is misaligned.
>   * How useful is the following paragraph without discussing how to
>     ensure that BFD control packets of different BFD sessions in the
>     ECMP environment traverse distinct paths?
>
>      If there are multiple alternate paths from an ingress LSR to an
>        egress LSR for an LDP IP FEC, LSP Ping traceroute MAY be used to
>        determine each of these alternate paths.  A BFD session SHOULD be
>        established for each alternate path that is discovered.
>
>   * Continuing on the case of ECMP described above, consider a
>     scenario when a single BFD session is used to monitor connectivity
>     between two LERs over MPLS. In such a case, is the level of the
>     normative language in the following reasonable? Could MUST be
>     replaced by SHOULD?
>
>      To use BFD for fault detection on an MPLS LSP, a BFD session MUST be
>        established for that particular MPLS LSP.  BFD Control packets MUST
>        be sent along the same data path as the LSP being verified and are
>        processed by the BFD processing module of the egress LSR.
>
Expanding on the point here, BFD behavior in the presence of ECMP was 
under-specified in our prior documents.  It periodically comes up as a 
discussion point - and more so for the explicitly routed MPLS cases.

Should we restrict our ECMP discussions primarily to the MPLS document 
or consider it earlier in the document cluster?

>   * It is not clear to me where the reference "as described above" in
>     Section 5 points to.
>   * Should the following text from Section 6 be moved to Abstract and
>     Introduction?
>
>      This specification
>        describes procedures only for BFD asynchronous mode.  BFD
>     demand mode
>        is outside the scope of this specification.  Further, the use
>     of the
>        BFD Echo function is outside the scope of this specification.
>
>   * It seems like a forward reference to Section 6.1 would be helpful
>     to a reader:
>
>      This BFD
>        Control packet MUST set the Your Discriminator field to the
>        discriminator received from the ingress LSR in the LSP Ping Echo
>        request message.
>
>   * Would adding a figure to Section 6.1 to visualize the BFD
>     Discriminator TLV be useful?
>   * It seems like text imported from RFC 7726 carries references to
>     RFC 5884, which can be removed from the 5884bis.
>   * Should the Operational Considerations section be added as required
>     by draft-ietf-opsawg-rfc5706bis
>     <https://datatracker.ietf.org/doc/draft-ietf-opsawg-rfc5706bis/>?
>
Our recent RFC work for the authentication documents did have some 
discussion with the IESG about operational considerations as part of the 
IESG review process.  At least one of the comments could largely have 
been read as "these are operational considerations generic to BFD and 
don't belong in the incremental feature document".

We're in the midst of -bis work, and thus it's appropriate to consider 
such general-purpose operational considerations, as well as such 
considerations for each specific document.

My two concerns for that are:

1. Our discussion with our AD was that we're trying to go for minimal 
changes for these -bis.

2. 5706-bis is itself in flight. Is it going to be "done" enough to want 
to attach it as a heavy boat anchor to the update?

We'll want to hear from our AD and the OPS AD on these points.

-- Jeff