[secdir] Re: Secdir early review of draft-ietf-rtgwg-srv6-egress-protection-16

"何涛(联通集团本部)" <het21@chinaunicom.cn> Wed, 19 March 2025 08:17 UTC

Return-Path: <het21@chinaunicom.cn>
X-Original-To: secdir@mail2.ietf.org
Delivered-To: secdir@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 5432DE8983E; Wed, 19 Mar 2025 01:17:16 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: 0.58
X-Spam-Level:
X-Spam-Status: No, score=0.58 tagged_above=-999 required=5 tests=[BAYES_20=-0.001, HTML_MESSAGE=0.001, INVALID_MSGID=0.568, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_KAM_HTML_FONT_INVALID=0.01] autolearn=no autolearn_force=no
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id nwZhL1O5hjFL; Wed, 19 Mar 2025 01:17:14 -0700 (PDT)
Received: from sendd.mailex.chinaunicom.cn (senda.mailex.chinaunicom.cn [123.138.59.136]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256)) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 68EB6E891A4; Wed, 19 Mar 2025 01:16:43 -0700 (PDT)
Received: from bg5.exmail.qq.com (unknown [10.172.147.156]) by sendd.mailex.chinaunicom.cn (SkyGuard) with ESMTPS id 4ZHgzG4wMHzpJDYw; Wed, 19 Mar 2025 15:57:14 +0800 (CST)
X-QQ-mid: qylesmxpt1742371033t9leu2z3h
Received: from hetao ( [10.2.112.204]) by bizesmtp.qq.com (ESMTP) with id ; Wed, 19 Mar 2025 15:57:12 +0800 (CST)
X-QQ-SSF: 0100000000000050K820000A0000000
X-QQ-FEAT: GFecu540AxnxtKnnpMj8tYoMEvLMqoEl
X-QQ-GoodBg: 0
Date: Wed, 19 Mar 2025 15:57:13 +0800
References: <173054964960.269138.9622228854134346911@dt-datatracker-84cf84bdcc-hlxgg>
X-Priority: 3
X-Has-Attach: no
X-Mailer: Foxmail 7.2.25.331[cn]
Mime-Version: 1.0
Message-ID: <202503191547212576186@chinaunicom.cn>
Content-Type: multipart/alternative; boundary="----=_001_NextPart456644718511_=----"
From: "何涛(联通集团本部)" <het21@chinaunicom.cn>
To: Phillip Hallam-Baker <hallam@gmail.com>, secdir <secdir@ietf.org>
X-QQ-SENDSIZE: 520
Feedback-ID: qylesmxpt:chinaunicom.cn:xx-kxq-mail-:xx-kxq-mail-0005.novalocal
Message-ID-Hash: KHTRZQ3BBCHULSXYW2VFVJQLTBFOI5Q5
X-Message-ID-Hash: KHTRZQ3BBCHULSXYW2VFVJQLTBFOI5Q5
X-MailFrom: het21@chinaunicom.cn
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-secdir.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "draft-ietf-rtgwg-srv6-egress-p rotection.all" <draft-ietf-rtgwg-srv6-egress-protection.all@ietf.org>, rtgwg <rtgwg@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [secdir] Re: Secdir early review of draft-ietf-rtgwg-srv6-egress-protection-16
List-Id: Security Area Directorate <secdir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/secdir/iPDO0JXcqAoG5PTzHFJzGvwq-84>
List-Archive: <https://mailarchive.ietf.org/arch/browse/secdir>
List-Help: <mailto:secdir-request@ietf.org?subject=help>
List-Owner: <mailto:secdir-owner@ietf.org>
List-Post: <mailto:secdir@ietf.org>
List-Subscribe: <mailto:secdir-join@ietf.org>
List-Unsubscribe: <mailto:secdir-leave@ietf.org>

Hi  Phillip,
Thanks for your review of the "draft-ietf-rtgwg-srv6-egress-protection-16".
       
        This draft indeed raises security concerns regarding the rerouting of traffic around egress node or link failures within a single administrative domain. However, these concerns are not unique to this proposal but are rather common in network environments. 

Specifically:
Security within a Single Administrative Domain
The assumption of a "single administrative domain" does limit certain types of attacks since nodes within the domain are typically protected by unified security policies. However, as you pointed out, attackers might indirectly affect traffic paths within the target domain by launching broader network attacks, such as denial-of-service attacks on other transit domains. Such attack methods do not rely on the protection mechanisms proposed in the draft but rather exploit the characteristics of network topology and routing protocols.
Possibility of Cross-Domain Attacks
The cross-domain attack scenario you mentioned (such as BGP attacks by Country X on Country Y) is indeed a real-world issue. The goal of such attacks is to manipulate routing information to change traffic paths and redirect traffic to websites or services controlled by the attacker. The root cause of these attacks lies in the security vulnerabilities of the BGP protocol, not the SRv6 egress protection mechanism proposed in the draft. In fact, the SRv6 egress protection mechanism is designed to quickly restore faults within the administrative domain and is not intended to address cross-domain attack issues.
Leverage for Attackers
The mechanisms proposed in the draft do not provide new leverage for attackers. On the contrary, they quickly switch to backup paths within the administrative domain to reduce the impact of faults on network services. This mechanism was designed with the security of the administrative domain in mind, such as using stronger authentication mechanisms (like ISO10589, RFC5304, RFC5310, etc.) to protect IS-IS and OSPFv3 protocols.
Mitigation Measures
For the attack scenarios you mentioned, mitigation measures should focus on strengthening the security of cross-domain traffic and the authentication mechanisms of routing protocols. For example, using strong authentication mechanisms for BGP (such as RFC4552 and RFC7166) can prevent the spread of malicious routing information. Additionally, network operators can reduce dependence on single transit paths by using traffic engineering and policy-based routing.




Best Regards!
===============================================
Tao He
Next Generation Internet Research Department
Research Institute
CHINA UNITED NETWORK COMMUNICATIONS CORPORATION LIMITED
Mobile: +86-18618484923
E-mail: het21@chinaunicom.cn
 
From: Phillip Hallam-Baker via Datatracker
Date: 2024-11-02 20:14
To: secdir@ietf.org
CC: draft-ietf-rtgwg-srv6-egress-protection.all; rtgwg
Subject: [secdir] Secdir early review of draft-ietf-rtgwg-srv6-egress-protection-16
Reviewer: Phillip Hallam-Baker
Review result: Has Issues
 
I have reviewed this document and in general, it seems ready. While it does
raise serious security concerns, it is not clear that these are new to this
proposal or that this proposal gives more leverage to an attacker.
 
Specifically, the draft stipulates that 'the area is in a single administrative
domain' the security considerations describes one set of attacks arising from
customers served by the domain. However, this set of attacks may be broader
than described. Consider for instance the case where there are two domains A
and B that provide transit for ISP C. An attacker that wants to ensure C is
serviced exclusively by B might perform a denial of service attack on A so as
to increase the cost of that route so as to achieve that goal.
 
A real world attack that has been seen in the past is country X preparing for
an invasion of country Y, performing BGP level attacks to effectively reroute
Internet traffic within Y so that the government Web sites were serviced by
fake sites set up by X. These sites containing messages of the form 'don't
worry about the military exercises'.