[secdir] Re: [Last-Call] [netconf] draft-ietf-netconf-yp-transport-capabilities-06 ietf last call Secdir review
Mahesh Jethanandani <mjethanandani@gmail.com> Thu, 20 August 2026 21:37 UTC
Return-Path: <mjethanandani@gmail.com>
X-Original-To: secdir@mail2.ietf.org
Delivered-To: secdir@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 2253E12D13E90 for <secdir@mail2.ietf.org>; Thu, 20 Aug 2026 14:37:44 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1787261864; bh=HUeu2AiwrPUYOG7v0Hr77Vn9VIy8oq890p/rQwpP2f8=; h=From:Subject:Date:In-Reply-To:Cc:To:References; b=rXekfvkjpym+5Z0mJAHC5b5pSe7Lkpo4hWhIRUTjYWb2Qmjd201ciXpFtdkahIzhR VzlrVXaUZTgbd9Q6d3mbHrbksVoX68RWvIXdsMRBbUgOtn1PnvgBbyR0InPmv5JuO+ ZveV1qbvIQR0U2IbHHNA8iNp14lDzkBJZpo0CtLM=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 614LzUlM8JRK for <secdir@mail2.ietf.org>; Thu, 20 Aug 2026 14:37:42 -0700 (PDT)
Received: from mail-pj1-x1029.google.com (mail-pj1-x1029.google.com [IPv6:2607:f8b0:4864:20::1029]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id E5C7E12D13E71 for <secdir@ietf.org>; Thu, 20 Aug 2026 14:37:41 -0700 (PDT)
Received: by mail-pj1-x1029.google.com with SMTP id 98e67ed59e1d1-38dc69c74b8so300929a91.0 for <secdir@ietf.org>; Thu, 20 Aug 2026 14:37:41 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20251104; t=1787261861; x=1787866661; darn=ietf.org; h=references:to:cc:in-reply-to:date:subject:mime-version:content-type :message-id:from:from:to:cc:subject:date:message-id:reply-to :content-type; bh=D6lyl/LWvrBmR+CodIQ14t/j6vuUCwuxfpOeDADZa+U=; b=hYeuolBxrc+69i8GBn9lrOgdT4/79vWNSybj6h3m8DsC2yzn2P3Hq085tcxU6SsICo lQEI3vf37cpIlTTHnq3+lACh1HtPFwlXucnG6C6us7yX75mCGE8/uOIN1B2/uX4WxCcv Thn2UF7tm2yg0ROaCMyiXRLn7WV/CpbPVJBAp2Mt/e3lKpSau3c7c7pLKz04THuvOojY yZpIcbOfLj03BlZgfdHVBIeYxfBcIIqWwhxGnwEu1DFz8hGUYphf2iFPbvAL2JsYyqYO 5WNaYCT6q6pMuu+Q++GE0iCXS9JqbSgRYS8bgTqBbaJJFsvfuU13L96EnG0V4rWSo76v sWbw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1787261861; x=1787866661; h=references:to:cc:in-reply-to:date:subject:mime-version:content-type :message-id:from:x-gm-gg:x-gm-message-state:from:to:cc:subject:date :message-id:reply-to:content-type; bh=D6lyl/LWvrBmR+CodIQ14t/j6vuUCwuxfpOeDADZa+U=; b=QssKyK+wGrDkjzsbzxs7tRVU5abYu5L6xMNzfHJvhAkFk6m6T1LPnt78G6qt4/udbM qxE0Wp8w2NpoJaTMP4oI4bk3sIOfNucb8qT6xGK0ST5y3aZnY1EmteX6vHlkZ9hjKwbp 1o+O4YkU1eFYo4kIWFnSM+YRZJKBrLvAdLjLCEE/DYUT54RNfEL52itx8INGnTHg5f4V zusp0l1tR7/PICaQLrqEVxc54TAi9g6s9NMS4o58e+g7fHfvHyAxINZFtc6ayfjr4Yin vZcItw+0pdNUoKAE6TefgEAZbE46cn/iNf0/zR4I/c5ftc0o0BTLRBOhD5SnXbshq3Y6 KLAA==
X-Forwarded-Encrypted: i=1; AHgh+RoWn+W040xYyximX5yryt7Q/Bmze5MJLFvzYWF9VIF+DRrrITxyOMlvxyah8QlqvdHKXWWQsrw=@ietf.org
X-Gm-Message-State: AFuF++kAcT59Nv6iWzM1apyczrQmWbRqO3ALa8hUKy3v+XlnW2p7fl/+ 6rcX8zVZ8UCNfZe0Mwq8wA+Pb2p2KFWp9JYX10IGpwXgMhVt11bPSc3d
X-Gm-Gg: AR+sD13msOz5Q9D5EmzsKIC+C8x5l+kozfSJ+LqWmMYUzaRlHygeMVIpejwM8uunOiF nvKOlKYoBTQGDqkEQURZihkRumqJmCcE9Vx2/rJorp3877I/zKrz25Ms3sL6cgh7levvCihARmO RdrOnDO8IAySympgm2sdwCeijqMdkuvGGTwDps/GlZZMv8mkE+Iz0NmBi5r29ztUcHMJZHWQFRN YgIMyL83ocw29oVfdgbwUcEbayC0IBj8l1r56uiftsmG1oGG6a2HFhqGXxsbfIpK6o6zyZmq8qI Rrq/wWhExIfuALnWfXF9IFmRMbSdHU1BpxuGRNl7AkvL7SsZnwvPbNa+o8HkN67+AZOUjtmzwI2 UsBdmE1mhd5cJwKNZq0cfgkTE42AVmXWBiMxrf/IJI1oUiAKw3DOw6QiPt0GeOn9VgF3whiDQZ1 YLVmKfOcIBuB0upLN9vwzN+uRr2G+oT4FEs7V/bHzyrZROprxoD26paksz8RxXwiZ4A9nHPMqyR 0pkmn6BjZaloSU=
X-Received: by 2002:a17:90b:2747:b0:380:540:d499 with SMTP id 98e67ed59e1d1-395c33cd87dmr2841697a91.6.1787261860830; Thu, 20 Aug 2026 14:37:40 -0700 (PDT)
Received: from smtpclient.apple ([38.99.102.194]) by smtp.gmail.com with ESMTPSA id 5a478bee46e88-327bf10d475sm21966724eec.18.2026.08.20.14.37.35 (version=TLS1_2 cipher=ECDHE-ECDSA-AES128-GCM-SHA256 bits=128/128); Thu, 20 Aug 2026 14:37:40 -0700 (PDT)
From: Mahesh Jethanandani <mjethanandani@gmail.com>
Message-Id: <38DF9D79-9DFE-42B6-9211-4FB25191DA2D@gmail.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_CBCF9D15-9CD0-449A-B61C-8C67DBD17492"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3864.600.51.1.1\))
Date: Thu, 20 Aug 2026 14:37:21 -0700
In-Reply-To: <E5AE0C02-5ED6-4509-9FA5-730235F57CD1@t-systems.com>
To: alex.huang-feng@t-systems.com
References: <178615071319.153546.9203560369914607963@dt-datatracker-559c48c7fb-9llwz> <50F320D3-F241-4966-A56C-B147B2A2BBA3@t-systems.com> <b1b635ea-2235-4a3e-8a39-825915ceaa60@huitema.net> <E5AE0C02-5ED6-4509-9FA5-730235F57CD1@t-systems.com>
X-Mailer: Apple Mail (2.3864.600.51.1.1)
Message-ID-Hash: QYSV24CXQZ7AEIEFTAOU2XA466DLQ6FJ
X-Message-ID-Hash: QYSV24CXQZ7AEIEFTAOU2XA466DLQ6FJ
X-MailFrom: mjethanandani@gmail.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-secdir.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: secdir@ietf.org, draft-ietf-netconf-yp-transport-capabilities.all@ietf.org, last-call@ietf.org, NETCONF WG <netconf@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [secdir] Re: [Last-Call] [netconf] draft-ietf-netconf-yp-transport-capabilities-06 ietf last call Secdir review
List-Id: Security Area Directorate <secdir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/secdir/Qj_wjENnaZSgIgjWu-LJPmws1CI>
List-Archive: <https://mailarchive.ietf.org/arch/browse/secdir>
List-Help: <mailto:secdir-request@ietf.org?subject=help>
List-Owner: <mailto:secdir-owner@ietf.org>
List-Post: <mailto:secdir@ietf.org>
List-Subscribe: <mailto:secdir-join@ietf.org>
List-Unsubscribe: <mailto:secdir-leave@ietf.org>
Hi Christian, Let me know if this update addresses your comments, and that you would be willing to update your review. Thanks. > On Aug 17, 2026, at 1:29 AM, alex.huang-feng@t-systems.com wrote: > > Dear Christian, > > I just submitted -07 to datatracker: https://datatracker.ietf.org/doc/draft-ietf-netconf-yp-transport-capabilities/07/ > > Apologies for the confusion. > > Regards, > Alex > >> On 14 Aug 2026, at 17:48, Christian Huitema <huitema@huitema.net> wrote: >> >> Did you actually submit draft 07? I did not find it yesterday in the IETF data tracker. >> >> -- Christian Huitema >> >> On 8/13/2026 4:57 AM, Alex.Huang-Feng=40t-systems.com@dmarc.ietf.org wrote: >>> Dear Christian, >>> >>> Thanks for the review. >>> >>> We addressed these comments in -07. >>> >>> Please find the diff in: https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fauthor-tools.ietf.org%2Fdiff%3Fdoc_1%3Ddraft-ietf-netconf-yp-transport-capabilities-06%26url_2%3Dhttps%3A%2F%2Fraw.githubusercontent.com%2Fnetwork-analytics%2Fdraft-netana-netconf-yang-push-transport-capabilities%2Frefs%2Fheads%2Fmain%2Fdraft-ietf-netconf-yp-transport-capabilities-07.txt&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739836714%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=3URe%2B0Fbnb%2BdKUVwYqlcBVKN%2B49%2FmjXOxWXL%2FGAaSdc%3D&reserved=0 <https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fauthor-tools.ietf.org%2Fdiff%3Fdoc_1%3Ddraft-ietf-netconf-yp-transport-capabilities-06%26url_2%3Dhttps%3A%2F%2Fraw.githubusercontent.com%2Fnetwork-analytics%2Fdraft-netana-netconf-yang-push-transport-capabilities%2Frefs%2Fheads%2Fmain%2Fdraft-ietf-netconf-yp-transport-capabilities-07.txt&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739852733%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=p1JlVxSUTJEWny3mMAhN43tErhOoSHgwZzqJfIBzfdY%3D&reserved=0> >>> >>> And the document: https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnetwork-analytics%2Fdraft-netana-netconf-yang-push-transport-capabilities%2Fblob%2Fmain%2Fdraft-ietf-netconf-yp-transport-capabilities-07.txt&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739862995%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=sNqNfGDxjkKKAXH28wywnp4qqvED0RESVgf2WRPR5e8%3D&reserved=0 >>> >>> Please see inline. >>> >>>> On 8 Aug 2026, at 02:58, Christian Huitema via Datatracker <noreply@ietf.org> wrote: >>>> >>>> Document: draft-ietf-netconf-yp-transport-capabilities >>>> Title: YANG Notification Transport Capabilities >>>> Reviewer: Christian Huitema >>>> Review result: Not Ready >>>> >>>> I have reviewed draft-ietf-netconf-yp-transport-capabilities-06 >>>> as part of the security directorate's ongoing effort to review all >>>> IETF documents being processed by the IESG. Theses comments were written >>>> primarily for the benefit of the security area directors. Document editors and >>>> WG chairs should treat these comments just like any other last call comments. >>>> >>>> The summary of the review is Not Ready. >>>> >>>> I find this document confusingbecause it uses generic terms like "server" >>>> or "transport" outside of the general understanding of these terms in IETF RFCs. >>>> >>>> Let's start with the introduction: The "ietf-system-capabilities" YANG module >>>> defined in [RFC9196] allows a client to discover a set of capabilities >>>> supported by a server (including, basic system capabilities and YANG-Push >>>> related capabilities) both at implementation time and at runtime. OK. What kind >>>> of server are we speaking about? A web server? An SMTP server? A server >>>> implementing protocols like NETCONF? A VPN server? Capabilities of servers tend >>>> to be very dependent on the type of application that the server is >>>> implementing. The split of functions between client and servers is also very >>>> dependent on the application. For example, a recursive DNS server is both a >>>> server for stub DNS resolvers and a client to authoritative DNS resolvers. >>>> >>>> If we mean any server on the Internet, then the review could just as well stop >>>> here. The concept of a unifying model for all Internet nodes that happen to >>>> accept a request and do something for another node is just silly. >>>> >>>> If we mean specialized servers used in network management such as NETCONF or >>>> RESTCONF, the draft should say so. >>> Yes, we meant NETCONF/RESTCONF server. >>> >>> We changed the wording throughout the document to refer to the NETCONF/RESTCONF client/server explicitly. >>> Additionally, note we have client/server definitions in the terminology section where we refer to RFC8342 for their definitions. >>> >>> These changes can be found in the abstract, introduction and section 2. >>>> >>>> Let's continue with the second paragraph of the introduction, the notion of >>>> transport protocol. At the lowest level, mentioning transport protocols on the >>>> Internet means something like TCP, UDP or QUIC. But then, the examples go on to >>>> include TLS, DTLS. I suspect that the authors' cocnept of what "transport" >>>> means is different from the regular understanding in, say, the IETF Web and >>>> Internet Transport Area. Again, it would be nice if the draft was rewritten to >>>> explain what is mean here by "transport", and if possible pick another name. >>> Good point. I changed the wording to "notification delivery protocol”. I also added the term “transport protocol” in the terminology section to specify that we refer to the protocol used to deliver notifications between a publisher and a receiver. >>> As this term comes from RFC8639, we refrain from changing it in the YANG module. >>>> >>>> The draft goes on to differentiate between TLS 1.2 and TLS 1.3, DTLS 1.2 and >>>> DTLS 1.3, which seems wrong. TLS 1.3 is defined in RFC 9846, which obsoletes >>>> older RFCa including RFC 5246 (TLS 1.2) and RFC 8446 (the original >>>> specification of TLS 1.3). RFC 6347 (DTLS 1.2) is obsoleted by RFC 9147 (DTLS >>>> 1.3). The draft should not make normative references to RFCs that are obsolete. >>>> I do not think that the draft should differentiate "identity dtls12" and >>>> "identity dtls13" -- these are just two version of the same protocol, that >>>> certainly do not change the "identity" of the server. >>> Such modelling was agreed by the WG and YANG doctors. The use of identities directly rather than the protocol and its version is because it would allow future users/developers to directly augment such YANG identities. >>> RFC9645 already uses this structure and we followed for consistency. >>> >>> Regarding referencing obsoleted RFCs as normative is because we define those identities. Shall we move these obsoleted references to informative? >>>> >>>> I can understand the need to provide the list of supported >>>> TLS or DTLS versions for management purposes, but this should be achieved by >>>> something like a supported version parameter. The TLS and DTLS negotiations >>>> include the capability of "negotiating down" from [D]TLS 1.3 to [D]TLS 1.2, if >>>> the server and the client are specifically configured to tolerate such >>>> downgrade. Maybe that acceptance or refusal of downgrade should be documented >>>> in the YML text? >>> The current document is not recommending any version of TLS or DTLS. The scope of the document is rather providing the NETCONF/RESTCONF server the capability to advertise what it supports for the notification delivery protocols, it does not define which protocols should be configured. >>> >>> Recommendations about which version to use are defined in their respective transport protocols (e.g. https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-netconf-udp-notif%23name-secured-layer-for-udp-notif&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739872646%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=yRj649kRFHC97PXr72mH%2BIa%2BE20QpSoJ7rFJVrQGGDA%3D&reserved=0) >>> >>>> >>>> I also do not really understand the relation between this "transport capability" >>>> description and the "HTTPS" or "CSVRV" DNS records that clients use to >>>> determine how to contact a server. Maybe that should be explained? Are clients >>>> expected to retrieve the YML description of the server before establishing a >>>> connection? It is pretty hard to review the security properties of this >>>> proposal without understanding its planned usage. >>> The intended usage of this model is between an orchestrator and a network device. Such network is configured beforehand by an operator and is typically dedicated to exchange configuration information. >>> We added the following paragraph, helping the reader about the expected usage: >>> >>> This model is intended to be used between an orchestrator and a >>> network device that provides YANG notifications. A management >>> network between the orchestrator and the network device is assumed to >>> be available for exchanging YANG management information. The >>> management connectivity and endpoint of the network device are >>> expected to be provisioned as part of the management network >>> configuration. The orchestrator can use the established management >>> connection to discover the notification transport capabilities of the >>> network device before establishing the notification subscription. >>> >>> I hope this text makes the document clearer. >>> >>> Regards, >>> Alex >>>> >>>> >>>> >>>> _______________________________________________ >>>> netconf mailing list -- netconf@ietf.org >>>> To unsubscribe send an email to netconf-leave@ietf.org >>> >>> > Mahesh Jethanandani mjethanandani@gmail.com
- [secdir] draft-ietf-netconf-yp-transport-capabili… Christian Huitema via Datatracker
- [secdir] Re: [netconf] draft-ietf-netconf-yp-tran… Alex.Huang-Feng
- [secdir] Re: [Last-Call] Re: [netconf] draft-ietf… Christian Huitema
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Alex.Huang-Feng
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Mahesh Jethanandani
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Christian Huitema
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Christian Huitema