[secdir] Re: [Last-Call] [netconf] draft-ietf-netconf-yp-transport-capabilities-06 ietf last call Secdir review
Alex.Huang-Feng@t-systems.com Mon, 17 August 2026 08:29 UTC
Return-Path: <Alex.Huang-Feng@t-systems.com>
X-Original-To: secdir@mail2.ietf.org
Delivered-To: secdir@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 60EAA12ADD884; Mon, 17 Aug 2026 01:29:34 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1786955374; bh=/axqZBp2fWvA04H+tx3KWAhidMeaOtPN3VwZJxXl3i4=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=tBDV5PZlcvBRkQhGNmNVbfuv2u0e/t/u/cwxevSV5rHWC10zoS9BjuRR4gROMHL8S gkqgyXr8dJyJHnlCwhCIgwrkHdJjrqWMYox2J34dnVUJN0sGueKCWm1iU7bYN6tp3D k8MO0ff6ZI7hHM8wQI+HrngrzTY4tae9kYDeqTMQ=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -4.396
X-Spam-Level:
X-Spam-Status: No, score=-4.396 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_NONE=0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=t-systems.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id uys_YJsXmxnc; Mon, 17 Aug 2026 01:29:32 -0700 (PDT)
Received: from mailout301.mail.telekom.de (mailout301.mail.telekom.de [3.124.155.16]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id B582012ADD86E; Mon, 17 Aug 2026 01:29:31 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=t-systems.com; i=@t-systems.com; q=dns/txt; s=mail; t=1786955372; x=1818491372; h=from:to:cc:subject:date:message-id:references: in-reply-to:mime-version; bh=/axqZBp2fWvA04H+tx3KWAhidMeaOtPN3VwZJxXl3i4=; b=C0cx8npy1RkdWIvrCaKMy2k8DrH8SpzvPBNadUyfGPKg32ozXx3WPRWw jFaQNvjsus7sS19jCPYkk5RJrsh9FB6vPhHFkm7jpnBOWl5ITDsZT8JXj LR9p5rCkCD48iwa+5/B0lJte0h3ljAEnAhrmDNZq3HYltWyuMeP+3Z7f9 FJPa/JB8DWCeGVhzppPaxmX8OaIueshUhq4PEAuvmwFtwdCWvm8rBLtg1 bKaAVLExxnC8++bme22V/4B47RSsR9SDKvIZwfHtHP5Ig8gHj/+rzmVxu eEQnlsBsbYaiFj0CKHORD6AiDT7+vFdPaBvqPMht6SX7p28ZssZMQssb5 Q==;
X-CSE-ConnectionGUID: EtMqFCcVT2Ortyrz4PPntQ==
X-CSE-MsgGUID: b7FcbSVCR0mfex2Em/vNhQ==
Received: from ip-10-175-186-70.eu-central-1.compute.internal (HELO mailbb04.mail.telekom.de) ([10.175.186.70]) by mailout301.mail.telekom.de with ESMTP/TLS/TLS_AES_256_GCM_SHA384; 17 Aug 2026 10:29:23 +0200
X-CSE-ConnectionGUID: Mx0YBtSXQMOKjGPy4DC6xA==
X-CSE-MsgGUID: m0j7CLO8RqS/hiMdYhyDkw==
IronPort-SDR: 6a82c662_FNI+TUqVyuA6a9wtM55+zq/bMTG93TeR9VmPz8Pi7Lu/jgk hb9Woy2rqBLywEjybNr3xeKFAmcmXSkt7DwcZ+g==
X-IronPort-AV: E=Sophos;i="6.25,228,1779141600"; d="scan'208,217";a="205597164"
Received: from he1a1289.emea1.cds.t-internal.com ([10.169.119.212]) by mailbb04.mail.telekom.de with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 17 Aug 2026 10:29:22 +0200
Received: from HE101190.emea1.cds.t-internal.com (10.169.119.196) by HE1A1289.emea1.cds.t-internal.com (10.169.119.212) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.2562.45; Mon, 17 Aug 2026 10:29:22 +0200
Received: from HE102772.emea1.cds.t-internal.com (10.171.40.44) by HE101190.emea1.cds.t-internal.com (10.169.119.196) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.2562.45 via Frontend Transport; Mon, 17 Aug 2026 10:29:22 +0200
Received: from FR4P281CU032.outbound.protection.outlook.com (40.93.78.51) by O365mail09.telekom.de (172.30.0.241) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.2.2562.45; Mon, 17 Aug 2026 10:29:22 +0200
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=kMNXx2zvYFJ1sx7JirtCtas8q2+VhrYFVkUxYYX/rESPSCAzlP71ZgNzqxUSbgMFm4Nqgw1wSmna/kvDfzh5S7mxP7XkkejG1MzeF1rkkz/3mdkx6LDKyAxg5ImW/0HwOaz2HiKcFam4ggGBw2nEhVK/x9CYVQNQ1D8CMKfqitmCP2bkdVVmTGL/o9t+vf2VCe+wGRug6XeSJ+GltM4r8500E3QGOG/yrH29qR3Dly5cdz0iSMsVT1LUruh5qHW3HGx0CMqsbYQN5fvbZRM+lgqjnLtyoFhuIceSeFbAflOiMxBp1P/YCKl9kAVOrXV2roO1pn32Fu+D9nNAyPPk5g==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=/axqZBp2fWvA04H+tx3KWAhidMeaOtPN3VwZJxXl3i4=; b=WfMF96yK0GKmhdCanT5HpYgPca+Uv01xSRPmfCLKlou5PikIeRiMoNNo88BYL/Up3Ox7/CqKzv2TZul+yDwZsEbrppR+kkrPjiQrPuSqnscqHDxeJ2r3f6GSGkTJepm5OY2rvaa0oOc20miQhHtdXrTM8+FjWt1MKfTHZl7ngqVPNdXu+CK3m8CwAQ4ZaWk3EGBZeJsK7lVaGsuKiJy+OlLIl0T1DecbUmNTPlp3QpQ7RWoy0jmZ2UW0HNiSZcs+SWrVjMfrsKame1C+cA79KBMJtvEAvCkeZqwj0UQ8mMhe71lJ7HfrwHa32t+WzwdQ9/obscrIx198QBpjF430Lw==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=t-systems.com; dmarc=pass action=none header.from=t-systems.com; dkim=pass header.d=t-systems.com; arc=none
Received: from BENP281MB6558.DEUP281.PROD.OUTLOOK.COM (2603:10a6:b10:120::10) by FR6P281MB5283.DEUP281.PROD.OUTLOOK.COM (2603:10a6:d10:196::8) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.315.17; Mon, 17 Aug 2026 08:29:20 +0000
Received: from BENP281MB6558.DEUP281.PROD.OUTLOOK.COM ([fe80::f85a:cd0f:6b66:d0b7]) by BENP281MB6558.DEUP281.PROD.OUTLOOK.COM ([fe80::f85a:cd0f:6b66:d0b7%6]) with mapi id 15.21.0315.016; Mon, 17 Aug 2026 08:29:20 +0000
From: Alex.Huang-Feng@t-systems.com
To: huitema@huitema.net
Thread-Topic: [Last-Call] [netconf] draft-ietf-netconf-yp-transport-capabilities-06 ietf last call Secdir review
Thread-Index: AQHdLiKAKHxEe2iwCEWcF5eL9FsI0A==
Date: Mon, 17 Aug 2026 08:29:20 +0000
Message-ID: <E5AE0C02-5ED6-4509-9FA5-730235F57CD1@t-systems.com>
References: <178615071319.153546.9203560369914607963@dt-datatracker-559c48c7fb-9llwz> <50F320D3-F241-4966-A56C-B147B2A2BBA3@t-systems.com> <b1b635ea-2235-4a3e-8a39-825915ceaa60@huitema.net>
In-Reply-To: <b1b635ea-2235-4a3e-8a39-825915ceaa60@huitema.net>
Accept-Language: es-ES, en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=t-systems.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: BENP281MB6558:EE_|FR6P281MB5283:EE_
x-ms-office365-filtering-correlation-id: 5cd33620-0399-4601-f47b-08defc39a2cf
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|4022899009|23010399003|376014|1800799024|366016|8096899003|18002099003|22082099003|38070700021|11063799006|4143699003|56012099006|3023799007|4133799003|10067099003|6133799003|13003099007;
x-microsoft-antispam-message-info: BpT7Amov7Tj/iTm+5Ca615aKtxvgUGoh4xsZz5rKhSL3ScuSUJkIeJBrIamT1zINaJw/ZFYmngO6Zjf6/AKkmErUD85iQCLomSuOBGyZdVwmi+sENpMV8s8bzYHWSTfLD1I7CMC06ZCg42kOcGLnZdx/vvXQnh3FH/YpZXmIaanBzgDOrG+/mFEoK4wpvKv4J8PicAE1oD1pfYMA32CXJF+MPQO9dLG2QP95JQW4cVW1da7nXiBh0zOPIvEIyjxfHD47EbpQC4rcyGpdLp5EVLAvXdOJANpmcgm2J6n/Bfi3TtyYuhFre7+JOKCkxxIS/rpry3yR6hM2+X5gfcM94KG3Q7jh3MoxVlnXJ/lEptif7YkIYrFF/uvWesLPX8Mh5mKhD35rzjDMXt3hjaqsTQmr5qzJGskH26UpPZji5YHBAAzwdfBsoLp6qY00nXnQlUZ/kUO1H26xq43L1F27LV+EbWjhRR9aLFqi6J2PmvcBUqOTyvh29j/w8NYCCYnxHlG9h5BZEO6nnduaZmSmpqEd1RDCZQyfBmfryCN/ev9bfSlvv2RaZ+aqL7ELwaYwllQXKAQ5wBtZedwTIC9X7C0w9hL8qSCHoH01ENaFL3oARo29/1qVLNAijZY954DL8Yt+aDj/Co1/E0M5lPJpVOW1shWLyqHMylPvzGOC8634CSBf/xqElZJiFk8GI049
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:BENP281MB6558.DEUP281.PROD.OUTLOOK.COM;PTR:;CAT:NONE;SFS:(13230040)(4022899009)(23010399003)(376014)(1800799024)(366016)(8096899003)(18002099003)(22082099003)(38070700021)(11063799006)(4143699003)(56012099006)(3023799007)(4133799003)(10067099003)(6133799003)(13003099007);DIR:OUT;SFP:1101;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: churMYS4LViyPv7Nr79OewBpXDB7X0Qljowc6/rBaY972KCse1qkq7vvm33/6cS2zo2Po7wAt25BkVqFGxYPWzep9zZfY6PBAIyuZ9lpYJ/Oq+2SIwpZF0w70DerQUnLKc8r+wiyWNVsTKw2xDdhwhboDfWtN/mwRcKsoF7iqrsGRIiInF2lTwiZ5UzIqStg9Ra1yYBgvQxld9AyIDavBEvrWyV0Amdr+iBuQOitJRCu86p6ab/7011necjb89bIRZrPCgfmk6RTxN10L4P2r7heH8SDt0CCYpAHQHvNUNaXoRxfJ8Ce3a61KryZ2uZ3gfuhDNY67xRhiEpEVtcBKBCX1ptIS9vkKg5hJWiNyZzpxDKU9WZQ4905QlfHqT5oUJuQ90QMNoCgFYLrZ1W+DO0cjCE4UZCUkU4P5MAoQiKGld3/BcrYPVttxg/rStWkseFbA9z9qOaZWPRceDQxP3H4lWwkEEGb7xwEwsd/hl4c9uXGW/2ZcpXZEM5WCeK0+VzLystHkPGphI8lY8lLV8kPJXhrD6SLr1hDrphe5Xj8aHFlCsigkMMw0D8S6CNJlJxtNbRpdoBT9CLq96jwhxfWArRhzUn2KQ3ON5sx4rlFDwb0T1QMTMwwPdy7xHj44hTsZYnd8YZ/Ga2Cf+lrOsEIcZFcgJ5QpJVh6C4E9bYXDxlxlasY6K1b1lH1XI8URDOwvzX+oGz8YAVn+JiOvLA6VEev++xgp+6pKa1lkqYg93wM3KpKxeBsbRo1ntZ26aZrhzu/UXsU04fLV8MUenJVHeUzmZCk1grhf1VMS6sbuaIYdVg4s+PUYVVw/h04vPcxzTubscRP/hRkPaE9Qc84MKCv0T4P9vyAlb1g4rudKF82R9/z2jpt/8u5QkszeA3bs1ew4rbyGcEUIymeQyHt1tMJHRdiAeFBH3vJZcwWjANI9IZhXBpQ540diS7kxnrsMiyFNJncS1IPfAw1W8uu+b42rmkip3JMrsFc7Q6v2ceTFz3XwBf8SlMdJb6zYGyOWJfU+BZkF/zaUah1JdwXekQ9Rx4o49d14T+4VgsHEhjT+C6GjA07FFfwgXoHBsFpMmoyfK+zdeXGOiPjd9g1f1rmPyADngH98EZFdAxPZtwCOkpbHYdQtwLJvKkCB+VTPran+woq77fBAAU4TuFlyauX400xTzGMCMqV/3/4p4XK3B+HpG1UiAXfVX41DZGTFQnq0+Ck+o+PPVrEGnlqIKYHXUSn1xZWc4cNq92PaWdwMXI2kl1oAF/03AFr95DClFrsKgVhsboL90ETnAnzAWJkIwZ03lpUYGZTiF4AWOppx2o6Epxl/syY69I+tGiIrduKeXo3ySvgkG35F245wGR+JL6oVP38v8mO7ARqp3v0EK7lwToMgpBdnBgv5YsCiDkBID5QEK759URlug4RVr3l6P7Fx19OgHWkWHAkyqr+73DBIm/gVVFvNmFRVdNEIV3KnaMpnwW8OYm5qJfXB5kktDOUWYuLA5HrfaYxJMZYHvxAfCUESskZ78Y+1fqLUMOPqei9GZ6zs2dviNLbS7qTBl7/vB904DnE/J9uK9J79N4bkpwjpSlX6yszv7szvtO3Mv6UDVHSapS8quUCcePPf0Vtk0kPN/UXws/K32xYXZMXcmvT7eqjlWA59vwLiluBL+069vs/bwKVEKKQCU8Bf68mx2BJTLGlz6QCnCgrOWmcqGx1/4U+Ln1A7ZqGu3/8avVwQ3mrHwVNn25joFHnBMi2yf1BWeFe8NkvuXrAOWvnOFLeyeLvL5Tn
Content-Type: multipart/alternative; boundary="_000_E5AE0C025ED645099FA5730235F57CD1tsystemscom_"
MIME-Version: 1.0
X-Exchange-RoutingPolicyChecked: NUPl5p6Hwzl7Xnfkzj5qSsB296ib7WIgd5qKz+gCagKUyNAVSTu0SRshThIym8b4BJYbyddrrcflLCFtJNX+k6h7nHiGehIegcYucXLEbnB6skFnfoKDh7rOQIb4COA50pcwEEDXl3Bu0/lfc0afQUjd9Gcg1CJZnHbgRToq6sHuKRAxWP/PH5Gtk4mgsNXsR6ZiznQXPyhrz/4vllFuwqd8nsUntuAs290PSriEvbDBSzikYrM9dXOP600Tngk5dnvCs0eUdQKTJE8zPt/GipMM51oopQa2he4FEt1m3PM7TTnqSf56mBzQkzMiv3k2WPeAf8J+awnGe0NqJEWH/w==
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: BENP281MB6558.DEUP281.PROD.OUTLOOK.COM
X-MS-Exchange-CrossTenant-Network-Message-Id: 5cd33620-0399-4601-f47b-08defc39a2cf
X-MS-Exchange-CrossTenant-originalarrivaltime: 17 Aug 2026 08:29:20.7841 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: bde4dffc-4b60-4cf6-8b04-a5eeb25f5c4f
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: pu8C85A9h+ygYh48nSniP7peY2hur0Pt6nNBFttt+Aio7T5HPCcXHlmbzko1T+j6joyxEDlc2c1Xnxz/HlBZHaQfYQATeR++dzm4xSu5Sgw=
X-MS-Exchange-Transport-CrossTenantHeadersStamped: FR6P281MB5283
X-OriginatorOrg: t-systems.com
Message-ID-Hash: GCBFAONUMKY57XNZNNQRD266ZLWW6WM5
X-Message-ID-Hash: GCBFAONUMKY57XNZNNQRD266ZLWW6WM5
X-MailFrom: Alex.Huang-Feng@t-systems.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-secdir.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: secdir@ietf.org, draft-ietf-netconf-yp-transport-capabilities.all@ietf.org, last-call@ietf.org, netconf@ietf.org
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [secdir] Re: [Last-Call] [netconf] draft-ietf-netconf-yp-transport-capabilities-06 ietf last call Secdir review
List-Id: Security Area Directorate <secdir.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/secdir/k7CGDi19mzarHpCwsQs0sbspzLo>
List-Archive: <https://mailarchive.ietf.org/arch/browse/secdir>
List-Help: <mailto:secdir-request@ietf.org?subject=help>
List-Owner: <mailto:secdir-owner@ietf.org>
List-Post: <mailto:secdir@ietf.org>
List-Subscribe: <mailto:secdir-join@ietf.org>
List-Unsubscribe: <mailto:secdir-leave@ietf.org>
Dear Christian, I just submitted -07 to datatracker: https://datatracker.ietf.org/doc/draft-ietf-netconf-yp-transport-capabilities/07/ Apologies for the confusion. Regards, Alex On 14 Aug 2026, at 17:48, Christian Huitema <huitema@huitema.net> wrote: Did you actually submit draft 07? I did not find it yesterday in the IETF data tracker. -- Christian Huitema On 8/13/2026 4:57 AM, Alex.Huang-Feng=40t-systems.com@dmarc.ietf.org wrote: Dear Christian, Thanks for the review. We addressed these comments in -07. Please find the diff in: https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fauthor-tools.ietf.org%2Fdiff%3Fdoc_1%3Ddraft-ietf-netconf-yp-transport-capabilities-06%26url_2%3Dhttps%3A%2F%2Fraw.githubusercontent.com%2Fnetwork-analytics%2Fdraft-netana-netconf-yang-push-transport-capabilities%2Frefs%2Fheads%2Fmain%2Fdraft-ietf-netconf-yp-transport-capabilities-07.txt&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739836714%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=3URe%2B0Fbnb%2BdKUVwYqlcBVKN%2B49%2FmjXOxWXL%2FGAaSdc%3D&reserved=0 <https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fauthor-tools.ietf.org%2Fdiff%3Fdoc_1%3Ddraft-ietf-netconf-yp-transport-capabilities-06%26url_2%3Dhttps%3A%2F%2Fraw.githubusercontent.com%2Fnetwork-analytics%2Fdraft-netana-netconf-yang-push-transport-capabilities%2Frefs%2Fheads%2Fmain%2Fdraft-ietf-netconf-yp-transport-capabilities-07.txt&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739852733%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=p1JlVxSUTJEWny3mMAhN43tErhOoSHgwZzqJfIBzfdY%3D&reserved=0> And the document: https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnetwork-analytics%2Fdraft-netana-netconf-yang-push-transport-capabilities%2Fblob%2Fmain%2Fdraft-ietf-netconf-yp-transport-capabilities-07.txt&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739862995%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=sNqNfGDxjkKKAXH28wywnp4qqvED0RESVgf2WRPR5e8%3D&reserved=0 Please see inline. On 8 Aug 2026, at 02:58, Christian Huitema via Datatracker <noreply@ietf.org> wrote: Document: draft-ietf-netconf-yp-transport-capabilities Title: YANG Notification Transport Capabilities Reviewer: Christian Huitema Review result: Not Ready I have reviewed draft-ietf-netconf-yp-transport-capabilities-06 as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. Theses comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments. The summary of the review is Not Ready. I find this document confusingbecause it uses generic terms like "server" or "transport" outside of the general understanding of these terms in IETF RFCs. Let's start with the introduction: The "ietf-system-capabilities" YANG module defined in [RFC9196] allows a client to discover a set of capabilities supported by a server (including, basic system capabilities and YANG-Push related capabilities) both at implementation time and at runtime. OK. What kind of server are we speaking about? A web server? An SMTP server? A server implementing protocols like NETCONF? A VPN server? Capabilities of servers tend to be very dependent on the type of application that the server is implementing. The split of functions between client and servers is also very dependent on the application. For example, a recursive DNS server is both a server for stub DNS resolvers and a client to authoritative DNS resolvers. If we mean any server on the Internet, then the review could just as well stop here. The concept of a unifying model for all Internet nodes that happen to accept a request and do something for another node is just silly. If we mean specialized servers used in network management such as NETCONF or RESTCONF, the draft should say so. Yes, we meant NETCONF/RESTCONF server. We changed the wording throughout the document to refer to the NETCONF/RESTCONF client/server explicitly. Additionally, note we have client/server definitions in the terminology section where we refer to RFC8342 for their definitions. These changes can be found in the abstract, introduction and section 2. Let's continue with the second paragraph of the introduction, the notion of transport protocol. At the lowest level, mentioning transport protocols on the Internet means something like TCP, UDP or QUIC. But then, the examples go on to include TLS, DTLS. I suspect that the authors' cocnept of what "transport" means is different from the regular understanding in, say, the IETF Web and Internet Transport Area. Again, it would be nice if the draft was rewritten to explain what is mean here by "transport", and if possible pick another name. Good point. I changed the wording to "notification delivery protocol”. I also added the term “transport protocol” in the terminology section to specify that we refer to the protocol used to deliver notifications between a publisher and a receiver. As this term comes from RFC8639, we refrain from changing it in the YANG module. The draft goes on to differentiate between TLS 1.2 and TLS 1.3, DTLS 1.2 and DTLS 1.3, which seems wrong. TLS 1.3 is defined in RFC 9846, which obsoletes older RFCa including RFC 5246 (TLS 1.2) and RFC 8446 (the original specification of TLS 1.3). RFC 6347 (DTLS 1.2) is obsoleted by RFC 9147 (DTLS 1.3). The draft should not make normative references to RFCs that are obsolete. I do not think that the draft should differentiate "identity dtls12" and "identity dtls13" -- these are just two version of the same protocol, that certainly do not change the "identity" of the server. Such modelling was agreed by the WG and YANG doctors. The use of identities directly rather than the protocol and its version is because it would allow future users/developers to directly augment such YANG identities. RFC9645 already uses this structure and we followed for consistency. Regarding referencing obsoleted RFCs as normative is because we define those identities. Shall we move these obsoleted references to informative? I can understand the need to provide the list of supported TLS or DTLS versions for management purposes, but this should be achieved by something like a supported version parameter. The TLS and DTLS negotiations include the capability of "negotiating down" from [D]TLS 1.3 to [D]TLS 1.2, if the server and the client are specifically configured to tolerate such downgrade. Maybe that acceptance or refusal of downgrade should be documented in the YML text? The current document is not recommending any version of TLS or DTLS. The scope of the document is rather providing the NETCONF/RESTCONF server the capability to advertise what it supports for the notification delivery protocols, it does not define which protocols should be configured. Recommendations about which version to use are defined in their respective transport protocols (e.g. https://deu01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-netconf-udp-notif%23name-secured-layer-for-udp-notif&data=05%7C02%7CAlex.Huang-Feng%40t-systems.com%7C3be8c5606359441ae3ab08defa1b9b64%7Cbde4dffc4b604cf68b04a5eeb25f5c4f%7C0%7C0%7C639223194739872646%7CUnknown%7CTWFpbGZsb3d8eyJFbXB0eU1hcGkiOnRydWUsIlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiTWFpbCIsIldUIjoyfQ%3D%3D%7C60000%7C%7C%7C&sdata=yRj649kRFHC97PXr72mH%2BIa%2BE20QpSoJ7rFJVrQGGDA%3D&reserved=0) I also do not really understand the relation between this "transport capability" description and the "HTTPS" or "CSVRV" DNS records that clients use to determine how to contact a server. Maybe that should be explained? Are clients expected to retrieve the YML description of the server before establishing a connection? It is pretty hard to review the security properties of this proposal without understanding its planned usage. The intended usage of this model is between an orchestrator and a network device. Such network is configured beforehand by an operator and is typically dedicated to exchange configuration information. We added the following paragraph, helping the reader about the expected usage: This model is intended to be used between an orchestrator and a network device that provides YANG notifications. A management network between the orchestrator and the network device is assumed to be available for exchanging YANG management information. The management connectivity and endpoint of the network device are expected to be provisioned as part of the management network configuration. The orchestrator can use the established management connection to discover the notification transport capabilities of the network device before establishing the notification subscription. I hope this text makes the document clearer. Regards, Alex _______________________________________________ netconf mailing list -- netconf@ietf.org To unsubscribe send an email to netconf-leave@ietf.org
- [secdir] draft-ietf-netconf-yp-transport-capabili… Christian Huitema via Datatracker
- [secdir] Re: [netconf] draft-ietf-netconf-yp-tran… Alex.Huang-Feng
- [secdir] Re: [Last-Call] Re: [netconf] draft-ietf… Christian Huitema
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Alex.Huang-Feng
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Mahesh Jethanandani
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Christian Huitema
- [secdir] Re: [Last-Call] [netconf] draft-ietf-net… Christian Huitema