[sfc] Robert Wilton's No Objection on draft-ietf-sfc-multi-layer-oam-27: (with COMMENT)

Robert Wilton via Datatracker <noreply@ietf.org> Thu, 06 July 2023 06:54 UTC

Return-Path: <noreply@ietf.org>
X-Original-To: sfc@ietf.org
Delivered-To: sfc@ietfa.amsl.com
Received: from ietfa.amsl.com (localhost [IPv6:::1]) by ietfa.amsl.com (Postfix) with ESMTP id 8B8C4C15107A; Wed, 5 Jul 2023 23:54:11 -0700 (PDT)
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit
From: Robert Wilton via Datatracker <noreply@ietf.org>
To: The IESG <iesg@ietf.org>
Cc: draft-ietf-sfc-multi-layer-oam@ietf.org, sfc-chairs@ietf.org, sfc@ietf.org, donald.eastlake@futurewei.com, d3e3e3@gmail.com, donald.eastlake@futurewei.com
X-Test-IDTracker: no
X-IETF-IDTracker: 11.3.0
Auto-Submitted: auto-generated
Precedence: bulk
Reply-To: Robert Wilton <rwilton@cisco.com>
Message-ID: <168862645156.65421.13234559852116734018@ietfa.amsl.com>
Date: Wed, 05 Jul 2023 23:54:11 -0700
Archived-At: <https://mailarchive.ietf.org/arch/msg/sfc/g4b7dSCn-uiFi9GeRDCS34CYgRg>
Subject: [sfc] Robert Wilton's No Objection on draft-ietf-sfc-multi-layer-oam-27: (with COMMENT)
X-BeenThere: sfc@ietf.org
X-Mailman-Version: 2.1.39
List-Id: Network Service Chaining <sfc.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/sfc>, <mailto:sfc-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/sfc/>
List-Post: <mailto:sfc@ietf.org>
List-Help: <mailto:sfc-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/sfc>, <mailto:sfc-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 06 Jul 2023 06:54:11 -0000

Robert Wilton has entered the following ballot position for
draft-ietf-sfc-multi-layer-oam-27: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)


Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.


The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sfc-multi-layer-oam/



----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

Thanks for this document.  I found various points in the document to be
unclear.  Please consider whether addressing these comments would improve the
clarity of the document.

(1) p 5, sec 3.  Requirements for Active OAM in SFC

   Once the SFF1 detects the defect, the objective of the SFC OAM
   changes from the detection of a defect to defect characterization and
   localization.

It wasn't clear to me why it is SFF1 that detects the defect, rather than say,
"Once an SFF detects the defect"?

(2) p 6, sec 3.  Requirements for Active OAM in SFC

   *  REQ#8: Can be addressed by an extension of the SFC Echo Request/
      Reply described in this document adding proxy capability.

Does this mean that requirement 8 isn't actually addressed by this
specification?  If so, this seems to conflict with the sentence above: "The
above listed requirements are satisfied in this specification as follows:"

(3) p 7, sec 6.  Echo Request/Echo Reply for SFC

   Echo Request/Reply is a well-known active OAM mechanism extensively
   used to verify a path's continuity, detect inconsistencies between a
   state in control and the data planes, and localize defects in the
   data plane.  ICMP ([RFC0792] for IPv4 and [RFC4443] for IPv6
   networks) and [RFC8029] are examples of broadly used active OAM
   protocols based on the Echo Request/Reply principle.  The SFC Echo
   Request/Reply control message format is presented in Figure 3.

I didn't entirely follow how these headers fit together.  Is the "SFC Echo
Request/Reply Format" an instance of an "SFC Active OAM Control Packet" that is
used in the "SFC Active OAM Header" above?  If so, then it would probably be
helpful for this to be explicitly stated.

(4) p 10, sec 6.1.  Return Codes

                       Table 1: SFC Echo Return Codes

It is unclear to me whether the SFC Echo Return Codes are those defined in this
table, or the ones specified in section 10.3.4.  Perhaps it would be better for
this section to just reference 10.3.4 rather than having duplicate normative
content?

(5) p 13, sec 6.4.  Processing Received SFC Echo Request

      1.1 Suppose the authentication validation has failed and the
      Source TLV is considered properly formatted.  In that case, the
      SFF MUST send to the system identified in the Source TLV (see
      Section 6.5), according to a rate-limit control mechanism, an SFC
      Echo Reply with the Return Code set to "Authentication failed" and
      the Subcode set to zero.

Does this effectively mean that even if authentication fails, some level of SFC
Echo Request/Reply is supported (e.g., at least to the first SFF)?  I was
wondering whether in this case, it wouldn't be safer to treat this like step
2.1.  I.e., an error is logged but no response is sent back?

(6) p 14, sec 6.4.  Processing Received SFC Echo Request

      8.  In all other cases, SFF MUST set the Return Code value to 0
      ("No Error, End of Path Reached") and the Subcode set to zero.

Some of these steps are very explicit in that they send a responce back, but
others, like 6, 7, and 8 do not explicitly indicate that they send a reply.

(7) p 14, sec 6.4.  Processing Received SFC Echo Request

      8.  In all other cases, SFF MUST set the Return Code value to 0
      ("No Error, End of Path Reached") and the Subcode set to zero.

I didn't understand the distinction between "End of the SFP" and "No Error, End
of Path Reached".  Is the difference that in one case reaching the end is
expected, and the other is that it is not?  Perhaps worth clarifying.

Nit level comments:

(8) p 12, sec 6.3.1.  Source TLV

      Source ID - the value MUST be 1 Section 10.4.

Perhaps "MUST be 1, as per Section 10.4."

Regards,
Rob