From buraglio@forwardingplane.net  Mon Feb  5 13:20:32 2024
Return-Path: <buraglio@forwardingplane.net>
X-Original-To: spring@ietfa.amsl.com
Delivered-To: spring@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1])
 by ietfa.amsl.com (Postfix) with ESMTP id 0BFC4C14F6A5
 for <spring@ietfa.amsl.com>; Mon,  5 Feb 2024 13:20:32 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.106
X-Spam-Level: 
X-Spam-Status: No, score=-2.106 tagged_above=-999 required=5
 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
 DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001,
 RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_ZEN_BLOCKED_OPENDNS=0.001,
 SPF_HELO_NONE=0.001, SPF_PASS=-0.001, T_SCC_BODY_TEXT_LINE=-0.01,
 URIBL_DBL_BLOCKED_OPENDNS=0.001, URIBL_ZEN_BLOCKED_OPENDNS=0.001]
 autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key)
 header.d=forwardingplane.net
Received: from mail.ietf.org ([50.223.129.194])
 by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024)
 with ESMTP id fMuiMDJhiiiK for <spring@ietfa.amsl.com>;
 Mon,  5 Feb 2024 13:20:27 -0800 (PST)
Received: from mail-qt1-x82c.google.com (mail-qt1-x82c.google.com
 [IPv6:2607:f8b0:4864:20::82c])
 (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits)
 key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256)
 (No client certificate requested)
 by ietfa.amsl.com (Postfix) with ESMTPS id DA7EDC14F69E
 for <spring@ietf.org>; Mon,  5 Feb 2024 13:20:27 -0800 (PST)
Received: by mail-qt1-x82c.google.com with SMTP id
 d75a77b69052e-42bf29aff0dso34515671cf.3
 for <spring@ietf.org>; Mon, 05 Feb 2024 13:20:27 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
 d=forwardingplane.net; s=google; t=1707168026; x=1707772826; darn=ietf.org;
 h=to:subject:message-id:date:from:in-reply-to:references:mime-version
 :from:to:cc:subject:date:message-id:reply-to;
 bh=c0xjir/f6da1DfTsx3oCN8au27Lelcwmc5skWBiQzgk=;
 b=sVAqUu38tDUv0KZn/W8jE9rTUTObUP9RaPpTiA5nIUx+lZ/uF7IXgmCf1nAhSDnmWI
 81M4Vo3QKt1179zWBNILvRZoNCkPJxKfW/cnwkTc339AglJg1B4QCRCtH0Nubq98QZDt
 IFNcthTXJ4+ZnzBueoDCm5LtM5m1o+z8rUmnU=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
 d=1e100.net; s=20230601; t=1707168026; x=1707772826;
 h=to:subject:message-id:date:from:in-reply-to:references:mime-version
 :x-gm-message-state:from:to:cc:subject:date:message-id:reply-to;
 bh=c0xjir/f6da1DfTsx3oCN8au27Lelcwmc5skWBiQzgk=;
 b=jhjhNR6rXZw0eNBXEAM8XVrTJwY0JW51yht6k4+8sSRY9JlngGIsXSKzacAjNketuF
 IKLNTK6mMcTjJ4jLVy1bcS/+prN0eKXEFlvJL+qvTntA7QTaHXGJT4eSeJUZ+CfCW1cK
 CB3bCO4eZIst16+K4HqybbLkD3nFIsU0vZamcYsP1caoRf5sJSOrbq4k7qbFVDV/PYCA
 piMhNVycRIHsBJi9H50ogI+tgs98og2WFdNBlo2i2urpiNOt/X3n9Vide59HSDsv1Lkg
 5waQO6thhQ7uEcxZ/P6CZo4eyJ4E0yoOZoTtGLVDIBTIcRNie3vEC6wTaDz6lT6Pz2kN
 Yufw==
X-Gm-Message-State: AOJu0YyugrR0dhYI4CdVSmRfZusoMnNcvggop7RIAgc0a4B2eQSIBesO
 dQZT42SjqNOOR1dJQKT3kaayyeBWd71Z+x8YDx5RO58Fhl8GAHQlvP5qR5ZDs8qxMl6xpdrDYF1
 QM8Tj4Ty+3GJjWQSPrhx0WmL3mLDMW/Y5t2ZCjng+CshfiLCvOQ==
X-Google-Smtp-Source: AGHT+IHVwNsGvq5oFjHZX+xEfmDfs/ZwCIQ1qWM8MmQma9LTKJ6jAQ6AIbawRnPJcAq0AnmXA+INeFR8nmwhsP80Ot4=
X-Received: by 2002:a05:622a:28e:b0:42b:ff8d:3719 with SMTP id
 z14-20020a05622a028e00b0042bff8d3719mr696157qtw.67.1707168026614; Mon, 05 Feb
 2024 13:20:26 -0800 (PST)
MIME-Version: 1.0
References: <DU2PR03MB8021764E2F17F0D527E3FA3CFA472@DU2PR03MB8021.eurprd03.prod.outlook.com>
 <BL0PR05MB53163A098023244520ADCEEBAE472@BL0PR05MB5316.namprd05.prod.outlook.com>
 <CAOj+MMEc1R8fZZwgOEF2-mK8S0+PE+zBR3Yz9vwXBh-umQPAjQ@mail.gmail.com>
 <DU2PR03MB8021CE3063F9E5B59B9A142FFA472@DU2PR03MB8021.eurprd03.prod.outlook.com>
In-Reply-To: <DU2PR03MB8021CE3063F9E5B59B9A142FFA472@DU2PR03MB8021.eurprd03.prod.outlook.com>
From: Nick Buraglio <buraglio@forwardingplane.net>
Date: Mon, 5 Feb 2024 15:20:15 -0600
Message-ID: <CACMsEX_8pAcS0PnjwnvyLg9+FTyaEZMp-EF2qyVC3MkXV-ZmNA@mail.gmail.com>
To: "spring@ietf.org" <spring@ietf.org>
Content-Type: multipart/alternative; boundary="000000000000cc71b70610a90706"
Archived-At: <https://mailarchive.ietf.org/arch/msg/spring/0MmCM0wHDcd8GUVj7yLXKfxGLbk>
Subject: Re: [spring] draft-ietf-spring-srv6-srh-compression
X-BeenThere: spring@ietf.org
X-Mailman-Version: 2.1.39
Precedence: list
List-Id: "Source Packet Routing in NetworkinG \(SPRING\)" <spring.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/spring>,
 <mailto:spring-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/spring/>
List-Post: <mailto:spring@ietf.org>
List-Help: <mailto:spring-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/spring>,
 <mailto:spring-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 05 Feb 2024 21:20:32 -0000

--000000000000cc71b70610a90706
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

There seems to be a fair amount of deployment and testing done here - Do we
have broken behavior that is repeatable in the wild, or easily
reproducible in a lab that can be shared? I understand the issue, I
believe, but am looking for a repeatable broken example to fiddle with, and
hoping someone has already done the legwork.
I would love to read / see results and test case examples of things that
should be considered. Existing work done in this space would be very useful
for another document that is currently in the works. I see that Tom Herbert
asked for something similar here
https://mailarchive.ietf.org/arch/msg/spring/1Sq_KaDRUYD-HiG7iebbcodXNLA/
but I have not seen a reply.

nb

On Mon, Feb 5, 2024 at 1:32=E2=80=AFPM Andrew Alston - IETF <andrew-ietf=3D
40liquid.tech@dmarc.ietf.org> wrote:

> I call breaking any middleware that does checksum validation a problem -
> and a big one
>
>
> Andrew Alston
>
> Internal All Employees
> ------------------------------
> *From:* Robert Raszuk <robert@raszuk.net>
> *Sent:* Monday, February 5, 2024 7:16:23 PM
> *To:* Ron Bonica <rbonica@juniper.net>
> *Cc:* Andrew Alston - IETF <andrew-ietf@liquid.tech>; spring@ietf.org <
> spring@ietf.org>
> *Subject:* Re: [spring] draft-ietf-spring-srv6-srh-compression
>
> Hi Ron,
>
> Is there a problem ?
>
> If I read RFC8200 L4 checksum is computed by the packet *originator and
> validated by the packet's ultimate receiver. *
>
> In all SPRING work to the best of my knowledge the vast majority of
> packets are only encapsulated by transit nodes.
>
> Is there any formal mandate in any of the RFCs that an encapsulating node
> must mangle the inner packet's L4 checksum ? I don't think so but stand
> open to get my understanding corrected.
>
> Cheers,
> Robert
>
>
>
>
>
>
> On Mon, Feb 5, 2024 at 5:04=E2=80=AFPM Ron Bonica <rbonica=3D
> 40juniper.net@dmarc.ietf.org> wrote:
>
> Folks,
>
> Has anyone proposed a solution to the L4 checksum problem that Andrew
> talks about?
>
>                                           Ron
>
> Juniper Business Use Only
> ------------------------------
> *From:* spring <spring-bounces@ietf.org> on behalf of Andrew Alston -
> IETF <andrew-ietf=3D40liquid.tech@dmarc.ietf.org>
> *Sent:* Monday, February 5, 2024 5:21 AM
> *To:* spring@ietf.org <spring@ietf.org>
> *Subject:* [spring] draft-ietf-spring-srv6-srh-compression
>
>
> [External Email. Be cautious of content]
>
> Hi All,
>
>
>
> (In capacity as a contributor and wearing no other hats)
>
>
>
> At this point I cannot support progression of this document until the
> issues around the L4 Checksum have been resolved.  It=E2=80=99s been clea=
rly stated
> in other emails on the list that in certain circumstances the behavior
> described in this document break the L4 checksum as defined in RFC8200.
> This requires an update to RFC8200 to fix it =E2=80=93 and I=E2=80=99m no=
t sure that spring
> can update 8200 absent the consent of 6man, which I=E2=80=99m not sure ha=
s been
> asked for, nor am I sure that a spring document can update something like
> 8200 in an area so fundamental as the checksum without a -BIS, which woul=
d
> have to be done via 6man.  The L4 checksum issue though is real =E2=80=93=
 and it
> cannot simply be ignored.
>
>
>
> I also have deep concerns that the compression document creates something
> that (in a similar way to SRv6) creates something that is completely
> non-conformant with RFC4291.  There are multiple references to this in
> draft-6man-sids, and should draft-6man-sids become an RFC I would argue
> that it should probably be a normative reference in this document =E2=80=
=93 on the
> logic that this document relies on similar RFC4291 violations that srv6
> itself does (and for the record, just because SRv6 itself violates RFC429=
1
> as is clearly documented in draft-6man-sids =E2=80=93 does not make it ac=
ceptable
> to do so in yet another draft without clear and unambiguously stating the
> deviations and ideally updating RFC4291 to allow for said deviations)
>
>
>
> I believe these two issues alone are sufficient that to pass this documen=
t
> would create still further tensions about the relationship between SRv6 a=
nd
> IPv6 and lead to confusion.  As such =E2=80=93 I believe these issues nee=
d to be
> adequately dealt with =E2=80=93 and the solutions to them need to be appr=
oved by
> 6man as the working group that holds responsibility for ipv6 maintenance.
>
>
>
> Thanks
>
>
>
> Andrew Alston
>
>
>
>
>
> Internal All Employees
> _______________________________________________
> spring mailing list
> spring@ietf.org
> https://www.ietf.org/mailman/listinfo/spring
>
> _______________________________________________
> spring mailing list
> spring@ietf.org
> https://www.ietf.org/mailman/listinfo/spring
>

--000000000000cc71b70610a90706
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">There seems to be a fair amount of deployment and testing =
done here - Do we have broken behavior that is repeatable in the wild,=C2=
=A0or easily reproducible=C2=A0in a lab that can be shared? I understand th=
e=C2=A0issue, I believe, but am=C2=A0looking=C2=A0for=C2=A0a repeatable bro=
ken=C2=A0example to=C2=A0fiddle with, and hoping someone has already done t=
he legwork.=C2=A0<div>I would love to read / see results and test case exam=
ples of things that should be considered. Existing work done in this space =
would be very useful for another=C2=A0document that is currently in the wor=
ks. I see that Tom Herbert asked for something similar here=C2=A0<a href=3D=
"https://mailarchive.ietf.org/arch/msg/spring/1Sq_KaDRUYD-HiG7iebbcodXNLA/"=
>https://mailarchive.ietf.org/arch/msg/spring/1Sq_KaDRUYD-HiG7iebbcodXNLA/<=
/a> but I have not seen a reply.=C2=A0<div><br></div><div>nb</div></div></d=
iv><br><div class=3D"gmail_quote"><div dir=3D"ltr" class=3D"gmail_attr">On =
Mon, Feb 5, 2024 at 1:32=E2=80=AFPM Andrew Alston - IETF &lt;andrew-ietf=3D=
<a href=3D"mailto:40liquid.tech@dmarc.ietf.org">40liquid.tech@dmarc.ietf.or=
g</a>&gt; wrote:<br></div><blockquote class=3D"gmail_quote" style=3D"margin=
:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"=
>



<div>
<div dir=3D"ltr">
<div dir=3D"ltr">I call breaking any middleware that does checksum validati=
on a problem - and a big one</div>
<div dir=3D"ltr"><br>
</div>
<div id=3D"m_-7795607484218893954ms-outlook-mobile-signature">
<div><br>
</div>
<div dir=3D"ltr">Andrew Alston</div>
</div>
</div>
<br>
<p style=3D"font-family:Calibri;font-size:10pt;color:rgb(0,0,0);margin:5pt;=
font-style:normal;font-weight:normal;text-decoration:none" align=3D"Center"=
>
Internal All Employees<br>
</p>
<hr style=3D"display:inline-block;width:98%">
<div id=3D"m_-7795607484218893954divRplyFwdMsg" dir=3D"ltr"><font face=3D"C=
alibri, sans-serif" style=3D"font-size:11pt" color=3D"#000000"><b>From:</b>=
 Robert Raszuk &lt;<a href=3D"mailto:robert@raszuk.net" target=3D"_blank">r=
obert@raszuk.net</a>&gt;<br>
<b>Sent:</b> Monday, February 5, 2024 7:16:23 PM<br>
<b>To:</b> Ron Bonica &lt;<a href=3D"mailto:rbonica@juniper.net" target=3D"=
_blank">rbonica@juniper.net</a>&gt;<br>
<b>Cc:</b> Andrew Alston - IETF &lt;andrew-ietf@liquid.tech&gt;; <a href=3D=
"mailto:spring@ietf.org" target=3D"_blank">spring@ietf.org</a> &lt;<a href=
=3D"mailto:spring@ietf.org" target=3D"_blank">spring@ietf.org</a>&gt;<br>
<b>Subject:</b> Re: [spring] draft-ietf-spring-srv6-srh-compression</font>
<div>=C2=A0</div>
</div>
<div>
<div dir=3D"ltr">Hi Ron,=C2=A0
<div><br>
</div>
<div>Is there a problem ?=C2=A0</div>
<div><br>
</div>
<div>If I read RFC8200 L4 checksum is computed by the packet <b>originator =
and validated by the=C2=A0packet&#39;s ultimate receiver.=C2=A0</b></div>
<div><b><br>
</b></div>
<div>In all SPRING work to the best of my knowledge the vast majority of pa=
ckets are only encapsulated=C2=A0by transit nodes.=C2=A0</div>
<div><br>
</div>
<div>Is there any formal mandate in any of the RFCs that an encapsulating n=
ode must mangle the inner packet&#39;s L4 checksum=C2=A0? I don&#39;t think=
 so but stand open=C2=A0to get my understanding corrected.=C2=A0</div>
<div><br>
</div>
<div>Cheers,</div>
<div>Robert</div>
<div><br>
</div>
<div><br>
</div>
<div><br>
</div>
<div><br>
</div>
<div><br>
</div>
</div>
<br>
<div>
<div dir=3D"ltr">On Mon, Feb 5, 2024 at 5:04=E2=80=AFPM Ron Bonica &lt;rbon=
ica=3D<a href=3D"mailto:40juniper.net@dmarc.ietf.org" target=3D"_blank">40j=
uniper.net@dmarc.ietf.org</a>&gt; wrote:<br>
</div>
<blockquote style=3D"margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204=
,204,204);padding-left:1ex">
<div>
<div dir=3D"ltr">
<div style=3D"font-family:Aptos,Aptos_EmbeddedFont,Aptos_MSFontService,Cali=
bri,Helvetica,sans-serif;font-size:11pt;color:rgb(0,0,0)">
Folks,</div>
<div style=3D"font-family:Aptos,Aptos_EmbeddedFont,Aptos_MSFontService,Cali=
bri,Helvetica,sans-serif;font-size:11pt;color:rgb(0,0,0)">
<br>
</div>
<div style=3D"font-family:Aptos,Aptos_EmbeddedFont,Aptos_MSFontService,Cali=
bri,Helvetica,sans-serif;font-size:11pt;color:rgb(0,0,0)">
Has anyone proposed a solution to the L4 checksum problem that Andrew talks=
 about?</div>
<div style=3D"font-family:Aptos,Aptos_EmbeddedFont,Aptos_MSFontService,Cali=
bri,Helvetica,sans-serif;font-size:11pt;color:rgb(0,0,0)">
<br>
</div>
<div style=3D"font-family:Aptos,Aptos_EmbeddedFont,Aptos_MSFontService,Cali=
bri,Helvetica,sans-serif;font-size:11pt;color:rgb(0,0,0)">
=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=
=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 R=
on</div>
<div id=3D"m_-7795607484218893954x_m_2703698055533795624appendonsend"></div=
>
<br>
<p align=3D"Center" style=3D"font-family:Calibri;font-size:7pt;color:rgb(0,=
0,0);margin:15pt;font-style:normal;font-weight:normal;text-decoration:none"=
>
Juniper Business Use Only<br>
</p>
<hr style=3D"display:inline-block;width:98%">
<div id=3D"m_-7795607484218893954x_m_2703698055533795624divRplyFwdMsg" dir=
=3D"ltr"><font face=3D"Calibri, sans-serif" color=3D"#000000" style=3D"font=
-size:11pt"><b>From:</b> spring &lt;<a href=3D"mailto:spring-bounces@ietf.o=
rg" target=3D"_blank">spring-bounces@ietf.org</a>&gt; on behalf of Andrew A=
lston
 - IETF &lt;andrew-ietf=3D<a href=3D"mailto:40liquid.tech@dmarc.ietf.org" t=
arget=3D"_blank">40liquid.tech@dmarc.ietf.org</a>&gt;<br>
<b>Sent:</b> Monday, February 5, 2024 5:21 AM<br>
<b>To:</b> <a href=3D"mailto:spring@ietf.org" target=3D"_blank">spring@ietf=
.org</a> &lt;<a href=3D"mailto:spring@ietf.org" target=3D"_blank">spring@ie=
tf.org</a>&gt;<br>
<b>Subject:</b> [spring] draft-ietf-spring-srv6-srh-compression</font>
<div>=C2=A0</div>
</div>
<div lang=3D"en-KE">
<p></p>
<div style=3D"background-color:rgb(255,235,156);width:100%;border-style:non=
e;border-color:rgb(156,101,0);border-width:1pt;padding:2pt;font-size:10.5pt=
;line-height:12pt;font-family:Lato;color:black;text-align:left;font-weight:=
bold">
<span style=3D"color:black">[External Email. Be cautious of content]</span>=
</div>
<br>
<p></p>
<div>
<div>
<p><span lang=3D"EN-US">Hi All,</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">(In capacity as a contributor and wearing no other =
hats)</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">At this point I cannot support progression of this =
document until the issues around the L4 Checksum have been resolved.=C2=A0 =
It=E2=80=99s been clearly stated in other emails on the list that in certai=
n circumstances the behavior described in this
 document break the L4 checksum as defined in RFC8200.=C2=A0 This requires =
an update to RFC8200 to fix it =E2=80=93 and I=E2=80=99m not sure that spri=
ng can update 8200 absent the consent of 6man, which I=E2=80=99m not sure h=
as been asked for, nor am I sure that a spring document can update
 something like 8200 in an area so fundamental as the checksum without a -B=
IS, which would have to be done via 6man.=C2=A0 The L4 checksum issue thoug=
h is real =E2=80=93 and it cannot simply be ignored.</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">I also have deep concerns that the compression docu=
ment creates something that (in a similar way to SRv6) creates something th=
at is completely non-conformant with RFC4291.=C2=A0 There are multiple refe=
rences to this in draft-6man-sids, and
 should draft-6man-sids become an RFC I would argue that it should probably=
 be a normative reference in this document =E2=80=93 on the logic that this=
 document relies on similar RFC4291 violations that srv6 itself does (and f=
or the record, just because SRv6 itself
 violates RFC4291 as is clearly documented in draft-6man-sids =E2=80=93 doe=
s not make it acceptable to do so in yet another draft without clear and un=
ambiguously stating the deviations and ideally updating RFC4291 to allow fo=
r said deviations)</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">I believe these two issues alone are sufficient tha=
t to pass this document would create still further tensions about the relat=
ionship between SRv6 and IPv6 and lead to confusion.=C2=A0 As such =E2=80=
=93 I believe these issues need to be adequately
 dealt with =E2=80=93 and the solutions to them need to be approved by 6man=
 as the working group that holds responsibility for ipv6 maintenance.</span=
></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">Thanks</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">Andrew Alston</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
<p><span lang=3D"EN-US">=C2=A0</span></p>
</div>
<br>
<p align=3D"Center" style=3D"font-family:Calibri;font-size:10pt;color:rgb(0=
,0,0);margin:5pt;font-style:normal;font-weight:normal;text-decoration:none"=
>
Internal All Employees<br>
</p>
</div>
</div>
</div>
_______________________________________________<br>
spring mailing list<br>
<a href=3D"mailto:spring@ietf.org" target=3D"_blank">spring@ietf.org</a><br=
>
<a href=3D"https://www.ietf.org/mailman/listinfo/spring" rel=3D"noreferrer"=
 target=3D"_blank">https://www.ietf.org/mailman/listinfo/spring</a><br>
</div>
</blockquote>
</div>
</div>
</div>

_______________________________________________<br>
spring mailing list<br>
<a href=3D"mailto:spring@ietf.org" target=3D"_blank">spring@ietf.org</a><br=
>
<a href=3D"https://www.ietf.org/mailman/listinfo/spring" rel=3D"noreferrer"=
 target=3D"_blank">https://www.ietf.org/mailman/listinfo/spring</a><br>
</blockquote></div>

--000000000000cc71b70610a90706--

