Re: [tcpPrague] Impact of an L4S experiment on non-TCP transports using ECT(1)
Colin Perkins <csp@csperkins.org> Wed, 20 July 2016 08:34 UTC
Return-Path: <csp@csperkins.org>
X-Original-To: tcpprague@ietfa.amsl.com
Delivered-To: tcpprague@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id BD10A12D9C1 for <tcpprague@ietfa.amsl.com>; Wed, 20 Jul 2016 01:34:35 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.199
X-Spam-Level:
X-Spam-Status: No, score=-4.199 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_MED=-2.3] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id yKBfa0LbYZe4 for <tcpprague@ietfa.amsl.com>; Wed, 20 Jul 2016 01:34:32 -0700 (PDT)
Received: from haggis.mythic-beasts.com (haggis.mythic-beasts.com [IPv6:2a00:1098:0:86:1000:0:2:1]) (using TLSv1.2 with cipher DHE-RSA-AES128-SHA (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 98A9112D0B8 for <tcpPrague@ietf.org>; Wed, 20 Jul 2016 01:34:32 -0700 (PDT)
Received: from [2001:67c:370:152:a0bb:2468:bce:8f02] (port=52159) by haggis.mythic-beasts.com with esmtpsa (TLS1.0:DHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.80) (envelope-from <csp@csperkins.org>) id 1bPmxZ-0004Mu-5R; Wed, 20 Jul 2016 09:34:30 +0100
Content-Type: multipart/alternative; boundary="Apple-Mail=_B94719FF-E2D1-4084-8B9D-AE559E20AC30"
Mime-Version: 1.0 (Mac OS X Mail 9.3 \(3124\))
From: Colin Perkins <csp@csperkins.org>
In-Reply-To: <578E61CE.4090404@bobbriscoe.net>
Date: Wed, 20 Jul 2016 10:34:17 +0200
Message-Id: <959F4E4E-1C8D-431B-9A11-80D3D69E7F92@csperkins.org>
References: <578E61CE.4090404@bobbriscoe.net>
To: Bob Briscoe <ietf@bobbriscoe.net>
X-Mailer: Apple Mail (2.3124)
X-BlackCat-Spam-Score: -28
X-Mythic-Debug: Threshold = On =
Archived-At: <https://mailarchive.ietf.org/arch/msg/tcpprague/y68dyBKGtK-UynBig-AZh9I10xQ>
Cc: TCP Prague List <tcpPrague@ietf.org>
Subject: Re: [tcpPrague] Impact of an L4S experiment on non-TCP transports using ECT(1)
X-BeenThere: tcpprague@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: "To coordinate implementation and standardisation of TCP Prague across platforms. TCP Prague will be an evolution of DCTCP designed to live alongside other TCP variants and derivatives." <tcpprague.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/tcpprague>, <mailto:tcpprague-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tcpprague/>
List-Post: <mailto:tcpprague@ietf.org>
List-Help: <mailto:tcpprague-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/tcpprague>, <mailto:tcpprague-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 20 Jul 2016 08:34:36 -0000
Bob, > On 19 Jul 2016, at 19:22, Bob Briscoe <ietf@bobbriscoe.net> wrote: > > Colin, > > For the writing about the proposed effect of L4S on RFC6679, see the L4S problem statement section 1.4, item 3B) > https://tools.ietf.org/html/draft-briscoe-tsvwg-aqm-tcpm-rmcat-l4s-problem-02#section-1.4 <https://tools.ietf.org/html/draft-briscoe-tsvwg-aqm-tcpm-rmcat-l4s-problem-02#section-1.4> > > It there are any other RFCs beyond the list there that use ECT(1) that we're not aware of, pls let me know. > Can you explain the impact on circuit breaker? The ongoing experiments with AQM and ECN, of which L4S is a part, have made it very unclear how a transport should respond to ECN-CE marks, for either ECT(0) or ECT(1). The circuit breaker got caught in that discussion. Colin > Prior to the problem statement, text about 6679 was written in the L4S identifier draft that I've presented in tsvwg, and mentioned the effect on other transports including RTP-ECN. > We wrote what we thought the process would be in https://tools.ietf.org/html/draft-briscoe-tsvwg-ecn-l4s-id-01#section-1.3 <https://tools.ietf.org/html/draft-briscoe-tsvwg-ecn-l4s-id-01#section-1.3> > However, the tsv management have now clarified how they want this done (I'm expecting discussion in tsvwg tomorrow now we've had the BoF). > > > I can send you the draft text we're proposing to use to update 3168, 6679 etc, if you want (or you can wait until it's actually submitted as a draft, perhaps tonight. > Essentially the idea is 2-stage: > 1) a PS to obsolete RFC3540 (experimental) and to update RFC3168 RFC4960 RFC6679 RFC4340 to reserve ECT(1) for future experiments again > 2) the L4S identifier draft (draft-briscoe-tsvwg-ecn-l4s-id) to use the newly reserved ECT(1) codepoint experimentally > > I appreciate that there might be implementations in progress that use ECT(1), but as 6679 did not say what ECT(1) is for, I doubt it. > If an RTP implementation is using a field in the IP header for something that hasn't been standardised by the IETF and is not the current experimental use (the ECN nonce), then I think it has no right to complain if it gets stamped on by a new IETF-sanctioned experiment. > > You will recall I checked the intent of the ECT(1) text in 6679 on the avtcore list some time ago. > See your response then, pasted below. > > > Bob > > > -------- Forwarded Message -------- > Subject: Re: [AVTCORE] RFC6679 ECN in RTP: intent of ect = 0, 1, or random? > Date: Mon, 9 Nov 2015 10:55:14 +0000 > From: Colin Perkins <csp@csperkins.org> <mailto:csp@csperkins.org> > To: Bob Briscoe <ietf@bobbriscoe.net> <mailto:ietf@bobbriscoe.net> > CC: Ingemar Johansson S <ingemar.s.johansson@ericsson.com> <mailto:ingemar.s.johansson@ericsson.com>, Magnus Westerlund <magnus.westerlund@ericsson.com> <mailto:magnus.westerlund@ericsson.com>, Ken Carlberg<carlberg@g11.org.uk> <mailto:carlberg@g11.org.uk> > > Bob, > > This sounds interesting, and would be a good fit for the RMCAT working group, but doesn’t sound like it would be an update to the ECN-for-RTP RFC (which specifies ECN negotiation, marking, and feedback, but no congestion control algorithms). > > Colin > > > > > > On 5 Nov 2015, at 10:04, Bob Briscoe <ietf@bobbriscoe.net> <mailto:ietf@bobbriscoe.net> wrote: > > > > Colin, > > > > OK. In the fullness of time, if our proposal continues to get traction, I'll draft a little experimental bis to ECN in RTP to specify scalable congestion control. It will be v simple: > > > > If using scalable cc: > > * sender only uses scalable cc if (all) receiver(s) report ECN support > > * sender rate equation is like TFRC equation, but with 1/p instead of 1/sqrt(p) > > * fall back to TFRC equation on loss rather than ECN (and also possibly on ECN accompanied by high variable delay) for 'a few' 1RTT (TBD) > > * sender sets ECT(1) not ECT(0) > > * no changes on receiver > > * I think it would work deployed one RTP hop at a time, but that would have to be tested > > > > But I'd want to implement and test it first, of course. > > > > > > > > Bob > > > > On 05/11/15 07:34, Colin Perkins wrote: > >> Bob, > >> > >>> On 4 Nov 2015, at 17:50, Bob Briscoe <ietf@bobbriscoe.net> <mailto:ietf@bobbriscoe.net> wrote: > >>> > >>> Piers, > >>> > >>> I realised I didn't send the mail thanking you for your response. Thank you - v useful, and confirmation of my vague memory of events. > >>> > >>> 1. Would the authors (and wider community) be happy to allow ECT(1) not to be set-aside for future anti-cheating use, as long as there was another way, in principle, for the sender to check for cheating? > >> I have no objection. You might check with the RMCAT chairs, since some of their proposals make use of ECN with RTP, but I doubt this will be a problem. > >> > >>> For TCP, we worked out a way for the sender to check for cheating without burning a codepoint - by the sender introducing one or two CE codepoints of its own, and checking the receiver reports them. Would this be harder for RTP? Are the receiver reports deterministic enough for the sender to determine whether codepoints it injected are correctly counted in the next report? > >> The sender could easily set a CE mark on a small number of packets it’s sending. For unicast cases, where there’s an explicit control loop, it should be able to correlate this with the returned RTCP feedback. Where it might be difficult is with open loop layered multicast congestion control, where some receivers might see the CE mark and drop a layer since they don’t know it’s a synthetic mark. > >> > >> Colin > >> > >> > >> > >> > >>> 2. A couple of days after I posted the original question, we posted the -00 individual draft aiming to start the process of repurposing ECT(1). You will see the sentence in the scope section <https://tools.ietf.org/html/draft-briscoe-tsvwg-ecn-l4s-id-00#section-1.3> <https://tools.ietf.org/html/draft-briscoe-tsvwg-ecn-l4s-id-00#section-1.3> > >>> > >>> See security considerations for discussion on feedback integrity checking. > >>> > >>> > >>> Bob > >>> > >>> On 19/10/15 10:15, Piers O'Hanlon wrote: > >>>> Hi Bob, > >>>> > >>>> I think the reasoning was that ECT(1)/random could potentially be used to detect cheating/failures as mentioned in section 7.4, but I can't see that it's going to make a lot of difference if ECT(1) is not used. > >>>> > >>>> Piers > >>>> > >>>> On 17 Oct 2015, at 22:59, Bob Briscoe wrote: > >>>> > >>>>> Guys, > >>>>> [Ignore last identical email - I left the list off the distr in error] > >>>>> > >>>>> I'm writing a draft to propose a new use for ECT(1). > >>>>> > >>>>> In reading RFC6679, It says that the there is no intent to use an ECN nonce. > >>>>> Also it says the receiver might want to advise the sender not to use ect=random, if its behind a header compression link. And that ect=0 is recommended and the default. > >>>>> > >>>>> But it doesn't seem to actually say why a sender might send ECT(1) instead of ECT(0). Or why a sender might use the two randomly. Or why a receiver might ask for ect=1, or ect=random. > >>>>> > >>>>> I'm trying to work out whether there would be any detriment to RFC6679 if it couldn't use ECT(1). It looks like not. > >>>>> > >>>>> > >>>>> Bob > >>>>> > >>>>> -- > >>>>> ________________________________________________________________ > >>>>> Bob Briscoehttp://bobbriscoe.net/ > >>> -- > >>> ________________________________________________________________ > >>> Bob Briscoehttp://bobbriscoe.net/ > >>> > >> > >> > > > > -- > > ________________________________________________________________ > > Bob Briscoe http://bobbriscoe.net/ <http://bobbriscoe.net/> > > > > _______________________________________________ > > Audio/Video Transport Core Maintenance > > avt@ietf.org <mailto:avt@ietf.org> > > https://www.ietf.org/mailman/listinfo/avt <https://www.ietf.org/mailman/listinfo/avt> > > > -- > ________________________________________________________________ > Bob Briscoe http://bobbriscoe.net/ <http://bobbriscoe.net/> -- Colin Perkins https://csperkins.org/
- [tcpPrague] Impact of an L4S experiment on non-TC… Bob Briscoe
- Re: [tcpPrague] Impact of an L4S experiment on no… Colin Perkins
- Re: [tcpPrague] Impact of an L4S experiment on no… Ingemar Johansson S