[TLS] Re: Artart ietf last call review of draft-ietf-tls-deprecate-obsolete-kex-05
Valery Smyslov <valery@smyslov.net> Fri, 23 May 2025 08:57 UTC
Return-Path: <valery@smyslov.net>
X-Original-To: tls@mail2.ietf.org
Delivered-To: tls@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id D3EBA2C33D3C; Fri, 23 May 2025 01:57:38 -0700 (PDT)
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.798
X-Spam-Level:
X-Spam-Status: No, score=-2.798 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (2048-bit key) header.d=smyslov.net
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Fs6zORxs_feu; Fri, 23 May 2025 01:57:36 -0700 (PDT)
Received: from direct.host-care.com (direct.host-care.com [198.136.54.115]) (using TLSv1.2 with cipher ECDHE-ECDSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 1FB5D2C33D33; Fri, 23 May 2025 01:57:35 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=smyslov.net ; s=default; h=Content-Transfer-Encoding:Content-Type:MIME-Version:Message-ID :Date:Subject:In-Reply-To:References:Cc:To:From:Sender:Reply-To:Content-ID: Content-Description:Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc :Resent-Message-ID:List-Id:List-Help:List-Unsubscribe:List-Subscribe: List-Post:List-Owner:List-Archive; bh=DOqpDSf6kxIRIwGxNOviJbwwvdIIdlgPu2Yax1m1dBA=; b=ZJroWG6MsYHkEIV6QFVvh8WsBS beINGbp69zW2H/4/gv5Hhnvtmy1z4t5f5xFC5h9Glor+8CIDOjt5tqH0pF1eSncqmDhP6E6AUYQEJ vRnm1BUy8PYmK1tqgdfjIV0ebKmGzKF4CyOlR5qLx/la/g5Wp5Vf4+4adAnLI6nxLc5v0x/W6hYqA sHyF9g0CaFaIMaExcu1itfO7xkDREWDQ2rx0U8p+HICWp16gNlYK/3jb3t7Ki/4vrttfc6oiNZASv bOVc0ano32c3T6ttDSCMkGa56D7TYO0ehLyGCCYXCsHUjAVxmGKcdy/orpewNuWF0HVsFWcm486hd leZTK3tQ==;
Received: from [93.188.44.204] (port=58247 helo=BuildPC) by direct.host-care.com with esmtpsa (TLS1.2) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.93) (envelope-from <valery@smyslov.net>) id 1uIODd-0003o1-Rw; Fri, 23 May 2025 04:57:34 -0400
From: Valery Smyslov <valery@smyslov.net>
To: 'Sean Turner' <sean@sn3rd.com>
References: <174487962528.1558890.7718119499790181368@dt-datatracker-64c5c9b5f9-hz6qg> <FE37343F-CD40-455F-BCB0-62BE4ABE8BC5@sn3rd.com>
In-Reply-To: <FE37343F-CD40-455F-BCB0-62BE4ABE8BC5@sn3rd.com>
Date: Fri, 23 May 2025 11:57:30 +0300
Message-ID: <059e01dbcbc0$b99dd690$2cd983b0$@smyslov.net>
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
X-Mailer: Microsoft Outlook 16.0
Thread-Index: AQG/XlNmpEIpUZUG31KilTQhbf+UGgKb7/TxtAPje6A=
Content-Language: ru
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - direct.host-care.com
X-AntiAbuse: Original Domain - ietf.org
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - smyslov.net
X-Get-Message-Sender-Via: direct.host-care.com: authenticated_id: valery@smyslov.net
X-Authenticated-Sender: direct.host-care.com: valery@smyslov.net
Message-ID-Hash: MVBMGASB7SZULGIZFBOW6VM2DZTNECG3
X-Message-ID-Hash: MVBMGASB7SZULGIZFBOW6VM2DZTNECG3
X-MailFrom: valery@smyslov.net
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-tls.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: art@ietf.org, draft-ietf-tls-deprecate-obsolete-kex.all@ietf.org, last-call@ietf.org, 'TLS List' <tls@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [TLS] Re: Artart ietf last call review of draft-ietf-tls-deprecate-obsolete-kex-05
List-Id: "This is the mailing list for the Transport Layer Security working group of the IETF." <tls.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tls/OsBMkQGfbsIv0fJNZy_WL7YlIh4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tls>
List-Help: <mailto:tls-request@ietf.org?subject=help>
List-Owner: <mailto:tls-owner@ietf.org>
List-Post: <mailto:tls@ietf.org>
List-Subscribe: <mailto:tls-join@ietf.org>
List-Unsubscribe: <mailto:tls-leave@ietf.org>
Hi Sean,
please see inline.
> Valery,
>
> Hi! I pinged the authors about this, but I will weigh in on your 1st issue below and
> one of the comments.
>
> > On Apr 17, 2025, at 4:47 AM, Valery Smyslov via Datatracker
> <noreply@ietf.org> wrote:
> >
> > Document: draft-ietf-tls-deprecate-obsolete-kex
> > Title: Deprecating Obsolete Key Exchange Methods in TLS 1.2
> > Reviewer: Valery Smyslov
> > Review result: Ready with Issues
> >
> > I am the assigned ART directorate reviewer for this document. These comments
> > were written primarily for the benefit of the ART area directors. Document
> > editors and WG chairs should treat these comments just like any other last call
> > comments.
> >
> > The document deprecates the use of RSA and FFDH key exchanges and
> discourages
> > the use of static ECDH cipher suites in TLS 1.2. The document is well written
> > and easy to read. I have few minor issues with the document, which I think are
> > easy to fix.
> >
> > Issues.
> > 1. The draft updates RFC 9325 that is part of BCP 195. I wonder whether this
> > draft should also be BCP (and part of BCP 195).
>
> I would prefer to leave this to the IESG to debate ;) There are times that a BCP
> has been updated by a standards track and it has not become part of the BCP:
> - RFC 8407 updated by RFC 8819
> - RFC 8340 updated by RFC 8791
> - RFC 8085 updated by RFC 8899
> - RFC 7595 updated by RFC 8615
>
> and the list goes on …
No problem, I just wanted to draw attention to this.
> > 2. It would be nice if there is a summary of changes compared to RFC 9325
> > (which is now the primary source of recommendations for use TLS) somewhere
> in
> > the draft. The draft contains some words regarding that, but they are sparsed
> > across the document.
> >
> > 3. The draft never mentiones DTLS, however it updates RFC 6347. I think DTLS
> > should be explicitly mentioned as being in scope of this document.
> >
> > 4. Perhaps some text should be added about potential interoperability problems
> > (or, as we hope, the lack of such) caused by deprecation of the mentioned key
> > exchnage methods. If this could be backed up by some figures from real word, it
> > would be great.
> >
> > Nits.
> > 1. Throughot document: s/Diffie Hellman/Diffie-Hellman
> >
> > 2. Does it make sense to update "Historic" RFC 4346, which is obsoleted long
> > ago and thus must not be used anyway?
>
> I can see your point, but it also doesn’t hurt to slam the door shut ;)
Again, no problem, I only asked (I'm not sure historic documents are formally allowed to be updated) :-)
Regards,
Valery.
> Cheers,
> spt
>
> > 3. Section 2, last para:
> >
> > These values only apply to TLS versions of 1.2 and
> > below.
> >
> > The text in the preceeding paras contains clarification that TLS 1.0 and TLS
> > 1.1 have been already deprecated ("Note that TLS 1.0 and 1.1 are deprecated
> by
> > [RFC8996]") and thus are implicitly out of scope. I wonder whether this note
> > should also be added here.
- [TLS] Artart ietf last call review of draft-ietf-… Valery Smyslov via Datatracker
- [TLS] Re: Artart ietf last call review of draft-i… Sean Turner
- [TLS] Re: Artart ietf last call review of draft-i… Sean Turner
- [TLS] Re: Artart ietf last call review of draft-i… Valery Smyslov