[Tools-discuss] travis-ci and xml2rfc

Michael Richardson <mcr@sandelman.ca> Sat, 19 September 2020 01:40 UTC

Return-Path: <mcr@sandelman.ca>
X-Original-To: tools-discuss@ietfa.amsl.com
Delivered-To: tools-discuss@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 07AEC3A0FF6 for <tools-discuss@ietfa.amsl.com>; Fri, 18 Sep 2020 18:40:11 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -0.835
X-Spam-Level:
X-Spam-Status: No, score=-0.835 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, KHOP_HELO_FCRDNS=0.398, SPF_HELO_NONE=0.001, SPF_SOFTFAIL=0.665, URIBL_BLOCKED=0.001] autolearn=no autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id CkH2mPoixYwv for <tools-discuss@ietfa.amsl.com>; Fri, 18 Sep 2020 18:40:08 -0700 (PDT)
Received: from relay.sandelman.ca (minerva.sandelman.ca [IPv6:2a01:7e00::3d:b000]) (using TLSv1.2 with cipher ADH-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id A84313A0FD8 for <tools-discuss@ietf.org>; Fri, 18 Sep 2020 18:40:08 -0700 (PDT)
Received: from dooku.sandelman.ca (desktop4.sandelman.ca [209.87.249.16]) by relay.sandelman.ca (Postfix) with ESMTPS id 18E8E1F4A4 for <tools-discuss@ietf.org>; Sat, 19 Sep 2020 01:40:06 +0000 (UTC)
Received: by dooku.sandelman.ca (Postfix, from userid 179) id AD6881A022D; Fri, 18 Sep 2020 21:40:04 -0400 (EDT)
From: Michael Richardson <mcr@sandelman.ca>
To: tools-discuss@ietf.org
X-Attribution: mcr
X-Mailer: MH-E 8.6+git; nmh 1.7+dev; GNU Emacs 26.3
MIME-Version: 1.0
Content-Type: multipart/signed; boundary="=-=-="; micalg=pgp-sha512; protocol="application/pgp-signature"
Date: Fri, 18 Sep 2020 21:40:04 -0400
Message-ID: <116643.1600479604@dooku>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tools-discuss/ofOW1UQZ0OzhoDENi2sD0x7blog>
Subject: [Tools-discuss] travis-ci and xml2rfc
X-BeenThere: tools-discuss@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: IETF Tools Discussion <tools-discuss.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/tools-discuss>, <mailto:tools-discuss-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tools-discuss/>
List-Post: <mailto:tools-discuss@ietf.org>
List-Help: <mailto:tools-discuss-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/tools-discuss>, <mailto:tools-discuss-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 19 Sep 2020 01:40:11 -0000

I tweaked my .travis.yml to run again for a repo which used to work.
I am not using the MT makefile, but my own.
I am now doing xml2rfc --v2v3, and this requires python3, so I told travis to
use that.

I am now getting "sre_constants.error: bad character range ‚-‐ at position 8"

I tried python 3.5, then tried python 3.7 as well... nope.
Something about virtualenv not really working right, but impossible to debug.

I then switch to "dist: bionic", and then everything worked using virtualenv
to install the xml2rfc.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     mcr@sandelman.ca  http://www.sandelman.ca/        |   ruby on rails    [