[Tsv-art] Re: draft-ietf-dmm-tn-aware-mobility-28 telechat Tsvart review

Kaippallimalil John <john.kaippallimalil@futurewei.com> Wed, 29 July 2026 14:52 UTC

Return-Path: <john.kaippallimalil@futurewei.com>
X-Original-To: tsv-art@mail2.ietf.org
Delivered-To: tsv-art@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id EE3F31208AD6F; Wed, 29 Jul 2026 07:52:04 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1785336724; bh=XtXdzPjLaEvTx/5c5eee5vYz+5C8Sa774aJtL7/RVFw=; h=From:To:CC:Subject:Date:References:In-Reply-To; b=nlwoTJj5aLsU7KlF3+U2aX5CYcUuvtvcEGQK56w2vmK8OvhU9QYyIEP1aBXq7ThAQ 0ROhlku/pRD+KB1P1nyEyu+Z3BotamjdB9dE2MnCWBnp7WxB4zIRNUe7IxY4hgmI6i EoQnKiWDexmF6gYhugAiIFKciaIV4K4MCOR007LM=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.098
X-Spam-Level:
X-Spam-Status: No, score=-2.098 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_MSPIKE_H2=0.001, RCVD_IN_VALIDITY_CERTIFIED_BLOCKED=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=futurewei.com
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id hiAJrjDBwRIA; Wed, 29 Jul 2026 07:52:04 -0700 (PDT)
Received: from CH1PR05CU001.outbound.protection.outlook.com (mail-northcentralusazon11020123.outbound.protection.outlook.com [52.101.193.123]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange ECDHE (P-384) server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id 5BA701208AD66; Wed, 29 Jul 2026 07:52:04 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; s=arcselector10001; d=microsoft.com; cv=none; b=IebO2NM0zegFprTHEVwZPv4Wat7ZF7T0odq9Z/3qravPl4R03NR06Vrn7vW+DwGVoWPPbiy7/RSnKM8IC3jMmLzABWZc/bMjyd/rEX37mmQRCW/vHEHmG9gtSWOLJolg9ZBaeN8ufT8bdPT1peCZp8J8ah6fUrU6D/K66GjYJmzTtv6gaf3nD4ct3cHdzXzC5M+jqCtJVZuBqtyfluikHYKVlhh0Ujw6Yn4dntamlLgoog2cJTeHLwhZQwoqa81o21sgWEE7j6pwhdf88G9wMzTuA4Uy+G4jZMLhbnLGv0BBZKJ+0EDMYBcWCEGcDgq/bwTPVzuUJv1XMDK8zKbcNA==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector10001; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=XtXdzPjLaEvTx/5c5eee5vYz+5C8Sa774aJtL7/RVFw=; b=GY0HuvyDptmOWIfyreXK1lsbKVEVRDqhsd4vuLVVhjgUnYaKiGSXU+52CAPdytuHmQMtCYvDuXbohJdlrIqO/1FvJ8Rb4VxC1FA+uRsMDgQW74udtuePkusaSOFGV+38g/nG0vITTugoUsVQxfDXGYcGB/glF3ztsBT+R0zixNLl2VHx6kw1e+wzF1QsFTv2OkIupuFhkm48ZWcJ84SIG0lfv9E0j6e0UhKqgx1K+1AnDZ23vindLhYXxa8f+1VrZsYr766oC+9UuPjrxnKiL393YpyRgTIRvzfQHoLBSUNemhwAyPsFZFIIqGhGytGnKL1D+Q+jpyxf7et2hkYg9w==
ARC-Authentication-Results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=futurewei.com; dmarc=pass action=none header.from=futurewei.com; dkim=pass header.d=futurewei.com; arc=none
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=Futurewei.com; s=selector2; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=XtXdzPjLaEvTx/5c5eee5vYz+5C8Sa774aJtL7/RVFw=; b=k9nT4gEHpH2p0CjFLRAqaihBHIQL8xfwYPePmC7fYTTQQ/2joxFp+DBcQeHm6zyAUVnm0oX32BziRxdeDhLfpQhlV091+mbV4egndkkaDx+iMxX70a0mjTBkHWl2q5r3thk9W5kMqPk2ylbFZ5pf8uUpzRtzSoIu7e6tH1wIjE0=
Received: from SN4PR13MB5311.namprd13.prod.outlook.com (2603:10b6:806:20a::7) by DS0PR13MB6273.namprd13.prod.outlook.com (2603:10b6:8:12c::12) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id 15.21.270.12; Wed, 29 Jul 2026 14:51:51 +0000
Received: from SN4PR13MB5311.namprd13.prod.outlook.com ([fe80::3f37:dd49:c31d:ae85]) by SN4PR13MB5311.namprd13.prod.outlook.com ([fe80::3f37:dd49:c31d:ae85%6]) with mapi id 15.21.0270.012; Wed, 29 Jul 2026 14:51:51 +0000
From: Kaippallimalil John <john.kaippallimalil@futurewei.com>
To: Joseph Touch <touch@strayalpha.com>, "tsv-art@ietf.org" <tsv-art@ietf.org>
Thread-Topic: draft-ietf-dmm-tn-aware-mobility-28 telechat Tsvart review
Thread-Index: AQHdGmVnF4LacLuH4keKHHRrV6Q2C7aEl/kQ
Date: Wed, 29 Jul 2026 14:51:50 +0000
Message-ID: <SN4PR13MB5311F0660B762100E1F53BE3E8CA2@SN4PR13MB5311.namprd13.prod.outlook.com>
References: <178478506766.524020.17072846228241854340@dt-datatracker-d4d6ff9d9-ql5mb>
In-Reply-To: <178478506766.524020.17072846228241854340@dt-datatracker-d4d6ff9d9-ql5mb>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
authentication-results: dkim=none (message not signed) header.d=none;dmarc=none action=none header.from=futurewei.com;
x-ms-publictraffictype: Email
x-ms-traffictypediagnostic: SN4PR13MB5311:EE_|DS0PR13MB6273:EE_
x-ms-office365-filtering-correlation-id: 5a67a4d3-0981-4143-ee7b-08deed80ec55
x-ms-exchange-senderadcheck: 1
x-ms-exchange-antispam-relay: 0
x-microsoft-antispam: BCL:0;ARA:13230040|366016|1800799024|23010399003|376014|38070700021|4133799003|11063799006|5023799004|56012099006|3023799007|10067099003|6133799003|22082099003|18002099003;
x-microsoft-antispam-message-info: r9dLmTUYeMnkv9qs78cS2xQSkjyMj00cL+dIcxOX9eVQwKcSch/BHqfe8uHJH5tHQVOy/7ldHDEZSy7Y0XRH3BsG52xRpkg/29vKfZ69TCypYMBU59McmkpiIvgw0bFPaXzpd3zCe4oLp9bLoH3EOB8qxwHKy0F3BAZeCHjeqWKtQXrF31x7+5hZdnoW4/j3qXuypnj0Udde9CUf40zSb9yyT55TBvzHEYdkg0JGONwRrd8j7nIGkqrFZVUT2tnn0kHLJxTkrbg83hN//X4qKpjFQqpgT7ZM3nnAXBoaHD3ucef4rQ0m1NgBEuZzD1ys8Jtlzt5e4BB0jqbaBE9jtGgSM0V8dMRaWl6N049Mfxwy3VDPz/GRl4UnsIDd89Q6hs4Wfgg9BvgDyk8Je7vuN8KaFobQKyerntITFLP6sWpZFOlk9T8rSLu6hF5o7+bV/a8Fcb2ggMhrDptuIy/uMdzekcA96tz2miHlLrEXTzHgonAKXCpph6gtF+EeA7GytdIHx4T2i+n7a5auvne5su1hdQWIpL04AMu7Fsx0wHqScTVE5Ff90PFg8H+X8Os8DYXQEwvNp6+JpFJd9T3tABlntKoPS02Dq2EK4pfGP7C6jZ8L+GfKqsMqXLkTF1V9u+DM/c2f1F6JsCYKyn3BGLsyQqwHA4Bc7IOb/2AjsVx8R5xaOjZG4z08pC8aznvubSAohaK8zur7n4Ugl2LtXXcmr7wN2hUivMY+EUV2sfw=
x-forefront-antispam-report: CIP:255.255.255.255;CTRY:;LANG:en;SCL:1;SRV:;IPV:NLI;SFV:NSPM;H:SN4PR13MB5311.namprd13.prod.outlook.com;PTR:;CAT:NONE;SFS:(13230040)(366016)(1800799024)(23010399003)(376014)(38070700021)(4133799003)(11063799006)(5023799004)(56012099006)(3023799007)(10067099003)(6133799003)(22082099003)(18002099003);DIR:OUT;SFP:1102;
x-ms-exchange-antispam-messagedata-chunkcount: 1
x-ms-exchange-antispam-messagedata-0: B5LpVNxC2bTKtlArHxnksVm4sgQkZEub4YPTFvUbYQ98KPQiRULtuMvBeE/bgFQ1SYoVqcIJ7YKpwcAiDSTiY2gBtMCcICmULqTAC75ZO1117XeASC11CMS/LLhvyZo2sOuWvyZ1WfvmUJYiKetylmF2zj5a4VLObKPtmZQ1laEBsFR5MN8eoNEFXf+NhSitduTukkv9cfOMxcLSrb+5dIg3jA8iW4rwD2fGg9dOMnK+jPeTX98VO3eNr9PiOI/4Np1eR8FlnFfyMvXykDPX/yCcqiW8b3u6FwebEDjbwLyiLhABoe3tZKvob0k55FZVHPMgUuHCuLhZHYkBvQyuAhrCHk4+nroZQB45ECCkKhPHczmBVN+BEoVnPSXlG8fA06+/7y93tCoTAvAwoFiOHVB5ALTCu81/DJEat7H/Zs2Ebkce+VIAbVwrNzH33vzrZeWkgwFSL+iO0lqt/516ICjs7PX9l0KyPpcEILSElghbt8GrgMBtn7maPZZKXePrbUkNBCfYxRskRfY834yr1kD4prFEIcB5zs1Fq/WksOBB3A34K0y8ITB9mBzuihelk8M29UcM/2CJguQZIFrUbYbsLvwFd8pjcn/6pvttgzfNb/XPwV+IhpTCQnL0relxlH4kPCNoP7PfdMpWPHqAlm8o0WTgHFH62grSoBs/qnfJdWgb9TewFxI/9Hjo3Nym0ZYvkUxUKOYJukHGrY2Ay4AopwQpf2HSdU89QhpZDnmMgQNIWQ9gu0lRTzthJ6UIxXmf5OqFw5S6wPfFdhUaZMGrUjvdlLUk7CiI6AFHxO5VEyppMU3CgBObAn0WYP5RbHO1NfBtxvuSbqqJ+JpGw+vyZrZ9pyJ7UXrzawriWDdm1zmzO79gfWmYrGLjmIQ/w3+IXPZosxHxCRBb3yewG/8920ZnO2SkGYOog/yCMCJqUJ9Q65Jv0JY71DoI6aHmd0Fs1D/jyw9lSYbViA2jWS1Ns17H3LL9L5AfWv+AmtNX5GVEy8PG6rc+0VKjQBl8Y2sh8P1zJUVpzQO0zm3l8KMfstmNz89Zlv3JFavYeAUD4SgJZFHrvqHjSDzpCz3n7nTlODg4IY3TBshUSacHAvV/a8jEqJ86QrdSSY46lPt6xIm91rjCmAJeU+mUVd8jITrvDbHtiCTDMQR5na22bsrSl1ICFxU9jgob5h0SwVHWkFpiD3n3JgYxgvqNhO950TI3FuO4+6FpEJjZ28NjEZP6dYRKv0ef4/rm/13cS0qS4YXIUfoWOcyczuxdPlHZceMu1DKIGoJXFAjczpQ2h9BKzQC5q/TSVGY29PLADLCmS6/eaYFrbiHHEd3QROV2u1B/wAHJL28IitU4IxrNj9QE03JhbLg7eSMW5JVhQowZh+nCdHQPcpP3xacnSoVDNVNxX4zCIPE/VrnSozQ71cuzELvWvD0kf6vMKtPq/RVPAMaZLM87oZBWt4mb7LCDXf1IUSDTevAOTTiCbCU1CrKWfabnNNCVqldyVxvEam465AG+Cq5KCWQFRgELhX+R4hyxW5oRSzq0wbKhH5p8fuXpSYt2UGxESasyG2pGWNGcq/CZQNNy04QvqieyaIGHNVxrtUT3PhlRsXiEx0dc9tJzgqGXAxdPo7/BOEhj8K50eclfPcdUM7pcMoOj7i8sNZ3T4ZwEfBV6dIEkOokTUYNH075O3XdMiPIRxf41kLHMYCLOHEpTco3QJl18wYVf
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-OriginatorOrg: Futurewei.com
X-MS-Exchange-CrossTenant-AuthAs: Internal
X-MS-Exchange-CrossTenant-AuthSource: SN4PR13MB5311.namprd13.prod.outlook.com
X-MS-Exchange-CrossTenant-Network-Message-Id: 5a67a4d3-0981-4143-ee7b-08deed80ec55
X-MS-Exchange-CrossTenant-originalarrivaltime: 29 Jul 2026 14:51:50.9421 (UTC)
X-MS-Exchange-CrossTenant-fromentityheader: Hosted
X-MS-Exchange-CrossTenant-id: 0fee8ff2-a3b2-4018-9c75-3a1d5591fedc
X-MS-Exchange-CrossTenant-mailboxtype: HOSTED
X-MS-Exchange-CrossTenant-userprincipalname: XB+hi12Ix6M0Clq8N5OkuyaSyn+VHc3CqDQFYzCuqG+6HLmIKmm3fNcehYltS9+AD7eShyP4qS4f9Uc+DkPkQg==
X-MS-Exchange-Transport-CrossTenantHeadersStamped: DS0PR13MB6273
Message-ID-Hash: OUJ6RMCQTZLLLFPTWU5LBKRLKNVUMBGX
X-Message-ID-Hash: OUJ6RMCQTZLLLFPTWU5LBKRLKNVUMBGX
X-MailFrom: john.kaippallimalil@futurewei.com
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-tsv-art.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: "dmm@ietf.org" <dmm@ietf.org>, "draft-ietf-dmm-tn-aware-mobility.all@ietf.org" <draft-ietf-dmm-tn-aware-mobility.all@ietf.org>, "last-call@ietf.org" <last-call@ietf.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [Tsv-art] Re: draft-ietf-dmm-tn-aware-mobility-28 telechat Tsvart review
List-Id: Transport Area Review Team <tsv-art.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tsv-art/_B0wrDOE9Jsb-wikx-d31tv6caA>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tsv-art>
List-Help: <mailto:tsv-art-request@ietf.org?subject=help>
List-Owner: <mailto:tsv-art-owner@ietf.org>
List-Post: <mailto:tsv-art@ietf.org>
List-Subscribe: <mailto:tsv-art-join@ietf.org>
List-Unsubscribe: <mailto:tsv-art-leave@ietf.org>

Hi Joe, all,

The authors have revised the draft (rev 29) to address the comments A - D.

Some short notes on the revision:
A: added text to clarify re: reserved or "0" value port + other recommended revisions (see Diff attached below).
B: revised instances of "IP source ports" to "UDP source ports"
     3GPP specifies the protocol encapsulations and we have referred to them. No changes to any of those encapsulations are made here.
C: Revised text to state that for many 5G inter and intra-domain cases there are no NATs in between the SEGs.
    In scenarios where NATs may be present (e.g., MVNOs), the draft now states that RFC3948 mandates port 4500 and since these procedures require port diversity, it cannot be used.
    Ongoing work in IETF such as [draft-xu-ipsecme-esp-in-udp-lb] and [draft-antony-ipsecme-udp-encap-multiport] can hopefully address that in the future.
D: This draft makes no additions to the encapsulations that exist in current 3GPP procedures (with GTP-U / UDP) - only reuses UDP source port.
     3GPP has mechanisms to specify how to handle fragmentation with GTP tunneling (i.e., PCO - Protocol Configuration Options that specify MTU, etc.)
     Added text to clarify that the 3GPP mechanisms should continue to be used.

Links:
URL:      https://www.ietf.org/archive/id/draft-ietf-dmm-tn-aware-mobility-29.txt

Diff:     https://author-tools.ietf.org/iddiff?url2=draft-ietf-dmm-tn-aware-mobility-29

Best Regards,
John



> -----Original Message-----
> From: Joseph Touch via Datatracker <noreply@ietf.org>
> Sent: Thursday, July 23, 2026 12:38 AM
> To: tsv-art@ietf.org
> Cc: dmm@ietf.org; draft-ietf-dmm-tn-aware-mobility.all@ietf.org; last-
> call@ietf.org
> Subject: draft-ietf-dmm-tn-aware-mobility-28 telechat Tsvart review
>
> Document: draft-ietf-dmm-tn-aware-mobility
> Title: Mobility-aware Transport Network Slicing for 5G
> Reviewer: Joseph Touch
> Review result: Not Ready
>
> This document has been reviewed as part of the transport area review team's
> ongoing effort to review key IETF documents. These comments were written
> primarily for the transport area directors, but are copied to the document's
> authors and WG to allow them to address any issues raised and also to the
> IETF discussion list for information.
>
> When done at the time of IETF Last Call, the authors should consider this
> review as part of the last-call comments they receive. Please always CC tsv-
> art@ietf.org if you reply to or forward this review.
>
> This document was reviewed solely from a transport perspective. It does not
> address the viability of this mechanism nor its intended utility.
>
> The key transport issues appear to be as listed below. Items A and B can be
> resolved by simple edits. Item C requires more extensive revision to address.
> Item D appears to be unresolvable, given this is intended as an informational
> RFC and intends to override a standards-track RFC.
>
> Joe
>
> A. Use of UDP source ports for packet identification
>     o   There is nothing inherently problematic about this,
>         as long as these ports are understood not to be assigned
>         or reserved, and to notably avoid the potentially hazardous
>         use of the “0” port value, which can trigger unexpected behavior
>         in some systems.
> B.      Referring incorrectly to “IP source ports” in numerous places
>     o   Transport layers have ports, not IP packets
>     o   If this refers to the UDP source port, it would be useful to
>         correct the terminology and more clearly explain the header
>         sequence expected
> C. Conflicts with RFC3948
>     o   RFC 3948 requires that UDP-encapsulated ESP “MUST” use the
>         same source and destination ports as that used by IKE traffic
>         (in that RFC, Sec 2.1)
>     o   This document appears to intend to override that rule such
>         that source ports are configurable (this doc, Sec 6, paragraph 4).
>     o   As an informational document, this document cannot override
>         RFC 3498, nor does it currently appear to correctly (it would
>         require an “updates” marking).
> D. Lack of discussion of path MTU and fragmentation concerns
>     o   The document makes liberal use of UDP encapsulation,
>         but never mentions any issues with increased overheads,
>         packet loss, computational effort, required storage, or
>         security implications involved with IP fragmentation and
>         reassembly, nor any discussion of interaction with PLPMTUD.
>     o   The key security implication is the increased potential
>         for DOS attacks at the reassembly points, and this should be
>         included in the security considerations.
>     o   In particular, IP fragmentation MUST occur in the encapsulated
>         IP outer packet, not by fragmenting the inner IP packet
>         because the potential for on-path fragmentation cannot be
>         assumed (the inner IP packet could be IPv4 with DF=0 or IPv6,
>         neither of which can be fragmented on-path).
>     o   New UDP options do support UDP-layer fragmentation (RFC 9868)
>         and could be included in this discussion, but these are not
>         yet widely deployed.
>
> --
>