[tsvwg] Re: New Version Notification for draft-trammell-tsvwg-443-is-enough-00.txt

"Brian Trammell (IETF)" <ietf@trammell.ch> Mon, 24 August 2026 14:01 UTC

Return-Path: <ietf@trammell.ch>
X-Original-To: tsvwg@mail2.ietf.org
Delivered-To: tsvwg@mail2.ietf.org
Received: from localhost (localhost [127.0.0.1]) by mail2.ietf.org (Postfix) with ESMTP id 03E8912E62C1A for <tsvwg@mail2.ietf.org>; Mon, 24 Aug 2026 07:01:01 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1; t=1787580061; bh=QqF/Jvn7RZ2RYST/9517l70W76GYl7X5YxA2sho00+Q=; h=From:Subject:Date:In-Reply-To:Cc:To:References; b=m8cRgALBIOnAQlIvnDasUIZb+A2cLZksOcEK0+YKW/saXh322j0jw2M2UkR1n3ZkX E3j7nhcvSuyjqqqaQnBytozWG+JZ9guqCmPNJWWDn4YfsQVoEjEYvVtaeyFiExf31R RxLoS9b7dJAeOP37qUSsdqTFjQxqGgEnzYzniacc=
X-Virus-Scanned: amavisd-new at ietf.org
X-Spam-Flag: NO
X-Spam-Score: -2.796
X-Spam-Level:
X-Spam-Status: No, score=-2.796 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, RCVD_IN_MSPIKE_H4=0.001, RCVD_IN_MSPIKE_WL=0.001, RCVD_IN_VALIDITY_RPBL_BLOCKED=0.001, RCVD_IN_VALIDITY_SAFE_BLOCKED=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: mail2.ietf.org (amavisd-new); dkim=pass (1024-bit key) header.d=trammell.ch
Received: from mail2.ietf.org ([166.84.6.31]) by localhost (mail2.ietf.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id jPXmOD5FNY89 for <tsvwg@mail2.ietf.org>; Mon, 24 Aug 2026 07:00:59 -0700 (PDT)
Received: from smtp-42a8.mail.infomaniak.ch (smtp-42a8.mail.infomaniak.ch [84.16.66.168]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature ECDSA (P-256) server-digest SHA256) (No client certificate requested) by mail2.ietf.org (Postfix) with ESMTPS id A840912E62C09 for <tsvwg@ietf.org>; Mon, 24 Aug 2026 07:00:59 -0700 (PDT)
Received: from smtp-4-0000.mail.infomaniak.ch (smtp-4-0000.mail.infomaniak.ch [10.7.10.107]) by smtp-3-3000.mail.infomaniak.ch (Postfix) with ESMTPS id 4hTCHS0BVZzZ5H; Mon, 24 Aug 2026 16:00:52 +0200 (CEST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=trammell.ch; s=20191114; t=1787580051; bh=YqNCyOh0/4ehHd8nHrqCLso/ajYMsGThHdt3FWtVMpQ=; h=From:Subject:Date:In-Reply-To:Cc:To:References:From; b=0Qqn/rUmp7wth/4qXaEAlAufa+FTSqjDZviOH0F85QkQDrhrAu+vC4y6/qcdORFim jt7fzcEg9APxCmnC3zMtvPwrqNJMmKv1g34TVZARg29IOk31jGFmK9rT2j8WN52ktd jAgPh34LmBsp9ZnV1R1ty/1vtLOkkgSywCIjUxT0=
Received: from unknown by smtp-4-0000.mail.infomaniak.ch (Postfix) with ESMTPA id 4hTCHR1jmSzVbn; Mon, 24 Aug 2026 16:00:51 +0200 (CEST)
From: "Brian Trammell (IETF)" <ietf@trammell.ch>
Message-Id: <AA99CD57-942F-42CC-8E6A-74C2ED7C080D@trammell.ch>
Content-Type: multipart/alternative; boundary="Apple-Mail=_A04AE863-4BC5-42A1-8DFD-A2932CB4E39C"
Mime-Version: 1.0 (Mac OS X Mail 16.0 \(3826.700.81.1.8\))
Date: Mon, 24 Aug 2026 16:00:40 +0200
In-Reply-To: <6D593C4C-D611-4797-B779-11866DB1CCFC@beachpine.com>
To: Joe Touch <touch@beachpine.com>
References: <178482385907.696930.5496940658323689925@dt-datatracker-d4d6ff9d9-ql5mb> <BA26A7D0-C749-48E7-8A9E-0C6AAD70EF72@trammell.ch> <6D593C4C-D611-4797-B779-11866DB1CCFC@beachpine.com>
X-Mailer: Apple Mail (2.3826.700.81.1.8)
X-Infomaniak-Routing: alpha
Message-ID-Hash: BQRTA6T7IHPVPQTC5OC3Z43B2KXIARY2
X-Message-ID-Hash: BQRTA6T7IHPVPQTC5OC3Z43B2KXIARY2
X-MailFrom: ietf@trammell.ch
X-Mailman-Rule-Misses: dmarc-mitigation; no-senders; approved; emergency; loop; banned-address; member-moderation; header-match-tsvwg.ietf.org-0; nonmember-moderation; administrivia; implicit-dest; max-recipients; max-size; news-moderation; no-subject; digests; suspicious-header
CC: tsvwg@ietf.org, Michael via IANA-Port-Experts Scharf <iana-port-experts@icann.org>
X-Mailman-Version: 3.3.9rc6
Precedence: list
Subject: [tsvwg] Re: New Version Notification for draft-trammell-tsvwg-443-is-enough-00.txt
List-Id: Transport Area Working Group <tsvwg.ietf.org>
Archived-At: <https://mailarchive.ietf.org/arch/msg/tsvwg/EmQwcF3Y3HcTP53u1cQQbbe1Vn4>
List-Archive: <https://mailarchive.ietf.org/arch/browse/tsvwg>
List-Help: <mailto:tsvwg-request@ietf.org?subject=help>
List-Owner: <mailto:tsvwg-owner@ietf.org>
List-Post: <mailto:tsvwg@ietf.org>
List-Subscribe: <mailto:tsvwg-join@ietf.org>
List-Unsubscribe: <mailto:tsvwg-leave@ietf.org>

hi Joe,

Good question. While the language in 7605 is concise, I’m not sure it’s adequate on this point for the present moment.

The primary reason I’m spending time on this is what I perceive (but have not yet rigorously measured) as a sharp uptick in the number of requests to the port experts for port assignments for what are basically REST APIs. An informal analysis of a sample of these requests suggests that we’re seeing way more inclusion of LLM-based coding tools in the protocol design process, which drives the cost of applying for a port down, and where here the model itself may see the wiggle room in the 7605 language as an invitation to try.

I aim to achieve two things with this draft:

(1) measure and document IETF consensus (or non-consensus, through non-publication) of the proposition that port assignments for substantially HTTP applications should be a rare exception

(2) provide additional signal to models asked to specify a protocol that they do not need to bother with a port assignment in this case.

Cheers,

Brian

> On 24 Jul 2026, at 17:30, Joe Touch <touch@beachpine.com> wrote:
> 
> On Jul 24, 2026, at 12:09 AM, Brian Trammell (IETF) <ietf@trammell.ch> wrote:
>> 
>> Greetings, all,
>> 
>> After some hallway discussion in Vienna, I’d like to bring this work to TSVWG for further discussion and development. This revision moves the draft into the -tsvwg namespace, and incorporates some changes from Christian’s comments (thanks again!)
>> 
>> I’d like to do this relatively quickly (ask for adoption at 127 or before, ask for WGLC shortly thereafter) as it’s a relatively simple proposition: augment 7605 to make it clearer when a port is warranted for applications over HTTP, and provide some commentary for application developers about why.
> 
> RFC7605 states that:
> 
> 1) HTTP is both a layer and an alias for the entire stack up to a web browser:
> 
>    As a concept, a service is the combination of ISO Layers 5-7 that
>    represents an application-protocol capability.  For example, www
>    (port number 80) is a service that uses HTTP as an application
>    protocol and provides access to a web server [RFC7230 <https://datatracker.ietf.org/doc/html/rfc7230>].  However, it
>    is possible to use HTTP for other purposes, such as command and
>    control.  This is why some current services (HTTP, e.g.) are a bit
>    overloaded -- they describe not only the application protocol, but a
>    particular service.
> 
> 2) there are mechanisms inside HTTP to demux, such that an additional port for some copies may not be needed:
> 
>       Copies of some existing services can be differentiated using in-
>       band information (e.g., URIs in the HTTP Host field and TLS Server
>       Name Indication extension) [RFC7230 <https://datatracker.ietf.org/doc/html/rfc7230>] [RFC6066 <https://datatracker.ietf.org/doc/html/rfc6066>].
> 
> 3) that such copies don’t warrant new ports, providing an objective metric for making that decision:
> 
>       Additional assigned port numbers are not intended to replicate an
>       existing service.  For example, if a device is configured to use a
>       typical web browser, then the port number used for that service is
>       a copy of the http service that is already assigned to port number
>       80 and does not warrant a new assignment.  However, an automated
>       system that happens to use HTTP framing -- but is not primarily
>       accessed by a browser -- might be a new service.  A good way to
>       tell is to ask, "Can an unmodified client of the existing service
>       interact with the proposed service?".  If so, that service would
>       be a copy of an existing service and would not merit a new
>       assignment.
> 
> Can you explain, specifically, what issue needs to be made more clear?
> 
> Joe